Subject: [102attendees] FYI - side meeting Weds 12noon for Website Packaging (WPACK)

From: Dan York <[email-masked]>
Date: Tue, 17 Jul 2018 21:11:56 +0000

Tomorrow (Weds, June 18), at 12noon, we'll have a side meeting for people interested in potential new work about "website packaging" that will allow people to bundle together the resources that make up a website so they can be shared offline, either with or without a proof that they came from the original website. (Or used in low connectivity environments... or see the other use cases: https://tools.ietf.org/html/draft-yasskin-webpackage-use-cases-01 <https://tools.ietf.org/html/draft-yasskin-webpackage-use-cases-01> )

The meeting will be in the Square Dorchester room on the 3rd floor.

Jeffrey Yasskin is the point person on this work but is not physically here in Montreal. He'll be joining in remotely.

He has more info at: https://github.com/WICG/webpackage <https://github.com/WICG/webpackage>
Agenda: https://github.com/WICG/webpackage/wiki/IETF-102-Agenda <https://github.com/WICG/webpackage/wiki/IETF-102-Agenda>
Explainer: https://github.com/WICG/webpackage/blob/master/explainer.md <https://github.com/WICG/webpackage/blob/master/explainer.md>

I summarized some of the work here: https://github.com/danyork/wpack-intro-ietf102/blob/master/wpack-intro-ietf102.pdf <https://github.com/danyork/wpack-intro-ietf102/blob/master/wpack-intro-ietf102.pdf>

Jeffrey has a few drafts around this:

- https://tools.ietf.org/html/draft-yasskin-webpackage-use-cases-01 <https://tools.ietf.org/html/draft-yasskin-webpackage-use-cases-01>
- https://tools.ietf.org/html/draft-yasskin-http-origin-signed-responses-04 <https://tools.ietf.org/html/draft-yasskin-http-origin-signed-responses-04>
- https://tools.ietf.org/html/draft-yasskin-wpack-bundled-exchanges-00 <https://tools.ietf.org/html/draft-yasskin-wpack-bundled-exchanges-00>

And there is a mailing list at:

- https://www.ietf.org/mailman/listinfo/Wpack <https://www.ietf.org/mailman/listinfo/Wpack>

The point of tomorrow's meeting is to get an update from Jeffrey on some of the developments and to determine what interest there may be in doing more with this work.

If you are interested but can't join the session tomorrow, please join the wpack mailing list.

Dan

--
Dan York
Director, Content & Web Strategy, Internet Society
[email-masked]   +1-802-735-1624 
Jabber: [email-masked]  Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 18 Jul 2018 15:57:17 +0000

The room is on the 2nd floor.

Regards,

Christer

From: 102attendees [mailto:[email-masked]] On Behalf Of Dan York
Sent: 17 July 2018 17:12
To: [email-masked]
Cc: Jeffrey Yasskin <[email-masked]>
Subject: [102attendees] FYI - side meeting Weds 12noon for Website Packaging (WPACK)

Tomorrow (Weds, June 18), at 12noon, we'll have a side meeting for people interested in potential new work about "website packaging" that will allow people to bundle together the resources that make up a website so they can be shared offline, either with or without a proof that they came from the original website. (Or used in low connectivity environments... or see the other use cases: https://tools.ietf.org/html/draft-yasskin-webpackage-use-cases-01 )

He has more info at: https://github.com/WICG/webpackage
Agenda: https://github.com/WICG/webpackage/wiki/IETF-102-Agenda
Explainer: https://github.com/WICG/webpackage/blob/master/explainer.md

I summarized some of the work here: https://github.com/danyork/wpack-intro-ietf102/blob/master/wpack-intro-ietf102.pdf

- https://tools.ietf.org/html/draft-yasskin-webpackage-use-cases-01
- https://tools.ietf.org/html/draft-yasskin-http-origin-signed-responses-04
- https://tools.ietf.org/html/draft-yasskin-wpack-bundled-exchanges-00

- https://www.ietf.org/mailman/listinfo/Wpack

Dan

--
Dan York
Director, Content & Web Strategy, Internet Society
[email-masked]<mailto:[email-masked]>   +1-802-735-1624
Jabber: [email-masked]<mailto:[email-masked]>  Skype: danyork   http://twitter.com/danyork