Subject: [102attendees] Visa problems - need a different invitation letter

From: Balazs Lengyel <[email-masked]>
Date: Tue, 4 Sep 2018 10:29:55 +0200

Hello,

This morning the Embassy of Thailand rejected my visa application as 
they found the invitation letter lacking. They sent me a 23 page 
template in Thai language that the invitation letter should follow.

Have you had similar problems?

regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909              email: [email-masked]

---

From: Ori Finkelman <[email-masked]>
Date: Tue, 4 Sep 2018 12:33:10 +0300

Is there a requirement to get a non tourist visa ?
For tourism you don't need a visa.

On Tue, Sep 4, 2018 at 11:29 AM, Balazs Lengyel <[email-masked]
> wrote:

> Hello,
>
> This morning the Embassy of Thailand rejected my visa application as they
> found the invitation letter lacking. They sent me a 23 page template in
> Thai language that the invitation letter should follow.
>
> _______________________________________________
> 102attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/102attendees
>

-- 

*Ori Finkelman*Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189 |
[email-masked]

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 4 Sep 2018 12:14:15 +0200

At least for us Hungarians there is. For tourists we do not need
a visa, but for ANY business we do need a non-immigrant visa.

You might get away with visiting as a tourist, but I tried to do
the correct thing.

regards Balazs

On 9/4/2018 11:33 AM, Ori Finkelman
wrote:

On Tue, Sep 4, 2018 at 11:29 AM, Balazs
Lengyel <[email-masked]>
wrote:

Hello,

This morning the Embassy of Thailand rejected my visa
application as they found the invitation letter lacking.
They sent me a 23 page template in Thai language that the
invitation letter should follow.

regards Balazs

--

Balazs Lengyel                       Ericsson Hungary
Ltd.

Senior Specialist

[email-masked]

--

Ori Finkelman

Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189
| [email-masked]

---

From: Ori Finkelman <[email-masked]>
Date: Tue, 4 Sep 2018 13:27:57 +0300

Got you, thanks.

On Tue, Sep 4, 2018 at 1:14 PM, Balazs Lengyel <[email-masked]>
wrote:

> At least for us Hungarians there is. For tourists we do not need a visa,
> but for ANY business we do need a non-immigrant visa.
> You might get away with visiting as a tourist, but I tried to do the
> correct thing.
>
> regards Balazs
> On 9/4/2018 11:33 AM, Ori Finkelman wrote:
>
> On Tue, Sep 4, 2018 at 11:29 AM, Balazs Lengyel <
> [email-masked]> wrote:
>
>> Hello,
>>
> *Ori Finkelman *Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189 |
> [email-masked]
>
> --

--

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Tue, 4 Sep 2018 18:30:18 +0800

Is IETF a real business?..

Probably the only place where you're going to trade something for something
is actually the whisky BoF.

---

From: Mehmet Ersue <[email-masked]>
Date: Tue, 04 Sep 2018 13:56:06 +0300

From immigrations pov. you do business if you sell or meet with the purpose to sell products.IOW attending an IETF meeting where you have discussions is not business. 
Cheers, Mehmet
Von meinem Samsung Galaxy Smartphone gesendet.
-------- Ursprüngliche Nachricht --------Von: Balazs Lengyel <[email-masked]> Datum: 04.09.18  13:14  (GMT+03:00) An: Ori Finkelman <[email-masked]> Cc: [email-masked], 102attendees <[email-masked]>, [email-masked] Betreff: Re: [102attendees] Visa problems - need a different invitation letter 

    

          Hello,

            regards Balazs

                -- 

                Senior Specialist

                [email-masked]

        

        
        -- 

          Ori Finkelman

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 4 Sep 2018 12:57:54 +0200

The Thai embassy had a different opinion. They sad a conference
is business, not tourism. Maybe I should not have asked. :-(

regards Balazs

On 9/4/2018 12:56 PM, Mehmet Ersue
wrote:

From immigrations pov. you do business if you sell or meet
with the purpose to sell products.

IOW attending an IETF meeting where you have discussions is
not business.

Cheers,

Mehmet

Von meinem
Samsung Galaxy Smartphone gesendet.

-------- Ursprüngliche Nachricht --------

Von: Balazs Lengyel <[email-masked]>

Datum: 04.09.18 13:14 (GMT+03:00)

An: Ori Finkelman <[email-masked]>

Cc: [email-masked], 102attendees
<[email-masked]>, [email-masked]

Betreff: Re: [102attendees] Visa problems - need a
different invitation letter

At least for us Hungarians there is. For tourists we do not
need a visa, but for ANY business we do need a non-immigrant
visa.

regards Balazs

Is there a requirement to get a non tourist visa
?

On Tue, Sep 4, 2018 at 11:29 AM,
Balazs Lengyel <[email-masked]>
wrote:

Hello,

regards Balazs

--

Senior Specialist

[email-masked]

--

Ori Finkelman

Qwilt | Work: +972-72-2221647 | Mobile:
+972-52-3832189 | [email-masked]

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Tue, 4 Sep 2018 19:03:38 +0800

NB: we might want to omit CCing ietf-registrar@ within this thread in
future. Apparently each message ends up as a new support ticket.

вт, 4 сент. 2018 г., 18:58 Balazs Lengyel <[email-masked]>:

> The Thai embassy had a different opinion. They sad a conference is
> business, not tourism. Maybe I should not have asked. :-(
>
> regards Balazs
>
>
> On 9/4/2018 12:56 PM, Mehmet Ersue wrote:
>
> From immigrations pov. you do business if you sell or meet with the
> purpose to sell products.
> IOW attending an IETF meeting where you have discussions is not business.
>
> Cheers,
> Mehmet
>
> <[email-masked]>
> An: Ori Finkelman <[email-masked]> <[email-masked]>
> Cc: [email-masked], 102attendees <[email-masked]>
> Betreff: Re: [102attendees] Visa problems - need a different invitation
> letter
>

---

From: Mehmet Ersue <[email-masked]>
Date: Tue, 04 Sep 2018 15:14:38 +0300

Never tell you want to do business.Actually IETF is a technical meeting.
Me
Von meinem Samsung Galaxy Smartphone gesendet.
-------- Ursprüngliche Nachricht --------Von: Balazs Lengyel <[email-masked]> Datum: 04.09.18  13:57  (GMT+03:00) An: Mehmet Ersue <[email-masked]>, Ori Finkelman <[email-masked]> Cc: [email-masked], 102attendees <[email-masked]>, [email-masked] Betreff: Re: [102attendees] Visa problems - need a different invitation letter 

    

      

      Cheers, 
      Mehmet

      
        Von meinem

      
        -------- Ursprüngliche Nachricht --------
        Von: Balazs Lengyel <[email-masked]> 
        Datum: 04.09.18 13:14 (GMT+03:00) 
        An: Ori Finkelman <[email-masked]> 
        Cc: [email-masked], 102attendees
          <[email-masked]>, [email-masked] 
        Betreff: Re: [102attendees] Visa problems - need a
          different invitation letter 

      

      

            Hello,

              regards Balazs

                  -- 

                  Senior Specialist

                  [email-masked]

          

          
          -- 

            Ori Finkelman

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 4 Sep 2018 15:17:53 +0200

Balazs,

I will simply print out: 

https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/
(thanks Andy!)

and go to Thailand as a tourist and mark that field in any
immigration form. If asked by a border agents, i will
say that i am attending the IETF103 technical conference. If
asked how that is tourism, i will pull the printout.

Also check if you can get to this TIMATIC page, you may need an
account at united, else check your own airline:

https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/

When i entered hungarian data, it also showed that one does not need a
visa.

I did similarily to you for IETF Buenos Aires ask consulates in
USA/Germany what i would need to enter the country when i attend a conference,
and they could not figure it out, so they recommended me a business
visa. Through the discussion on the IETF mailing list (thanks Mehmet)
i also came to recognize that i am not doing business when i am attending
a conference (no money involved). Just that Argentina didn't have a
good web page like that above one from the Thailand ministry. But
i also went to IETF Buenos Aires fine as a tourist. Like probably most
everybody else attending IETF and who is visa exempt as a tourist.

Thats just me. No recommendation what you or anybody else should do.
You'll have to figure out yourself how much useless paper work you need in your life. 
There is still enough time to get an invitation letter from IETF and
retry to visa if thats what you want to do.

Cheers
    Toerless

On Tue, Sep 04, 2018 at 10:29:55AM +0200, Balazs Lengyel wrote:
> found the invitation letter lacking. They sent me a 23 page template in Thai
> language that the invitation letter should follow.
> 

-- 
---
[email-masked]

---

From: Niel Harper <[email-masked]>
Date: Tue, 4 Sep 2018 13:57:19 +0000

Toerless,

I'm with you on this.

The Royal Thai Embassy Washington D.C. informational web page states that visiting Thailand for the following requires a tourist visa:

            2.1 Participating in meetings, conferences or seminars

            2.2  Attending exhibitions or trade shows

            2.3 Visiting businesses or having business meetings

The URL is http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html

Regards,

-----------------------------

Niel Harper

Director, NGL & Fellowships

Internet Society

11710 Plaza America Drive

Reston, VA 20190

Email: [email-masked]

Skype: OlokunBB

Follow us on Twitter @ISOC_NextGen <https://twitter.com/ISOC_NextGen>

On 9/4/18, 9:18 AM, "103attendees on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    Balazs,

    I will simply print out: 

    (thanks Andy!)

    visa.

    Cheers

        Toerless

    > Hello,

    > 

    > This morning the Embassy of Thailand rejected my visa application as they

    > found the invitation letter lacking. They sent me a 23 page template in Thai

    > language that the invitation letter should follow.

    > 

    > Have you had similar problems?

    > 

    > regards Balazs

    > 

    > -- 

    > Balazs Lengyel                       Ericsson Hungary Ltd.

    > Senior Specialist

    > Mobile: +36-70-330-7909              email: [email-masked]

    > 

    > _______________________________________________

    > 102attendees mailing list

    > [email-masked]

    > https://www.ietf.org/mailman/listinfo/102attendees

    -- 

    ---

    [email-masked]

    -- 

    103attendees mailing list

    [email-masked]

    https://www.ietf.org/mailman/listinfo/103attendees

---

From: Ben Campbell <[email-masked]>
Date: Tue, 4 Sep 2018 12:48:09 -0500

Hi Niel,

I don’t disagree with the answers, but the URL you sent is for the Thai Embassy in Finland, not Washington DC.

Thanks!

Ben.

> On Sep 4, 2018, at 8:57 AM, Niel Harper <[email-masked]> wrote:
> 
> Toerless,
> 
> I'm with you on this.
> 
> The URL is http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html <http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html>
> 
> Regards,
> 
> Email: [email-masked] <mailto:[email-masked]>
> Skype: OlokunBB
> Follow us on Twitter @ISOC_NextGen <https://twitter.com/ISOC_NextGen <https://twitter.com/ISOC_NextGen>>
> 
> On 9/4/18, 9:18 AM, "103attendees on behalf of Toerless Eckert" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
>     Balazs,
> 
>     I will simply print out:
> 
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/103attendees <https://www.ietf.org/mailman/listinfo/103attendees>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/102attendees <https://www.ietf.org/mailman/listinfo/102attendees>

---

From: Niel Harper <[email-masked]>
Date: Tue, 4 Sep 2018 17:57:07 +0000

Hello Ben,

I recognized that after the fact.

I was directed to that URL because the Thai Embassy in DC doesn’t provide a lot of detailed information about visas.

Regards,

Niel Harper

Internet Society

Reston, VA 20190

Email: [email-masked]

Skype: OlokunBB

Follow us on Twitter @ISOC_NextGen

From: Ben Campbell <[email-masked]>
Date: Tuesday, September 4, 2018 at 1:48 PM
To: Niel Harper <[email-masked]>
Cc: Toerless Eckert <[email-masked]>, Balazs Lengyel <[email-masked]>, "[email-masked]" <[email-masked]>, 102attendees <[email-masked]>
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

Hi Niel,

Thanks!

Ben.

Toerless,

I'm with you on this.

Regards,

Niel Harper

Internet Society

Reston, VA 20190

Email: [email-masked]

Skype: OlokunBB

    Balazs,

    I will simply print out: 

    (thanks Andy!)

    visa.

    Cheers

        Toerless

    -- 

    ---

    [email-masked]

    -- 

    [email-masked]

---

From: John C Klensin <[email-masked]>
Date: Tue, 04 Sep 2018 14:07:57 -0400

Hi.

If only to keep mailing list traffic down, can I encourage
everyone who is speculating on what type of visa is needed to
find the note that Andrew Sullivan posted on the subject a few
weeks ago and reread it carefully.

WIth a very small number of exceptions, the final decision about
what category of visa is, or is not, required belongs to the
authorities at the border when you try to enter the country.  If
you appear with a tourist visa or waiver and they ask questions
and conclude that category is inappropriate, you are either
headed home or in for a long conversation (and maybe an exercise
in filling out forms) while your status is sorted out.  If you
have a letter from you local consulate or a copy of their web
page indicating that your choice was consistent with their
guidance, the actual border authorities might accept that as
evidence that you should get in on that category of visa, might
accept it as evidence that whatever decision you made was made
in good faith, or might ignore it entirely. 

Again, Andrew's summary and comments are much better than mine.
But my point is that these decision belong to border authorities
in the country you are trying to enter and we really cannot
accomplish very much (other that causing noise on the lists) by
crowdsourcing opinions about what is needed or appropriate.
This is one area in which IETF Consensus, even if it existed,
would be of little value.

best,
    john

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Wed, 5 Sep 2018 02:18:32 +0800

On Wed, Sep 5, 2018 at 2:08 AM John C Klensin <[email-masked]> wrote:
> [..] can I encourage
> weeks ago

Sure. Which mailing list was it?

> in filling out forms) while your status is sorted out.

Unfortunately, that (small) number of exceptions includes a case when
you occasionally don't get any questions at the border and then after
a couple of days simply go to jail for several years for violating the
visa regulations. And, the government of Thailand is famous for its
strict policies on working without a permit.

| Töma Gavrichenkov
| gpg: 2deb 97b1 0a3c 151d b67f 1ee5 00e7 94bc 4d08 9191
| mailto: [email-masked]
| fb: ximaera
| telegram: xima_era
| skype: xima_era
| tel. no: +7 916 515 49 58

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 4 Sep 2018 21:17:56 +0200

> weeks ago and reread it carefully.

Ok......... failed. Please provide URL.

> in filling out forms) while your status is sorted out. 

Sure.

> If you

Sure. Sure. But also Visas do not guarantee entry either. I am
also not aware of data points that entereing on visa waiver has a
higher chance of failure on the places we go to. 

> Again, Andrew's summary and comments are much better than mine.

Please provide URL. The only one i found is that IASA can not
provide legal guidance *doh* (obvious).

> in the country you are trying to enter

Sure.

> and we really cannot

No idea how the points you made above are evidence for that conclusion.
With contradicting information from different consulates for the same
trip, the insight i got from these mailing  lists was in the past a 
lot more useful than what consulates told me.

> would be of little value.

I though the main benefit of this thread is more BCP than consensus.

Cheers
    Toerless

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 4 Sep 2018 21:04:43 +0100

John,

While all this is true, it is also not very useful. The equivalent advice for US visitors would be that you can be shot every moment by a police officer that got a bit agitated. That is not useful advice. Useful advice would be how not to get into situations with those dangerous people. While some legal advice can be useful here, this is mostly about being street-smart. It is hard to be this without some experience, and this is why the only useful posts here have been on previous experience. 

Sent from mobile

> On 4. Sep 2018, at 19:07, John C Klensin <[email-masked]> wrote:
> 
> Hi.
>

---

From: Philip Prindeville <[email-masked]>
Date: Tue, 4 Sep 2018 13:32:21 -0700

That’s a bit of an apples to oranges comparison.

I think as North Americans (Canadians and Americans) and Western Europeans, we’re used to the rule of law and the equal application of it.

Not always the case in less developed countries.

I think that’s part of John’s point.

> On Sep 4, 2018, at 1:04 PM, Carsten Bormann <[email-masked]> wrote:
> 
> John,
> 
> On 4. Sep 2018, at 19:07, John C Klensin <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi.
>>

---

From: Fred Baker <[email-masked]>
Date: Tue, 4 Sep 2018 18:26:44 -0700

Well, and the US has issues in that respect. That said, Carsten is correct that a vanishingly small percentage of our police force seems to be xenophobic, and that vanishingly small percentage seems to dominate the papers.

> On Sep 4, 2018, at 1:32 PM, Philip Prindeville <[email-masked]> wrote:
> 
> Signed PGP part

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: Mike Bishop <[email-masked]>
Date: Wed, 5 Sep 2018 04:35:18 +0000

Personally, I think the key takeaway of this is that we should probably have included some more precise language about visas in the mtgvenue docs or we should read the existing language to include new evaluations based on this experience.  What we wrote was:

      Travel barriers to entry, *including visa requirements*, are likely
      to be such that an overwhelming majority of participants who wish
      to do so can attend.  The term "travel barriers" is to be read
      broadly by the IASA in the context of whether a successful meeting
      can be had.

We're having direct experience now that another of these barriers to entry is determining whether a visa is needed in the first place.  If that can't be readily ascertained for participants from most countries, that might be a strike against a choice of venue.

I know that if Thailand shows up on the venue feedback e-mails again, I'll give feedback on that as a reason not to meet in Bangkok unless the Thai government seriously overhauls their immigration guidance.

-----Original Message-----
From: 102attendees <[email-masked]> On Behalf Of Toerless Eckert
Sent: Tuesday, September 4, 2018 12:18 PM
To: John C Klensin <[email-masked]>
Cc: Ben Campbell <[email-masked]>; Niel Harper <[email-masked]>; [email-masked]; 102attendees <[email-masked]>; Balazs Lengyel <[email-masked]>
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

On Tue, Sep 04, 2018 at 02:07:57PM -0400, John C Klensin wrote:
> Hi.
> 
> If only to keep mailing list traffic down, can I encourage everyone 
> who is speculating on what type of visa is needed to find the note 
> that Andrew Sullivan posted on the subject a few weeks ago and reread 
> it carefully.

> WIth a very small number of exceptions, the final decision about what 
> category of visa is, or is not, required belongs to the authorities at 
> the border when you try to enter the country.  If you appear with a 
> tourist visa or waiver and they ask questions and conclude that 
> category is inappropriate, you are either headed home or in for a long 
> conversation (and maybe an exercise in filling out forms) while your 
> status is sorted out.

Sure.

> If you
> have a letter from you local consulate or a copy of their web page 
> indicating that your choice was consistent with their guidance, the 
> actual border authorities might accept that as evidence that you 
> should get in on that category of visa, might accept it as evidence 
> that whatever decision you made was made in good faith, or might 
> ignore it entirely.

Sure. Sure. But also Visas do not guarantee entry either. I am also not aware of data points that entereing on visa waiver has a higher chance of failure on the places we go to. 

> Again, Andrew's summary and comments are much better than mine.

Please provide URL. The only one i found is that IASA can not provide legal guidance *doh* (obvious).

> But my point is that these decision belong to border authorities in 
> the country you are trying to enter

Sure.

No idea how the points you made above are evidence for that conclusion.
With contradicting information from different consulates for the same trip, the insight i got from these mailing  lists was in the past a lot more useful than what consulates told me.

> This is one area in which IETF Consensus, even if it existed, would be 
> of little value.

Cheers
    Toerless

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Wed, 5 Sep 2018 20:08:30 +0000

Here is the answer from the US Thai Embassy.
Nicely dodged the question.
I can just imagine trying to convince a border guard that no business is conducted at a conference.
All they have to do is ask: "Are you attending the conference in that hotel you are staying at?"
Say "no" and go to jail.

Regards,
Jakob.

-----Original Message-----
From: 102attendees <[email-masked]> On Behalf Of Toerless Eckert
Sent: Tuesday, September 4, 2018 12:18 PM
To: John C Klensin <[email-masked]>
Cc: Ben Campbell <[email-masked]>; Niel Harper <[email-masked]>; [email-masked]; 102attendees <[email-masked]>; Balazs Lengyel <[email-masked]>
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

Sure.

Sure.

Cheers
    Toerless

Subject: Re: New submission from Contact En
From: "Thai Embassy DC (Visa)" <[email-masked]>
To: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Wed, 5 Sep 2018 18:05:33 +0000

Dear Sir/Madame

    For business purposes, visa is required.

    For your information, you could apply for the visa by hand or by mail at the Royal Thai Embassy in Washington, D.C., or the Royal Thai Consulate General in Chicago, Los Angeles or New York. And you should do so approximately a month before your departure.

    And regarding the location/mailing information and required documents please check the homepage of the office in your area.

Best,
Visa Section
Consular Office,
Royal Thai Embassy,
2300 Kalorama Rd., N. W.,
Washington, DC 20008.
E-mail - [email-masked]<mailto:[email-masked]>

On Tue, Sep 4, 2018 at 2:19 PM, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> wrote:

Name
         Jakob Heitz
Email
         [email-masked]<mailto:[email-masked]>
Subject
         Visa
Message
         Is a business visa required to attend the IETF conference in Bangkok?
The IETF is an organization of internet equipment vendors that produces standards for internet equipment. We do not conduct commerce. More info at http://ietf.org/.
The conference is held on 3 Nov to 9 Nov 2018.
If I attend the conference, I intend to stay a few more days, but not more than 30 days in total.

Kind Regards,
Jakob.

---

From: Michael StJohns <[email-masked]>
Date: Wed, 5 Sep 2018 18:48:33 -0400

This is the clearest web site I've seen with respect to which type of 
visa is needed:

The above is a page from the Thailand Convention and Exhibits board 
which appears to be at least quasi-governmental having been established 
by royal decree.

AFAICT from reading this, all of the secretariat will need business 
visa's, all of the rest of us - unless we're doing things that make 
money from Thai sources - can get by on Tourist visas.

> Foreigners entering Thailand for MICE without the purposes of being 
> employed or working for income, but being event attendants will be 
> regarded as tourists under the definition of Tourism Authority of 
> Thailand Act of B.E. 2522 (1979).

I'm using the visa exemption program for US tourists.

http://thaiembdc.org/visa-exemption-and-visa-on-arrival/

Later, Mike

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 5 Sep 2018 23:52:06 +0100

On 05/09/18 23:48, Michael StJohns wrote:
> visa's, all of the rest of us

/me imagines the outcome if the secretariat didn't get to the
venue but the rest of us did...  :-)

S.

---

From: Michael StJohns <[email-masked]>
Date: Wed, 5 Sep 2018 18:53:37 -0400

> venue but the rest of us did...  :-)

*heh*  Much worse than the secretariat getting there and the rest of us 
being stopped at the border!

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Thu, 6 Sep 2018 05:57:34 +0000

That is an interpretation of
TOURISM AUTHORITY OF THAILAND ACT, B.E. 2522 (1979)
http://www.asianlii.org/th/legis/consol_act/taota1979337/
in which the definition of tourist is:

"tourist" means any person who freely travels from his normal place of residence to other place for temporary period with the objective other than to carry on his occupation or to earn income;

If your occupation is to develop IETF standards and your employer pays you to do that and that is what you do at the conference, then you might have difficulty in persuading a border guard that you are a tourist.

Maybe the guard is in a good mood and will overlook the detail, believing you will spend money in his country and all will be well.
Or not.

Regards,
Jakob.

-----Original Message-----
From: 102attendees <[email-masked]> On Behalf Of Michael StJohns
Sent: Wednesday, September 5, 2018 3:49 PM
To: [email-masked]
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

Later, Mike

---

From: George Michaelson <[email-masked]>
Date: Thu, 6 Sep 2018 16:20:24 +1000

A friend got permission to travel to the US for a health related
conference, as an Iranian, resident in Australia, and working in a
non-nuclear field. She even got to the door of the conference and the
registration desk before somebody realised the university housed a nuclear
reactor, and therefore by definition she should have been denied entry for
this  specific meeting. She wound up being personally directed off campus,
escorted back to LAX, and sat with until outside the US border until she
could be flown home, hugely embarrassing for her personally, and the
conference, who risked defaulting on US embargo rules which are otherwise
strictly enforced.

The moral of the story, (because this is on topic) is that you should
*never* trust a website associated with a conference or meeting to
correctly describe your personal immigration status, right of entry, visa
obligations. They cannot know everything about you.

Have you ever insulted the Thai royal family in print or online? You are
strongly advised not to go to Thailand as imprisonment may offend (you). Is
this discussed on the visa page?

Folks, the IETF information is at best advisory: They cannot guarantee you
will get entry, even if you wave the letter of invitation. "it depends"

PS I have an APEC card. I am pre-cleared at visa equivalent level, as a
business related person, to be in Thailand. I'm not 100% confident either,
I always have a days change of underclothes in carryon, and I'm prepared to
be told "no" because .. you never ever know.

For any country. Including your own because after all, people do get
excluded from coming home too.

YMMV

-G

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 6 Sep 2018 09:28:57 +0200

The people from THNIC, which as I understand serves as a local host, 
were kind enough to contact the Thai embassy in Budapest for my sake, 
and they seem to have agreed on the issue. I do not yet know if that 
means I do not need a visa or that I will get one based on the current 
LOI. Anyway they seemed very helpful.

regards Balazs

--

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 08:41:34 +0000

Heho,
I am currently facing the same issue (German passport). The consulate in Amsterdam insists that I need a Type-B visa, and requests a full range of documents about TU Delft (full financial report of the last year, overview of employees etc., signed and sealed by the executive board of TU Delft, including copies of their passports). In addition, from the company that is employing me in Thailand (I presume that this means THNic), they also want a copy of the passport of the person signing the LOI in addition to the LOI, signed and sealed financial reports of the current year, official registration, list of employees etc.

I opened a case with IETF registrar for this, and hope to figure this out before the meeting. 

However, would it maybe be possible that THNic tries to find some authoritative information on the needed visa type?

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,
Assistant Professor / Universitair Docent
Department Engineering Systems and Services

Informatie- en Communicatie Technologie (ICT)
 
TU Delft / Dept. ESS
Faculty of Technology, Policy and Management (TBM)
Building 31
Jaffalaan 5 - room B3.170
2628 BX  Delft
P.O.Box 5015
2600 GA Delft, The Netherlands
T +31 (0)15 27 85700
E  [email-masked]

Present: Monday t/m Friday

---

From: "Jiankang Yao" <[email-masked]>
Date: Thu, 6 Sep 2018 17:29:21 +0800

Hello,

German is on the list of "Summary of Countries and Territories entitled for Visa Exemption and Visa on Arrival to Thailand "
http://www.thaiembbeij.org/upload/downloads/pdf/visa/7_List-of-countries-cn.pdf 

You may just use the tourist visa. You are both a tourist and meeting man. It is easy.

Jiankang Yao

From: Tobias Fiebig
Date: 2018-09-06 16:41

Met vriendelijke groet,

Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 6 Sep 2018 11:34:16 +0200

Tobias:

How does Amsterdam (Thai embassy ?) "insist" that you need a Type-B visa ?
E.g.: what exactly did they tell you ? Just the usual "if you do
business you need a busienss visa" that Jake mentioned ?

Maybe fill out the form on:

https://www.businesseventsthailand.com/about-us/contact-us/

and tell them you want to attend a conference in thailand and
your embassy is giving you answers that are different from what
TCEb writes in its web page:

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Jeff Haas <[email-masked]>
Date: Thu, 6 Sep 2018 09:50:39 +0000

> On Sep 6, 2018, at 01:57, Jakob Heitz (jheitz) <jheitz=[email-masked]> wrote:
> 
> https://urldefense.proofpoint.com/v2/url?u=http-3A__www.asianlii.org_th_legis_consol-5Fact_taota1979337_&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=T-sa37bq-QjZoC4jLQ0QAtNyQAPQqGdTNBvhTirOBqc&m=WKh2tSIuZNODPuDlzIrPmgYBrEqjFJX61BvBNsC8TiI&s=EBIb_cqlekX4cyIFs48pIrEsuGi93RwCPVwx0iib1Bs&e=

I don't argue any of these points.  That said, the advice I've listened to over the years is to keep my conversation with immigration very simple:
1. I am here to attend the X conference or Y meeting.
2. I am not being paid by anyone in this country to do 1.

The second point is usually where the argument of "doing work" comes up.  

Whether the first point comes up as "doing business" or the second point comes up as "doing work in this country" is often left to the interpretation of the immigration officer. Thus far, it hasn't.  I simply stay honest with those points with the possible expectation that I might be denied entry at the whim of the person I'm speaking to.  It's a good reason to have the emergency contact information for your employer's travel agency on hand.

-- Jeff

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 6 Sep 2018 12:06:18 +0200

After THNIC contacted the Thai embassy in Budapest, the very same 
officer sad,  I will get the visa based on the original letter of 
invitation.

regards Balazs

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 10:48:16 +0000

Hello Toerless,
The consulate, actually. I called them yesterday and they were like "Type-B!". Then, after some research, I wrote a mail asking them again (citing businesseventsthailand and the Helsinki embassy) which lead to a rather shroff response of "we already told you that you need a type b".

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

-----Original Message-----
From: Toerless Eckert <[email-masked]> 
Sent: Thursday, September 6, 2018 11:34 AM
To: Tobias Fiebig <[email-masked]>
Cc: [email-masked]
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

Tobias:

How does Amsterdam (Thai embassy ?) "insist" that you need a Type-B visa ?
E.g.: what exactly did they tell you ? Just the usual "if you do business you need a busienss visa" that Jake mentioned ?

and tell them you want to attend a conference in thailand and your embassy is giving you answers that are different from what TCEb writes in its web page:

Cheers
    Toerless

On Thu, Sep 06, 2018 at 08:41:34AM +0000, Tobias Fiebig wrote:
> Assistant Professor / Universitair Docent Department Engineering 
> Systems and Services
> 
> Faculty of Technology, Policy and Management (TBM) Building 31 

--
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 6 Sep 2018 12:55:39 +0200

Thanks, Tobias

sounds like:

"We have Type-B visa to sell, don't expect us to tell you about
 these free 'visa wwaiver' products from the competition
 that have us fear about our jobs"

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 10:59:16 +0000

Hello Toerless,
Yeah, but me sounding like "yeah, I kind of got arrested in Thailand, help" is also not really something I'd be looking forward to. Unless we get a somewhat authoritative answer on this matter, I will go with assuming a Type B is necessary.

The question now is whether I can get the required documents from my university and THNic in time. Otherwise, I might have to skip this meeting. -.-'

P.S.: The contact form of businesseventsthailand.com does not work. Timeout when submitting the filled form.

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 11:01:53 +0000

> You may just use the tourist visa. You are both a tourist and meeting man. It is easy.

Well, it is for tourism purposes only, and the consulate claims that attending IETF is not tourism.

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS
Faculty of Technology, Policy and Management (TBM)
Building 31
Jaffalaan 5 - room B3.170
2628 BX  Delft
P.O.Box 5015
2600 GA Delft, The Netherlands
T +31 (0)15 27 85700
E  mailto:[email-masked]

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 6 Sep 2018 13:05:16 +0200

You could try what I did. Ask via the registrar that THNIC should 
contact the embassy and smooth out the visa process.

regards Balazs

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 11:11:22 +0000

Well, before that, I will have to collect all necessary documents for the type B, which is relatively hard. They want--among other things; only listing what will be difficult to get in time--to see the following [0]:

- A letter from a company in the Netherlands stating the objective of the visit to Thailand and a copy of valid passport or European ID card of the person who signs a signature in the letter
- A letter of invitation from companies qualified to employ foreigners  and a copy of Thai ID card or valid passport and working permit (for foreigner) of the person who signs a signature in the letter
- Employment contract indicating rationale for employing the applicant as well as his/her salary, position and qualifications (document must be signed by authorized managing director and affixed the seal of the company)
- Copy of corporate documents from the company in Thailand; namely 1) list of shareholders 2) business registration and business license 3) company profile 4) details of business operation 5) list of foreign workers stating names, nationalities and positions 6) map indicating the location of the company 7) Balance sheet, statement of Income Tax and Business Tax (Por Ngor Dor 50 and Por Ngor Dor 30) of the latest year 8) Alien income tax return (Por Ngor Dor 91) and 9) Value-added tax registration (Por Ngor Dor 20) , etc.
- Copy of corporate documents from the company in the Netherlands; namely 1) list of shareholders 2) business registration and business license 3) company profile 4) details of business operation

[0] http://www.royalthaiconsulateamsterdam.nl/index.php/en/visa-service/non-immigrant-visa-english 

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

-----Original Message-----
From: Balazs Lengyel <[email-masked]> 
Sent: Thursday, September 6, 2018 1:05 PM
To: Tobias Fiebig <[email-masked]>; Toerless Eckert <[email-masked]>
Cc: [email-masked]
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

You could try what I did. Ask via the registrar that THNIC should contact the embassy and smooth out the visa process.

regards Balazs

---

From: Roni Even <[email-masked]>
Date: Thu, 6 Sep 2018 14:14:32 +0300

and this list shows that you do not needneed type b visa, you do not have
an employer in Thailand.

On Thu, Sep 6, 2018, 14:11 Tobias Fiebig <[email-masked]> wrote:

> Well, before that, I will have to collect all necessary documents for the
> type B, which is relatively hard. They want--among other things; only
> listing what will be difficult to get in time--to see the following [0]:
>
> - A letter from a company in the Netherlands stating the objective of the
> visit to Thailand and a copy of valid passport or European ID card of the
> person who signs a signature in the letter
> - A letter of invitation from companies qualified to employ foreigners
> and a copy of Thai ID card or valid passport and working permit (for
> foreigner) of the person who signs a signature in the letter
> - Employment contract indicating rationale for employing the applicant as
> well as his/her salary, position and qualifications (document must be
> signed by authorized managing director and affixed the seal of the company)
> - Copy of corporate documents from the company in Thailand; namely 1) list
> of shareholders 2) business registration and business license 3) company
> profile 4) details of business operation 5) list of foreign workers stating
> names, nationalities and positions 6) map indicating the location of the
> company 7) Balance sheet, statement of Income Tax and Business Tax (Por
> Ngor Dor 50 and Por Ngor Dor 30) of the latest year 8) Alien income tax
> return (Por Ngor Dor 91) and 9) Value-added tax registration (Por Ngor Dor
> 20) , etc.
> - Copy of corporate documents from the company in the Netherlands; namely
> 1) list of shareholders 2) business registration and business license 3)
> company profile 4) details of business operation
>
> [0]
> http://www.royalthaiconsulateamsterdam.nl/index.php/en/visa-service/non-immigrant-visa-english
>
> Met vriendelijke groet,
>
> Dr.-Ing. Tobias Fiebig,
> You could try what I did. Ask via the registrar that THNIC should contact
> the embassy and smooth out the visa process.
>
> regards Balazs
>
> > Yeah, but me sounding like "yeah, I kind of got arrested in Thailand,
> help" is also not really something I'd be looking forward to. Unless we get
> a somewhat authoritative answer on this matter, I will go with assuming a
> Type B is necessary.
> >
> > The question now is whether I can get the required documents from my
> university and THNic in time. Otherwise, I might have to skip this meeting.
> -.-'
> >

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 11:17:18 +0000

So... this might just be me--coming from Germany with its associated buerocracy fetish--but I presume that the "employer" parts then reflect to the closest organization to that, which I have: THNic as sponsoring organization for the meeting. 

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 11:21:39 +0000

Found a mail account to mail to... mailbox full. So,... their website might simply be outdated.

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

-----Original Message-----
From: 102attendees <[email-masked]> On Behalf Of Tobias Fiebig
Sent: Thursday, September 6, 2018 12:59 PM
To: Toerless Eckert <[email-masked]>
Cc: [email-masked]
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

Hello Toerless,

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,
Assistant Professor / Universitair Docent Department Engineering Systems and Services

TU Delft / Dept. ESS
Faculty of Technology, Policy and Management (TBM) Building 31 Jaffalaan 5 - room B3.170
2628 BX  Delft
P.O.Box 5015
2600 GA Delft, The Netherlands
T +31 (0)15 27 85700
E  [email-masked]

---

From: Balazs Lengyel <[email-masked]>
Date: Thu, 6 Sep 2018 13:37:30 +0200

I was told I need a "non-immigrant visa" not a type B visa. My
whole point was that by getting THNIC to call the embassy and
explain, your list of documents should get shorter.

For me they accepted the visa application with

my passport

application form

the 2 versions of the LOI available from IETF

photos

a letter from my employer documenting that I am working

proof that I have flight tickets to and from Thailand

proof of my hotel accommodation

regards Balazs

On 9/6/2018 1:11 PM, Tobias Fiebig
wrote:

Met vriendelijke groet,

Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

-----Original Message-----
From: Balazs Lengyel <[email-masked]>
Sent: Thursday, September 6, 2018 1:05 PM
To: Tobias Fiebig <[email-masked]>; Toerless Eckert <[email-masked]>
Cc: [email-masked]
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

regards Balazs

Hello Toerless,

Met vriendelijke groet,

Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 11:41:21 +0000

Hello Balazs,
The "type b" is short for "non-immigrant visa for conducting business (Type B)". ;-)

I will wait for the registrar to get back to me/them check with THNic what they can do.

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

---

From: Roni Even <[email-masked]>
Date: Thu, 6 Sep 2018 15:24:04 +0300

they are asking for employment contract , are you being contracted to work
forfor thnic?

On Thu, Sep 6, 2018, 14:17 Tobias Fiebig <[email-masked]> wrote:

> So... this might just be me--coming from Germany with its associated
> buerocracy fetish--but I presume that the "employer" parts then reflect to
> the closest organization to that, which I have: THNic as sponsoring
> organization for the meeting.
>
> Met vriendelijke groet,
>
> Dr.-Ing. Tobias Fiebig,

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 12:31:01 +0000

No; Of course I am not. Still, I expect to have to provide something which is as close to this as possible; For the case at hand I presume that the invitation letter+remaining documents might be sufficient, but let's see.

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

---

From: Vittorio Bertola <[email-masked]>
Date: Thu, 6 Sep 2018 14:45:01 +0200 (CEST)

> Il 6 settembre 2018 alle 12.48 Tobias Fiebig <[email-masked]> ha scritto:
> 
> 
> Hello Toerless,

You may now have the additional problem that they cannot back up from their initial statement without losing their face on how well they are doing their job, which is a serious problem in cultures that are not as direct as central-northern European ones. Maybe you did it and it did not work, but perhaps it could have worked better if you had formulated the initial question in a way that suggested the answer you were expecting, mentioning since the beginning that other reputable sources had told you so (so that, to give you a different answer, they would have needed to openly refute those sources and create undesirable conflict), and including a polite acknowledgement of the help you needed from them. 

This said, often in these situations a third party intervention by a local can go a long way - the local will know how to best approach them to ask for some kind understanding of the situation, and will also figure out how to give them an acceptable reason to say, without losing their face, that things now have changed and so they can give you the answer you need. It will even be easier if the local has some kind of authority and official status, as it will allow them to offload their responsibilities if someone later complained that they should not have given you the answer you want.

In practice: at the point you are, I don't think they will ever tell you that a tourist visa is ok, but IMHO some kind of intervention by the Thai organizers, offering to support them in dealing with your case but also politely reminding them that this is an important international conference and there are national authorities that would like to see it go well, could get them to substantially reduce the amount of pickiness in accepting whatever documents you can realistically give them. Though of course I would trust the judgement of any Thai person on this matter much more then I trust mine :-)

Regards,
-- 

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked]
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 6 Sep 2018 15:09:20 +0200

The problem is that the business of embassies is to sell Visas,
so they are not interested in figuring out the correct rules for visa
waiver options. And more fundamentally, they could very likely not
guarantee that you would be allowed to enter on a visa waiver even
if they tried to clarify the rules. Then again, they could also not
guarantee that you will be permitted into the country on a visa they
issue. 

-- 
---
[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Thu, 06 Sep 2018 09:13:48 -0400

Everyone, especially everyone who is giving advice to others
about whether a tourist visa works and anyone inclined to take
such advice without doing their own evaluation...

Please read George's note carefully.  Please read Andrew
Sullivan's explanation on the IETF list of why IAOC could not
give more specific guidance and should not try.   And read my
earlier comments, and those of others, about decisions at the
borders.  

I have been to Thailand several times and have found their
border police/ immigration officers considerably more courteous
and reasonable than those of several countries where the IETF
has met without a big fuss.  YMMV depending on a whole series of
factors, possibly including bad luck.

Note that there has been advice on this thread that I believe to
be seriously bad, e.g., that a business visa is not needed if
one's company does not have offices in Thailand.  If the company
does and you might be stopping by those offices, a business visa
would probably be good insurance against time-consuming and
unpleasant misunderstandings.  Whether it or was required could
be something you might find out only after the fact (or, if you
get one, not at all).  But, if you come in with a tourist visa
and then give a talk to your company's customers or try to sell
products, "my company doesn't have offices there" would probably
provide little help even if those activities are very much
incidental to IETF attendance.  

That actually points to another problem: most countries will
tolerate some small percentage of business activity if you are
on a tourist visa and its is clear that your primary purpose is
tourism.  However, almost no country will give a clear answer to
questions about the maximum percentage and how they measure it,
nor a clear answer as to whether spending a week in meeting
rooms gets the same rating for "clearly tourism" as, e.g., lying
on a beach soaking up the local sunshine.  So, whether that
information is of any use at all depends on your risk aversion
(see below).

Individual circumstances will also differ for reasons not
mentioned here.  Let me try an example that is certainly not
limited to Thailand: If the IETF schedule included something
like bits-and-bytes, and I worked for a company that was
planning to exhibit and discuss a product there, I'd be afraid
to show up at the meeting on a tourist visa rather than a
business one.  I'd have similar concerns if my company were a
meeting sponsor, an executive of the company were planning to
give a talk, and that talk might sound like a product pitch.
The odds of my getting into trouble in most countries, most
days, if I were not personally involved in those types of
activities are fairly low.  But consider the loss function: if I
did get into trouble, or if my status were questioned beyond a
question or two at the airport, the odds of my being really
unhappy  are astronomical.  

As another example of an individual situation, there are
countries I'd feel comfortable entering on a tourist visa while
bringing a standard commercial tablet or laptop but a lot less
comfortable while carrying a few circuit boards and a Raspberry
Pi kit or two... especially so if I didn't speak the local
language well enough to explain what the latter were and what I
intended to do with them.  We think of those sorts of things as
customs issues, but they can be visa status issues as well.  

That is the one bit of advice I would give and that I've hinted
about before: if, after looking at assorted web sites and trying
to understand the conflicting advice, you find yourself confused
and anxious about what category you should be in, go for a
business visa.  I have never heard of anyone being put in jail
for arriving on a business visa and then going to a meeting that
didn't really require it or doing a little tourist stuff.
People do go to jail, or get unceremoniously ejected, for
representing themselves as tourists only to have the country
decide they are something else.  

Actually a second bit, following up one of George's comments: if
you are on record as criticizing the royal family, or even the
morals, religion or eating habits of a country's leadership,
think carefully about how they deal with that sort of that sort
of dissent, and whether you want to go there at all, independent
of visa category.  Again, there is little in that advice that is
specific to Thailand.

If you are inclined to take either of those bits of advice,
remember what you paid for them and that I make no claim to
expertise about any situation not identical to my own.

But let's not drag this discussion out further: it appears to me
to be adding almost no signal to the noise.  YMMD about that to;
if it does, I suppose you should go for it.

best,
   john

--On Thursday, September 6, 2018 16:20 +1000 George Michaelson
<[email-masked]> wrote:

> A friend got permission to travel to the US for a health
> related conference, as an Iranian, resident in Australia, and
> working in a non-nuclear field. She even got to the door of
> the conference and the registration desk before somebody
> realised the university housed a nuclear reactor, and
> therefore by definition she should have been denied entry for
> this  specific meeting. She wound up being personally directed
> off campus, escorted back to LAX, and sat with until outside
> the US border until she could be flown home, hugely
> embarrassing for her personally, and the conference, who
> risked defaulting on US embargo rules which are otherwise
> strictly enforced.
> 
> The moral of the story, (because this is on topic) is that you
> should *never* trust a website associated with a conference or
> meeting to correctly describe your personal immigration
> status, right of entry, visa obligations. They cannot know
> everything about you.
> 
> Have you ever insulted the Thai royal family in print or
> online? You are strongly advised not to go to Thailand as
> imprisonment may offend (you). Is this discussed on the visa
> page?
> 
> Folks, the IETF information is at best advisory: They cannot
> guarantee you will get entry, even if you wave the letter of
> invitation. "it depends"
>...

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 6 Sep 2018 15:38:30 +0200

On Thu, Sep 06, 2018 at 09:13:48AM -0400, John C Klensin wrote:
> give more specific guidance and should not try. 

Can you provide message-IDs or the like ? I could not find either
after you mentioned them the first time around. Alas, google does
not even seem to index the mailing list archive... Or i am just
incapable to do the right search.

> decide they are something else.  

Any example for Thailand you can point to ?

Btw: Not sure if this could happen in thaling, but another degree
of border confusion (entering USA in this case):

You have a B1 Visa to conduct business for the USA. The actual
admission state to the USA is NOT the visa itself, but whatever
the border agent may scribble/include in the admission stamp:
how long you can stay AND your admission state. So for whatever
reason (like tiredness) the border agent put B2 into the stamp.
Then you come to the business' company offices, they check the
stamp and see its not a B1 stamp, and then they won't let you
attend the business meeting and/or have someone rush off to the
airport to get the stamp fixed/upgraded to B1/B2.

> or even the ... eating habits of a country's leadership,

Are you suggesting americans to stop obsessing about their
leaderships eating habbits and find something less fun to waste
their time on ?

http://newsfeed.time.com/2011/06/03/what-the-fork-trump-explains-why-he-used-utensils-with-his-pizza/

> if it does, I suppose you should go for it.

I feel that continue to learn new good insights from this thread,
you explanations included.

Chers
    Toerless

-- 
---
[email-masked]

---

From: Cj Aronson <[email-masked]>
Date: Thu, 6 Sep 2018 08:06:53 -0600

I found this site that specifically says conferences are not considered
business..

-----Cathy

{Ô,Ô}
  (( ))
  ◊  ◊

On Tue, Sep 4, 2018 at 4:30 AM, Artyom Gavrichenkov <[email-masked]>
wrote:

> Probably the only place where you're going to trade something for
> something is actually the whisky BoF.
>
>>> they found the invitation letter lacking. They sent me a 23 page template
>>> in Thai language that the invitation letter should follow.
>>>
>> *Ori Finkelman *Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189
>> | [email-masked]
>>
>> --

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Thu, 06 Sep 2018 11:09:49 -0300

The honorary consul of the Kingdom of Thailand in Uruguay is of the same 
opinion, conferences are not business.

So far I’m betting for my tourist status.

S2

/Carlos

On 6 Sep 2018, at 11:06, Cj Aronson wrote:

>>>> template

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Thu, 6 Sep 2018 23:01:03 +0800

Is it an overly optimistic idea to bring someone from the host to the
thread and ask them for advice? A host proposing an event in their country
must have known about the visa regulations beforehand.

I'm perfectly aware there are complicated scenarios out there which the
host may not know how to handle, but the case of a EU citizen coming to the
proposed international event looks rather straightforward and typical for
me.

---

From: Jim Reid <[email-masked]>
Date: Thu, 6 Sep 2018 16:15:34 +0100

On 6 Sep 2018, at 16:01, Artyom Gavrichenkov <[email-masked]> wrote:
> 
> Is it an overly optimistic idea to bring someone from the host to the thread and ask them for advice?

Yes. It’s utterly impractical to expect anyone to provide advice on visa issues which will or won’t apply to everyone going to an IETF meeting. See the earlier comments by Andrew Sullivan and John Klensin. Everybody has to make their own decisions about this and get definitive advice specific to their individual circumstances from the relevant embassy/consulate. It’s that simple.

Further discussion on this topic/thread is just pointless noise. It’s time to shut it down.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 6 Sep 2018 15:23:29 +0000

Always, interesting / entertaining this list ;-)

I have been multiple times in Thailand for business meetings with customers in my employer' local office while obviously being paid by my employer (Belgian contract) with my Belgian passport. I never needed a visa. So, I will try the same thing this time.

Entry in any country is heavily depending on the immigration officer in some cases... ranging from a smiling welcome to more trouble :-O

See you in Bangkok (or not...)

-éric (not a lawyer just hoping that history is an indicator of the future)

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Thu, 6 Sep 2018 23:27:08 +0800

"Further discussion on this topic/thread is just pointless noise"

Sorry, it's not. There's already a lot of valuable information in this
thread regarding actual visa processing cases, and more is to come.

чт, 6 сент. 2018 г., 23:15 Jim Reid <[email-masked]>:

> thread and ask them for advice?
>
> Yes. It’s utterly impractical to expect anyone to provide advice on visa
> issues which will or won’t apply to everyone going to an IETF meeting. See
> the earlier comments by Andrew Sullivan and John Klensin. Everybody has to
> make their own decisions about this and get definitive advice specific to
> their individual circumstances from the relevant embassy/consulate. It’s
> that simple.
>

---

From: Michael StJohns <[email-masked]>
Date: Thu, 6 Sep 2018 12:45:00 -0400

Yup - found this as well.   If you read the article and then google for 
"Memo of Office of the Council of State No. 152/2556 thailand" to find:

http://www.pricesanond.com/knowledge/visas-and-work-permits/new-exemptions-to-thailands-urgent-work-permit-requirements.php 
- a lawyer interpreting above and indicating in response to the issuance 
of that document that
> the Office of Foreign Workers Administration of the Department of 
> Labor (Office of Foreign Workers) issued new guidelines providing that 
> a work permit is not required for the following activities:
>
>   * attending a conference or seminar
>   * attending an exhibition or trade show
>   * attending a business visit or business negotiation
>   * attending an academic lecture
>   * attending a training course or technical seminar
>   * purchasing goods at a trade show
>

YMMV.  I couldn't find the "new guidelines" document mentioned above, 
only this summary of it.

Mike

On 9/6/2018 10:06 AM, Cj Aronson wrote:
> I found this site that specifically says conferences are not 
> considered business..
>

---

From: Ilpo Järvinen <[email-masked]>
Date: Thu, 6 Sep 2018 20:21:30 +0300 (EEST)

Hi,

I've digged more into this using the legislation reference numbers and 
finally came across even more recent amendment than what you're refering 
to:
  https://www.bakermckenzie.com/en/insight/publications/2018/04/new-amendments-to-the-work-permit-law

I'm yet to find the actual text for it instead of the interpretation on 
that webpage but luckily it seems to finally settle it for good (From 
what I gathered elsewhere, in the earlier legislation there was a word 
trap that "attending" something did not including the right to present 
there and the latter might have required to apply for a work permit(!) 
besides the B visa).

--
 i.

On Thu, 6 Sep 2018, Michael StJohns wrote:

> http://www.pricesanond.com/knowledge/visas-and-work-permits/new-exemptions-
> to-thailands-urgent-work-permit-requirements.php - a lawyer interpreting
> above and indicating in response to the issuance of that document that
>       the Office of Foreign Workers Administration of the Department
>       of Labor (Office of Foreign Workers) issued new guidelines
>       providing that a work permit is not required for the following
>       activities:
>        o  attending a conference or seminar
>        o  attending an exhibition or trade show
>        o  attending a business visit or business negotiation
>        o  attending an academic lecture
>        o  attending a training course or technical seminar
>        o  purchasing goods at a trade show
> 
> 
> YMMV.  I couldn't find the "new guidelines" document mentioned above, only
> this summary of it.

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Fri, 7 Sep 2018 01:58:18 +0800

I have decided it's a good idea to be more explicit regarding this
piece. Answers inline,

> See the earlier comments by Andrew Sullivan

...which no one to date has bothered to give a hyperlink to (though
Mr. Eckert and me have both kindly asked for that quite a few times).

The best direction on where to look for those comments was: "Andrew
Sullivan's explanation on the IETF list". Nah. Never knew there's only
one mailing list in the IETF.

> and John Klensin.
> Everybody has to make their own decisions about this and get definitive advice specific to their individual circumstances from the relevant embassy/consulate. It’s that simple.

Sorry, but it is *not* that simple.

Though I'm somewhat younger and definitely less experienced than you,
I've lived most of my life under a citizenship which pretty much
doesn't get you a visa waiver in most of the countries out there, and
I have a different view over this one.

With all due respect to all the countries in the world, for *most* of
them, it is *not* possible to get a definitive advice from a consulate
or embassy. Sometimes the [visa] regulations are vague and unclear.
Sometimes, on the other hand, they are overly strict and the consulate
is afraid of assigning too much of permissions to you. Sometimes, the
consulate doesn't know much about those regulations at all and is just
acting according to their own common sense.

Each time you face it, it's one-on-one. The other side might be too
strict or too permissive. The more information you have, the more
definitive facts you're able to bring into play — the more chances you
have to ask the right questions and convince the other side to settle
on a decision which is best to you.

> Yes. It’s utterly impractical to expect anyone to provide advice on visa issues which will or won’t apply to everyone going to an IETF meeting.

Repeating once again: "I'm perfectly aware there are complicated
scenarios out there which the host may not know how to handle, but the
case of a EU citizen coming to the proposed international event looks
rather straightforward and typical for me."

See? I wasn't speaking about "everyone" from the very beginning.

| Töma Gavrichenkov

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Fri, 7 Sep 2018 02:18:22 +0800

On Thu, Sep 6, 2018 at 9:14 PM John C Klensin <[email-masked]> wrote:
> I have never heard of anyone being put in jail

FYI: I've once spoken to a guy who was escorted from U.S. and denied
entry ever since for coming to see his relatives while his original
request was for a business visa (B1). He had been given a B1/B2 visa
(business+tourist, combined), then the original meeting he had applied
for a visa for had been cancelled, and he decided it's a good idea to
use the visa to visit his second cousin somewhere in the middle of
States.

The border control decided he'd been lying at the consulate interview
about his intentions before, and denied him entry. Not a jail yet,
right, but still pretty much unpleasant.

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 18:18:49 +0000

So, my reading is that this just solves the "work permit" part, and not the "Visa Type" question, does it?

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,

TU Delft / Dept. ESS

-----Original Message-----
From: 102attendees <[email-masked]> On Behalf Of Ilpo Järvinen
Sent: Thursday, September 6, 2018 7:22 PM
To: Michael StJohns <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [102attendees] Visa problems - need a different invitation letter

Hi,

I've digged more into this using the legislation reference numbers and finally came across even more recent amendment than what you're refering
to:
  https://www.bakermckenzie.com/en/insight/publications/2018/04/new-amendments-to-the-work-permit-law

I'm yet to find the actual text for it instead of the interpretation on that webpage but luckily it seems to finally settle it for good (From what I gathered elsewhere, in the earlier legislation there was a word trap that "attending" something did not including the right to present there and the latter might have required to apply for a work permit(!) besides the B visa).

--
 i.

On Thu, 6 Sep 2018, Michael StJohns wrote:

> Yup - found this as well.   If you read the article and then google 
> for "Memo of Office of the Council of State No. 152/2556 thailand" to find:
> 
> http://www.pricesanond.com/knowledge/visas-and-work-permits/new-exempt
> ions- to-thailands-urgent-work-permit-requirements.php - a lawyer 
> interpreting above and indicating in response to the issuance of that 
> document that

---

From: Robert Wilton <[email-masked]>
Date: Fri, 7 Sep 2018 10:18:20 +0100

Hi Artyom,

I presume that Andrew's email is probably this one:
https://mailarchive.ietf.org/arch/msg/ietf/v_vECz7MtHUiMfu7INCh9VmJSKc

Or, otherwise this query makes it fairly easy to see other likely 
candidate emails:
https://mailarchive.ietf.org/arch/browse/ietf/?q=Andrew#

Personally I'm not inclined to apply for work visa, it seems a bit 
arduous, so the choice I'm trying to decide between is do I travel on 
the tourist visa-waver, or do I skip this meeting.

FWIW, my current conclusion of this thread (traveling from the UK) is 
that a tourist visa/visa-waver is sufficient, but I would need to be 
careful about what I say when entering, along the lines of what Mehmet 
suggested previously, i.e. attending a technical conference, etc.

I've never been to Thailand before, so may also tack a couple of extra 
days of tourism on the end anyway.

Regards,
Rob

---

From: Christian Hopps <[email-masked]>
Date: Fri, 07 Sep 2018 07:01:22 -0400

+1

I have to admit this thread has made me wonder if I should skip this one. I'll probably go, but I'm not going to go through all the hassle of getting a work-visa. I guess I'm risking being turned around at the border, which is annoying given it takes more than 24 hours of travel for me to get there.

Thanks,
Chris.

---

From: Lawrence M <[email-masked]>
Date: Fri, 7 Sep 2018 14:21:16 +0300

Hi guys,
The Embassy informed me that for any conference, training, i have to apply
for a Non-Immigrant VISA and not the Tourist visa.

-- 
with kind regards
Muchilwa Lawrence
Solutions Engineer

---

From: Heinrich Singh <[email-masked]>
Date: Fri, 7 Sep 2018 14:28:35 +0300

Hello Lawrence,

Can you tell which embassy was this. Where is it located so that others can
benefit from this information.

Ciao
Heinrich

On Fri, 7 Sep 2018 at 14:22, Lawrence M <[email-masked]> wrote:

> On Tue, Sep 4, 2018 at 11:30 AM Balazs Lengyel <
>> Mobile: +36-70-330-7909              email: [email-masked]
>> <[email-masked]>
>>
>> --

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 7 Sep 2018 14:05:22 +0200

Kenya ?

-- 
---
[email-masked]

---

From: Lawrence M <[email-masked]>
Date: Sun, 9 Sep 2018 18:35:41 +0300

This is the embassy in Kenya.

Regards,
Muchilwal Lawrence,
Systems Solutions Architect

On Fri, Sep 7, 2018, 2:28 PM Heinrich Singh <[email-masked]> wrote:

> Hello Lawrence,
>
> Can you tell which embassy was this. Where is it located so that others
> can benefit from this information.
>
> Ciao
> Heinrich
>
>> The Embassy informed me that for any conference, training, i have to
>> apply for a Non-Immigrant VISA and not the Tourist visa.
>>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 11 Sep 2018 16:44:51 +0000

I was planning on doing the same (tourist visa waiver)  but then a Canadian colleague sent this response from Thai embassy in Canada (FYI).

===================================================

Sent: September 6, 2018 10:15 AM
Subject: visas
 
for those who travel to Thailand for business purposes, attend conferences you will need to apply for a Non-Immigrant visa and send the following to the Embassy:
 
- original passport (no copies)
- one visa application filled out completely and singed
 
- one photo Canadian passport size and stamped in the back from the store purchased from
 
- either an official letter from your office addressed to the Embassy or invitation letter from Thailand stating that you will attend a meeting conference. the letter must mention your name and nationality
 
- visa fee $100.- in Canadian funds, money order only payable to the "Royal Thai Embassy"
 
- a prepaid express post envelop must be included for the return of your passport.

On 2018-09-07, 5:18 AM, "102attendees on behalf of Robert Wilton" <[email-masked] on behalf of rwilton=[email-masked]> wrote:

    Hi Artyom,

    

    
    Regards,
    Rob

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 11 Sep 2018 16:56:43 +0000

I had a similar experience for Buenos Aires (although one person at one Argentinian consulate finally did verbally say that a conference isn't considered "business"). Nobody at the embassy is really motivated to try and find a way to confirm that a visa isn't required so they'll just say to get one to avoid any risk.  Maybe one is actually needed but personally I doubt it.

Everyone has their own circumstances, but it is really a shame that we (IETF as an organization) can't get a definitive statement from the Thai authorities (i.e. in writing that we can all print & bring) that attending this conference is not considered as "business" by Thailand.  That would save a lot of grief (and same was true for Buenos Aires and will be true for many future IETFs).

Jason

> From: 102attendees <[email-masked]> On Behalf Of Reshad
> Rahman (rrahman)
> Sent: Tuesday, September 11, 2018 12:45 PM
> To: Robert Wilton <rwilton=[email-masked]>; Artyom
> Gavrichenkov <[email-masked]>; [email-masked]
> Cc: 102attendees <[email-masked]>
> I was planning on doing the same (tourist visa waiver)  but then a Canadian
> colleague sent this response from Thai embassy in Canada (FYI).
> 
> for those who travel to Thailand for business purposes, attend conferences
> you will need to apply for a Non-Immigrant visa and send the following to the
> Embassy:
> 
> - either an official letter from your office addressed to the Embassy or
> invitation letter from Thailand stating that you will attend a meeting
> conference. the letter must mention your name and nationality
> 
> On 2018-09-07, 5:18 AM, "102attendees on behalf of Robert Wilton"
> <[email-masked] on behalf of
> rwilton=[email-masked]> wrote:
> 
>     Hi Artyom,
> 
>     >> Everybody has to make their own decisions about this and get definitive
> advice specific to their individual circumstances from the relevant
> embassy/consulate. It’s that simple.
> issues which will or won’t apply to everyone going to an IETF meeting.

---

From: Christian Hopps <[email-masked]>
Date: Tue, 11 Sep 2018 13:57:47 -0400

> Everyone has their own circumstances, but it is really a shame that we (IETF as an organization) can't get a definitive statement from the Thai authorities (i.e. in writing that we can all print &…

This sure would be nice. Just the simple declaration that attending the conference is not considered conducting business would be enough I think.

Thanks,
Chris.

---

From: "Marc Blanchet" <[email-masked]>
Date: Tue, 11 Sep 2018 14:01:46 -0400

On 11 Sep 2018, at 13:57, Christian Hopps wrote:

>> Everyone has their own circumstances, but it is really a shame that 
>> we (IETF as an organization) can't get a definitive statement from 
>> the Thai authorities (i.e. in writing that we can all print & bring) 
>> that attending this conference is not considered as "business" by 
>> Thailand.  That would save a lot of grief (and same was true for 
>> Buenos Aires and will be true for many future IETFs).
>
> This sure would be nice. Just the simple declaration that attending 
> the conference is not considered conducting business would be enough I 
> think.

+1

Marc.

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 Sep 2018 14:06:25 -0400

--On Tuesday, September 11, 2018 16:56 +0000 "Sterne, Jason
(Nokia - CA/Ottawa)" <[email-masked]> wrote:

>...
> Everyone has their own circumstances, but it is really a shame
> that we (IETF as an organization) can't get a definitive
> statement from the Thai authorities (i.e. in writing that we
> can all print & bring) that attending this conference is not
> considered as "business" by Thailand.  That would save a lot
> of grief (and same was true for Buenos Aires and will be true
> for many future IETFs).

First of all, this is not really about Thailand but about
general practices.  Your comments about Argentina reinforce
that.  Second, it could be "business" for some of us and not for
others, so, in the case of some countries and circumstances, the
answer may not be that the meeting is or is not "business" for
all participants.

It may well be a shame, and probably is, but the only times I'm
aware of getting that sort of guarantee (or clear and binding
statement) from a government (at least a government that has not
established a visa category for "standards body meeting" or
equivalent) is when the government is actually a sponsor of the
meeting.   There may well be exceptions (my experience is
definitely not comprehensive) but, by and large, what people
have been experiencing is fairly normal.   And, for whatever it
worth, there are actually reasons for it that, from the
perspective of the government, provide motivation to behave
exactly the way people, especially local consulates, are
behaving.  Those reasons go well beyond lack of motivation even
though, in some cases, that might be part of the picture too. 

Get the best information you can about your situation and people
holding passports (or other travel documents) from your country,
act as conservatively about it as you think appropriate, and
then go for it, hoping for the best and making whatever
contingency plans you think appropriate.  

If you need guarantees, especially guarantees you can enforce,
you are probably better off participating remotely.

   john

---

From: Philip Prindeville <[email-masked]>
Date: Tue, 11 Sep 2018 14:26:27 -0400

At the very least it raises the question of whether it’s worth having further IETF’s in Thailand.

-Philip

> On Sep 7, 2018, at 7:01 AM, Christian Hopps <[email-masked]> wrote:
> 
> 
> +1
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 11 Sep 2018 20:42:46 +0200

What type of interactions do the folks setting up IETF meetings have
with local authorities about this ? Why is it not possible to ask:

What is the best written guidance for attendees to our conference
whether or not your countries Visa Waiver program is sufficient to enter
the country if one is attending our conference ?

Since i raised this question firt before argentina, i have seen no one
from the meetings committee or the like provide any answer to this
question.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 11 Sep 2018 18:44:19 +0000

Hi John,

Whether an individual person needs a VISA is based on individual circumstances (origin country,etc).

But I think whether Thailand considers (typical) participation at IETF to be "business" vs "tourist" (or whatever categories Thailand uses) is the same for everyone and purely based on Thailand immigration authority determination of how they consider IETF attendance.

Why do you say it could be "business for some" and not for others ?  I think this thread is mainly concerned with the typical conference attendee.

Jason

> From: John C Klensin <[email-masked]>
> Sent: Tuesday, September 11, 2018 2:06 PM
> To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
> Cc: [email-masked]; 102attendees <[email-masked]>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 11 Sep 2018 20:52:50 +0200

> Why do you say it could be "business for some" and not for others ?  I think this thread is mainly concerned with the typical conference attendee.

One distinction of course is how you receive money for your conference
attendance. For example, it was not clear to me from the refernces to
thai law circulated on this thread why for example IETF secretariat
staff might need a visa if they would not need one (as per their
passport) if they where attendees. In both cases, you get paid by your
employer to be at the conference and perform likely your "normal" job chores.
But someone here on the thread suggested that IETF staff might need
visa. The way i read the information available, you would have to be
paid for by a thai source before you needed a work/business visa.

Maybe the real issue is that countries with Visa Waiver programs need
a contact specifically for those visa waiver programs. The consulates/
embassies have a clear conflict of interest and maybe are also
unqualified to provide Visa Waiver guidance.

Toerless

-- 
---
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Tue, 11 Sep 2018 12:27:47 -0700

Phillip,

> On Sep 11, 2018, at 11:26 AM, Philip Prindeville <[email-masked]> wrote:
> 
> Signed PGP part

As far as I can tell, the issue here is what kind of visa one needs (tourist or business).  It’s not about getting into the country at all.

This doesn’t seem like an issue that should keep the IETF from having another meeting in Thailand.

We wouldn’t be having any IETF meetings anywhere if there was a requirement like visas are not required for anyone.

Bob

---

From: "Jiankang Yao" <[email-masked]>
Date: Wed, 12 Sep 2018 09:08:28 +0800

From: Bob Hinden
Date: 2018-09-12 03:27
To: Philip Prindeville
CC: Christian Hopps; 102attendees; Robert Wilton; Bob Hinden; 103attendees; Artyom Gavrichenkov
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

>This doesn’t seem like an issue that should keep the IETF from having another meeting in Thailand.

Agree.  Thailand is a very friendly country. I have been there for international conferences many times.

Best Regards.
Jiankang Yao

---

From: Ludwig Seitz <[email-masked]>
Date: Wed, 12 Sep 2018 07:56:33 +0200

On 12/09/18 03:08, Jiankang Yao wrote:
> *From:* Bob Hinden <mailto:[email-masked]>
> *Date:* 2018-09-12 03:27
> *To:* Philip Prindeville <mailto:[email-masked]>
> *CC:* Christian Hopps <mailto:[email-masked]>; 102attendees 
> <mailto:[email-masked]>; Robert Wilton 
> <mailto:rwilton=[email-masked]>; Bob Hinden 
> <mailto:[email-masked]>; 103attendees 
> <mailto:[email-masked]>; Artyom Gavrichenkov 
> <mailto:[email-masked]>
> *Subject:* Re: [102attendees] [103attendees] Visa problems - need a 

Friendly for some definitions of friendly.

Thailand is a military dictatorship and if I'm not mistaken under 
martial law (source: 
https://en.wikipedia.org/wiki/National_Council_for_Peace_and_Order), so 
I for my part see very big issues with having IETF meetings there, 
notwithstanding the fact that they may treat tourists nicely.

Best regards,

Ludwig Seitz

-- 
Ludwig Seitz, PhD
Security Lab, RISE
Phone +46(0)70-349 92 51

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 12 Sep 2018 09:41:41 -0500

On Tue, Sep 11, 2018 at 11:57 AM Sterne, Jason (Nokia - CA/Ottawa) <
[email-masked]> wrote:

> I had a similar experience for Buenos Aires (although one person at one
> Argentinian consulate finally did verbally say that a conference isn't
> considered "business"). Nobody at the embassy is really motivated to try
> and find a way to confirm that a visa isn't required so they'll just say to
> get one to avoid any risk.  Maybe one is actually needed but personally I
> doubt it.
>
>
My recollection for Buenos Aires in March 2015 was, I did pay some money
and get a visa but right after there was a presidential visit from US to
Argentina and Argentina waived the visa requirement so I  did not need any
visa.

My suggestion is to go there as a tourist and try to get in.
If not successful, just arrange a few days in a Tai resort, possibly in
Phuket :)
There I guarantee, they would not turn you down.

Behcet

> Everyone has their own circumstances, but it is really a shame that we
> (IETF as an organization) can't get a definitive statement from the Thai
> authorities (i.e. in writing that we can all print & bring) that attending
> this conference is not considered as "business" by Thailand.  That would
> save a lot of grief (and same was true for Buenos Aires and will be true
> for many future IETFs).
>
> Jason
>
> > - visa fee $100.- in Canadian funds, money order only payable to the
> "Royal
> > Thai Embassy"
> >