Subject: [105attendees] Why do we need to go for 128 bits address space?

From: shyam bandyopadhyay <[email-masked]>
Date: Fri, 26 Jul 2019 19:58:33 +0530

To:    The entire IETF community

 Sub: Why do we need to go for 128 bits address space if
         whatever is been trying to achieve with the existing
         approach of IPv6, can be achieved by 64 bits address space?

Dear Folks,

 I raised this issue couple of time earlier. My intention
was to collect all the points in support of 128 bits address
space and try to figure out whether they can be solved
with 64 bits address space as well. I am thankful to
Mr. Suresh Krishnan for all the queries that he had. I
have shown that all the points that he had, can be solved
with 64 bits address space (Please follow a copy of my last mail
as an attachment with all the answers). I believe all the points
that were mentioned in the requirement specification of IPv6 can
be achieved with 64 bits address space as well. I would request
all the people mainly those who have been working with IPv6 for long
to come forward in favor of 128 bits address space that can not
be achieved with 64 bits address space.

 If it can be shown that 64 bits address space is good enough to
solve all the requirements, either we have to move back to 64 bits
address space in the future or we have to carry through this extra
burden for ever for no reason.

 I would request readers to go through draft-shyam-real-ip-framework
as a reference. It shows that if address space gets assigned to
customer networks based on their actual need (in contrast to
64 bits address space (at least) for any customer network in IPv6), 64 bits
address space is good enough for this world. Along with that, it comes up
with the following:

1. It shows how to make a transition from (NAT based) private IP
   space to (NAT free) real IP space.
2. It comes up with a light weight routing protocol applicable inside
   VLSM tree that satisfies all the features supported by BGP.
3. It come up with a simple protocol for Host Identification with Provider
   Independent Address with the approach of DNS. This can be considered
   as an alternative of existing protocol (HIP).
4. It comes up with a hierarchical distribution of network for the
   convenience of routing and distribution that may be considered
   as useful in the long run.

Hence, I would request all the like minded people to come forward
and look into this matter seriously.

Thanks.

---

From: Mike Bishop <[email-masked]>
Date: Fri, 26 Jul 2019 14:42:35 +0000

The attendees list is not an appropriate venue for a technical proposal. Perhaps you should present at HotRFC next time.

Sent from Nine<http://www.9folders.com/>
________________________________
From: shyam bandyopadhyay <[email-masked]>
Sent: Friday, July 26, 2019 10:29 AM
To: [email-masked]; [email-masked]
Subject: [105attendees] Why do we need to go for 128 bits address space?

Dear Folks,

Thanks.

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 26 Jul 2019 11:01:02 -0400

Take it to the general IETF list...

On 7/26/19 10:42 AM, Mike Bishop wrote:
> The attendees list is not an appropriate venue for a technical 
> proposal. Perhaps you should present at HotRFC next time.
>
> Sent from Nine <http://www.9folders.com/>
> ------------------------------------------------------------------------
> *From:* shyam bandyopadhyay <[email-masked]>
> *Sent:* Friday, July 26, 2019 10:29 AM
> *To:* [email-masked]; [email-masked]
> *Subject:* [105attendees] Why do we need to go for 128 bits address space?
>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Clemens Schrimpe <[email-masked]>
Date: Fri, 26 Jul 2019 17:18:43 +0200

Could it also be, that this train has left the station decade(s) ago? We aren‘t „going for 128bits address space“, we have 128 bits address space.

🤔

Clemens

PS: I can‘t read your word document. Could you transform it into a (current) open format, please?

Von meinem iPad gesendet

> Am 26.07.2019 um 16:28 schrieb shyam bandyopadhyay <[email-masked]>:
> 
> <prev_letter.txt.doc>
> 105attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/105attendees

---

From: Suresh Krishnan <[email-masked]>
Date: Fri, 26 Jul 2019 13:13:27 -0400

Hi all,
  Apologies for further spamming this list. Since my queries were specifically referenced I felt obliged to respond. In my view, 105attendees is not the appropriate venue for this technical discussion, and I have hence responded on the 6man WG mailing list with my original technical comments on this proposal from a year ago.

https://mailarchive.ietf.org/arch/msg/ipv6/ZjODueIaDUnHSbmq9Dmd9-pm5Yg

If you are interested in technical discussions on this topic, feel free to respond on the 6man mailing list.

Thanks
Suresh

> On Jul 26, 2019, at 11:01 AM, Robert Moskowitz <[email-masked]> wrote:
> 
>> From: shyam bandyopadhyay <[email-masked]> <mailto:[email-masked]>
>> To: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Robert Moskowitz
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked] <mailto:[email-masked]>
> 
> There's no limit to what can be accomplished if it doesn't matter who gets the credit
> --