Subject: RE: [16NG]I-DACTION:draft-ietf-16ng-ip-over-ethernet-over-802.16-01.txt

From: "Burcak Beser" <[email-masked]>
Date: Mon, 2 Apr 2007 11:16:09 -0700

Max, 

Since you agree with my first point now, let's look at the second point
before jumping into any conclusions:

What is the objective of the draft? Is this simply "(from the abstract)
transmission of IPv4 as well as IPv6 over Ethernet in a network
deploying the IEEE 802.16 cellular radio transmission technology" or
something more?

Regards,
-burcak

-----Original Message-----
From: Riegel, Maximilian [mailto:[email-masked]] 
Sent: Friday, March 23, 2007 12:02 PM
To: Burcak Beser
Cc: [email-masked]
Subject: RE:
[16NG]I-DACTION:draft-ietf-16ng-ip-over-ethernet-over-802.16-01.txt 

Burcak,

Downlink multicast and broadcast is not the issue, but how does this
work in the uplink direction?
Can you point me to the sections in the IEEE802.16 specification, where
I can find the details?

Bye
Max

-----Original Message-----
From: Burcak Beser [mailto:[email-masked]] 
Sent: Monday, March 19, 2007 3:01 AM
To: Riegel, Maximilian
Cc: [email-masked]
Subject: RE:
[16NG]I-DACTION:draft-ietf-16ng-ip-over-ethernet-over-802.16-01.txt 

Max,

I am not aware of anything missing in the 802.16 regarding downlink
broadcast and multicast data transmissions. Can you elaborate on what is
missing? 

Regards,
-burcak 

-----Original Message-----
From: Riegel, Maximilian [mailto:[email-masked]] 
Sent: Sunday, March 18, 2007 11:28 AM
To: Burcak Beser
Cc: [email-masked]
Subject: RE:
[16NG]I-DACTION:draft-ietf-16ng-ip-over-ethernet-over-802.16-01.txt 

Burcak,

First, even when there are examples out how to provide IP multicast and
broadcast on link layers providing uplink unicast and downlink
multicast, the IEEE802.16 specification does not provide the details how
to accomplish this over an 802.16 transport connection (... as stated in
the I-D). 

Second, I agree with you that there is not enough normative language in
this revision. More normative language is due for the next version when
we have established the right framework for it. When reviewing all the
comments on -00.txt we found that most of the comments were addressing
just clarifications on how the pieces are fitting together.

Bye
Max

-----Original Message-----
From: Burcak Beser [mailto:[email-masked]]
Sent: Saturday, March 17, 2007 1:08 AM
To: [email-masked]
Subject: RE:
[16NG]I-DACTION:draft-ietf-16ng-ip-over-ethernet-over-802.16-01.txt 

I have two basic issues before going into a detailed readout fo the
draft.

First, the draft states that (from section 5.2.) "Current IEEE 802.16
[IEEE802.16][IEEE802.16e] does not define any transport connection for
IP broadcast and multicast data." 

Even though it is true that the IEEE 802.16 MAC does not natively
support bi-directional broadcast domains, it is my understanding that
IEEE 802.16 has both broadcast and multicast downlink CID's defined,
which is being used effectively to transport IP broadcast and multicast
data on downlink direction for various deployments today. 

If the aim of the draft is "(from the abstract) transmission of IPv4 as
well as IPv6 over Ethernet in a network deploying the IEEE 802.16
cellular radio transmission technology", the subject is well researched
and there are many simpler schemes alrady deployed for this purpose on
systems where uplink is unicast and broadcast downlink exists. If there
are other implied requirements I would like to see them on a problem
statement section since these are beyond the published scope of this
draft.

Second, the use of minimal normative language with only one "SHOULD"
statement along with a single non-normative "shall" statement alludes to
the fact that it is possible and highly probable that various
implentations will not behave the same manner. One example is whether a
Proxy ARP (section 6.2.) is required or not; further where should it
reside?

It can further be said that the draft does not even meet its own purpose
of emulating broadcast domains for the purpose of IPv4 and IPv6
transmissions. The draft will be improved greately by the careful
addition of normative statements which would also make sure that all
implentations based on this draft will behave in a predictable manner.

Regards,
-burcak

_______________________________________________
16NG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/16ng

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 268.18.13/726 - Release Date:
3/18/2007 3:34 PM

_______________________________________________
16NG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/16ng

---

From: "Riegel, Maximilian" <[email-masked]>
Date: Thu, 5 Apr 2007 12:33:17 +0200

Burcak,

I am still missing the explanation how multicast and broadcast may work
in IEEE802.16? You mentioned multicast and broadcast CIDs, but they are
only available in downlink, and how to realize Ethernet behavior on top
of IEEE802.16? In the best case I can imagine some fragments, but no
complete picture.

Bye
Max

-----Original Message-----
From: Burcak Beser [mailto:[email-masked]] 
Sent: Monday, April 02, 2007 8:16 PM
To: Riegel, Maximilian
Cc: [email-masked]
Subject: RE:

Max, 

Regards,
-burcak

-----Original Message-----
From: Riegel, Maximilian [mailto:[email-masked]] 
Sent: Friday, March 23, 2007 12:02 PM
To: Burcak Beser
Cc: [email-masked]
Subject: RE:

Burcak,

Bye
Max

-----Original Message-----
From: Burcak Beser [mailto:[email-masked]] 
Sent: Monday, March 19, 2007 3:01 AM
To: Riegel, Maximilian
Cc: [email-masked]
Subject: RE:

Max,

Regards,
-burcak 

-----Original Message-----
From: Riegel, Maximilian [mailto:[email-masked]] 
Sent: Sunday, March 18, 2007 11:28 AM
To: Burcak Beser
Cc: [email-masked]
Subject: RE:

Burcak,

Bye
Max

-----Original Message-----
From: Burcak Beser [mailto:[email-masked]]
Sent: Saturday, March 17, 2007 1:08 AM
To: [email-masked]
Subject: RE:

Regards,
-burcak

---

From: "Junghoon Jee" <[email-masked]>
Date: Thu, 5 Apr 2007 21:59:29 +0900

Hello Max/Burcak,

That's right. Previously, there's no way to realize the Ethernet behavior
which provides bidirectional multicast and broadcast. That's why a sort of
bridging facility is required when using Ethernet CS between MS and AR in
802.16 links.

Junghoon

---

From: "Riegel, Maximilian" <[email-masked]>
Date: Thu, 5 Apr 2007 15:22:34 +0200

And the really tricky issue starts, if you like to define in detail how
a IEEE802.1D bridge fits to IEEE802.16. Usually you have to break the
Ethernet architecture model to make it working somehow.
 
Bye
Max

________________________________

From: ext Junghoon Jee [mailto:[email-masked]] 
Sent: Thursday, April 05, 2007 2:59 PM
To: Riegel, Maximilian
Cc: Burcak Beser; [email-masked]
Subject: Re:
[16NG]I-DACTION:draft-ietf-16ng-ip-over-ethernet-over-802.16-01.txt

Hello Max/Burcak,
 
That's right. Previously, there's no way to realize the Ethernet
behavior which provides bidirectional multicast and broadcast. That's
why a sort of bridging facility is required when using Ethernet CS
between MS and AR in 802.16 links.
 
Junghoon

	Burcak,
	
	I am still missing the explanation how multicast and broadcast
may work
	in IEEE802.16? You mentioned multicast and broadcast CIDs, but
they are 
	only available in downlink, and how to realize Ethernet behavior
on top
	of IEEE802.16? In the best case I can imagine some fragments,
but no
	complete picture.
	
	Bye
	Max
	
	-----Original Message-----
	From: Burcak Beser [mailto:[email-masked]]
	Sent: Monday, April 02, 2007 8:16 PM
	To: Riegel, Maximilian
	Cc: [email-masked]
	Subject: RE:

	Max,
	
	Since you agree with my first point now, let's look at the
second point
	before jumping into any conclusions:
	
	What is the objective of the draft? Is this simply "(from the
abstract)
	transmission of IPv4 as well as IPv6 over Ethernet in a network
	deploying the IEEE 802.16 cellular radio transmission
technology" or 
	something more?
	
	Regards,
	-burcak
	
	-----Original Message-----
	From: Riegel, Maximilian [mailto:[email-masked]]
	Sent: Friday, March 23, 2007 12:02 PM 
	To: Burcak Beser
	Cc: [email-masked]
	Subject: RE:

	Burcak,
	
	Downlink multicast and broadcast is not the issue, but how does
this 
	work in the uplink direction?
	Can you point me to the sections in the IEEE802.16
specification, where
	I can find the details?
	
	Bye
	Max
	
	-----Original Message-----
	From: Burcak Beser [mailto: [email-masked]
<mailto:[email-masked]> ]
	Sent: Monday, March 19, 2007 3:01 AM
	To: Riegel, Maximilian
	Cc: [email-masked]
	Subject: RE:

	Max,
	
	I am not aware of anything missing in the 802.16 regarding
downlink
	broadcast and multicast data transmissions. Can you elaborate on
what is
	missing?
	
	Regards,
	-burcak
	
	-----Original Message----- 
	From: Riegel, Maximilian [mailto:[email-masked]]
	Sent: Sunday, March 18, 2007 11:28 AM
	To: Burcak Beser
	Cc: [email-masked] 
	Subject: RE:

	Burcak,
	
	First, even when there are examples out how to provide IP
multicast and
	broadcast on link layers providing uplink unicast and downlink 
	multicast, the IEEE802.16 specification does not provide the
details how
	to accomplish this over an 802.16 transport connection (... as
stated in
	the I-D).
	
	Second, I agree with you that there is not enough normative
language in 
	this revision. More normative language is due for the next
version when
	we have established the right framework for it. When reviewing
all the
	comments on -00.txt we found that most of the comments were
addressing 
	just clarifications on how the pieces are fitting together.
	
	Bye
	Max
	
	-----Original Message-----
	From: Burcak Beser [mailto:[email-masked]]
	Sent: Saturday, March 17, 2007 1:08 AM
	To: [email-masked]
	Subject: RE:

	I have two basic issues before going into a detailed readout fo
the 
	draft.
	
	First, the draft states that (from section 5.2.) "Current IEEE
802.16
	[IEEE802.16][IEEE802.16e] does not define any transport
connection for
	IP broadcast and multicast data."
	
	Even though it is true that the IEEE 802.16 MAC does not
natively
	support bi-directional broadcast domains, it is my understanding
that
	IEEE 802.16 has both broadcast and multicast downlink CID's
defined,
	which is being used effectively to transport IP broadcast and
multicast 
	data on downlink direction for various deployments today.
	
	If the aim of the draft is "(from the abstract) transmission of
IPv4 as
	well as IPv6 over Ethernet in a network deploying the IEEE
802.16
	cellular radio transmission technology", the subject is well
researched 
	and there are many simpler schemes alrady deployed for this
purpose on
	systems where uplink is unicast and broadcast downlink exists.
If there
	are other implied requirements I would like to see them on a
problem 
	statement section since these are beyond the published scope of
this
	draft.
	
	Second, the use of minimal normative language with only one
"SHOULD"
	statement along with a single non-normative "shall" statement
alludes to 
	the fact that it is possible and highly probable that various
	implentations will not behave the same manner. One example is
whether a
	Proxy ARP (section 6.2.) is required or not; further where
should it
	reside? 
	
	It can further be said that the draft does not even meet its own
purpose
	of emulating broadcast domains for the purpose of IPv4 and IPv6
	transmissions. The draft will be improved greately by the
careful
	addition of normative statements which would also make sure that
all 
	implentations based on this draft will behave in a predictable
manner.
	
	Regards,
	-burcak