Subject: [16NG] IEEE 802.16 review on PS and Goal document

From: "Daniel Park" <[email-masked]>
Date: Fri, 14 Dec 2007 11:45:20 +0900

Junghoon,

This is another IEEE 802.16 expert review.

Thanks much Erik Colban...

Daniel Park
 ------------------------------

*From:* Erik Colban
*Sent:* Monday, October 15, 2007 11:30 AM
*To:* 'Johnston, DJ'
*Subject:* 16ng review

Hi DJ,

I haven't noticed any emails related to the 16ng ad-hoc. I have compiled the
following comments:

1)       The document is focused on the problem of configuring an IP subnet
over the 802.16 link. However, despite mentioning work done in NWG, the
draft does not address the case where IP packets are tunneled to and from a
Home Agent in the home or visited CSN. Problems that the draft focuses on
are not relevant in this case. The document should be clearer on which
deployment scenarios it is or is not addressing, or put into context the
scenario where the SS's IP address is assigned by a home network.

2)       The document mentions problems with PPP because there is no
Convergence Sublayer for PPP. However, GPCS was introduced in 802.16g to
avoid having to keep changing the 802.16 standard to introduce CS layers for
yet other protocols. In the early days of 16ng I was trying to push the
group to take GPCS into consideration and was then met with the argument
that 16g was not yet published. However, now that 16g has been approved by
the IEEE-SA Standards Board for publication (which happened on 9/27), 16ng
should reconsider the use of GPCS. When 16g actually becomes published, the
reference section should be updated to include a reference to the
802.16gamendment. GPCS is not only useful for the PPP link model, but
also when
classification at the BS is done based on the data path identifier (e.g.,
GRE key) used to tunnel packets between the BS and the ASN-GW.

3)       Section 4. "Overview of the IEEE 802.16-2004 MAC layer" states

"Each node in the network possesses a 48-bit MAC address (though in the Base
Station this 48-bit unique identifier is called "BSId")."

This statement is not correct. The BSId is not the BS MAC Address. The BS
may have a MAC Address different from the BSId to communicate with other
nodes on the backhaul. Unless the Ethernet CS is used, the BS MAC Address is
not known to the SS. Furthermore the section title should be changed to
"Overview of the IEEE 802.16 MAC layer", and the section should include
reference to 16e, and if possible, more generically to the latest published
version of the 802.16 standard including all published amendments.

Do you plan to set up another conference call, or should I just go ahead and
send my comments?

Erik
_______________________________________________
16NG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/16ng

---

From: "Junghoon Jee" <[email-masked]>
Date: Fri, 14 Dec 2007 15:34:55 +0900

Let me try to resolve the noted comments.

> 1)       The document is focused on the problem of configuring an IP subnet over the 802.16 link. However, despite mentioning work done in NWG, the draft does not address the case where IP 
>         packets are tunneled to and from a Home Agent in the home or visited CSN. Problems that the draft focuses on are not relevant in this case. The document should be clearer on which 
>         deployment scenarios it is or is not addressing, or put into context the scenario where the SS's IP address is assigned by a home network. 

About that mobility aspect, we may treat that after the currently charted work is finished.
Probably, we might touch that issue in line with the current discussion in MEXT WG regarding the home link operation of the MIP6 protocol.

> 2)       The document mentions problems with PPP because there is no Convergence Sublayer for PPP. However, GPCS was introduced in 802.16g to avoid having to keep changing the 802.16 
> standard to introduce CS layers for yet other protocols. In the early days of 16ng I was trying to push the group to take GPCS into consideration and was then met with the argument that 16g >was not yet published. However, now that 16g has been approved by the IEEE-SA Standards Board for publication (which happened on 9/27), 16ng should reconsider the use of GPCS. When >16g actually becomes published, the reference section should be updated to include a reference to the 802.16g amendment. GPCS is not only useful for the PPP link model, but also when 
> classification at the BS is done based on the data path identifier (e.g., GRE key) used to tunnel packets between the BS and the ASN-GW. 

Currently, our scope only touches IP CS and Ethernet CS. I am not saying the consideration of the GPCS is not required. Hopefully, we can touch that in the next round regarding the GPCS work is finalized more clearly in the 802.16 standard. AFAIK, the mentioned specification was decided as "not mandatory" during the sponsor ballot stage. 

> "Each node in the network possesses a 48-bit MAC address (though in the Base Station this 48-bit unique identifier is called "BSId")." This statement is not correct. The BSId is not the BS
 > MAC Address. The BS may have a MAC Address different from the BSId to communicate with other nodes on the backhaul. Unless the Ethernet CS is used, the BS MAC Address is not 
> known to the SS. Furthermore the section title should be changed to "Overview of the IEEE 802.16 MAC layer", and the section should include reference to 16e, and if possible, more generically > to the latest published version of the 802.16 standard including all published amendments. 

Okay, let me apply the following changes to reflect the comment about the MAC address.

From: 
Each node in the network possesses a 48-bit MAC address (though in the Base Station this 48-bit unique identifier is called "BSId").  
The BS and SS learn each others' MAC Address/BSId during the SS's entry into the network.

To:
Each SS in the network possesses a 48-bit MAC address. The Base Station possesses an 48-bit unique identifier called "BSId".  
The BS and SS learn each others' MAC Address/BSId during the SS's entry into the network.

About the comment of referencing all 802.16 specifications, previously we got a recommendation from DJ as our liaison to 802.16 of majorly referencing the base 802.16 specification through the document. Also, in line with that, I don't see the need to change the title of the section 3. Thankyou for the comments!

-Junghoon

----- Original Message ----- 
  From: Daniel Park 
  To: [email-masked] 
  Cc: 지정훈 ; [email-masked] 
  Sent: Friday, December 14, 2007 11:45 AM
  Subject: IEEE 802.16 review on PS and Goal document

  Junghoon, 

  Daniel Park 

------------------------------------------------------------------------------

  From: Erik Colban 
  Sent: Monday, October 15, 2007 11:30 AM
  To: 'Johnston, DJ'
  Subject: 16ng review

  Hi DJ,

  I haven't noticed any emails related to the 16ng ad-hoc. I have compiled the following comments:

  1)       The document is focused on the problem of configuring an IP subnet over the 802.16 link. However, despite mentioning work done in NWG, the draft does not address the case where IP packets are tunneled to and from a Home Agent in the home or visited CSN. Problems that the draft focuses on are not relevant in this case. The document should be clearer on which deployment scenarios it is or is not addressing, or put into context the scenario where the SS's IP address is assigned by a home network. 

  2)       The document mentions problems with PPP because there is no Convergence Sublayer for PPP. However, GPCS was introduced in 802.16g to avoid having to keep changing the 802.16 standard to introduce CS layers for yet other protocols. In the early days of 16ng I was trying to push the group to take GPCS into consideration and was then met with the argument that 16g was not yet published. However, now that 16g has been approved by the IEEE-SA Standards Board for publication (which happened on 9/27), 16ng should reconsider the use of GPCS. When 16g actually becomes published, the reference section should be updated to include a reference to the 802.16g amendment. GPCS is not only useful for the PPP link model, but also when classification at the BS is done based on the data path identifier (e.g., GRE key) used to tunnel packets between the BS and the ASN-GW. 

  "Each node in the network possesses a 48-bit MAC address (though in the Base Station this 48-bit unique identifier is called "BSId")." 

  This statement is not correct. The BSId is not the BS MAC Address. The BS may have a MAC Address different from the BSId to communicate with other nodes on the backhaul. Unless the Ethernet CS is used, the BS MAC Address is not known to the SS. Furthermore the section title should be changed to "Overview of the IEEE 802.16 MAC layer", and the section should include reference to 16e, and if possible, more generically to the latest published version of the 802.16 standard including all published amendments. 

  Do you plan to set up another conference call, or should I just go ahead and send my comments?

  Erik