Subject: [3gv6] IPv6 Transition Software on mobile platforms

From: "Ahmed Abu-Abed" <[email-masked]>
Date: Wed, 27 Jul 2011 15:37:53 +0300

Hello All,

How useful will it be to have IPv6 Transition software implementations done on mobile platforms ? For example, this could be implementing DS-Lite via software clients to get IPv4-in-IPv6.

I know DS-Lite software client is available on PCs, and I am trying to see if its useful to port it to mobile operating systems. Similar question for vice versa, is it useful to have software enabling of IPv6-in-IPv4, to rapidly bring up IPv6 with public addresses on mobile platforms (when only the network core is IPv6 ready) ?

Note that TR 23.975 "IPv6 Migration Guidelines" document mentions DS-Lite so there is interest in that migration concept, but it doesn't tackle rapid IPv6 deployment over IPv4 using IPv6-in-IPv4. For the latter there are TSP protocol soft clients (RFC 5572) implementations.

Regards,
-Ahmed

---

From: Hui Deng <[email-masked]>
Date: Wed, 27 Jul 2011 14:26:28 -0400

Just remind you that 3GPP has GTP  tunnel in GPRS/EPC which could be equal
to any tunneling like DS-Lite et al. which IETF are discussing here,
GI-DS-Lite is concatenate GTP tunneling with DS-Lite tunneling to CGN. but
any of them doesn't go to mobile host, maybe some implementation of
translation could be useful in the host.

-Hui

2011/7/27 Ahmed Abu-Abed <[email-masked]>

> **
> Hello All,
>
> How useful will it be to have IPv6 Transition software implementations done
> on mobile platforms ? For example, this could be implementing DS-Lite via
> software clients to get IPv4-in-IPv6.
>
> I know DS-Lite software client is available on PCs, and I am trying to see
> if its useful to port it to mobile operating systems. Similar question for
> vice versa, is it useful to have software enabling of IPv6-in-IPv4, to
> rapidly bring up IPv6 with public addresses on mobile platforms (when only
> the network core is IPv6 ready) ?
>
> Note that TR 23.975 "IPv6 Migration Guidelines" document mentions DS-Lite
> so there is interest in that migration concept, but it doesn't tackle rapid
> IPv6 deployment over IPv4 using IPv6-in-IPv4. For the latter there are TSP
> protocol soft clients (RFC 5572) implementations.
>
> Regards,
> -Ahmed
>
>
> _______________________________________________
> 3gv6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/3gv6
>
>

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 27 Jul 2011 11:48:26 -0700

Adding to what Hui said.

There is very little value building a DS Lite tunnel from the UE to the CGN.
Mobile architectures (PMIPv6/GTP) are based on tunneling techniques, with
clear semantics for carrying UE traffic with overlapping IP addressing. This
was discussed extensively last year and there is not much value seen for
this approach,  impacting the UE and  originating a tunnel from the UE to
CGN, in the mobile context.

Sri

On 7/27/11 11:26 AM, "Hui Deng" <[email-masked]> wrote:

> Just remind you that 3GPP has GTP  tunnel in GPRS/EPC which could be equal to
> any tunneling like DS-Lite et al. which IETF are discussing here, GI-DS-Lite
> is concatenate GTP tunneling with DS-Lite tunneling to CGN. but any of them
> doesn't go to mobile host, maybe some implementation of translation could be
> useful in the host.
>  
> -Hui
>  
>  
>  
>> I know DS-Lite software client is available on PCs, and I am trying to see if
>> its useful to port it to mobile operating systems. Similar question for vice
>> versa, is it useful to have software enabling of IPv6-in-IPv4, to rapidly
>> bring up IPv6 with public addresses on mobile platforms (when only the
>> network core is IPv6 ready) ?
>>  
>> Note that TR 23.975 "IPv6 Migration Guidelines" document mentions DS-Lite so
>> there is interest in that migration concept, but it doesn't tackle rapid IPv6
>> deployment over IPv4 using IPv6-in-IPv4. For the latter there are TSP

---

From: "Ahmed Abu-Abed" <[email-masked]>
Date: Thu, 28 Jul 2011 09:14:49 +0300

DS-Lite can be implemented in software on mobile hosts, and it is a solution to public IPv4 address shortage issues.

I can rephrase my question as how will the IPv4 public address shortage be solved without reverting to multi-level NATs for mobile networking ? Or is there no solution until all content moves to IPv6 (which will take a very long time) ?

Note that two way translation standards have been deprecated/removed by the IETF as they create more issues than they solve. One way translation, NAT64/DNS64 from and IPv6-only host to IPv4 content is a draft standard, but it presumes that the IPv4 stack is disabled on the terminal which may not be practical for now.

-Ahmed

From: Hui Deng 
Sent: Wednesday, July 27, 2011 9:26 PM
To: Ahmed Abu-Abed 
Cc: [email-masked] 
Subject: Re: [3gv6] IPv6 Transition Software on mobile platforms

Just remind you that 3GPP has GTP  tunnel in GPRS/EPC which could be equal to any tunneling like DS-Lite et al. which IETF are discussing here, GI-DS-Lite is concatenate GTP tunneling with DS-Lite tunneling to CGN. but any of them doesn't go to mobile host, maybe some implementation of translation could be useful in the host.

-Hui

  Hello All,

  Regards,
  -Ahmed

---

From: <[email-masked]>
Date: Thu, 28 Jul 2011 14:23:20 +0200

Hello,

The problem with this approach (DS-lite in the host) is that it would break the bearer model as described in TS 23.060 and 23.401 and would have big impact on PCC stuff.

Hope that helps,

Julien

De : [email-masked] [mailto:[email-masked]] De la part de Ahmed Abu-Abed
Envoyé : jeudi 28 juillet 2011 08:15
À : Hui Deng
Cc : [email-masked]
Objet : Re: [3gv6] IPv6 Transition Software on mobile platforms

-Ahmed

From: Hui Deng <mailto:[email-masked]>  

To: Ahmed Abu-Abed <mailto:[email-masked]>  

Cc: [email-masked] 

-Hui

	Hello All,

	Regards,

	-Ahmed