Subject: Re: [6lo] draft-kelsey-intarea-mesh-link-establishment (was Re: Focusing the charter)

From: Ralph Droms <[email-masked]>
Date: Mon, 8 Jul 2013 15:03:49 -0400

Richard - what is the state of this draft at present?

- Ralph

On Jun 17, 2013, at 2:51 PM 6/17/13, Richard Kelsey <[email-masked]> wrote:

>> From: Ulrich Herberg <[email-masked]>
>> Date: Fri, 14 Jun 2013 08:21:22 -0700
>> 
>> [...]
>> 
>> I am a bit concerned about
>> draft-kelsey-intarea-mesh-link-establishment, which I remember
>> I read when it was posted on the MANET mailing list. There were
>> some review comments that the same functionality could be
>> achieved with RFC6130 (NHDP). It may need further discussions
>> to see if there is a unique use case and if it's the best way
>> to achieve what is intended.
> 
> There was some confusion with the reviewers about the purpose
> of the draft, in particular that the link establishment operates
> below the routing layer.  I updated the draft to make this clearer.
> Here is the current abstract:
> 
>   This document defines the mesh link establishment (MLE) protocol for
>   establishing and configuring secure radio links in IEEE 802.15.4
>   radio mesh networks.  MLE extends IEEE 802.15.4 for use in multihop
>   mesh networks by adding three capabilities: 1) dynamically
>   configuring and securing radio links, 2) enabling network-wide
>   changes to radio parameters, and 3) detecting neighboring devices.
>   MLE operates below the routing layer, insulating it from the details
>   of configuring, securing, and maintaining individual radio links
>   within a larger mesh network.
> 
> Please send me any comments.
> 
>                                   -Richard Kelsey
> This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed and may contain information that is non-public, proprietary, privileged, confidential, and exempt from disclosure under applicable law or may constitute as attorney work product.  If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this communication in error, notify us immediately by telephone and (i) destroy this message if a facsimile or (ii) delete this message immediately if this is an electronic communication.  
> 
> Thank you.
> 
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: Richard Kelsey <[email-masked]>
Date: Wed, 10 Jul 2013 08:55:15 -0400

Ralph,

It has stalled.  From the datatracker history Ted Lemon is waiting
for something for me and from my email log I am waiting for something
from him.  I'll ping him and try to get get it moving again.

                                      -Richard

> From: Ralph Droms <[email-masked]>
> Date: Mon, 8 Jul 2013 15:03:49 -0400
> 

Thank you.