Subject: [6lo] No consensus to publish draft-ietf-6lo-lowpan-mib

From: Ulrich Herberg <[email-masked]>
Date: Wed, 14 May 2014 13:43:39 -0700

Hello,

the WGLC of draft-ietf-6lo-lowpan-mib has ended on April 28. On April
30, I asked for additional comments and indication of whether or not
to request publication for this draft. Given the lack of responses, it
is not possible for the chairs to determine consensus, and we can
therefore (currently) not proceed with publication, unless there is
further support from the WG to publish the draft.

One option is to discuss an information model first, before continuing
the work on a data model. We may also want to talk about the general
requirements for management of constrained nodes; I can only speculate
that maybe some participants feel that the current MIB module does not
fit their needs (e.g., in terms of constrainedness of the nodes). I am
interested in determining *how* we want/expect these low-powered
devices to be monitored/managed if WG participants feel that the
currently suggested approach is not the right one.

I realize that some of these discussions have been led in the COMAN
activity, so there could be some duplication. We will definitely have
time to discuss this issue in Toronto, but I encourage to have an open
discussion on the mailing list first.

Best regards
Ulrich

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 15 May 2014 08:23:37 +0000

Hi,

Taking into account the effort already invested in creating a data model, would it be appropriate to consider that instead of 'discussing the information model' we could publish the current document as a 'reference information model'? Before you ask - I am well aware about the differences between data models and information models as described in RFC 3444. I have seen however MIB modules published (some as Proposed Standard RFCs) but not implemented for SNMP agents - however the modeling effort was used in part or as a whole for other protocols or management access interfaces. It seems to me that the I-D could be published as an Informational RFC with a note reflecting the history of the effort and stating that although the MIB module could not get consensus to be used as a data model, the modeling work can be used as a reference information model. 

Regards,

Dan

> -----Original Message-----
> From: 6lo [mailto:[email-masked]] On Behalf Of Ulrich Herberg
> Sent: Wednesday, May 14, 2014 11:44 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [6lo] No consensus to publish draft-ietf-6lo-lowpan-mib
> 
> Hello,
> 
> the WGLC of draft-ietf-6lo-lowpan-mib has ended on April 28. On April 30, I
> asked for additional comments and indication of whether or not to request
> publication for this draft. Given the lack of responses, it is not possible for the
> chairs to determine consensus, and we can therefore (currently) not
> proceed with publication, unless there is further support from the WG to
> publish the draft.
> 
> One option is to discuss an information model first, before continuing the
> work on a data model. We may also want to talk about the general
> that maybe some participants feel that the current MIB module does not fit
> their needs (e.g., in terms of constrainedness of the nodes). I am interested
> in determining *how* we want/expect these low-powered devices to be
> monitored/managed if WG participants feel that the currently suggested
> approach is not the right one.
> 
> I realize that some of these discussions have been led in the COMAN activity,
> so there could be some duplication. We will definitely have time to discuss
> this issue in Toronto, but I encourage to have an open discussion on the
> mailing list first.
> 
> Best regards
> Ulrich
> 
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: Michael Richardson <[email-masked]>
Date: Thu, 15 May 2014 09:29:19 -0400

> further support from the WG to publish the draft.

I support publication of this document. Given the difficulty most WG have in
getting anyone to produce a data model, the fact that we've had ANY
discussion about it is support.

I don't think I've read the last version, but I know that I've reviewed
previous versions.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 15 May 2014 16:15:15 +0200

On 14 May 2014, at 22:43, Ulrich Herberg <[email-masked]> wrote:

> we can

I apologize for not paying much attention — I had thought that this document would be a safe bet for going forward.
Like Michael, I haven’t done a recent review of the spec, but I certainly agree with its principles.
We need a set of indicators on our constrained devices, and this set seemed good enough for determining the health of 6LoWPAN without overtaxing the devices.

Grüße, Carsten

---

From: Ulrich Herberg <[email-masked]>
Date: Thu, 15 May 2014 09:31:12 -0700

Hi Dan,

that's a good suggestion if there is no consensus to go standards
track. Thanks for pointing this out.

Best regards
Ulrich