Subject: [6lo] GHC plan

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 27 Jun 2014 23:56:30 +0100

Hi Ulrich,

I suggest the main plan is to discuss and answer questions related to
this WG draft.

It seems that the new draft -01 is making now approach clear to readers.
I am not sure of editor plan related to this draft. Regarding my review in
this WG, I usually need some answers to my questions if it is allowed.
Usually in WG meetings, why editors/chairs present WG drafts? IMHO the
first reason they present is to get interaction with the community, and to
answer questions, the last important reason of presenting is to get
volunteer reviewers.

On Wednesday, March 26, 2014, Ulrich Herberg wrote:

> Abdussalam,
>
> see below
>
>
> On Wed, Mar 26, 2014 at 2:42 AM, Abdussalam Baryun <
> [email-masked]> wrote:
>
>> I think the plan is not the WG plan but the draft is WG draft.
>
>
> I don't understand what you are saying here.
>

It was a reply comment to editor proposed plan on the list, but the
proposal did not mention it was a proposal, so that comment was needed.

>
>> IMHO,
>> the GHC plan for having draft-01 with only editorial updates is not
>> enough.
>
>
> Fair enough. But without any concrete non-editorial change requests, this
> sentence is not constructive. Just saying we need more discussions, without
> concrete suggestions what to change is not helpful
>

I still was not encouraged to review. I have posted questions for
discussion in past, related to scope. No respond from editors. Not
facilitating discussions/answers in WG is not constructive either.  I
thought that the chair or draft editors are able to answer to reviewers
needs.

> and will only delay the process without getting anywhere closer to
> publication.
>
>
>> The meeting plan included asking for more reviews. However, we
>> still have time before next meeting for discussions and reviews.
>>
>
> I do encourage everyone on the mailing list to review this draft (as well
> as all other WG drafts). Note that the GHC draft has been around for quite
> a while and presented multiple times in the 6lowpan WG.
>

I think 6lowpan WG is not active now, and its group is different than this
new working group. GHC is starting newly.

If it failed to be submitted in another WG, makes me worried more, why?

I do encourage editors to answer all questions to make reviewers able to
continue/complete their work. However, I will try to follow the chair and
do my review, but hope more answers.

I will review quickly the new draft-01 and if I need clarification I will
post here hoping for discussions to be positive and interactive with all
community without discrimination.

AB

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 30 Jun 2014 21:56:02 +0200

Hi Abdussalam,

Ulrich was kind enough to trace back the emails and extract some questions for me that I can actually try to answer.

> 1) Why is there no applicability section, or use case section?

Because nobody wrote one.
If the WG wants one, they’d have to tell me what it wants in there.
Upon first reading your comment, I was waiting for other people in the WG to possibly chime in here with some specifics, but that hasn’t happened, so I didn’t see a need for action.

> 2) What is the draft main scope (there is mentioned some purpose of
> the draft contribution in introduction but not sure of the scope)?

I don’t know what the fine point between applicability and scope is here.
Anyway, we don’t usually have formal scope sections in IETF specifications (unlike, say, the scope sections in ISO documents).

> and
> is the solution proposed the best solution, or was it tested to be
> better solution for such problem?

I wouldn't usually try for the “best solution”.
There has been some discussion on protocol quality in the two mailing lists.
I’m not going to summarize that discussion in some simple text, because it is a complicated issue.
Imagine trying to answer to the exact same question for, say, RFC 793.

Keying on “better”, there are two things that probably are worth optimizing here:
1) the bit allocation in the byte code.  As the draft says, Sebastian Dominik has examined this (and, I might add, surprisingly my initial hunch turns out to have been better than a number of variations he tried).
2) the static dictionary.  As I said repeatedly, this is a bit haphazard, but it seems to work well the way it is with the corpus at http://svn.tools.ietf.org/svn/wg/6lowpan/packets

Thomas Björklund made another great suggestion for optimizing (by simplifying some more), which is in the recent draft.

So it seems simple to me:
— Author's view: good enough, and a number of reviewers seemed to agree.
— unless the WG wants to improve things (or decides the whole thing is no longer worth the effort), we are done.

> It mentions that it is a short draft, I don't think so. Please remove
> describing the size of the draft, because in future it may develop and
> become larger.”

The specification is short, not the entirety of the draft any more (it is interesting to look at the page count over time since 2010-10-18 for a spec that essentially has become *simpler* since the first draft!); as you can see I had already updated that word in the abstract of the most recent draft.

Grüße, Carsten