Subject: [6lo] I-D Action: draft-ietf-6lo-btle-03.txt

From: [email-masked]
Date: Mon, 01 Sep 2014 01:52:20 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IPv6 over Networks of Resource-constrained Nodes Working Group of the IETF.

        Title           : Transmission of IPv6 Packets over BLUETOOTH(R) Low Energy
        Authors         : Johanna Nieminen
                          Teemu Savolainen
                          Markus Isomaki
                          Basavaraj Patil
                          Zach Shelby
                          Carles Gomez
	Filename        : draft-ietf-6lo-btle-03.txt
	Pages           : 17
	Date            : 2014-09-01

Abstract:
   Bluetooth Smart is the brand name for the Bluetooth low energy
   feature in the Bluetooth specification defined by the Bluetooth
   Special Interest Group.  The standard Bluetooth radio has been widely
   implemented and available in mobile phones, notebook computers, audio
   headsets and many other devices.  The low power version of Bluetooth
   is a specification that enables the use of this air interface with
   devices such as sensors, smart meters, appliances, etc.  The low
   power variant of Bluetooth is standardized since the revision 4.0 of
   the Bluetooth specifications, although version 4.1 or newer is
   required for IPv6.  This document describes how IPv6 is transported
   over Bluetooth low energy using 6LoWPAN techniques.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6lo-btle/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-6lo-btle-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-6lo-btle-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Mon, 1 Sep 2014 08:58:26 +0000

Hi,

Here are some updates ref. discussion earlier about possibly conflicting device addresses, link-local address configuration, and DAD optimizations.

Also added clarification that IPv6 packets are sent in network byte order, even though Bluetooth LE protocols utilize little-endian byte ordering (Bluetooth specifications say that byte ordering of L2CAP payload is "application specific" and hence we can have network byte order for IPv6 traffic).

Right after uploading I noticed a too early change of "will publish" to "has published"... i.e. there is no IPSP document available for public yet.

Best regards,

	Teemu

-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of ext [email-masked]
Sent: 1. syyskuuta 2014 11:52
To: [email-masked]
Cc: [email-masked]
Subject: [6lo] I-D Action: draft-ietf-6lo-btle-03.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
6lo mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lo