Subject: [6lo] 6lo Interoperability

From: "van de Logt, Marco" <[email-masked]>
Date: Fri, 12 Sep 2014 07:32:59 +0000

Dear colleagues,

I had a short chat with Samita on 6lo interoperability and the suggestion was to share this with the WG
for comments and interest.

Since 6lo handles multiple L2 technologies  - two things are important –
1) interoperability among the 6lo devices
2) A bridge or GW device that connect the multiple technologies.

There is the plan to have an IETF plugfest in March timeframe.

On the other side there are activities ongoing in e.g.

-          ETSI http://<http://www.etsi.org/news-events/events/663-2013-6lowpan-plugtests>www.etsi.org/news-events/events/663-2013-6lowpan-plugtests<http://www.etsi.org/news-events/events/663-2013-6lowpan-plugtests>
which is using IEEE 802.15.4 bearer, but seems to be open to use other PHY/MAC combinations.
So, could most probably somehow be aligned with point 1 above.

-          For the DRAFT http://datatracker.ietf.org/doc/draft-ietf-6lo-dect-ule/ the http://www.ulealliance.org/
is currently discussing certification possibilities (where I am involved), which are related to point 1

-          HGI (Home Gateway initiative) is to my best understanding dealing with “Device Abstraction”
concepts, which may fits to the point 2 mentioned above

-          Most probably there are add. activities ongoing for the other L2 technologies like BT-LE, NFC, … which
I am currently not aware of.

So the question to the group, what´s your views/knowledge/interest on interop activities?

Thanks
Marco van de Logt

---

From: <[email-masked]>
Date: Fri, 12 Sep 2014 12:46:36 +0000

Hi,

I can confirm that there are actions ongoing with IPv6 over BLE, and hence quite likely there would be interest for these kind of tests.

I’m not sure how many GW devices there are/will be in near future that support multiple different low-power radios.. but wouldn’t it be enough for interoperability testing if IPv6 packets from each low-power radio were forwarded first, say, to a 802.3/802.11 link that probably is commonly supported uplink by gateways of low-power networks.  I.e. topology could be such that for every low-power radio there would be a GW that works between the low-power radio and 802.3 (802.11) network, and packets between low-power networks would just be forwarded over this well-supported link type?

Best regards,

Teemu

From: 6lo [mailto:[email-masked]] On Behalf Of ext van de Logt, Marco
Sent: 12. syyskuuta 2014 10:33
To: [email-masked]
Cc: van de Logt, Marco
Subject: [6lo] 6lo Interoperability

Dear colleagues,

Thanks
Marco van de Logt

---

From: "van de Logt, Marco" <[email-masked]>
Date: Thu, 25 Sep 2014 12:03:33 +0000

Hi Teemu,

sorry for late response.

Do you have some more details on “actions ongoing with IPv6 over BLE”?

Regarding your GW statement, I agree simple bridges to e.g. 802.3 (802.11) network could be used!

Best regards
Marco

Von: [email-masked] [mailto:[email-masked]]
Gesendet: Freitag, 12. September 2014 14:47
An: van de Logt, Marco; [email-masked]
Betreff: RE: 6lo Interoperability

Hi,

Best regards,

Teemu

From: 6lo [mailto:[email-masked]] On Behalf Of ext van de Logt, Marco
Sent: 12. syyskuuta 2014 10:33
To: [email-masked]<mailto:[email-masked]>
Cc: van de Logt, Marco
Subject: [6lo] 6lo Interoperability

Dear colleagues,

Thanks
Marco van de Logt