Subject: Re: [6lo] Is 16-bit addressing out? (Re: RFC 4944bis anyone ?)

From: Randy Turner <[email-masked]>
Date: Mon, 08 Sep 2014 17:58:45 -0400

I don't know if it's a prevailing opinion, but it's something we have to deal with and there are warnings about using them in one or more drafts/rfcs, and rfc 770 seems to prefer them by my reading, plus we deploy AMI networks for which we would like to reduce the possibility of address changes - it just seems like an eui64 and a more secure option for slaac would be sufficient

Randy

Sent from my Verizon Wireless 4G LTE smartphone

-------- Original message --------
From: Carsten Bormann <[email-masked]> 
Date:09/08/2014  5:26 PM  (GMT-05:00) 
To: "Turner, Randy" <[email-masked]> 
Cc: [email-masked] 
Subject: [6lo] Is 16-bit addressing out? (Re:  RFC 4944bis anyone ?) 

On 08 Sep 2014, at 19:05, Turner, Randy <[email-masked]> wrote:

> - It would be nice if we could rely on interface identifiers based on EUI-64, and a more secure version - it would be nice if we could deprecate the use of 15.4 short addressing...the transient nature of these addresses seems to aggravate an already pressing issue with nodes in the LLN changing their IP address frequently.

This made me curious — is a need to deprecate short (16-bit) addresses a widely held opinion?
I’m hearing this view for the first time.

Grüße, Carsten

_______________________________________________
6lo mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lo

---

From: "Turner, Randy" <[email-masked]>
Date: Mon, 8 Sep 2014 22:01:07 +0000

In my last email I meant to reference rfc 6775...not 770

That'll teach me to use a cell phone for replies

Randy

-------- Original message --------
From: Randy Turner <[email-masked]>
Date:09/08/2014 5:58 PM (GMT-05:00)
To: Carsten Bormann <[email-masked]>, "Turner, Randy" <[email-masked]>
Cc: [email-masked]
Subject: RE: [6lo] Is 16-bit addressing out? (Re: RFC 4944bis anyone ?)

Randy

-------- Original message --------

> - It would be nice if we could rely on interface identifiers based on EUI-64, and a more secure version - it would be nice if we could deprecate the use of 15.4 short addressing...the transient nat…

This made me curious - is a need to deprecate short (16-bit) addresses a widely held opinion?
I'm hearing this view for the first time.

Gr??e, Carsten

P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.