Subject: [6lo] Call for Adoption for draft-thubert-6lo-routing-dispatch

From: Gabriel Montenegro <[email-masked]>
Date: Tue, 17 Nov 2015 20:06:40 +0000

All,

This starts a 6lo Working Group adoption call for the following draft:

A Routing Header Dispatch for 6LoWPAN

https://datatracker.ietf.org/doc/draft-thubert-6lo-routing-dispatch/

This draft solves a problem for ROLL, namely that of compression of RPL artifacts. It also appears to be extensible enough that it could be useful for other scenarios, especially after discussions at IETF 93 in Prague (context switch approach) and confirmation at IETF 94 in Yokohama.

This document is intended as standards-track.

Please send your opinion ("Yes" or "No") to the mailing list on adopting this document as a 6lo WG document.

This call will end at 00:00 UTC on December 1, 2015.

Regards,

Chairs

---

From: Samita Chakrabarti <[email-masked]>
Date: Wed, 18 Nov 2015 07:06:07 +0000

As a WG member, I support the adoption of this document.

With chair hat on - after adoption it would be good to make a decision whether we should split the document into two. One for generic non-ESC dispatch specification and the 2nd one is for RPL specific definition of the non-ESC dispatch. That way, in future any 6lo usecase that wants to use the non-ESC dispatch specification can follow the generic document.

Regards,
-Samita

From: Gabriel Montenegro [mailto:[email-masked]]
Sent: Tuesday, November 17, 2015 12:07 PM
To: [email-masked]
Cc: Samita Chakrabarti
Subject: Call for Adoption for draft-thubert-6lo-routing-dispatch

All,

Regards,

Chairs

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 19 Nov 2015 17:02:50 +0000

Dear Samita:

I agree that the split is a good idea. That way, ROLL can concentrate on the compression of the RPL artifacts themselves while 6lo has more focus on the paging mechanism.

Cheers,

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of Samita Chakrabarti
Sent: mercredi 18 novembre 2015 08:06
To: Gabriel Montenegro <[email-masked]>; [email-masked]
Subject: Re: [6lo] Call for Adoption for draft-thubert-6lo-routing-dispatch

Regards,
-Samita

All,

Regards,

Chairs

---

From: Laurent Toutain <[email-masked]>
Date: Fri, 27 Nov 2015 13:42:46 +0100

Hi,

I'm approve the adoption, this will give more flexibility to manage
information specific to a LoWPAN network.

Laurent

On Tue, Nov 17, 2015 at 9:06 PM, Gabriel Montenegro <
[email-masked]> wrote:

> This draft solves a problem for ROLL, namely that of compression of RPL
> artifacts. It also appears to be extensible enough that it could be useful
> for other scenarios, especially after discussions at IETF 93 in Prague
> (context switch approach) and confirmation at IETF 94 in Yokohama.
>
>
>
>
> Please send your opinion (“Yes” or “No”) to the mailing list on adopting
> this document as a 6lo WG document.
>
>
>
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>
>

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 30 96 6312    | Tel: + 33 2 99 12 7026                 | Visit
:
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 27 Nov 2015 14:20:44 +0000

I support the adoption,

This draft makes a difference in the size of data packets in a RPL LLN, which translates impact positively the energy consumption, the delivery ratio and the available payload size.

Cheers,

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of Gabriel Montenegro
Sent: mardi 17 novembre 2015 21:07
To: [email-masked]
Cc: Samita Chakrabarti <[email-masked]>
Subject: [6lo] Call for Adoption for draft-thubert-6lo-routing-dispatch

All,

Regards,

Chairs

---

From: "S.V.R.Anand" <[email-masked]>
Date: Mon, 30 Nov 2015 18:36:51 +0530

Hi Pascal,

I certainly support the adoption even with respect to the upcoming 6tisch WG
activities since bit savings are desirable in LLNs. Thanks a lot for the 
draft!

There could however be one view that, as we are predominantly moving towards
centralized routing and scheduling based architecture, managed through PCE
installed routes and tracks, the role of distributed routing may somewhat be
diminished. This is not imply RPL goes away as there are always going to be
scenarios to carry IP traffic. The counter argument for this line of 
argument
is that if the soft cells left at LLN's disposal are indeed going to be at
premium, why not these be better utilized ? The draft is going to be 
extremely
useful. What do you say ?

Anand

-------- Forwarded Message --------
Subject:     Re: [Roll] Call for Adoption for
draft-thubert-6lo-routing-dispatch
Date:     Fri, 27 Nov 2015 14:20:44 +0000
From:     Pascal Thubert (pthubert) <[email-masked]>
Reply-To:     Routing Over Low power and Lossy networks <[email-masked]>
To:     Gabriel Montenegro <[email-masked]>, Routing
Over Low power and Lossy networks <[email-masked]>
CC:     Samita Chakrabarti <[email-masked]>,
[email-masked] <[email-masked]>

I support the adoption,

This draft makes a difference in the size of data packets in a RPL LLN,
which translates impact positively the energy consumption, the delivery
ratio and the available payload size.

Cheers,

Pascal

All,

This draft solves a problem for ROLL, namely that of compression of RPL
artifacts. It also appears to be extensible enough that it could be
useful for other scenarios, especially after discussions at IETF 93 in
Prague (context switch approach) and confirmation at IETF 94 in Yokohama.

Please send your opinion (Yes or No) to the mailing list on adopting
this document as a 6lo WG document.

Regards,

Chairs

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: Ana Minaburo <[email-masked]>
Date: Mon, 30 Nov 2015 14:40:11 +0100

Hello,

I support the adoption of this draft as a 6lo WG document, It is important
to reduce the number of bytes send in the LLN's. Thanks for this work

There are one thing to be discussed about the same values used for the IPv6
datagram in page 0 and page 1. Perhaps it could be enough to separate the
information of the dispatches in each pages without have the information
twice. It is only necessary to make a distinction between MESH 10xxxxxx and
RH could be allocated, so you can use page 0 when Mesh is not present.

The general idea of this draft is totally in accordance what it is need in
the lowpan networks.

Ana

On Mon, Nov 30, 2015 at 2:06 PM, S.V.R.Anand <[email-masked]>
wrote:

> Please send your opinion ( Yes  or  No ) to the mailing list on adopting

---

From: "S.V.R.Anand" <[email-masked]>
Date: Mon, 30 Nov 2015 21:20:19 +0530

Hi Pascal,

I agree with your points and thanks for the reference !

Anand

On Monday 30 November 2015 05:44 PM, Pascal Thubert (pthubert) wrote:
> Hello Anand;
>
> At ROLL, we are discussing how the PCE could compute routes and use RPL signaling to install them (https://tools.ietf.org/html/draft-thubert-roll-dao-projection).
> This is independent of whether there is a TSCH network or not. If there is none, we do not benefit from the cell reservation and the associated deterministic properties, but we can still optimize the path based on constraints from a centralized perspective, and we still need 6loRH for packets.
>
> Actually, the 6TiSCH architecture suggests (unless we change that in the future) that even for tracks, if the packet inside the track is an IP packet, then there is an RPI HbH option indicates the flow.
>
> Cheers,
>
> Pascal
>
>
>> -----Original Message-----
>> From: S.V.R.Anand [mailto:[email-masked]]
>> Sent: lundi 30 novembre 2015 12:09
>> To: Pascal Thubert (pthubert) <[email-masked]>
>> Cc: [email-masked]
>> Subject: Fwd: Re: [Roll] Call for Adoption for draft-thubert-6lo-routing-dispatch
>>
>> Hi Pascal,
>>
>> activities since bit savings are desirable in LLNs. Thanks a lot for the draft!
>>
>> There could however be one view that, as we are predominantly moving
>> towards centralized routing and scheduling based architecture, managed
>> through PCE installed routes and tracks, the role of distributed routing may
>> somewhat be diminished. This is not imply RPL goes away as there are always
>> going to be scenarios to carry IP traffic. The counter argument for this line of
>> argument is that if the soft cells left at LLN's disposal are indeed going to be at
>> premium, why not these be better utilized ? The draft is going to be extremely
>> This draft makes a difference in the size of data packets in a RPL LLN, which
>> translates impact positively the energy consumption, the delivery ratio and the
>> available payload size.
>>
>>
>>
>> Cheers,
>>
>>
>>
>> Pascal
>>
>>
>>
>> artifacts. It also appears to be extensible enough that it could be useful for other
>> scenarios, especially after discussions at IETF 93 in Prague (context switch
>> approach) and confirmation at IETF 94 in Yokohama.
>>
>>
>>
>> Please send your opinion (Yes or No) to the mailing list on adopting this
>> document as a 6lo WG document.
>>
>>
>>

---

From: "S.V.R.Anand" <[email-masked]>
Date: Mon, 30 Nov 2015 15:00:16 +0530

Dear All,

I support the adoption!

Anand

On Friday 27 November 2015 07:50 PM, Pascal Thubert (pthubert) wrote:
>
> I support the adoption,
>
> This draft makes a difference in the size of data packets in a RPL 
> LLN, which translates impact positively the energy consumption, the 
> delivery ratio and the available payload size.
>
> Cheers,
>
> Pascal
>
> *From:* 6lo [mailto:[email-masked]] *On Behalf Of *Gabriel 
> Montenegro
> *Sent:* mardi 17 novembre 2015 21:07
> *To:* [email-masked]
> *Cc:* Samita Chakrabarti <[email-masked]>
> *Subject:* [6lo] Call for Adoption for draft-thubert-6lo-routing-dispatch
>
> All,
>
> This draft solves a problem for ROLL, namely that of compression of 
> RPL artifacts. It also appears to be extensible enough that it could 
> be useful for other scenarios, especially after discussions at IETF 93 
> in Prague (context switch approach) and confirmation at IETF 94 in 
> Yokohama.
>
> Please send your opinion (“Yes” or “No”) to the mailing list on 
> adopting this document as a 6lo WG document.
>
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>
>
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll