Subject: Re: [6lo] [Roll] Call for Adoption for draft-thubert-6lo-routing-dispatch

From: Robert Cragie <[email-masked]>
Date: Wed, 2 Dec 2015 12:00:25 +0000

Sorry for the late response - I also agree that a split would be a good
idea.

Robert

On 19 November 2015 at 17:02, Pascal Thubert (pthubert) <[email-masked]>
wrote:

> Dear Samita:
>
>
>
> I agree that the split is a good idea. That way, ROLL can concentrate on
> the compression of the RPL artifacts themselves while 6lo has more focus on
> the paging mechanism.
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* 6lo [mailto:[email-masked]] *On Behalf Of *Samita
> Chakrabarti
> *Sent:* mercredi 18 novembre 2015 08:06
> *To:* Gabriel Montenegro <[email-masked]>; [email-masked]
> *Subject:* Re: [6lo] Call for Adoption for
> draft-thubert-6lo-routing-dispatch
>
>
>
> As a WG member, I support the adoption of this document.
>
>
>
> With chair hat on – after adoption it would be good to make a decision
> whether we should split the document into two. One for generic non-ESC
> dispatch specification and the 2nd one is for RPL specific definition of
> the non-ESC dispatch. That way, in future any 6lo usecase that wants to use
> the non-ESC dispatch specification can follow the generic document.
>
>
>
> Regards,
>
> -Samita
>
>
>
> *From:* Gabriel Montenegro [mailto:[email-masked]]
> *Sent:* Tuesday, November 17, 2015 12:07 PM
> *To:* [email-masked]
> *Cc:* Samita Chakrabarti
> *Subject:* Call for Adoption for draft-thubert-6lo-routing-dispatch
>
>
>
> All,
>
>
>
> This starts a 6lo Working Group adoption call for the following draft:
>
>
>
> A Routing Header Dispatch for 6LoWPAN
>
> https://datatracker.ietf.org/doc/draft-thubert-6lo-routing-dispatch/
>
>
>
> This draft solves a problem for ROLL, namely that of compression of RPL
> artifacts. It also appears to be extensible enough that it could be useful
> for other scenarios, especially after discussions at IETF 93 in Prague
> (context switch approach) and confirmation at IETF 94 in Yokohama.
>
>
>
>
> This document is intended as standards-track.
>
>
>
> Please send your opinion (“Yes” or “No”) to the mailing list on adopting
> this document as a 6lo WG document.
>
>
>
> This call will end at 00:00 UTC on December 1, 2015.
>
>
>
> Regards,
>
> Chairs
>
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
>

---

From: Gabriel Montenegro <[email-masked]>
Date: Thu, 3 Dec 2015 19:33:28 +0000

Thanks for the responses. Seems very clear that there is strong interest in adopting this work, so let's go ahead.

Authors, please submit your next revision as an official WG document:

    draft-ietf-6lo-routing-dispatch

We can then discuss what changes the WG would like to see on the document. One discussion that has already started is whether to separate it into two documents, and how.

Thanks,

Gabriel

From: 6lo [mailto:[email-masked]] On Behalf Of Gabriel Montenegro
Sent: Tuesday, November 17, 2015 12:07
To: [email-masked]
Cc: Samita Chakrabarti <[email-masked]>
Subject: [6lo] Call for Adoption for draft-thubert-6lo-routing-dispatch

All,

https://datatracker.ietf.org/doc/draft-thubert-6lo-routing-dispatch/<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fdatatracker.ietf.org%2fdoc%2fdraft-thubert-6lo-routing-dispatch%2f&data=01%7c01%7cGabriel.Montenegro%40microsoft.com%7c898f21d1670b4245d2f908d2ef8aab5a%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=QUxlGMHMrzJoPD2q8gnvLfLhS6S9Hev75UFNNB6TZbE%3d>

This draft solves a problem for ROLL, namely that of compression of RPL artifacts. It also appears to be extensible enough that it could be useful for other scenarios, especially after discussions at IETF 93 in Prague (context switch approach) and confirmation at IETF 94 in Yokohama.

Please send your opinion ("Yes" or "No") to the mailing list on adopting this document as a 6lo WG document.

Regards,

Chairs

---

From: Michael Richardson <[email-masked]>
Date: Thu, 03 Dec 2015 15:34:35 -0500

On 17/11/15 03:06 PM, Gabriel Montenegro wrote:
> This draft solves a problem for ROLL, namely that of compression of 
> RPL artifacts. It also appears to be
>

I support adoption of this document by 6lo.

I think that the page numbers fit into RFC4944 Figure 2, filling in the 
space marked "Reserved for future use"

I have often been wrong and confused some header numbers with others, 
and I think that I'm not the only one.  Perhaps during the progress of 
this document we can come up with some useful nomenclature errata that 
would make it easier for people coming to this document set in the future.

(sending this through imap system)