Subject: [6lo] Address protected neighbor discovery

From: Thagadur Prakash Shiva <[email-masked]>
Date: Wed, 20 Jul 2016 13:17:26 +0000

Hi Pascal, Behcet, Mohit and others

I have also read through the draft briefly. It seems interesting and useful.

If I understood correctly, you plan to use standard CGA for generating the cryptographic IDs. Is this true?

Would you use elliptic curve variants for this instead of RSA that is specified in RFC 3972? Are there some existing CGA implementations for generating cryptographic IDs that can be used?

Thanks
Shiva

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 20 Jul 2016 15:25:05 +0200

On 07/20/2016 03:17 PM, Thagadur Prakash Shiva wrote:
> Would you use elliptic curve variants for this instead of RSA that is 
> specified in RFC 3972? Are there some existing CGA implementations for 
> generating cryptographic IDs that can be used?

Don't know how much this would help, but HIPv2 (rfc 7401) specifies how 
to use a ECDSA (e.g. p256) value into ORCHIDv2 (rfc 7343).