Subject: [6lo] FW: New Version Notification for draft-lijo-6lo-expiration-time-02.txt

From: "Lijo Thomas" <[email-masked]>
Date: Tue, 14 Mar 2017 17:02:37 +0530

Hi All,

A new version of I-D, draft-lijo-6lo-expiration-time-02.txt has been successfully submitted and posted to the IETF repository.

https://www.ietf.org/internet-drafts/draft-lijo-6lo-expiration-time-02.txt

The draft has been revised according to the comments received during IETF 97 meeting and on the  mailing lists.

Thanks to Pascal, Thomas and Dale for their comments. 

Happy to receive comments and feedback on the new version.

Thanks and Regards,
Lijo Thomas

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 13 March 2017 23:41
To: S.V.R Anand; Charles Perkins; Satish Anamalamudi; Lijo Thomas; Malati Hegde; P.M. Akshay; Charles E. Perkins
Subject: New Version Notification for draft-lijo-6lo-expiration-time-02.txt

A new version of I-D, draft-lijo-6lo-expiration-time-02.txt
has been successfully submitted by Charles E. Perkins and posted to the IETF repository.

Name:		draft-lijo-6lo-expiration-time
Revision:	02
Title:		Packet expiration time in 6LoWPAN Routing Header
Document date:	2017-03-13
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-lijo-6lo-expiration-time-02.txt
Status:         https://datatracker.ietf.org/doc/draft-lijo-6lo-expiration-time/
Htmlized:       https://tools.ietf.org/html/draft-lijo-6lo-expiration-time-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-lijo-6lo-expiration-time-02

Abstract:
   This document specifies a new type to the 6LoWPAN Dispatch Page 1 for
   carrying the expiration time of data packets within the 6LoWPAN
   routing header.  The expiration time is useful in making forwarding
   and scheduling decisions for time critical IoT M2M applications that
   need deterministic delay guarantees over constrained networks and
   operate within time-synchronized networks.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-------------------------------------------------------------------------------------------------------------------------------
[ C-DAC is on Social-Media too. Kindly follow us at:
Facebook: https://www.facebook.com/CDACINDIA & Twitter: @cdacindia ]

This e-mail is for the sole use of the intended recipient(s) and may
contain confidential and privileged information. If you are not the
intended recipient, please contact the sender by reply e-mail and destroy
all copies and the original message. Any unauthorized review, use,
disclosure, dissemination, forwarding, printing or copying of this email
is strictly prohibited and appropriate legal action will be taken.
-------------------------------------------------------------------------------------------------------------------------------

---

From: sajjad akbar <[email-masked]>
Date: Tue, 21 Mar 2017 21:48:06 +0000

Hi

The drafts looks very interesting, I still have a confusion that its really
hard to define a expiration time in such environment specially in context
of IoTs, moreover, how forwarding nodes can give priority to some packet in
a scalable similar network, where every node have same expiration time like
10 ms.

Regards
Sajjad

On Tue, Mar 14, 2017 at 11:32 AM, Lijo Thomas <[email-masked]> wrote:

> Hi All,
>
> A new version of I-D, draft-lijo-6lo-expiration-time-02.txt has been
> successfully submitted and posted to the IETF repository.
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
> ------------------------------------------------------------
> -------------------------------------------------------------------
> ------------------------------------------------------------
> -------------------------------------------------------------------
>
>
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>
>

---

From: "Lijo Thomas" <[email-masked]>
Date: Wed, 22 Mar 2017 11:51:43 +0530

Hi Sajjad,

Thanks for finding our draft interesting!

One should be able to define packet expiration time in a time-slotted MAC access network such as a 6TiSCH based IoT. Prioritization among the packets having the same expiration time requires some kind of flow/track based service 

differentiation or some other means.

Thanks & Regards,

Lijo Thomas 

From: 6lo [mailto:[email-masked]] On Behalf Of sajjad akbar
Sent: 22 March 2017 03:18
To: Lijo Thomas
Cc: lo
Subject: Re: [6lo] FW: New Version Notification for draft-lijo-6lo-expiration-time-02.txt

Hi

The drafts looks very interesting, I still have a confusion that its really hard to define a expiration time in such environment specially in context of IoTs, moreover, how forwarding nodes can give priority to some packet in a scalable similar network, where every node have same expiration time like 10 ms. 

Regards

Sajjad

On Tue, Mar 14, 2017 at 11:32 AM, Lijo Thomas <[email-masked] <mailto:[email-masked]> > wrote:

Hi All,

Thanks and Regards,
Lijo Thomas

-----Original Message-----
From: [email-masked] <mailto:[email-masked]>  [mailto:[email-masked] <mailto:[email-masked]> ]
Sent: 13 March 2017 23:41
To: S.V.R Anand; Charles Perkins; Satish Anamalamudi; Lijo Thomas; Malati Hegde; P.M. Akshay; Charles E. Perkins
Subject: New Version Notification for draft-lijo-6lo-expiration-time-02.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org> .

The IETF Secretariat

_______________________________________________
6lo mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/6lo