Subject: [6lo] Draft applicability for 6775bis

From: Erik Nordmark <[email-masked]>
Date: Wed, 29 Mar 2017 10:49:35 -0500

Here is an attempt at an applicability statement based on what we talked 
about today.
It is sufficiently strong?
Other RFCs or drafts that we should reference?

    Erik

----

Applicability

The purpose of the ARO and EARO is to facilitate duplicate address 
detection for hosts and pre-populate NCEs in the routers to reduce the 
need for sending multicast neighbor solicitations and also to be able to 
support backbone routers.

In some cases the address registration can fail or be useless for 
reasons other than a duplicate address. Example are the router having 
run out of space, the host having a stale sequence number, or the host 
is using an address which does not match the prefix(es) for the link. In 
such cases the host will receive an error to help diagnose the issue and 
retry.

However, the ability to return errors to address registrations MUST NOT 
be used to restrict the ability of hosts to form and use addresses as 
specified in [RFC7934]. In particular, this is needed for enhanced 
privacy, which implies that each host will register a multiplicity of 
address as part mechanisms like [RFC4941]. This implies that a 6LR or 
6LBR which is intended to support N hosts MUST have space to register at 
least on the order of 10N IPv6 addresses.

---

---

From: Dave Thaler <[email-masked]>
Date: Wed, 29 Mar 2017 17:47:44 +0000

Any issue with a standards track document having a normative reference to a BCP?
If so, then could reword so that the MUST NOT is not in the same sentence as the BCP reference, e.g.

> However, the ability to return errors to address registrations MUST NOT be
> used to restrict the ability of hosts to form and use addresses.  See [RFC7934]
> for further discussion.

If there is no issue in having a normative reference to a BCP then I think Erik's text is fine.

Dave

> -----Original Message-----
> From: 6lo [mailto:[email-masked]] On Behalf Of Erik Nordmark
> Sent: Wednesday, March 29, 2017 10:50 AM
> To: Lorenzo Colitti <[email-masked]>; huitema
> <[email-masked]>
> Cc: [email-masked]
> Subject: [6lo] Draft applicability for 6775bis
> 
> 
> The purpose of the ARO and EARO is to facilitate duplicate address detection
> for hosts and pre-populate NCEs in the routers to reduce the need for
> sending multicast neighbor solicitations and also to be able to support
> backbone routers.
> 
> In some cases the address registration can fail or be useless for reasons other
> than a duplicate address. Example are the router having run out of space, the
> host having a stale sequence number, or the host is using an address which
> does not match the prefix(es) for the link. In such cases the host will receive
> an error to help diagnose the issue and retry.
> 
> However, the ability to return errors to address registrations MUST NOT be
> used to restrict the ability of hosts to form and use addresses as specified in
> [RFC7934]. In particular, this is needed for enhanced privacy, which implies
> that each host will register a multiplicity of address as part mechanisms like
> [RFC4941]. This implies that a 6LR or 6LBR which is intended to support N
> hosts MUST have space to register at least on the order of 10N IPv6
> addresses.
> 
> ---
> 
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 29 Mar 2017 23:20:56 +0000

Hello Erik 
Superb!

On this particular sentence 

"
 Example are the router having run out of space, the host having a stale sequence number, or the host is using an address which does not match the prefix(es) for the link. In such cases the host will receive an error to help diagnose the issue and retry.
"

 I'd suggest:
" Examples are the router having run out of space, a registration bearing a stale sequence number (e.g. denoting a movement of the host after this registration was placed), a host misbehaving and attempting to register an invalid address such as the UNSPECIFIED addresses, or the host using an address which is not topologically correct on that link. In such cases the host will receive an error to help diagnose the issue and may retry, possibly with a different address, and possibly via a different 6LR.

"

Regards,

Pascal

> Le 29 mars 2017 à 10:49, Erik Nordmark <[email-masked]> a écrit :
> 
> Example are the router having run out of space, the host having a stale sequence number, or the host is using an address which does not match the prefix(es) for the link. In such cases the host will receive an error to help diagnose the issue and retry.