Subject: [6lo] MLE docs to be dropped

From: Gabriel Montenegro <[email-masked]>
Date: Mon, 3 Apr 2017 01:16:29 +0000

Folks,

Making sure the list is aware of this: at the meeting in Chicago last Wednesday we indicated that we intend to drop the MLE documents we had adopted (in large part due to ZigBee's Jupiter Mesh request) for Experimental status.

The documents are:

  *   https://tools.ietf.org/wg/6lo/draft-ietf-6lo-mesh-link-establishment/
  *   https://tools.ietf.org/wg/6lo/draft-ietf-6lo-mle-hip-dex/

MLE even went through WG LC and received some comments, but there has been no revision, and in the meantime, Jupiter Mesh is no longer depending on it. Furthermore, the other potential interested party was the Thread Group, but it became clear a few months ago that they do not depend on this document either.

The WG will drop the MLE documents by the end of this week (April 7) unless we hear some new information.

Thanks,

Gabriel, on behalf of 6lo chairs

---

From: Robert Cragie <[email-masked]>
Date: Tue, 4 Apr 2017 02:24:40 +0100

As one of the original supporters, I have no concerns with this.

Robert

On 3 April 2017 at 02:16, Gabriel Montenegro <
[email-masked]> wrote:

> Folks,
>
>
>
> Making sure the list is aware of this: at the meeting in Chicago last
> Wednesday we indicated that we intend to drop the MLE documents we had
> adopted (in large part due to ZigBee’s Jupiter Mesh request) for
> Experimental status.
>
>
>
> The documents are:
>
>    - https://tools.ietf.org/wg/6lo/draft-ietf-6lo-mesh-link-establishment/
>    - https://tools.ietf.org/wg/6lo/draft-ietf-6lo-mle-hip-dex/
>
>
>
> MLE even went through WG LC and received some comments, but there has been
> no revision, and in the meantime, Jupiter Mesh is no longer depending on
> it. Furthermore, the other potential interested party was the Thread Group,
> but it became clear a few months ago that they do not depend on this
> document either.
>
>
>
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 4 Apr 2017 09:29:39 +0200

Dear Robert and Gabriel,

I did not follow these documents and did not review but I am not sure why
we don't have reviewers in IETF, while the group adopted it. I hope the
authors look into this issue and reply that they are the authors and they
want to drop it as well. If the authors don't want to continue authoring we
may get some interests from the group to continue it because we adopted it.
Authors are responsible to follow up any adopted document they author but
they need to follow with the group and see the group's views. Few authors
in IETF (ex. MANET) make some reviewers out of the picture and argue not to
follow comments/discussions. This behaviour I have seen in IETF but hope it
is not the reason for our problem.

I see this as a problem, because I don't think we SHOULD depend on other
companies in adopting our work. I have argued with LLN WG before not to
close because of that, some thought that we have less companies interest in
the WG so close. We need to focus on humans/engineers not companies. If a
company is not interested any more to use the technology we adopted then we
don't close it as followes to them, IETF should be a leader in the world
not following a company/country policy/controllers.

I hope our WG gets a good reason of such drop, and I hope our authors'
confirm their reactions.

BEst Wishes,

AB

On Tue, Apr 4, 2017 at 3:24 AM, Robert Cragie <[email-masked]>
wrote:

>> MLE even went through WG LC and received some comments, but there has
>> been no revision, and in the meantime, Jupiter Mesh is no longer depending
>> on it. Furthermore, the other potential interested party was the Thread
>> Group, but it became clear a few months ago that they do not depend on this
>> document either.
>>
>>
>>

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 4 Apr 2017 09:33:59 +0200

I ment......LLN WG = ROLL WG

sorry I forgot the correct name, but there it is,

AB

On Tue, Apr 4, 2017 at 9:29 AM, Abdussalam Baryun <
[email-masked]> wrote:

> On Tue, Apr 4, 2017 at 3:24 AM, Robert Cragie <[email-masked]
> > wrote:
>

---

From: Richard Kelsey <[email-masked]>
Date: Tue, 4 Apr 2017 10:20:25 +0000

OK with me.

  -Richard Kelsey (author of draft-ietf-6lo-mesh-link-establishment)
________________________________________
From: Robert Cragie [[email-masked]]
Sent: Monday, April 3, 2017 9:24 PM

Robert

On 3 April 2017 at 02:16, Gabriel Montenegro <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

Making sure the list is aware of this: at the meeting in Chicago last Wednesday we indicated that we intend to drop the MLE documents we had adopted (in large part due to ZigBee’s Jupiter Mesh request) for Experimental status.

The documents are:

Thanks,

_______________________________________________
6lo mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6lo

---

From: <[email-masked]>
Date: Wed, 5 Apr 2017 01:21:56 +0000

I am author of mle-hip-dex document, but my technical area has been changed, and I no longer work on 6lo-related things including Jupiter Mesh.

I am OK with dropping the MLE documents( or if the WG requires the document, please handover editorship to others).
Best Regards,
Yoshihiro Ohba

From: 6lo [mailto:[email-masked]] On Behalf Of Gabriel Montenegro
Sent: Monday, April 03, 2017 10:16 AM
To: [email-masked]
Subject: [6lo] MLE docs to be dropped

Folks,

The documents are:

Thanks,

---

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 14 Apr 2017 00:43:38 +0000

Thanks for the discussion on this.

These document have been marked as "Dead WG documents."

From: 6lo [mailto:[email-masked]] On Behalf Of Gabriel Montenegro
Sent: Sunday, April 2, 2017 18:16
To: [email-masked]
Subject: [6lo] MLE docs to be dropped

Folks,

The documents are:

Thanks,