Subject: Re: [6lo] Warren Kumari's No Objection on draft-ietf-6lo-nfc-13: (with COMMENT)

From: 최영환 <[email-masked]>
Date: Fri, 7 Jun 2019 07:59:39 +0000

Hello Warren and all,

Thanks for your valuable reviews.
Please find my answers inline.

BRs,
Younghwan Choi

> -----Original Message-----
> From: Warren Kumari via Datatracker <[email-masked]>
> Sent: Thursday, March 14, 2019 5:24 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Carles Gomez 
> <[email-masked]>; Samita Chakrabarti <[email-masked]>; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Warren Kumari's No Objection on draft-ietf-6lo-nfc-13: (with
> COMMENT)
> 
> Warren Kumari has entered the following ballot position for
> draft-ietf-6lo-nfc-13: No Objection
> 
> When responding, please keep the subject line intact and reply to all 
> email addresses included in the To and CC lines. (Feel free to cut 
> this introductory paragraph, however.)
> 
> 
> Please refer to 
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-6lo-nfc/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> I apologize - I've read the document, but it doesn't seem like it 
> contains enough information to allow a full implementation.
> 
> The document keeps talking about the fact that the range is limited to 
> 10cm, and makes some security assertions from this - from the little 
> that I understand about this technology (and I wasn't able to follow 
> all the references), ISO 15693 tags using NDEF are now part of the NFC 
> specification - these  work up to 1M. I have no idea if this protocol 
> is supposed to work over that, but if so, 1M is greater than 10cm.

You are right. Normally, NFC applications says communications with less than 10cm or single touch between two NFC devices, but I also know 1M range is available technically. But, 1M, I think, is also very short distance. Either 10cm distance or 1M distance of NFC is ok for IPv6 over NFC. Even though 1M is used for IPv6 over NFC, nothing of this document needs to change. Only some more explanations about the maximum 1M distance of NFC can be put if it is ok.

> 
> Also, I see you did respond to the OpsDir review ( 
> https://datatracker.ietf.org/doc/review-ietf-6lo-nfc-12-opsdir-lc-wu-
> 2018-12-19/
> -- thank you very much, Qin) , but there are things in these which 
> don't seem fully addressed. As an example, Qin asked: ----  Section 3.4 said ”
> the MTU size in NFC LLCP MUST be calculated from the MIU
>    value as follows:
>                              MIU = 128 + MIUX.”
> Can you provide formula to calculate MTU from MIU? Not clear how MTU 
> is related to MIU? ---

It would be "MTU = MIU = 128 + MIUX."

> 
> You responded: "YH >> Actually, MIU is the same as MTU. Specifications 
> in NFC forum use 'MIU', and we use 'MTU'. But these two has the same 
> meaning."
> 
> I read version 13 of this document and had the exact same question -- 
> how do I calculate the MTU from the MIU? If they really are the same 
> thing (which I'm not sure they are), the document should state that, 
> so readers can more easily implement.
> 

This document uses the two terms, "MIU" and "MTU". Actually, technical meaning of the two terms is the same. NFC spec says it as MIU. IETF says it as MTU. So, I mentioned this one in section 3.4. If more explanations about MIU for clarification, I will put the explanations about relationships between the two terms.

---

From: Warren Kumari <[email-masked]>
Date: Mon, 10 Jun 2019 16:40:43 -0400

> You are right. Normally, NFC applications says communications with less than 10cm or single touch between two NFC devices, but I also know 1M range is available technically. But, 1M, I think, is al…

Yup.

> It would be "MTU = MIU = 128 + MIUX."

Sorry, that comment was from Qin - the formula should be added to the document.

> This document uses the two terms, "MIU" and "MTU". Actually, technical meaning of the two terms is the same. NFC spec says it as MIU. IETF says it as MTU. So, I mentioned this one in section 3.4. I…

Yes please -- simply clarifying that the terms mean the same thing
will address the issue.

Thanks,
W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf