Subject: Re: [6lo] Eric Rescorla's Discuss on draft-ietf-6lo-nfc-13: (with DISCUSS)

From: 최영환 <[email-masked]>
Date: Fri, 7 Jun 2019 08:00:28 +0000

Hello Eric and all,

Thanks for your valuable reviews.
Please find my answers inline.

BRs,
Younghwan Choi

> -----Original Message-----
> From: Eric Rescorla via Datatracker <[email-masked]>
> Sent: Thursday, March 14, 2019 1:20 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Carles Gomez 
> <[email-masked]>; Samita Chakrabarti <[email-masked]>; 
> [email-masked]; [email-masked]; [email-masked]
> Subject: Eric Rescorla's Discuss on draft-ietf-6lo-nfc-13: (with 
> DISCUSS)
> 
> Eric Rescorla has entered the following ballot position for
> draft-ietf-6lo-nfc-13: Discuss
> 
> When responding, please keep the subject line intact and reply to all 
> email addresses included in the To and CC lines. (Feel free to cut 
> this introductory paragraph, however.)
> 
> 
> Please refer to 
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-6lo-nfc/
> 
> 
> 
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
> 
> I am unable to adequately review this document because the first 
> normative reference and hence this DISCUSS is incomplete (ordinarily 
> this would conflict with the DISCUSS guidelines, but I believe it is 
> necessary in this case).
> 
>    [LLCP-1.3]
>               "NFC Logical Link Control Protocol version 1.3", NFC Forum
>               Technical Specification , March 2016.
> 
> Does not appear to be publicly available (the web site contains a 
> single- page PDF which reads in part "To view the complete 
> specification, go to
> http://nfc-forum.org/our-
> work/specifications-and-application-documents/specifications/nfc-forum
> - technical-specifications/. Complete the license agreement, and then 
> download the specification."). Please supply an unencumbered 
> specification and then I can rereview.

The specification, LLCP-1.3, is not free of charge. I also bought it. I have no idea to supply unencumbered specification about that. If so, I need to remove the reference [LLCP-1.3] in section 9.1. 

> 
> I have read S 3.4 repeatedly, but am unable to work out the mapping of 
> an
> IPv6 datagram to LLCP. Please provide a diagram that shows how this 
> works and then perhaps I can assist you with the text.
> 
> 

Section 3.4 has the original intention to introduce how MTU of NFC Data Link is extendable. So, the figure 2 shows LLCP's option field for the extension. When two NFC devices start to connect with each other with LLCP, they has an option whether they extend its MTU size or not. I think exchanging the option field like figure 2 between two NFC devices is quite simple. One thing that Benjamin pointed and I agreed is that the value of the figure 2 must be mentioned with 0x480(this is a size of extension to cover MTU of IPv6, 1280) in the section 3.2. So I will put this in the next draft. 
Please refer to my response on the Benjamin's DISCUSS.

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 10 Jun 2019 09:20:11 -0700

I am no longer on the IESG. I will trust the SEC ADs to handle this.

-Ekr

On Fri, Jun 7, 2019 at 1:00 AM 최영환 <[email-masked]> wrote:

> The specification, LLCP-1.3, is not free of charge. I also bought it. I
> have no idea to supply unencumbered specification about that. If so, I need
> to remove the reference [LLCP-1.3] in section 9.1.
>
> >
> Section 3.4 has the original intention to introduce how MTU of NFC Data
> Link is extendable. So, the figure 2 shows LLCP's option field for the
> extension. When two NFC devices start to connect with each other with LLCP,
> they has an option whether they extend its MTU size or not. I think
> exchanging the option field like figure 2 between two NFC devices is quite
> simple. One thing that Benjamin pointed and I agreed is that the value of
> the figure 2 must be mentioned with 0x480(this is a size of extension to
> cover MTU of IPv6, 1280) in the section 3.2. So I will put this in the next
> draft.