Subject: [6lowapp] the role of gateway nodes

From: Xavi Vilajosana Guillen <[email-masked]>
Date: Fri, 27 Nov 2009 15:37:45 +0100

Hi everybody,

I am addressing the problem of application level protocol compatibility between Internet and 6LowPan networks. As you may know current Internet protocols (http,xmpp...) make use of too heavy headers... my opinion is that a protocol transformation is required at gateway level, that is, current Internet protocols should be compressed/transformed once they reach a low power losy network...

what's the approach at 6LowApp? anyone knows ongoing work on that issue?

regards,
xavier

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 27 Nov 2009 16:00:39 +0100

> what's the approach at 6LowApp? anyone knows ongoing work on that issue?

I would summarize the thinking that went into the BOF as follows:

Some nodes in a CE (constrained environment) may actually be not that constrained (as nodes and with respect to their network).  These can directly speak the appropriate application protocol (HTTP, SNMP, XMPP, SIP) to some correspondent node outside (or inside) the CE.  (We didn't put this on the slides because that is nothing new.)

Some nodes may want to run the constrained application protocol (called CoAP on the BOF slides) right to a correspondent node on the outside.  See the bottom half of slide 13 in http://www.ietf.org/proceedings/09nov/slides/6lowapp-0.pdf as well as the use of CoAP inside the CE (if we had two CEs, this also could be between CEs).

In these two cases, no intermediary (above the IP layer) is involved.

To connect constrained nodes that want to talk CoAP to correspondent nodes outside the CE that want to speak established application protocols, an intermediary is required.  We purposely tried to avoid calling this a gateway, proxy, translator, server, or whatever, because each of these seems to invoke some inappropriate connotations of big hunks of hardware.  Instead we invented the name CoGII (Constrained-node to General Internet Intermediary).  In a 6LoWPAN, this could be the job of a device as simple as an Edge Router, or it could be placed in a quite different position (as CoAP is an Internet-based protocol, there is no restriction on the placement of the CoGII).

Gruesse, Carsten

---

From: JP Vasseur <[email-masked]>
Date: Fri, 27 Nov 2009 17:00:17 +0100

On Nov 27, 2009, at 4:00 PM, Carsten Bormann wrote:

> Some nodes in a CE (constrained environment) may actually be not  
> that constrained (as nodes and with respect to their network).   
> These can directly speak the appropriate application protocol (HTTP,  
> SNMP, XMPP, SIP) to some correspondent node outside (or inside) the  
> CE.  (We didn't put this on the slides because that is nothing new.)
>
> Some nodes may want to run the constrained application protocol  
> (called CoAP on the BOF slides) right to a correspondent node on the  
> outside.  See the bottom half of slide 13 in http://www.ietf.org/proceedings/09nov/slides/6lowapp-0.pdf 
>  as well as the use of CoAP inside the CE (if we had two CEs, this  
> also could be between CEs).
>
> To connect constrained nodes that want to talk CoAP to correspondent  
> nodes outside the CE that want to speak established application  
> protocols, an intermediary is required.  We purposely tried to avoid  
> calling this a gateway, proxy, translator, server, or whatever,  
> because each of these seems to invoke some inappropriate  
> connotations of big hunks of hardware.  Instead we invented the name  
> CoGII (Constrained-node to General Internet Intermediary).  In a  
> 6LoWPAN, this could be the job of a device as simple as an Edge  
> Router, or it could be placed in a quite different position (as CoAP  
> is an Internet-based protocol, there is no restriction on the  
> placement of the CoGII).
>

Just a side note we may want to use the same terminology accross all  
WGs: 6LoWPAN refers to something specific, in ROLL we use LLN (Low  
power and Lossy Networks), I saw CEnet, ... how about using one  
terminology ?

Thanks.

JP.

> Gruesse, Carsten
>
> _______________________________________________
> 6lowapp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowapp

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 27 Nov 2009 17:19:54 +0100

On Nov 27, 2009, at 17:00, JP Vasseur wrote:

> how about using one terminology

Let's be careful about using the same term for different things.
A CE does not necessarily connect via an LLN, just as not every LLN is a LoWPAN.

Gruesse, Carsten

---

From: John Mani <[email-masked]>
Date: Fri, 27 Nov 2009 08:47:24 -0800

Are there similar issues and how have been addressed in other perhaps
similar areas?

E.g., UPnP or DLNA that uses similar stuff - IP/HTTP, etc.

-john

On 11/27/09 6:37 AM, "Xavi Vilajosana Guillen" <[email-masked]> wrote:

> Hi everybody,
> 
> I am addressing the problem of application level protocol compatibility
> between Internet and 6LowPan networks. As you may know current Internet
> protocols (http,xmpp...) make use of too heavy headers... my opinion is that a
> protocol transformation is required at gateway level, that is, current
> Internet protocols should be compressed/transformed once they reach a low
> power losy network...
>

---

From: Zach Shelby <[email-masked]>
Date: Mon, 30 Nov 2009 15:24:19 +0200

On Nov 27, 2009, at 18:00 , JP Vasseur wrote:
> 
> Just a side note we may want to use the same terminology accross all WGs: 6LoWPAN refers to something specific, in ROLL we use LLN (Low power and Lossy Networks), I saw CEnet, ... how about using one terminology ?
> 

This is good advice JP. In my opinion the CoRE WG should actually avoid making terminology at all if possible, as in new acronyms for networks, nodes etc. Carsten is right that constrained environments might be made up of LoWPANs, LLNs (which are not always LoWPANs)  but also will be run over other IP networks.

We can probably get away with CoRE and CoAP being the only acronyms used here. CoRE describes the WG and the general set of requirements, but is not any particular network. CoAP makes sense as the name for a protocol.

The simplification of the charter suggested in the Hiroshima BOF hints that we probably don't need to talk about CoGIIs at all, just that there is an HTTP mapping. And I don't see a need for CE, CoNet and CoNode all that. We can just talk about CoRE or write it out as constrained environments? 

Zach  

-- 
http://www.sensinode.com
http://zachshelby.org - My blog "On the Internet of Things"
http://6lowpan.net - New book - "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

Zach Shelby
Head of Research
Sensinode Ltd.
Kidekuja 2
88610 Vuokatti, FINLAND

This e-mail and all attached material are confidential and may contain legally privileged information. If you are not the intended recipient, please contact the sender and delete the e-mail from your system without producing, distributing or retaining copies thereof.