Subject: Re: [6lowpan] A suggestion ... With regards to re-chartering

From: Mark Townsley <[email-masked]>
Date: Mon, 09 Jun 2008 17:33:58 +0200

Jonathan Hui wrote:
> Hi Everyone,
>
> In support of most of this. For ND, we should add work on route-over  
> as well, which I've committed to at the last WG meeting. 
Could you provide some charter text that would help quantify what you 
are willing to commit to here?
> Architecture  
> is needed at this stage, and I'm willing to help drive it. 
Please do.

- Mark

> RFC 4944  
> maintenance is needed as well.
>
> I still think we need some document to define requirements for a L2  
> meshing over 802.15.4 subnetwork. As I've said before, this could be a  
> separate document or a part of the architecture document.
>
> I hope we can close on this quickly...
>
> --
> Jonathan Hui
>
> On May 30, 2008, at 5:48 AM, Pascal Thubert (pthubert) wrote:
>
>   
>> Hi JP
>>
>> Works with me. I went through the published work and the recent  
>> thread "
>> New charter for 6lowpan".
>> My conclusion is as follows:
>>
>> From the reworked charter, we should keep Work Items 1, 3, and 5 which
>> appear of foremost importance, drop 2 and 4 because pragmatically we  
>> are
>> not advanced enough in these areas.
>>
>> For 1) we have draft-chakrabarti-6lowpan-ipv6-nd that we can couple  
>> with
>> draft-thubert-6lowpan-backbone-router and we have most of the  
>> content we
>> need to make a standard track doc.
>>
>> For 3) we have draft-culler-6lowpan-architecture. It needs improvement
>> in particular in explaining route over vs. mesh under in details as we
>> currently discuss in the ML. Also mobility, backbone... but we have
>> people interested in the discussion (see current threads) so we should
>> work it out.
>>
>> For 5) we have draft-daniel-6lowpan-security-analysis. We need to make
>> sure we have people committed to the effort but the current draft  
>> looks
>> good already.
>>
>> To those 3, I'd add:
>>
>> Explore requirements and usages.
>> ---------------------------------
>> We have a draft, draft-ekim-6lowpan-scenarios that we can leverage.  
>> I'd
>> add to it some words on existing standards that need or use 6LowPAN.  
>> In
>> particular, we need to place ISA100 requirements in there to be able  
>> to
>> better serve them later.
>>
>> RFC 4944 maintenance and improvements
>> -------------------------------------
>> This should cover at least 6lowpan HC and fragment recovery efforts.  
>> We
>> can discuss if we want ECN in that work item as well.
>>
>> What do you think?
>>
>> Pascal
>> ________________________________________
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Jean Philippe Vasseur (jvasseur)
>> Sent: vendredi 30 mai 2008 04:25
>> To: [email-masked]
>> Subject: [6lowpan] A suggestion ... With regards to re-chartering
>>
>> Hi,
>>
>> Just a suggestion for the chairs and the WG.
>>
>> We have discussed many important items for 6lowpan.
>>
>> For several of them, all important, I think that there was a clear
>> agreement: stateful header compression, security, Architecture ID,
>> fragmentation, ..... For other ones such as the "Mesh-under" and  
>> "Route
>> over" discussion, there are diverging point of views.
>>
>> So why not trying to quickly re-charter adding the items for which  
>> there
>> is a consensus and continue the discussion on the open issues in the
>> meantime until we have an agreement at which point the WG may re- 
>> charter
>> ?
>>
>> As we all know, the WG has been fairly slow in term of progress and it
>> is I think now urgent to move on.
>>
>> Thoughts ?
>>
>> Thanks.
>>
>> JP.
>> _______________________________________________
>> 6lowpan mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/6lowpan
>>     
>
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan
>
>   

_______________________________________________
6lowpan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lowpan

---

From: "Samita Chakrabarti" <[email-masked]>
Date: Wed, 11 Jun 2008 01:08:27 -0700

Hi Geoff,

Pascal's analysis of  prioritizing items makes sense to me.

On 5/30/08, Geoff Mulligan <[email-masked]> wrote:
> Could item 3 - the architecture work item include the requirements for
> mesh under as mentioned by Jonathan and should that be a single
> document?
>

A summary of mesh-under requirements is needed in the architecture
document even if we decide to have a separate elaborate document
afterwards.

Thanks,
-Samita

>
> On Fri, 2008-05-30 at 04:25 +0200, JP Vasseur wrote:
> > Hi,
> >
> > agreement: statefull header compression, security, Architecture ID,
> > "Route over" discussion, there are diverging point of views.
> >
> > there is a consensus and continue the discussion on the open issues in
> > the meantime until we have an agreement at which point the WG may
> > re-charter ?
> >