Subject: Re: [6tisch-security] Comments on "6-TiSCH Security - Some Notes and Thoughts on Security Properties; Date: 2014-03-24"

From: Thomas Watteyne <[email-masked]>
Date: Sat, 5 Apr 2014 13:24:04 -0700

Quick note, I assume we are talking about the LWIG classification
(generally agreed upon by LLN WGs such as ROLL) at
http://tools.ietf.org/html/draft-ietf-lwig-terminology-07#section-3.

Thomas

On Mon, Mar 31, 2014 at 7:43 AM, Paul Duffy <[email-masked]> wrote:

>  No worries at all.
>
> I'm in the process of reviewing several related IETF and IEEE constrained
> security efforts.  Just making sure I've got them lined up correctly.
>
>
>
> On 3/31/2014 10:40 AM, Michael Behringer (mbehring) wrote:
>
>  Sorry, still learning a lot here, I'm not a "small device" guy at all,
> so will need to be corrected from time to time ;-)
>
>
>
> Michael
>
>
>
> *From:* Paul Duffy (paduffy)
> *Sent:* 31 March 2014 16:22
> *To:* Michael Behringer (mbehring); [email-masked]
> *Subject:* Re: [6tisch-security] Comments on "6-TiSCH Security - Some
> Notes and Thoughts on Security Properties; Date: 2014-03-24"
>
>
>
> OK, you were referring to the core designations.  Thanks
>
>
> On 3/31/2014 10:19 AM, Michael Behringer (mbehring) wrote:
>
> Paul, I'm referring to slide 8 of
> http://www.ietf.org/proceedings/89/slides/slides-89-ace-2.pdf.
>
>
>
> Michael
>
>
>
> *From:* Paul Duffy (paduffy)
> *Sent:* 31 March 2014 16:09
> *To:* Michael Behringer (mbehring); [email-masked]
> *Subject:* Re: [6tisch-security] Comments on "6-TiSCH Security - Some
> Notes and Thoughts on Security Properties; Date: 2014-03-24"
>
>
>
> On 3/31/2014 7:17 AM, Michael Behringer (mbehring) wrote:
>
>
>
> Some statements on this slide make me nervous, like the last line
> "Dependency on on-board trusted platforms and trusted I/O interfaces should
> be reduced". ACE is defining 3 classes of devices with varying
> capabilities, and I think we should do the same, right?
>
>
> Hi Michael
>
> Can you clarify re: the three device classes ACE is defining? I want to be
> sure we're not confusing these with CORE device classifications.
>
>
>
>  So the fact that low-end devices may not support trusted platform
> modules should not mean we don't support it. In fact, I think those are a
> key element in a secure solution (for a certain device class, for sure).
>
>
>
>
>
>
> Agreed.
>
> Cheers
>
>
>
>
>
>
>
> _______________________________________________
> 6tisch-security mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch-security
>
>

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Mon, 7 Apr 2014 12:36:43 +0000

Yes, that is my understanding.

Michael

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: 06 April 2014 01:54
To: Paul Duffy (paduffy)
Cc: Michael Behringer (mbehring); [email-masked]
Subject: Re: [6tisch-security] Comments on "6-TiSCH Security - Some Notes and Thoughts on Security Properties; Date: 2014-03-24"

Quick note, I assume we are talking about the LWIG classification (generally agreed upon by LLN WGs such as ROLL) at http://tools.ietf.org/html/draft-ietf-lwig-terminology-07#section-3.

Thomas

On Mon, Mar 31, 2014 at 7:43 AM, Paul Duffy <[email-masked]<mailto:[email-masked]>> wrote:
No worries at all.

I'm in the process of reviewing several related IETF and IEEE constrained security efforts.  Just making sure I've got them lined up correctly.

On 3/31/2014 10:40 AM, Michael Behringer (mbehring) wrote:
Sorry, still learning a lot here, I'm not a "small device" guy at all, so will need to be corrected from time to time ;-)

Michael

From: Paul Duffy (paduffy)
Sent: 31 March 2014 16:22
To: Michael Behringer (mbehring); [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch-security] Comments on "6-TiSCH Security - Some Notes and Thoughts on Security Properties; Date: 2014-03-24"

On 3/31/2014 10:19 AM, Michael Behringer (mbehring) wrote:
Paul, I'm referring to slide 8 of http://www.ietf.org/proceedings/89/slides/slides-89-ace-2.pdf.

Michael

From: Paul Duffy (paduffy)
Sent: 31 March 2014 16:09
To: Michael Behringer (mbehring); [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch-security] Comments on "6-TiSCH Security - Some Notes and Thoughts on Security Properties; Date: 2014-03-24"

Some statements on this slide make me nervous, like the last line "Dependency on on-board trusted platforms and trusted I/O interfaces should be reduced". ACE is defining 3 classes of devices with varying capabilities, and I think we should do the same, right?

Hi Michael

Can you clarify re: the three device classes ACE is defining? I want to be sure we're not confusing these with CORE device classifications.

So the fact that low-end devices may not support trusted platform modules should not mean we don't support it. In fact, I think those are a key element in a secure solution (for a certain device class, for sure).

Agreed.

Cheers

_______________________________________________
6tisch-security mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch-security