Subject: [6tisch-security] people who have responded -- planned meetings

From: Michael Richardson <[email-masked]>
Date: Fri, 06 May 2016 09:50:40 -0400

I sent out an email a week or so ago about rebooting the 6tisch security
effort.  I'd like to use JITSI for meetings at https://jitsi.tools.ietf.org/
[the DHCPv6-BIS team has been using it quite successfully for a few months]
(webex is increasingly hostile to non-windows platforms)

I've cleared out the list, and added the following people back in based upon
replies:

[email-masked]
[email-masked]
Pascal Thubert <[email-masked]>
max pritikin <[email-masked]>
Giuseppe Piro <[email-masked]>
Michael Richardson <[email-masked]>
Michael Behringer <[email-masked]>
Randy Turner <[email-masked]>

I hope that we can have a meeting on May 13, 13:15UTC using:
  https://jitsi.tools.ietf.org/6tischsecurity

I think that we might need a few more people, perhaps:
  Tengfei Chang <[email-masked]>
??

This is 45 minutes before the regular 6tisch meeting.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Tengfei Chang <[email-masked]>
Date: Fri, 6 May 2016 16:56:17 +0200

Hi Michael,

I am very glad to attend the meeting, though I think I am not an expert on
security.
Very much looking forward to help on the topic!

Tengfei

-- 
Chang Tengfei,
Pre-Postdoctoral Research Engineer, Inria

---

From: Michael Richardson <[email-masked]>
Date: Sat, 07 May 2016 15:41:18 -0400

> Very much looking forward to help on the topic!

I want to have implementers on the list, and you are doing OpenWSN things as
I recall.

---

From: Thomas Watteyne <[email-masked]>
Date: Sun, 8 May 2016 18:52:07 +0200

Michael,

Great! I would like to move fast on this, and suggest to have the security
call at least 24 before the meeting so that we can complete the action
items we will have discussed by the time of the 6TiSCH call.

Would Thursday 7am Pacific (same time as 6TiSCH meeting) work for all?

Thomas

On Sat, May 7, 2016 at 9:41 PM, Michael Richardson <[email-masked]>
wrote:

> _______________________________________________
> 6tisch-security mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch-security
>
>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 9 May 2016 02:47:11 +0000

Not for me, Thomas but I can do 8AM...

Regards,

Pascal

Le 8 mai 2016 ? 18:52, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> a ?crit :

Michael,

Great! I would like to move fast on this, and suggest to have the security call at least 24 before the meeting so that we can complete the action items we will have discussed by the time of the 6TiSCH call.

Thomas

On Sat, May 7, 2016 at 9:41 PM, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>, Sandelman Software Works
 -= IPv6 IoT consulting =-

_______________________________________________
6tisch-security mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch-security

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________
_______________________________________________
6tisch-security mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch-security

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 9 May 2016 07:13:14 +0200

Hmm. I can anytime except 8-9am Pacific.

The easiest is probably to fill out http://doodle.com/poll/zugwwi9nkfqg2sk5.
Please do; we'll make a decision in 24h.

Thomas

On Mon, May 9, 2016 at 4:47 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> Le 8 mai 2016 à 18:52, Thomas Watteyne <[email-masked]> a
> écrit :
>
> Michael,
>

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 9 May 2016 07:26:33 +0000

Then let's Keep it at 7Am if people like that time, Thomas.

I'll organize the Webex but attend on the side.

I'm not contributing much anyway so listening to the recording will do : )

Please confirm the time when you are sure,

Regards,

Pascal

Le 9 mai 2016 ? 07:13, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> a ?crit :

The easiest is probably to fill out http://doodle.com/poll/zugwwi9nkfqg2sk5. Please do; we'll make a decision in 24h.

Thomas

On Mon, May 9, 2016 at 4:47 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Not for me, Thomas but I can do 8AM...

Regards,

Pascal

Michael,

Thomas

Thomas Watteyne, PhD

Thomas Watteyne, PhD

---

From: Michael Richardson <[email-masked]>
Date: Mon, 09 May 2016 10:53:04 -0400

Thomas Watteyne <[email-masked]> wrote:
    > items
    > we will have discussed by the time of the 6TiSCH call.

I had already proposed to have the meeting 45 minutes before the 6tisch call,
but to do it weekly.

    > Would Thursday 7am Pacific (same time as 6TiSCH meeting) work for all?

It would not work for me on a sufficient number of Thursdays that it would be
a problem.

Thomas Watteyne <[email-masked]> wrote:
    > Would you agree that the agenda for the next sec meeting is to identify
    > the potential for using Object Security for secure joining a 6TiSCH
    > network, and that the homework to prepare is to read:

    > - [high] draft-selander-ace-object-security
    > - [med] draft-ietf-cose-msg
    > - [low] draft-selander-ace-cose-ecdhe
    > - [low] draft-hartke-core-e2e-security-reqs
    > - [low] draft-ietf-ace-oauth-authz

I'm fortunate that I've read most of these documents in detail.
I agree that this is an important thing to consider.

I want to point out that OSCOAP does not have a clear session key exchange
protocol as yet (several ideas proposed), and once it does, it still needs to
do enough certificate processing and ownership voucher analysis to enable the
security.

I had proposed DTLS/COAP (are we calling this coaps yet.. rhymes with soaps?)
with blockwise support.  From my point of view, sitting inside the
unconstrained JCE, it matters little if it's OSCOAP (security inside COAP) vs
DTLS/COAP (security outside of COAP).  They seem to have the same essential
properties in the end.

**to the constrained node it matters that we reuse as much code as possible**

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 10 May 2016 09:37:35 +0200

Reminder, fill in http://doodle.com/poll/zugwwi9nkfqg2sk5 in the next hours.

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 10 May 2016 09:42:55 +0200

PS: please note that one of the first discussion items is to fix a
discussion slot for possible periodic calls.

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 10 May 2016 11:24:05 +0200

All,
The most popular date for meeting is Thursday 1pm Paris time. Let's meet
then.
Thomas

On Tue, May 10, 2016 at 9:42 AM, Thomas Watteyne <[email-masked]>
wrote:

> On Tue, May 10, 2016 at 9:37 AM, Thomas Watteyne <[email-masked]
> > wrote:
>
>> On Mon, May 9, 2016 at 4:53 PM, Michael Richardson <[email-masked]
>> > wrote:
>>
>>>

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Michael Richardson <[email-masked]>
Date: Tue, 10 May 2016 10:00:31 -0400

> The most popular date for meeting is Thursday 1pm Paris time. Let's meet

That time is 7am Ottawa; I will need to leave at 7:45am.

Can you mark the doodle as decided so that it is reflected in our calendars?

I'd prefer to use https://jitsi.tools.ietf.org/6tischSecurity rather than
webex, as webex has become more and more hostile to non-windows desktops.

Here is an additional link to help those with the time period:
     https://www.timeanddate.com/worldclock/converted.html?iso=20160512T13&p1=195&p2=188

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Tue, 10 May 2016 15:11:14 +0000

Apologies for the late response, as I am in Califorina, 1pm Paris would be 4am my time which I don't think I can make.
I did do a very late response to the doodle....

Nancy

From: 6tisch-security <[email-masked]<mailto:[email-masked]>> on behalf of Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, May 10, 2016 at 2:24 AM
To: Michael Richardson <[email-masked]<mailto:[email-masked]>>
Cc: 6tisch-security <[email-masked]<mailto:[email-masked]>>
Subject: Re: [6tisch-security] people who have responded -- planned meetings

All,
The most popular date for meeting is Thursday 1pm Paris time. Let's meet then.
Thomas

On Tue, May 10, 2016 at 9:42 AM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
PS: please note that one of the first discussion items is to fix a discussion slot for possible periodic calls.

On Tue, May 10, 2016 at 9:37 AM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
Reminder, fill in http://doodle.com/poll/zugwwi9nkfqg2sk5 in the next hours.

On Mon, May 9, 2016 at 4:53 PM, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:

Thomas Watteyne, PhD

Thomas Watteyne, PhD

Thomas Watteyne, PhD

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 10 May 2016 23:00:18 +0200

inline

> That time is 7am Ottawa; I will need to leave at 7:45am.

OK

> Can you mark the doodle as decided so that it is reflected in our

done

> webex, as webex has become more and more hostile to non-windows desktops.

sounds good

> https://www.timeanddate.com/worldclock/converted.html?iso=20160512T13&p1=195&p2=188
As for the homework before the call, is this reading list accurate?

Thomas Watteyne, PhD

www.thomaswatteyne.com