Subject: [6tisch-security] Fwd: New Version Notification for draft-vucinic-6tisch-minimal-security-00.txt

From: Mališa Vučinić <[email-masked]>
Date: Tue, 25 Oct 2016 13:18:15 +0200

Dear all,

We have submitted a new draft on the join process in 6TiSCH. The draft is quite efficient when it comes to PSKs and requires a single round trip for the authenticated key transport from JCE to JN. We use OSCOAP for protection of CoAP messages end-to-end (through the proxy) and EDHOC for the security handshake when using public keys for joining. 

It would be great if we could discuss some of the related aspects at the meeting this afternoon.

Regards,
Mališa

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-vucinic-6tisch-minimal-security-00.txt
> Date: 25 October 2016 at 11:37:52 GMT+2
> To: "Kris Pister" <[email-masked]>, "Malisa Vucinic" <[email-masked]>, " [email-masked]" <[email-masked]>, "Jonathan Simon" <[email-masked]>
> 
> 
> A new version of I-D, draft-vucinic-6tisch-minimal-security-00.txt
> has been successfully submitted by Malisa Vucinic and posted to the
> IETF repository.
> 
> Name:		draft-vucinic-6tisch-minimal-security
> Revision:	00
> Title:		Minimal Security Framework for 6TiSCH 
> Document date:	2016-10-25
> Group:		Individual Submission
> Pages:		17
> URL:            https://www.ietf.org/internet-drafts/draft-vucinic-6tisch-minimal-security-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-vucinic-6tisch-minimal-security/
> Htmlized:       https://tools.ietf.org/html/draft-vucinic-6tisch-minimal-security-00
> 
> 
> Abstract:
>   This draft describes the minimal mechanisms required to support
>   secure initial configuration in a device being added to a 6TiSCH
>   network.  The goal of this configuration is to set link-layer keys,
>   and to establish a secure session between each joining node and the
>   JCE who may use that to further configure the joining device.
>   Additional security behaviors and mechanisms may be added on top of
>   this minimal framework.
> 
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 25 Oct 2016 12:14:25 -0400

Mališa Vučinić <[email-masked]> wrote:
    > We have submitted a new draft on the join process in 6TiSCH. The draft is
    > quite efficient when it comes to PSKs and requires a single round trip
    > for the authenticated key transport from JCE to JN. We use OSCOAP for
    > protection of CoAP messages end-to-end (through the proxy) and EDHOC
    > for the security
    > handshake when using public keys for joining.

    > It would be great if we could discuss some of the related aspects at the

Give us a day to read the document ... :-)
Is 30 minutes on Nov. 8 meeting okay for you?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Mališa Vučinić <[email-masked]>
Date: Wed, 26 Oct 2016 13:10:11 +0200

Yes, that would be great!

> On 25 Oct 2016, at 18:14, Michael Richardson <[email-masked]> wrote:
> 
>