Subject: Re: [6tisch] nits draft-piro-6tisch-security-issues-01

From: Giuseppe Piro <[email-masked]>
Date: Sat, 18 Jan 2014 17:31:09 +0100

Thomas,

thanks for these important comments: we will carefully consider them to
write the next version of the draft.

Giuseppe

On Fri, Dec 20, 2013 at 3:00 AM, Thomas Watteyne <[email-masked]
> wrote:

> Authors,
> You find a list of nits below. More (content-related) remarks to come.
> Thomas
>
>
> Minor:
>
>    - The introduction reads like a research paper. I would suggest
>    trimming that down. In particular, the "related work" on ZigBee, the
>    complexity of security,  and such might not be needed.
>    - Most radio and some uC have AES-128 ciphers built in. Speeds up
>    cryptographic operations. I would be careful about claims about
>    implementability, or maybe even remove those paragraphs from the
>    introduction.
>    - you should add KMP to your definitions
>    - "It is not valid if the * attribute is not valid". That's usually
>    the case :)
>
> Trivial (*a* means add, **a** means remove, please Ctrl+F)
>
>    - newline in title? See
>    http://xml.resource.org/xml2rfcFAQ.html#anchor31
>    - "for the setting up" -> "for setting up"
>    - please use a xref statement to link
>    to [I-D.palattella-6tischterminology]
>    - same for [I-D.wang-6tisch-6top], and several others. You can look at
>    the pdf and find the ones which are not underlined.
>    - [I-D.palattella-6tischterminology] is out of date, please use
>    [draft-ietf-6tisch-terminology]
>    - same for [ID.watteyne-6tisch-tsch]
>    - born -> created
>    - that need -> that needs
>    - these work*s*
>    - IEFT->IETF
>    - In [*] is present -> [*] presents
>    - neglectable -> negligeable
>    - PAN -> PANA?
>    - establish a secure communication with -> establish secure
>    communication with
>    - composed by -> composed of
>    - high layer -> higher/upper layer
>    - there is a huge overflow on page 34
>    - it customary to put the full first name in the author's addresses
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
*Giuseppe Piro, PhD*
Post Doc Researcher
DEI, Politecnico di Bari
via Orabona 4 - 70125 (Bari), Italy.
email: [email-masked]
phone: +39 080 5963301
web: telematics.poliba.it/piro

---

From: Thomas Watteyne <[email-masked]>
Date: Sat, 18 Jan 2014 18:29:38 -0800

Excellent, thanks.

On Sat, Jan 18, 2014 at 8:31 AM, Giuseppe Piro <[email-masked]>wrote:

> On Fri, Dec 20, 2013 at 3:00 AM, Thomas Watteyne <
> [email-masked]> wrote:
>
>> Authors,
>>    - same for [I-D.wang-6tisch-6top], and several others. You can look
>>    at the pdf and find the ones which are not underlined.