Subject: Re: [6tisch] Frequency Hopping

From: Tom Phinney <[email-masked]>
Date: Sat, 11 Jan 2014 22:43:59 -0700

What do you mean by frequency hopping at the MAC layer? Frequency is
a physical characteristic, so setting it or changing it, whether
statically or dynamically, always occurs WITHIN the Physical Layer.
When the frequency is set statically, that's often done by layer
management, but when it's set dynamically, as in TSCH, that's done
by the MAC layer coordinating its own operation with changes in
Physical Layer parameters (e.g., selection of FDM channel).

The spread-spectrum pulse shaping of the IEEE 802.15.4 radio is
orthogonal to frequency hopping, which is why the original Zigbee
systems used spread spectrum on a single channel while TSCH uses
spread spectrum across a set of channels that are selected in an
underlying cyclic manner.

The reality is that the correlator for the IECC 802.15.4 OQPSK
signaling improves effective S/N over most similar Eb/No signaling
in the channel, primarily due to the coding-induced time spread of
the information in the channel. Independently, frequency hopping
provides a way to circumvent persistent narrow-band fading in the
channel, where in both cases a "channel" is the aggregate
propagation path between two correspondents.

===

On 2014.01.11 13:37, rahul sen wrote:

I dont know if it is a right forum to ask this question but
let me try anyway.

Is there
any advantage of using frequency hopping at MAC layer oppose
to frequency hopping spread spectrum technique? or the
development of Frequency hopping at MAC layer is because use
of frequency hopping spread spectrum at physical layer would
have made alreay available 802.15.4 radios irrelevant.

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: rahul sen <[email-masked]>
Date: Mon, 13 Jan 2014 05:58:58 +0800 (SGT)

Yes the correct term should have been frequency hopping management at MAC layer. The advantage of frequency hopping is evident as i've already mentioned in the original mail. My question was why not use the frequency hopping at physical layer itself, it would have simplified MAC layer. The advantage would have been more channels available (i'm just assuming because of 26/78 channels available to 802.11 FHSS compared to 3 channel 802.11 DSSS)

In case of 802.11, original specification used both DSSS and FHSS, and due to the restriction posed by FCC 15.247, the bandwidth offered by both systems were quite similar (1-2 Mbps). But due to the use of PPM/MBOK/CCK, DSSS started offering 5.5/11 Mbps data rate, but the 5 Mbps FHSS were rejected by FCC. Hence in that field DSSS had obvious advantage over FHSS. (All those things were before OFDM).

 Ref.- http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Linux.Wireless.modem.html

The obvious advantage of DSSS over FHSS were , as you and other mentioned was improved S/N ratio which translates into better range, but FHSS has better immunity to mutipath fading and interference, which has been exploited by TSCH.

Other issue which has pointed out was power consumption, but some references points out that the DSSS transceivers are complex to implement and consumes more power. (Again, FHSS transreceivers with same power budget will have less transmission range, but in LRWPAN application that alone should not be a limiting
 factor).

http://books.google.co.in/books?id=e1s5k6RYbT0C&pg=PA29&lpg=PA29&dq=power+consumption+dsss+vs+fhss&source=bl&ots=KcN7mfcxZi&sig=JJAV3pHwBn4zWiNvl9Y8Xro-HVU&hl=en&sa=X&ei=oAnTUqvNLcamrAe1joCIDg&ved=0CEkQ6AEwBjgK#v=onepage&q=power%20consumption%20dsss%20vs%20fhss&f=false

http://books.google.co.in/books?id=AylGzU3yOE4C&pg=PT224&lpg=PT224&dq=power+consumption+dsss+vs+fhss&source=bl&ots=HjRMG19ct7&sig=joJEeFrW-yE8bD5hTuxEIgIVCuM&hl=en&sa=X&ei=ignTUoLEJ8OFrAfxzoHIBA&ved=0CE0Q6AEwBQ#v=onepage&q=power%20consumption%20dsss%20vs%20fhss&f=false

http://books.google.co.in/books?id=ChkR77PM5K0C&pg=PA499&dq=%22Comparison+of+DSSS+and+FHSS%22&hl=en&sa=X&ei=uQ3TUvGpEoqJrAfj_YGYBQ&redir_esc=y#v=onepage&q=%22Comparison%20of%20DSSS%20and%20FHSS%22&f=false

Thats why i think, TSCH  and other channel hopping MACs (IEC 6591, ISA100.11a, CWPAN) have been designed to use existing 802.15.4 radios, because use of frequency hopping at physical layer would have involved support from different radio manufacturers and thus large development time. Is there any other reason?

On Sunday, 12 January 2014 11:14 AM, Tom Phinney <[email-masked]> wrote:
 
What do you mean by frequency hopping at the MAC layer? Frequency is a physical characteristic, so setting it or changing it, whether statically or dynamically, always occurs WITHIN the Physical Layer. When the frequency is set statically, that's often done by layer management, but when it's set dynamically, as in TSCH, that's done by the MAC layer coordinating its own operation with changes in Physical Layer parameters (e.g., selection of FDM channel). 

I dont know if it is a right forum to ask this question but let me try anyway.
>
>
>
>Is there any advantage of using frequency hopping at MAC layer oppose to frequency hopping spread spectrum technique? or the development of Frequency hopping at MAC layer is because use of frequency hopping spread spectrum at physical layer would have made alreay available 802.15.4 radios irrelevant.
>
>
>
6tisch mailing list [email-masked] https://www.ietf.org/mailman/listinfo/6tisch

---

From: Kris Pister <[email-masked]>
Date: Tue, 14 Jan 2014 15:22:18 -0800

Rahul -
  you're correct that TSCH and the various standards that use it were 
designed to use existing 802.15.4
radios.  There were market forces that operated in favor of that choice, 
but there
were a lot of good things about the 15.4 standard to work with (and some 
bad things too).

A technical discussion of the tradeoffs between different phy/mac 
schemes for WSN
is usually a very long discussion, the majority of which is spent making 
sure that everyone
agrees on terminology and is familiar with the same literature.  A 
whiteboard is required.
Coffee is helpful.

The book passages that you point to make gross generalizations. 
Statements like "DSSS
transceivers are complex to implement and consume more power" are at 
best debatable
(I would argue that that particular statement is simply false).

Can you build a reliable low-power mesh with an FHSS phy?  I believe 
that you can.
If you consider the 802.15.1 bluetooth phy to be FHSS, and you can 
synchronize your
clocks to << 0.625ms (not trivial, but doable), then you can probably 
pretty quickly port
e.g. the openWSN stack and have a mesh up and running.  Cells are still 
composed of
time and frequency offsets, but the frequency offset is now just the 
first frequency used,
and the PHY hops from there.  There would be a *lot* of details to work 
out, but it would
probably work.  Would it work better than 15.4e?  That is going to 
depend entirely on the
tradeoffs made in working out the details.
If you hop much faster than bluetooth (1600 hops/sec) then you have real 
problems with
receiver synchronization at the beginning of the packet.
If you hop much slower, you don't end up hopping before you're done 
sending.

[Apologies to all since this is clearly out of scope for the 6TiSCH 
working group, sorry.]

ksjp

On 1/12/2014 1:58 PM, rahul sen wrote:
> Yes the correct term should have been frequency hopping management at 
> MAC layer. The advantage of frequency hopping is evident as i've 
> already mentioned in the original mail. My question was why not use 
> the frequency hopping at physical layer itself, it would have 
> simplified MAC layer. The advantage would have been more channels 
> available (i'm just assuming because of 26/78 channels available to 
> 802.11 FHSS compared to 3 channel 802.11 DSSS)
>
> In case of 802.11, original specification used both DSSS and FHSS, and 
> due to the restriction posed by FCC 15.247, the bandwidth offered by 
> both systems were quite similar (1-2 Mbps). But due to the use of 
> PPM/MBOK/CCK, DSSS started offering 5.5/11 Mbps data rate, but the 5 
> Mbps FHSS were rejected by FCC. Hence in that field DSSS had obvious 
> advantage over FHSS. (All those things were before OFDM).
>
>  Ref.- 
> http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Linux.Wireless.modem.html
>
> The obvious advantage of DSSS over FHSS were , as you and other 
> mentioned was improved S/N ratio which translates into better range, 
> but FHSS has better immunity to mutipath fading and interference, 
> which has been exploited by TSCH.
>
> Other issue which has pointed out was power consumption, but some 
> references points out that the DSSS transceivers are complex to 
> implement and consumes more power. (Again, FHSS transreceivers with 
> same power budget will have less transmission range, but in LRWPAN 
> application that alone should not be a limiting factor).
>
> Thats why i think, TSCH  and other channel hopping MACs (IEC 6591, 
> ISA100.11a, CWPAN) have been designed to use existing 802.15.4 radios, 
> because use of frequency hopping at physical layer would have involved 
> support from different radio manufacturers and thus large development 
> time. Is there any other reason?
>
>
> What do you mean by frequency hopping at the MAC layer? Frequency is a 
> physical characteristic, so setting it or changing it, whether 
> management, but when it's set dynamically, as in TSCH, that's done by 
> the MAC layer coordinating its own operation with changes in Physical 
> Layer parameters (e.g., selection of FDM channel).
>
> signaling improves effective S/N over most similar Eb/No signaling in 
> the channel, primarily due to the coding-induced time spread of the 
> information in the channel. Independently, frequency hopping provides 
> a way to circumvent persistent narrow-band fading in the channel, 
> where in both cases a "channel" is the aggregate propagation path 
> between two correspondents.
> ===
>
>> Is there any advantage of using frequency hopping at MAC layer oppose 
>> to frequency hopping spread spectrum technique? or the development of 
>> Frequency hopping at MAC layer is because use of frequency hopping 
>> spread spectrum at physical layer would have made alreay available 
>> 802.15.4 radios irrelevant.
>>
>>
>> [email-masked]  <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>

---

From: rahul sen <[email-masked]>
Date: Wed, 15 Jan 2014 15:57:38 +0800 (SGT)

Yes i am in total agreement with you, development of mesh over FHSS phy may involve complex design issues and it is totally unfair to compare one transceiver with other in terms of power consumption without knowing complete building blocks and technology involved. (In the books, i think the conclusion were derived based on GSM and WiFi based transceivers) 
I asked this question just out of curiosity and i apologize for it being out of scope for this working group. 

On Wednesday, 15 January 2014 4:52 AM, Kris Pister <[email-masked]> wrote:
 
Rahul - 
 you're correct that TSCH and the various standards that use it were
    designed to use existing 802.15.4
radios.  There were market forces that operated in favor of that
    choice, but there
were a lot of good things about the 15.4 standard to work with (and
    some bad things too).

A technical discussion of the tradeoffs between different phy/mac
    schemes for WSN 
is usually a very long discussion, the majority of which is spent
    making sure that everyone
agrees on terminology and is familiar with the same literature.  A
    whiteboard is required.  
Coffee is helpful.

Can you build a reliable low-power mesh with an FHSS phy?  I believe
    that you can.
If you consider the 802.15.1 bluetooth phy to be FHSS, and you can
    synchronize your 
clocks to << 0.625ms (not trivial, but doable), then you can
    probably pretty quickly port
e.g. the openWSN stack and have a mesh up and running.  Cells are
    still composed of
time and frequency offsets, but the frequency offset is now just the
    first frequency used,
and the PHY hops from there.  There would be a *lot* of details to
    work out, but it would
probably work.  Would it work better than 15.4e?  That is going to
    depend entirely on the
tradeoffs made in working out the details.
If you hop much faster than bluetooth (1600 hops/sec) then you have
    real problems with
receiver synchronization at the beginning of the packet. 
If you hop much slower, you don't end up hopping before you're done
    sending. 

ksjp

>Other issue which has pointed out was
                              power consumption, but some references
                              points out that the DSSS transceivers are
                              complex to implement and consumes more
                              power. (Again, FHSS transreceivers with
                              same power budget will have less
                              transmission range, but in LRWPAN
                              application that alone should not be a
                              limiting factor).
>Thats why i think, TSCH  and other channel
                              hopping MACs (IEC 6591, ISA100.11a, CWPAN)
                              have been designed to use existing
                              802.15.4 radios, because use of frequency
                              hopping at physical layer would have
                              involved support from different radio
                              manufacturers and thus large development
                              time. Is there any other reason?
>The spread-spectrum pulse
                                            shaping of the IEEE 802.15.4
                                            radio is orthogonal to
                                            frequency hopping, which is
                                            why the original Zigbee
                                            systems used spread spectrum
                                            on a single channel while
                                            TSCH uses spread spectrum
                                            across a set of channels
                                            that are selected in an
                                            underlying cyclic manner.
>The reality is that the
                                            correlator for the IECC
                                            802.15.4 OQPSK signaling
                                            improves effective S/N over
                                            most similar Eb/No signaling
                                            in the channel, primarily
                                            due to the coding-induced
                                            time spread of the
                                            information in the channel.
                                            Independently, frequency
                                            hopping provides a way to
                                            circumvent persistent
                                            narrow-band fading in the
                                            channel, where in both cases
                                            a "channel" is the aggregate
                                            propagation path between two
                                            correspondents.

---

From: rahul sen <[email-masked]>
Date: Mon, 20 Jan 2014 03:29:11 +0800 (SGT)

Just read something interesting
from 802.15.4e annex I section I.4.4.2

"Channel hopping and channel adaptation do not exclude physical layer frequency hopping (PHY-FH) in which the PHY changes the channels independent of the MAC. In this manner, the fundamental difference between the channel hopping done in the MAC versus channel hopping done in the PHY is whether channel switching can occur during the transmission of a PPDU." 

And then it goes on to explain the operation of PHY-FH with MAC-CH. Is really any such development at physical layer is under consideration or i'm reading too much into it?

On Wednesday, 15 January 2014 1:27 PM, rahul sen <[email-masked]> wrote:

 
Rahul - 

ksjp

                                            correlator for the IECC
                                            802.15.4 OQPSK signaling

---

From: Qin Wang <[email-masked]>
Date: Thu, 23 Jan 2014 21:45:02 +0800

Hi Rahul,

In the IEEE802.15.4e, there are several MAC specifications. TSCH, which we
are talking about in 6TiSCH group, is one of them, What you read from
IEEE802.15.4e is associated with another MAC specification, named as DSME,
which is really different from TSCH.

Thanks
Qin

On Mon, Jan 20, 2014 at 3:29 AM, rahul sen <[email-masked]> wrote:

> "Channel hopping and channel adaptation do not exclude physical layer
> frequency hopping (PHY-FH) in which the PHY changes the channels
> independent of the MAC. In this manner, the fundamental difference between
> the channel hopping done in the MAC versus channel hopping done in the
> PHY is whether channel switching can occur during the transmission of a
> PPDU."
>
> And then it goes on to explain the operation of PHY-FH with MAC-CH. Is
> really any such development at physical layer is under consideration or i'm
> reading too much into it?
>
>
>  Yes i am in total agreement with you, development of mesh over FHSS phy
> may involve complex design issues and it is totally unfair to compare one
> transceiver with other in terms of power consumption without knowing
> complete building blocks and technology involved. (In the books, i think
> the conclusion were derived based on GSM and WiFi based transceivers)
> A technical discussion of the tradeoffs between different phy/mac schemes
> for WSN
> transceivers are complex to implement and consume more power" are at best
> debatable
> Can you build a reliable low-power mesh with an FHSS phy?  I believe that
> you can.
> time and frequency offsets, but the frequency offset is now just the first
> frequency used,
> probably work.  Would it work better than 15.4e?  That is going to depend
> entirely on the
>      Yes the correct term should have been frequency hopping management
> at MAC layer. The advantage of frequency hopping is evident as i've already
> mentioned in the original mail. My question was why not use the frequency
> hopping at physical layer itself, it would have simplified MAC layer. The
> advantage would have been more channels available (i'm just assuming
> because of 26/78 channels available to 802.11 FHSS compared to 3 channel
> 802.11 DSSS)
>
> due to the restriction posed by FCC 15.247, the bandwidth offered by both
> systems were quite similar (1-2 Mbps). But due to the use of PPM/MBOK/CCK,
> DSSS started offering 5.5/11 Mbps data rate, but the 5 Mbps FHSS were
> rejected by FCC. Hence in that field DSSS had obvious advantage over FHSS.
> (All those things were before OFDM).
>
>   Ref.-
> mentioned was improved S/N ratio which translates into better range, but
> FHSS has better immunity to mutipath fading and interference, which has
> been exploited by TSCH.
>
> references points out that the DSSS transceivers are complex to implement
> and consumes more power. (Again, FHSS transreceivers with same power budget
> will have less transmission range, but in LRWPAN application that alone
> should not be a limiting factor).
>
>
> support from different radio manufacturers and thus large development time.
> Is there any other reason?
>
>
>     On Sunday, 12 January 2014 11:14 AM, Tom Phinney <[email-masked]><[email-masked]>wrote:
> physical characteristic, so setting it or changing it, whether statically
> or dynamically, always occurs WITHIN the Physical Layer. When the frequency
> is set statically, that's often done by layer management, but when it's set
> dynamically, as in TSCH, that's done by the MAC layer coordinating its own
> operation with changes in Physical Layer parameters (e.g., selection of FDM
> channel).
>
> The spread-spectrum pulse shaping of the IEEE 802.15.4 radio is orthogonal
> to frequency hopping, which is why the original Zigbee systems used spread
> spectrum on a single channel while TSCH uses spread spectrum across a set
> of channels that are selected in an underlying cyclic manner.
>
> The reality is that the correlator for the IECC 802.15.4 OQPSK signaling
> improves effective S/N over most similar Eb/No signaling in the channel,
> primarily due to the coding-induced time spread of the information in the
> channel. Independently, frequency hopping provides a way to circumvent
> persistent narrow-band fading in the channel, where in both cases a
> "channel" is the aggregate propagation path between two correspondents.
> ===
>
>  Is there any advantage of using frequency hopping at MAC layer oppose to
> frequency hopping spread spectrum technique? or the development of
> Frequency hopping at MAC layer is because use of frequency hopping spread
> spectrum at physical layer would have made alreay available 802.15.4 radios
> irrelevant.
>
>
> 6tisch mailing [email-masked]://www.ietf.org/mailman/listinfo/6tisch
>
>
>
> 6tisch mailing [email-masked]://www.ietf.org/mailman/listinfo/6tisch
>
>
>

---

From: rahul sen <[email-masked]>
Date: Sat, 25 Jan 2014 14:39:43 +0800 (SGT)

i'm not denying that, but the channel hopping mechanism specified in the annex mentions a PHY-FH layer, which has not been defined in specs anywhere. Since these new amendments are result of other industrial network standards devleopment, may be one of these standards may contain PHY-FH, but i'm not sure?

On Thursday, 23 January 2014 7:15 PM, Qin Wang <[email-masked]> wrote:
 
Hi Rahul,

In the IEEE802.15.4e, there are several MAC specifications. TSCH, which we are talking about in 6TiSCH group, is one of them, What you read from IEEE802.15.4e is associated with another MAC specification, named as DSME, which is really different from TSCH.

Thanks
Qin

    choice, but there
    some bad things too).
    schemes for WSN 
    whiteboard is required.  
    Statements like "DSSS
    best debatable
    that you can.
    synchronize your 
    still composed of
    first frequency used,
    work out, but it would
    depend entirely on the
    real problems with
    sending. 
    working group, sorry.]
                                            correlator for the IECC
                                            802.15.4 OQPSK signaling

---

From: rahul sen <[email-masked]>
Date: Sat, 25 Jan 2014 14:39:45 +0800 (SGT)

Hi Rahul,

Thanks
Qin

    choice, but there
    some bad things too).
    schemes for WSN 
    whiteboard is required.  
    Statements like "DSSS
    best debatable
    that you can.
    synchronize your 
    still composed of
    first frequency used,
    work out, but it would
    depend entirely on the
    real problems with
    sending. 
    working group, sorry.]
                                            correlator for the IECC
                                            802.15.4 OQPSK signaling

---

From: Pat Kinney <[email-masked]>
Date: Sat, 25 Jan 2014 10:13:34 -0600

Hi Rahul;

The MAC is supposed to be PHY agnostic, hence the behaviors in the MAC should be applicable to every PHY.  

During the period of time of the 4e project, there was a discussion in the PHY task groups of a "fast hop" device where the hopping rate would be higher than the symbol rate.  A fast hop has advantages and disadvantages with one significant disadvantage being additional complexity versus channel hopping with a dwell period greater or equal to one frame time.  The channel hopping mechanism can be placed in the MAC, whereas the fast hop mechanism must be in the PHY.  None of the PHY task groups believed the advantages of a fast hop PHY justified its additional complexity hence it wasn't standardized.  

The text in the annex was merely to declare that it was considered.

Pat
 
Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]

On Jan 25, 2014, at 12:39 AM, rahul sen <[email-masked]> wrote:

Thanks
Qin

On Wednesday, 15 January 2014 4:52 AM, Kris Pister <[email-masked]> wrote:
Rahul - 
 you're correct that TSCH and the various standards that use it were designed to use existing 802.15.4
radios.  There were market forces that operated in favor of that choice, but there
were a lot of good things about the 15.4 standard to work with (and some bad things too).

A technical discussion of the tradeoffs between different phy/mac schemes for WSN 
is usually a very long discussion, the majority of which is spent making sure that everyone
agrees on terminology and is familiar with the same literature.  A whiteboard is required.  
Coffee is helpful.

The book passages that you point to make gross generalizations.  Statements like "DSSS
transceivers are complex to implement and consume more power" are at best debatable
(I would argue that that particular statement is simply false).

Can you build a reliable low-power mesh with an FHSS phy?  I believe that you can.
If you consider the 802.15.1 bluetooth phy to be FHSS, and you can synchronize your 
clocks to << 0.625ms (not trivial, but doable), then you can probably pretty quickly port
e.g. the openWSN stack and have a mesh up and running.  Cells are still composed of
time and frequency offsets, but the frequency offset is now just the first frequency used,
and the PHY hops from there.  There would be a *lot* of details to work out, but it would
probably work.  Would it work better than 15.4e?  That is going to depend entirely on the
tradeoffs made in working out the details.
If you hop much faster than bluetooth (1600 hops/sec) then you have real problems with
receiver synchronization at the beginning of the packet. 
If you hop much slower, you don't end up hopping before you're done sending. 

[Apologies to all since this is clearly out of scope for the 6TiSCH working group, sorry.]

ksjp

On 1/12/2014 1:58 PM, rahul sen wrote:
> Other issue which has pointed out was power consumption, but some references points out that the DSSS transceivers are complex to implement and consumes more power. (Again, FHSS transreceivers with same power budget will have less transmission range, but in LRWPAN application that alone should not be a limiting factor).
> 
> The spread-spectrum pulse shaping of the IEEE 802.15.4 radio is orthogonal to frequency hopping, which is why the original Zigbee systems used spread spectrum on a single channel while TSCH uses spread spectrum                                             across a set of channels that are selected in an underlying cyclic manner.
> 
> The reality is that the correlator for the IECC 802.15.4 OQPSK signaling improves effective S/N over most similar Eb/No signaling in the channel, primarily due to the coding-induced time spread of the information in the channel. Independently, frequency hopping provides a way to circumvent persistent narrow-band fading in the channel, where in both cases a "channel" is the aggregate propagation path between two correspondents.
> ===
>