Subject: [6tisch] Need command to read bandwidth of a bundle?

From: Qin Wang <[email-masked]>
Date: Sat, 25 Jan 2014 20:48:13 +0800

Hi Diego and all,

I understand that OTF needs getting information about the bandwidth to a
specific neighbor from 6top, but I'm not sure if it is necessary to add
read.bundle command in 6top. It is because upper layer can calculate the
bandwidth by scanning the cell list, i.e. by calling command read.cell
repeatedly. Thus, providing read.bundle command seems redundant even though
it may be a little bit more convenient.

What do you think?

Thanks
Qin

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Sat, 25 Jan 2014 15:29:23 -0200

Qin,
     I agree. The algorithm can calculate the number of
scheduled cells with each neighbour, for example:

Neighbour 1:
Bundle 1: 4 softcells
Bundle 2: 8 softcells
Individually scheduled: 3 softcells

In this case, although 4 softcells are scheduled for Bundle 1,
the algorithm has allocated 2 of them (meaning that
there are still 2 cells to fill the Bundle). So the internal
Bundle accounting has to be managed by OTF and not
by 6top.

For the algorithm running in OTF, it is important to know
the remaining cells inside each Bundle, so only when the
Bundle is complete (meaning all cells are allocated), either:

- an individual softcell is scheduled
- a new Bundle is scheduled
- a Bundle resize request is issued.

To the contrary, the algorithm can decide to reduce the
number of scheduled cells if the Bandwidth requirements
have decreased. In this case:

- a Bundle resize request is issued
- the Bundle is unscheduled and a smaller group of individual
softcells is scheduled

What do you think?

Thank you.

                                   Diego

2014-01-25 Qin Wang <[email-masked]>

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Qin Wang <[email-masked]>
Date: Sun, 26 Jan 2014 21:33:08 +0800

Hi Diego,

Quick questions:

(1) In your case, the difference between Bundle1 and Bundle2 is that they
belong to different Tracks, correct?
(2) What is individually scheduled cell?
(3) What do you mean internal bundle management? Is there any difference
among the cells in a bundle?

Thanks
Qin

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Sun, 26 Jan 2014 19:42:09 -0200

Qin,

Quick answers:

1) In my case, I tried to define a general case, where there may be
more than one scheduled Bundle between two neighbours,
even on the same track. In think this condition could happen if Bundles
cannot
be resized. Is there a limitation in the number of Bundles between
neighbours?

2) I just call "individually scheduled cell" to highlight the fact that it
does not
belong to a Bundle. You can replace it with Softcell. OTF can schedule
Bundles,
Softcells or both.

3) AFAIK, a Bundle is a group of scheduled Softcells which are shared
between
two neighbours. They are all plain Softcells. Nevertheless, either the
algorithm
itself or OTF should know how many cells are still unallocated inside the
Bundle.
I call this management/accounting.

Does it make sense?

Regards,

                       Diego

2014-01-26 Qin Wang <[email-masked]>

---

From: Qin Wang <[email-masked]>
Date: Mon, 27 Jan 2014 21:48:10 +0800

Hi Diego,

According to my understanding, a bundle is a set of scheduled cells and
identified by a specific (TargetNodeAddress, TrackID), which implies a
scheduled cell must belong to a bundle and only belong to one bundle.
correct? Based on the definition,

(1) It is impossible to have more than one bundles toward to same neighbor
on the same track.
(2) The individually scheduled cells are exactly the unscheduled cells in
(slotOffset, channelOffset) Matrix for given slotFrameID.

What do you think?

Thanks
Qin

On Mon, Jan 27, 2014 at 5:42 AM, Prof. Diego Dujovne <
[email-masked]> wrote:

>>>> I understand that OTF needs getting information about the bandwidth to
>>>> a specific neighbor from 6top, but I'm not sure if it is necessary to add

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 27 Jan 2014 13:27:01 -0200

Qin,
      According to (1) the BundleID is solely based on the combination of
(TargetNodeAddress, TrackID), then I agree that there would
be only one Bundle in the example. Then, would it be possible to ask for a
Bundle resize? That reduces the number of options (from the
ones on the Jan 25th mail) to Bundle resize an Softcell scheduling. As a
matter of fact, until now, we have not discussed if the use
of tracks should be within the scope of OTF.
Also, which is the cause of the Bundle restriction to (TargetNodeAddress,
TrackID)?
      (2) Individual scheduled cells are bare simple Softcells. I agree. I
will change this definition on the next version of the draft.
      Thank you.
       Regards,

                                           Diego Dujovne

2014-01-27 Qin Wang <[email-masked]>

>> 2) I just call "individually scheduled cell" to highlight the fact that
>> it does not
>>> (1) In your case, the difference between Bundle1 and Bundle2 is that
>>> they belong to different Tracks, correct?

---

From: Qin Wang <[email-masked]>
Date: Tue, 28 Jan 2014 00:10:08 +0800

Diego,

Regarding to Softcell, what upper layer can do is calling 6top command
Create/Delete/Reallocate.softcell with parameters like Target node address
and TrackID, which results in a new Bundle or a existing Bundle resize.  In
another word, you can ask for a Bundle resize by calling those commands. In
addition, considering how a Bundle is generated or resized as described
here, it seems natural that Bundle is restricted to (TargetNodeAddress,
TrackID).

What do you think?

Thanks
Qin

On Mon, Jan 27, 2014 at 11:27 PM, Prof. Diego Dujovne <
[email-masked]> wrote:

>> (1) It is impossible to have more than one bundles toward to same
>> neighbor on the same track.
>>> itself or OTF should know how many cells are still unallocated inside
>>> the Bundle.
>>>> (3) What do you mean internal bundle management? Is there any
>>>> difference among the cells in a bundle?
>>>>
>>>> Thanks
>>>> Qin
>>>>
>>>>
>>>>
>>>>
>>>>>> I understand that OTF needs getting information about the bandwidth
>>>>>> to a specific neighbor from 6top, but I'm not sure if it is necessary to
>>>>>> add read.bundle command in 6top. It is because upper layer can calculate
>>>>>> the bandwidth by scanning the cell list, i.e. by calling command read.cell

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 27 Jan 2014 15:00:20 -0200

Qin,
      So I can conclude that when a track is defined, the only possible
scheduling is a Bundle. There is no possibility of scheduling Softcells
without Bundles. Am I right?
      Thank you.
      Regards,

                       Diego

>> be only one Bundle in the example. Then, would it be possible to ask for
>> a Bundle resize? That reduces the number of options (from the
>>       (2) Individual scheduled cells are bare simple Softcells. I agree.
>> I will change this definition on the next version of the draft.
>>       Thank you.
>>        Regards,
>>
>>                                            Diego Dujovne
>>
>>
>>
>>
>>> (2) The individually scheduled cells are exactly the unscheduled cells
>>> in (slotOffset, channelOffset) Matrix for given slotFrameID.
>>>
>>> What do you think?
>>>
>>> Thanks
>>> Qin
>>>
>>>
>>>

---

From: Qin Wang <[email-masked]>
Date: Tue, 28 Jan 2014 02:19:09 +0800

Diego,

Yes, it is what is defined in the current version. Is there any problem for
OTF?

Thanks
Qin

On Tue, Jan 28, 2014 at 1:00 AM, Prof. Diego Dujovne <
[email-masked]> wrote:

>>>       According to (1) the BundleID is solely based on the combination
>>> of (TargetNodeAddress, TrackID), then I agree that there would
>>> Also, which is the cause of the Bundle restriction to
>>> (TargetNodeAddress, TrackID)?
>>>>> even on the same track. In think this condition could happen if
>>>>> Bundles cannot
>>>>> 2) I just call "individually scheduled cell" to highlight the fact
>>>>> that it does not

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 27 Jan 2014 11:23:20 -0800

+1

On Mon, Jan 27, 2014 at 10:19 AM, Qin Wang <[email-masked]> wrote:

> Diego,
>
> Yes, it is what is defined in the current version. Is there any problem
> for OTF?
>
> Thanks
> Qin
>
>
>>>> be only one Bundle in the example. Then, would it be possible to ask
>>>> for a Bundle resize? That reduces the number of options (from the
>>>> ones on the Jan 25th mail) to Bundle resize an Softcell scheduling. As
>>>> a matter of fact, until now, we have not discussed if the use
>>>>       (2) Individual scheduled cells are bare simple Softcells. I
>>>> agree. I will change this definition on the next version of the draft.
>>>>       Thank you.
>>>>        Regards,
>>>>
>>>>                                            Diego Dujovne
>>>>
>>>>
>>>>
>>>>
>>>>> According to my understanding, a bundle is a set of scheduled cells
>>>>> and identified by a specific (TargetNodeAddress, TrackID), which implies a
>>>>>> belong to a Bundle. You can replace it with Softcell. OTF can
>>>>>> schedule Bundles,
>>>>>> Softcells or both.
>>>>>>
>>>>>> two neighbours. They are all plain Softcells. Nevertheless, either
>>>>>> the algorithm
>>>>>>>>> I understand that OTF needs getting information about the
>>>>>>>>> bandwidth to a specific neighbor from 6top, but I'm not sure if it is
>>>>>>>>> necessary to add read.bundle command in 6top. It is because upper layer can
>>>>>>>>> calculate the bandwidth by scanning the cell list, i.e. by calling command
>>>>>>>>> read.cell repeatedly. Thus, providing read.bundle command seems redundant
>>>>>>>>> even though it may be a little bit more convenient.
>>>>>>>>>
>>>>>>>>> What do you think?
>>>>>>>>>
>>>>>>>>> Thanks
>>>>>>>>> Qin
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> DIEGO DUJOVNE
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 28 Jan 2014 08:04:10 +0000

I'm missing something, Qin:

We have bundles for any communication between 2 peers that are one radio hop away (that is between this node and a peer known as TargetNodeAddress).
This is the basis of our 6top link abstraction, knowing that there can we multiple of such links between this node and a given peer. So far so good.
I understand that some of those bundles are associated to tracks for GMPLS-like track forwarding. For those I understand the indexing by (TargetNodeAddress, TrackID).

What I'm unclear of from the description below is for the bundles that are associated to L3 (best effort, RPL) traffic. How do we index such a bundle?

I could see that we have either a single one so there is just no TrackId, or there are multiple ones per QoS and then we'd need to add the QoS in the index.
One the side, it does not appear by analogy to experience in WiFi / .11e that multiple best effort bundles per QoS would be very useful.

What do you think?

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: lundi 27 janvier 2014 14:48
To: Prof. Diego Dujovne
Cc: [email-masked]
Subject: Re: [6tisch] Need command to read bandwidth of a bundle?

Hi Diego,

According to my understanding, a bundle is a set of scheduled cells and identified by a specific (TargetNodeAddress, TrackID), which implies a scheduled cell must belong to a bundle and only belong to one bundle. correct? Based on the definition,

(1) It is impossible to have more than one bundles toward to same neighbor on the same track.
(2) The individually scheduled cells are exactly the unscheduled cells in (slotOffset, channelOffset) Matrix for given slotFrameID.

What do you think?

Thanks
Qin

On Mon, Jan 27, 2014 at 5:42 AM, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> wrote:
Qin,
Quick answers:
1) In my case, I tried to define a general case, where there may be
more than one scheduled Bundle between two neighbours,
even on the same track. In think this condition could happen if Bundles cannot
be resized. Is there a limitation in the number of Bundles between neighbours?
2) I just call "individually scheduled cell" to highlight the fact that it does not
belong to a Bundle. You can replace it with Softcell. OTF can schedule Bundles,
Softcells or both.
3) AFAIK, a Bundle is a group of scheduled Softcells which are shared between
two neighbours. They are all plain Softcells. Nevertheless, either the algorithm
itself or OTF should know how many cells are still unallocated inside the Bundle.
I call this management/accounting.
Does it make sense?
Regards,
                       Diego

2014-01-26 Qin Wang <[email-masked]<mailto:[email-masked]>>

Hi Diego,

Quick questions:

(1) In your case, the difference between Bundle1 and Bundle2 is that they belong to different Tracks, correct?
(2) What is individually scheduled cell?
(3) What do you mean internal bundle management? Is there any difference among the cells in a bundle?

Thanks
Qin

On Sun, Jan 26, 2014 at 1:29 AM, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> wrote:
Qin,

2014-01-25 Qin Wang <[email-masked]<mailto:[email-masked]>>

Hi Diego and all,

I understand that OTF needs getting information about the bandwidth to a specific neighbor from 6top, but I'm not sure if it is necessary to add read.bundle command in 6top. It is because upper layer can calculate the bandwidth by scanning the cell list, i.e. by calling command read.cell repeatedly. Thus, providing read.bundle command seems redundant even though it may be a little bit more convenient.

What do you think?

Thanks
Qin

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125<tel:%2856%202%29%20676%208125>

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

---

From: Qin Wang <[email-masked]>
Date: Tue, 28 Jan 2014 21:30:19 +0800

Hi Pascal,

In the current 6top draft, the TrackID is defined as follows.

(1) A tuple (TrackOwnerAddr,InstanceID), where TrackOwnerAddr is the
address of  the node which initializes the process of creating the track,
i.e.,   the owner of the track; and InstanceID is an instance identifier
given by the owner of the track.
(2) If the TrackID is set to (0,0), the cell can be used by the best-effort
QoS configuration.

Does it address your concern?

BTW, can you explain more about "multiple best effort bundles per QoS"?

Thanks
Qin

On Tue, Jan 28, 2014 at 4:04 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> We have bundles for any communication between 2 peers that are one radio
> hop away (that is between this node and a peer known as TargetNodeAddress).
>
> This is the basis of our 6top link abstraction, knowing that there can we
> multiple of such links between this node and a given peer. So far so good.
>
> I understand that some of those bundles are associated to tracks for
> GMPLS-like track forwarding. For those I understand the indexing by
> (TargetNodeAddress, TrackID).
>
>
>
> What I'm unclear of from the description below is for the bundles that are
> associated to L3 (best effort, RPL) traffic. How do we index such a bundle?
>
>
>
> I could see that we have either a single one so there is just no TrackId,
> or there are multiple ones per QoS and then we'd need to add the QoS in the
> index.
>
> One the side, it does not appear by analogy to experience in WiFi / .11e
> that multiple best effort bundles per QoS would be very useful.
>
>
>
> What do you think?
>
>
>
> Pascal
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Qin Wang
> *Sent:* lundi 27 janvier 2014 14:48
> *To:* Prof. Diego Dujovne
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] Need command to read bandwidth of a bundle?
>
>
>
> Hi Diego,
>
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 28 Jan 2014 13:50:35 +0000

Hello Qin:

This is perfect. And I think that we can live with a single bundle for best effort.
The idea of multiple per QoS is basically so have additional slots that we'd use only in case of high QoS, like network priority.
I think we discussed something like that in the past but it does not look like a good tradeoff between complexity and value.

Cheers,

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: mardi 28 janvier 2014 14:30
To: Pascal Thubert (pthubert)
Cc: Prof. Diego Dujovne; [email-masked]
Subject: Re: [6tisch] Need command to read bandwidth of a bundle?

Hi Pascal,

(1) A tuple (TrackOwnerAddr,InstanceID), where TrackOwnerAddr is the address of  the node which initializes the process of creating the track, i.e.,   the owner of the track; and InstanceID is an instance identifier given by the owner of the track.
(2) If the TrackID is set to (0,0), the cell can be used by the best-effort QoS configuration.

Thanks
Qin

On Tue, Jan 28, 2014 at 4:04 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
I'm missing something, Qin:

What do you think?

Pascal

From: 6tisch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Qin Wang
Sent: lundi 27 janvier 2014 14:48
To: Prof. Diego Dujovne
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] Need command to read bandwidth of a bundle?

Hi Diego,

What do you think?

Thanks
Qin

Hi Diego,

Quick questions:

Thanks
Qin

Hi Diego and all,

What do you think?

Thanks
Qin