Subject: [6tisch] feature of 6top Queue

From: Qin Wang <[email-masked]>
Date: Thu, 20 Mar 2014 10:56:41 -0700 (PDT)

Hi all,

In the 6top sublayer, Queues are defined to buffer and shape traffic. The question is how to select a Queue to put a incoming packet in, by the slotframe in which the packet is received, or by the TrackID of the cell on which the packet is received, or by the Priority of the packet. (BTW, in the current version of 6top, there is no packet priority field yet.)

I don't think Queue should be associated with slotframe, because slotframe represents the frequency of periodic communication. Queue can associate with a Track if the packets on a Track have same priority, otherwise, we may need add Priority field (or IE)  in the data packets. 

What do your think?

Thanks
Qin

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 20 Mar 2014 20:02:06 -0700

Qin,
I agree with your analysis of slotframe. For me, the trackid already
includes the notion of priority, so having both tracks and priority looks
redundant?
Thomas

On Thursday, March 20, 2014, Qin Wang <[email-masked]> wrote:

> Hi all,
>
> In the 6top sublayer, Queues are defined to buffer and shape traffic. The
> question is how to select a Queue to put a incoming packet in, by the
> slotframe in which the packet is received, or by the TrackID of the cell on
> which the packet is received, or by the Priority of the packet. (BTW, in
> the current version of 6top, there is no packet priority field yet.)
>
> I don't think Queue should be associated with slotframe, because slotframe
> represents the frequency of periodic communication. Queue can associate
> with a Track if the packets on a Track have same priority, otherwise, we
> may need add Priority field (or IE)  in the data packets.
>
> What do your think?
>
> Thanks
> Qin
>
>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 21 Mar 2014 09:05:04 +0000

Hi Qin and Thomas,
I do agree with both of you...
I mean, for sure the queue shouldn't be associated with the slotframe.
And the trackID should already include a given priority that has to be provided to that flow. Thus, the TrackID should be enough.
Maria Rita
From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Friday, March 21, 2014 4:02 AM
To: Qin Wang
Cc: [email-masked]
Subject: Re: [6tisch] feature of 6top Queue

Qin,
I agree with your analysis of slotframe. For me, the trackid already includes the notion of priority, so having both tracks and priority looks redundant?
Thomas

On Thursday, March 20, 2014, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

What do your think?

Thanks
Qin

---

From: Qin Wang <[email-masked]>
Date: Fri, 21 Mar 2014 06:15:50 -0700 (PDT)

Hi Thomas and Maria Rita,

Besides the priority of packet, I think TrackID also represents the a end-to-end path. For example, there are two multi-hop paths owned by node N1 and N2 respectively, thus, TrackID equal to (N1,instanceID) and (N2,instanceID), respectively. Assume both of the two paths includes nodeA->nodeB hop, and transfer the packets of same priority. Then, the problem is:  in the nodeB, how to configure the queues, one queue or two queues corresponding to the two TrackIDs? I think the answer should be one Queue, and a mapping between trackID and priority should be established along the path while a Track is created.

What do you think?

Thanks
Qin

On Friday, March 21, 2014 5:05 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
 
Hi Qin and Thomas,
I do agree with both of you…
I mean, for sure the queue shouldn’t be associated with the slotframe. 
And the trackID should already include a given priority that has to be provided to that flow. Thus, the TrackID should be enough.
Maria Rita
From:6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Friday, March 21, 2014 4:02 AM
To: Qin Wang
Cc: [email-masked]
Subject: Re: [6tisch] feature of 6top Queue
 
Qin,

 
 
What do your think?
 
Thanks
Qin

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 21 Mar 2014 14:12:57 +0000

Qin,
Sure, a TrackID corresponds to a flow along a e2e multi-hop path. In the example you have provided, I think node B should have a single queue, where storing the pkt belonging to different trackID.
I don’t think having pkt belonging to different TrackID in the same queue can create problems! At least, now, I don’t see them!
When a cell on a TrackID is available for tx in the schedule, then, the first pkt belonging to that TrackID will leave the queue.
In term of priority, different flows, along different e2e paths, may even have some priority, but this I don’t think it will impact the queue.
What do you think?
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Friday, March 21, 2014 2:16 PM
To: Maria Rita PALATTELLA; Thomas Watteyne
Cc: [email-masked]
Subject: Re: [6tisch] feature of 6top Queue

What do you think?

Thanks
Qin

On Friday, March 21, 2014 5:05 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qin and Thomas,
I do agree with both of you…
I mean, for sure the queue shouldn’t be associated with the slotframe.
And the trackID should already include a given priority that has to be provided to that flow. Thus, the TrackID should be enough.
Maria Rita
From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Friday, March 21, 2014 4:02 AM
To: Qin Wang
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] feature of 6top Queue

Qin,

What do your think?

Thanks
Qin

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Qin Wang <[email-masked]>
Date: Fri, 21 Mar 2014 07:27:33 -0700 (PDT)

Hi Maria Rita,

I agree there is no problem to forward the packets already in a queue. My concern is when a packet comes in at specific cell with a TrackID, how does 6top know which queue the packet should be put in just based on the trackID. So I propose to establish a mapping between TrackID and priority while the Track is created. What do you think?

Thanks
Qin

On Friday, March 21, 2014 10:13 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
 
Qin,
 
From:Qin Wang [mailto:[email-masked]] 
Sent: Friday, March 21, 2014 2:16 PM
To: Maria Rita PALATTELLA; Thomas Watteyne
Cc: [email-masked]
Subject: Re: [6tisch] feature of 6top Queue

 
What do you think?
 
Thanks
Qin

 
Qin,

 
 
What do your think?
 
Thanks
Qin

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 21 Mar 2014 14:29:38 +0000

I see your point Qin. Then, we should associate a priority to each TrackID, and have on each node different queue per different priority…
Is it correct? By doing so, we can do the mapping when we have a new pkt coming in.
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Friday, March 21, 2014 3:28 PM
To: Maria Rita PALATTELLA; Thomas Watteyne
Cc: [email-masked]
Subject: Re: [6tisch] feature of 6top Queue

Hi Maria Rita,

Thanks
Qin

On Friday, March 21, 2014 10:13 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Qin,

What do you think?

Thanks
Qin

Qin,

What do your think?

Thanks
Qin

---

From: Qin Wang <[email-masked]>
Date: Fri, 21 Mar 2014 07:45:30 -0700 (PDT)

Maria Rita,

My understanding is the set of Priority should be defined in some QoS draft. And, 6top queues will be configured according to the set of Priority. Then, when a Track is created, 6top will be told which queue, i.e. what priority, the track is associated. Based on the TrackID-Queue relationship, 6top will know how to put a incoming packet into queue.

What do you think?

Thanks
Qin

On Friday, March 21, 2014 10:29 PM, Maria Rita PALATTELLA <[email-masked]> wrote:

 
Hi Maria Rita,

Thanks
Qin

 

What do you think?
 
Thanks
Qin

 
Qin,

 
 
What do your think?
 
Thanks
Qin

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 21 Mar 2014 14:48:05 +0000

Yes, I do agree it should work in this way.
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Friday, March 21, 2014 3:46 PM
To: Maria Rita PALATTELLA; Thomas Watteyne
Cc: [email-masked]
Subject: Re: [6tisch] feature of 6top Queue

Maria Rita,

What do you think?

Thanks
Qin

On Friday, March 21, 2014 10:29 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
I see your point Qin. Then, we should associate a priority to each TrackID, and have on each node different queue per different priority…
Is it correct? By doing so, we can do the mapping when we have a new pkt coming in.
Maria Rita

Hi Maria Rita,

Thanks
Qin

What do you think?

Thanks
Qin

Qin,

What do your think?

Thanks
Qin