Subject: [6tisch] SOFT cells selection procedure MISSING in 6top

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 20 Mar 2014 10:29:38 +0000

Dear Qin, Xavi (all)

(As promised) I have been reading in deep the 6top sublayer draft, in order to check the commands offered by 6top that can be useful for OTF.

While doing so, I have realized that a SOFT cell selection procedure for adding/deleting soft cells,  is MISSING in the draft.
6top describes in details the negotiation phase, and thus, the messages exchanged between 6top & 6top (on the two neighbor nodes), but not the method used for selecting the  specific cells that will be added or deleted.
Moreover, also the behavior of the nodes when the soft cells negotiation phase fails is not defined.

In detail, in the draft it is clearly said:

"The policy to build a candidate cell set and the policy to select cells from the candidate cell set to reserve are out of scope"
"The behavior of the nodes when the soft cells negotiation fails is out of scope"
"The policy to select cells corresponding to a delete soft cell command is out of scope".

I do believe that these are important missing pieces that should be defined, either  in 6top or somewhere else in the 6TiSCH context.
They are needed, not only for OTF but for any module that uses 6top, and for any implementation/network  built on 6TiSCH architecture.

What do you (and others in the group) think about?

Thank you!
Maria Rita

---

From: Qin Wang <[email-masked]>
Date: Thu, 20 Mar 2014 07:21:41 -0700 (PDT)

Hi Maria Rita,

Thank you very much for examining the detail and providing your comments.

I agree that for OTF and others to run 6top, those missing pieces you pointed out are necessary. However, those "out of scope"s are intention. The reason is that there are more than one solutions for each missing piece, and we don't want to specify it in the draft. I think we can have two approaches to address the issue. (1) add a default but not optimized scheme for each missing piece; or (2) describe one by one in separate drafts.

What do you and others think?

Thanks
Qin

On Thursday, March 20, 2014 6:29 PM, Maria Rita PALATTELLA <[email-masked]> wrote:

Dear Qin, Xavi (all)

 
 
“The policy to build a candidate cell set and the policy to select cells from the candidate cell set to reserve are out of scope”
“The behavior of the nodes when the soft cells negotiation fails is out of scope”
“The policy to select cells corresponding to a delete soft cell command is out of scope”.
 
I do believe that theseare  important missing pieces that should be defined, either  in 6top or somewhere else in the 6TiSCH context.
They are needed, not only for OTF but for any module that uses 6top, and for any implementation/network  built on 6TiSCH architecture.

Thank you!
Maria Rita
 
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 20 Mar 2014 15:13:40 +0000

Hi Qin,
I do agree with you that we may include some simple default procedures for cells selection and negotiation failure into 6top, in order to allow also a minimal default implementation of TSCH when also soft cells are used.
And then dedicate separated drafts on these missing procedures, suggesting different potential solutions.
Thank you!
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Thursday, March 20, 2014 3:22 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavi Vilajosana Guillén ([email-masked])
Cc: [email-masked]
Subject: Re: [6tisch] SOFT cells selection procedure MISSING in 6top

Hi Maria Rita,

Thanks
Qin

On Thursday, March 20, 2014 6:29 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Dear Qin, Xavi (all)

Thank you!
Maria Rita

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Xavier Vilajosana <[email-masked]>
Date: Thu, 20 Mar 2014 21:08:14 +0100

Hi Qin, agree with you. I'm in favour of having an "example" case (or
default if example is not enough) and let everyone implement their own
"optimized" policies.
regards,
Xavi

2014-03-20 16:13 GMT+01:00 Maria Rita PALATTELLA <
[email-masked]>:

>  Hi Qin,
>
> I do agree with you that we may include some simple default procedures for
> cells selection and negotiation failure into 6top, in order to allow also a
> minimal default implementation of TSCH when also soft cells are used.
>
> *From:* Qin Wang [mailto:[email-masked]]
> *Sent:* Thursday, March 20, 2014 3:22 PM
> *To:* Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavi
> Vilajosana Guillén ([email-masked])
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] SOFT cells selection procedure MISSING in 6top
>
>
>
> Hi Maria Rita,
>
>
>
> I agree that for OTF and others to run 6top, those missing pieces you
> pointed out are necessary. However, those "out of scope"s are intention.
> The reason is that there are more than one solutions for each missing
> piece, and we don't want to specify it in the draft. I think we can have
> two approaches to address the issue. (1) add a default but not optimized
> scheme for each missing piece; or (2) describe one by one in separate
> drafts.
>
>
>
> (As promised) I have been reading in deep the 6top sublayer draft, in
> order to check the commands offered by 6top that can be useful for OTF.
>
>
>
> While doing so, I have realized that a SOFT cell selection procedure for
> adding/deleting soft cells,  is MISSING in the draft.
>
> 6top describes in details the negotiation phase, and thus, the messages
> exchanged between 6top & 6top (on the two neighbor nodes), but not the
> method used for selecting the  specific cells that will be added or deleted.
>
> "The *policy to build a candidate cell set and the policy to select cells*from the candidate cell set to reserve are out
> of scope"
>
> "The *behavior of the nodes when the soft cells negotiation fails* is out
> of scope"
>
> "The *policy to select cells corresponding to a delete* soft cell command
> is out of scope".
>
>
>
> I do believe that these are *important missing pieces* that should be
> defined, either  in 6top or somewhere else in the 6TiSCH context.
>
> They are needed, not only for OTF but for any module that uses 6top, and
> for any implementation/network  built on 6TiSCH architecture.
>
>
>

---

From: Thomas Watteyne <[email-masked]>
Date: Sun, 23 Mar 2014 23:37:34 -0700

+1

The selection policy/algorithm does not affect what goes over the air. I
would second Xavi's proposal to maybe add an example, but not mandate some
particular algorithm. This applies to the following elements.

"The *policy to build a candidate cell set and the policy to select cells* from
the candidate cell set to reserve are out of scope"

Xavi, do you think we need some text to describe:

?

Thomas

On Thu, Mar 20, 2014 at 1:08 PM, Xavier Vilajosana <
[email-masked]> wrote:

>> I do agree with you that we may include some simple default procedures
>> for cells selection and negotiation failure into 6top, in order to allow
>> also a minimal default implementation of TSCH when also soft cells are used.
>>
>> And then dedicate separated drafts on these missing procedures,
>> suggesting different potential solutions.
>>
>> Thank you!
>>
>> Maria Rita
>>
>>
>>
>>
>>
>> "The *policy to build a candidate cell set and the policy to select
>> cells* from the candidate cell set to reserve are out of scope"
>>
>> "The *policy to select cells corresponding to a delete* soft cell
>> command is out of scope".
>>
>>
>>

---

From: Xavier Vilajosana <[email-masked]>
Date: Mon, 24 Mar 2014 11:45:33 +0100

Hi Thomas,

I have doubts on that.

When the softcell negotiation process fails, there are many different
policies to handle the situation. Some policies will retry negotiation
after a while, while others may decide to select another neighbor. Not sure
if we have to define them or in contrast give examples of ways to handle
that.

What I think it is important is to identify if there are special
requirements/messages to handle that situation, our task is to provide the
tools to support any kind of behaviour to handle negotiation failures.

what do you think?
X

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Mon, 24 Mar 2014 11:26:11 +0000

Hi Xavi,
I do agree with you that we should at least provide some examples about how to handle this situation (soft cell negotiation failure), in different contexts. For sure, by doing so, we will figure out if there are new messages that should be added in 6top.
Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Xavier Vilajosana
Sent: Monday, March 24, 2014 11:46 AM
To: Thomas Watteyne
Cc: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Qin Wang; [email-masked]
Subject: Re: [6tisch] SOFT cells selection procedure MISSING in 6top

Hi Thomas,

I have doubts on that.

When the softcell negotiation process fails, there are many different policies to handle the situation. Some policies will retry negotiation after a while, while others may decide to select another neighbor. Not sure if we have to define them or in contrast give examples of ways to handle that.

What I think it is important is to identify if there are special requirements/messages to handle that situation, our task is to provide the tools to support any kind of behaviour to handle negotiation failures.

what do you think?
X

2014-03-24 7:37 GMT+01:00 Thomas Watteyne <[email-masked]<mailto:[email-masked]>>:
+1

The selection policy/algorithm does not affect what goes over the air. I would second Xavi's proposal to maybe add an example, but not mandate some particular algorithm. This applies to the following elements.

?

Thomas

On Thu, Mar 20, 2014 at 1:08 PM, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qin, agree with you. I'm in favour of having an "example" case (or default if example is not enough) and let everyone implement their own "optimized" policies.
regards,
Xavi

2014-03-20 16:13 GMT+01:00 Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>>:

Hi Qin,

From: Qin Wang [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, March 20, 2014 3:22 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]<mailto:[email-masked]>); Xavi Vilajosana Guillén ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] SOFT cells selection procedure MISSING in 6top

Hi Maria Rita,

Thanks
Qin

Thank you!
Maria Rita

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 24 Mar 2014 22:37:22 -0700

Qin,
Could you capture this discussion in issues?
Thanks,
Thomas

On Mon, Mar 24, 2014 at 4:26 AM, Maria Rita PALATTELLA <
[email-masked]> wrote:

>  Hi Xavi,
>
> I do agree with you that we should at least provide some examples about
> how to handle this situation (soft cell negotiation failure), in different
> contexts. For sure, by doing so, we will figure out if there are new
> messages that should be added in 6top.
>
> Maria Rita
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Xavier Vilajosana
> *Sent:* Monday, March 24, 2014 11:46 AM
> *To:* Thomas Watteyne
> *Cc:* Maria Rita PALATTELLA; Qin Wang ([email-masked]); Qin Wang;
> [email-masked]
>
> I do believe that these are * important missing pieces* that should be

---

From: Qin Wang <[email-masked]>
Date: Tue, 25 Mar 2014 07:09:55 -0700 (PDT)

sure!

Qin

On Tuesday, March 25, 2014 1:37 PM, Thomas Watteyne <[email-masked]> wrote:
 
Qin,

On Mon, Mar 24, 2014 at 4:26 AM, Maria Rita PALATTELLA <[email-masked]> wrote:

Hi Xavi,
>From:[email-masked] [mailto:[email-masked]] On Behalf Of Xavier Vilajosana
>On Thu, Mar 20, 2014 at 1:08 PM, Xavier Vilajosana <[email-masked]> wrote:
>2014-03-20 16:13 GMT+01:00 Maria Rita PALATTELLA <[email-masked]>:
> 
>>Hi Qin,
>>From:Qin Wang [mailto:[email-masked]]