Subject: [6tisch] chunk: hard or soft cells?

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 21 Mar 2014 17:27:49 +0000

Dear all,
We have been discussing a lot about chunks on the ML, but I believe there is still one point related to chunks to be clarified.
In the current version of 6top draft, it seems that only hard cells can be allocated within a chunk, by using the CREATE.hardcell.fromchunk (see sec.3.11.1 for detail).
I do believe that it shouldn't be the case, because this creates strong limitations, and does not allow to use chunks in many contexts, such as OTF, or other distributed approach.
I would suggest that cells within a chunk can be scheduled either as HARD or SOFT cells, according to the implementation's need, and the specific use case.
IMHO, I don't see why they should be HARD. The node that owns the chunk can decide to allocate soft cells to its children by using 6top. 6top only needs to know what is the set of cells that belong to that chunk.
What do you think about?
Thanks
Maria Rita

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 21 Mar 2014 17:31:15 +0000

Same here Maria Rita

IMHO, chunks are mostly useful in the context of cells that are locally administered by a device (a RPL parent) for best effort bundles with its children.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: vendredi 21 mars 2014 18:28
To: [email-masked]
Subject: [6tisch] chunk: hard or soft cells?

Dear all,

---

From: Qin Wang <[email-masked]>
Date: Fri, 21 Mar 2014 14:21:27 -0700 (PDT)

Hi Maria Rita,

I agree with you. Actually, in the "OTF& chunk thread" we have discussed the issue, and here is my answer to Nicola's requirement.

"The negotiation to allocate softcells can base on a given slotframe or a part of the slotframe (i.e. a chunk). Actually, it can be achieved based on current version of 6top, by using chunkID to define candidate list (see the sublayer draft)."

That means the underline mechanism of soft cell allocation/reallocation can support softcell operations based on slot frame or chunk . What we need to do is adding command to allow upper layer to call the function.

What do you think?

Thanks
Qin

On Friday, March 21, 2014 1:27 PM, Maria Rita PALATTELLA <[email-masked]> wrote:

Dear all,
We have been discussing a lot about chunks on the ML, but I believe there is still one point related to chunks to be clarified.
In the current version of 6top draft, it seems that only hard cells can be allocated within a chunk, by using the CREATE.hardcell.fromchunk (see sec.3.11.1 for detail).
I do believe that it shouldn’t be the case, because this creates strong limitations, and does not allow to use chunks in many contexts, such as OTF, or other distributed approach.
I would suggest that cells within a chunk can be scheduled either as HARD or SOFT cells, according to the implementation’s need, and the specific use case.
IMHO, I don’t see why they should be HARD. The node that owns the chunk can decide to allocate soft cells to its children by using 6top. 6top only needs to know what is the set of cells that belong to that chunk.
What do you think about?
Thanks
Maria Rita

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 22 Mar 2014 08:35:39 +0000

Hello Qin:

A chunk is like a heap of memory that can be used later for multiple usages.

The parent appropriates a chunk by some method to be refined and then it can use cells from that chunk and place them in various bundles.

Also, chunks are an optional mechanism, and we can imagine that a parent may get its cells from some other mechanism in the future (or just get them from config. Or PCE).

So I do not think that the chunk ID should appear in the 6-2-6 or OTF-2-6. IMHO it is really an artifact to get something as close as possible to unique control of a cell within an interference domain.

And as Pouria points out, there is a limit to that unique control. There could be other users for that chunk that are not detected by the appropriation process, or there could be other users of the channel.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: vendredi 21 mars 2014 22:21
To: Maria Rita PALATTELLA; [email-masked]
Subject: Re: [6tisch] chunk: hard or soft cells?

Hi Maria Rita,

What do you think?

Thanks
Qin

On Friday, March 21, 2014 1:27 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Thomas Watteyne <[email-masked]>
Date: Sun, 23 Mar 2014 23:53:15 -0700

All,
I believe there consensus, both from the last webex and from the ML
activity, that the concept of chunks is orthogonal to hard/soft cells.

Maria Rita,
What changes does this entail? In
http://tools.ietf.org/html/draft-wang-6tisch-6top-interface-02#section-4,
we have CREATE.hardcell.fromchunk and DELETE.hardcell.fromchunk. Are you
suggesting we need to add the equivalent CREATE.softcell.fromchunk and
DELETE.softcell.fromchunk, or were you thinking of another set of commands
altogether?

Thomas

On Sat, Mar 22, 2014 at 1:35 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> The parent appropriates a chunk by some method to be refined and then it
> can use cells from that chunk and place them in various bundles.
>
>
>
> Also, chunks are an optional mechanism, and we can imagine that a parent
> may get its cells from some other mechanism in the future (or just get them
> from config. Or PCE).
>
>
>
> So I do not think that the chunk ID should appear in the 6-2-6 or OTF-2-6.
> IMHO it is really an artifact to get something as close as possible to
> unique control of a cell within an interference domain.
>
>
>
> And as Pouria points out, there is a limit to that unique control. There
> could be other users for that chunk that are not detected by the
> appropriation process, or there could be other users of the channel.
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Qin Wang
> *Sent:* vendredi 21 mars 2014 22:21
> *To:* Maria Rita PALATTELLA; [email-masked]
> *Subject:* Re: [6tisch] chunk: hard or soft cells?
>
>
>
> Hi Maria Rita,
>
>
>
> I agree with you. Actually, in the "OTF& chunk thread" we have discussed
> the issue, and here is my answer to Nicola's requirement.
>
>
>
> "The negotiation to allocate softcells can base on a given slotframe or a
> part of the slotframe (i.e. a chunk). Actually, it can be achieved based on
> current version of 6top, by using chunkID to define candidate list (see the
> sublayer draft)."
>
>
>
> That means the underline mechanism of soft cell allocation/reallocation
> can support softcell operations based on slot frame or chunk . What we need
> to do is adding command to allow upper layer to call the function.
>
>
>
> What do you think?
>
>
>
> Thanks
>
> Qin
>
>
>
> We have been discussing a lot about chunks on the ML, but I believe there
> is still one point related to chunks to be clarified.
>
> In the current version of 6top draft, it seems that only *hard cells* can
> be allocated within a chunk, by using the *CREATE.hardcell.fromchunk *(see
> sec.3.11.1 for detail).
>
> I do believe that it shouldn't be the case, because this creates strong
> limitations, and does not allow to use chunks in many contexts, such as
> OTF, or other distributed approach.
>
> I would suggest that cells within a chunk can be scheduled either as HARD
> or SOFT cells, according to the implementation's need, and the specific use
> case.
>
> IMHO, I don't see why they should be HARD. The node that owns the chunk
> can decide to allocate soft cells to its children by using 6top. 6top only
> needs to know what is the set of cells that belong to that chunk.
>
> What do you think about?
>
> Thanks
>
> Maria Rita
>
>
>
>
>
>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Mon, 24 Mar 2014 07:43:55 +0000

Thomas,
For the time being I think that the two commands (CREATE.softcell.fromchunk and DELETE.softcell.fromchunk) you are suggesting are at least the minimum set we need.
Afterward, while keeping in defining OTF in more details, or checking how DeTAS could be implemented, maybe we will discover the need of other commands. Let's see.
Thank you!
Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Monday, March 24, 2014 7:53 AM
To: Pascal Thubert (pthubert)
Cc: Qin Wang; Maria Rita PALATTELLA; [email-masked]
Subject: Re: [6tisch] chunk: hard or soft cells?

All,
I believe there consensus, both from the last webex and from the ML activity, that the concept of chunks is orthogonal to hard/soft cells.

Maria Rita,
What changes does this entail? In http://tools.ietf.org/html/draft-wang-6tisch-6top-interface-02#section-4, we have CREATE.hardcell.fromchunk and DELETE.hardcell.fromchunk. Are you suggesting we need to add the equivalent CREATE.softcell.fromchunk and DELETE.softcell.fromchunk, or were you thinking of another set of commands altogether?

Thomas

On Sat, Mar 22, 2014 at 1:35 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Qin:

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Qin Wang
Sent: vendredi 21 mars 2014 22:21
To: Maria Rita PALATTELLA; [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] chunk: hard or soft cells?

Hi Maria Rita,

What do you think?

Thanks
Qin

---

From: Qin Wang <[email-masked]>
Date: Mon, 24 Mar 2014 06:39:20 -0700 (PDT)

Hi Maria Rita and Nicola,

After reading the comments from Pascal and thinking about the feature of chunk again, I have some hesitation to add CREATE.softcell.fromchunk and DELETE.softcell.fromchunk commands. The reason is: the cells of a chunk is managed by a parent only. The children have no right to negotiate with parent in re-allocating the cell. When the parent find some cell in bad condition, the parent just simply deletes the cell and choose another cell by calling 6top commands. The procedure is more like PCE to operate hardcell, instead of a pair of 6top to operate softcell. So, I think if OTF wants to use the cells in chunk, it should use the hardcell mechanism.

What do you think?

Thanks
Qin

On Monday, March 24, 2014 3:44 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
 
Thomas,
For the time being I think that the two commands (CREATE.softcell.fromchunk and DELETE.softcell.fromchunk) you are suggesting are at least the minimum set we need.
Afterward, while keeping in defining OTF in more details, or checking how DeTAS could be implemented, maybe we will discover the need of other commands. Let’s see.
Thank you!
Maria Rita
 
From:[email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
 
All,
 
Maria Rita,
 
Thomas
 
On Sat, Mar 22, 2014 at 1:35 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:
Hello Qin:

 

 
Cheers,
 
Pascal
 
From:6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: vendredi 21 mars 2014 22:21
To: Maria Rita PALATTELLA; [email-masked]
Subject: Re: [6tisch] chunk: hard or soft cells?
 
Hi Maria Rita,

 
 
What do you think?
 
Thanks
Qin

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 24 Mar 2014 14:52:21 +0000

+1 Qin,

Also, I think it would be nice for the child to be able to ask for a cell that is bounded in time. For instance please shift that cell left or right by at least so many time slots, or add me a cell between time slots a and b… This may be useful e.g. for a parent to avoid queuing between multiple receives from children and before xmit to grandparents.
Also, the parent should be able to black list the times it is receiving from its own children so that the grandparent does not give it a slot that overlaps.

What do you think?

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: lundi 24 mars 2014 14:39
To: Maria Rita PALATTELLA; Thomas Watteyne; Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tisch] chunk: hard or soft cells?

What do you think?

Thanks
Qin

On Monday, March 24, 2014 3:44 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Thomas,
For the time being I think that the two commands (CREATE.softcell.fromchunk and DELETE.softcell.fromchunk) you are suggesting are at least the minimum set we need.
Afterward, while keeping in defining OTF in more details, or checking how DeTAS could be implemented, maybe we will discover the need of other commands. Let’s see.
Thank you!
Maria Rita

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Monday, March 24, 2014 7:53 AM
To: Pascal Thubert (pthubert)
Cc: Qin Wang; Maria Rita PALATTELLA; [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] chunk: hard or soft cells?

All,

Maria Rita,

Thomas

Cheers,

Pascal

Hi Maria Rita,

What do you think?

Thanks
Qin

---

From: Qin Wang <[email-masked]>
Date: Mon, 24 Mar 2014 08:14:40 -0700 (PDT)

Hi Pascal,

If the parent can read  its children's MIB or be reported periodically by its children via something like Wrapper IE, I think that the parent can get equivalent information as you mentioned. What do you think?

Thanks
Qin

On Monday, March 24, 2014 10:52 PM, Pascal Thubert (pthubert) <[email-masked]> wrote:
 
+1 Qin,

What do you think?
 
Pascal
 
From:Qin Wang [mailto:[email-masked]] 
Sent: lundi 24 mars 2014 14:39
To: Maria Rita PALATTELLA; Thomas Watteyne; Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tisch] chunk: hard or soft cells?

 
What do you think?
 
Thanks
Qin

 
All,
 
Maria Rita,
 
Thomas

 

 
 
Cheers,
 
Pascal

Hi Maria Rita,

 
 
What do you think?
 
Thanks
Qin

---

From: Michael Richardson <[email-masked]>
Date: Mon, 24 Mar 2014 12:26:03 -0400

Qin Wang <[email-masked]> wrote:
    > If the parent can read  its children's MIB or be reported periodically by its
    > children via something like Wrapper IE, I think that the parent can get
    > equivalent information as you mentioned. What do you think?

A question:

In the non-PCE case, it is my understanding that the parent will assign a
timeslot to each child.  Based upon the above comment, it is assumed that the
parent will do this by *writing* a schedule into the child using the MIB?

Or could this happen by RPL DAO-ACK messages, or some such?

I'm asking because I had not previously understood a trust relationship like
that would be required.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Qin Wang <[email-masked]>
Date: Mon, 24 Mar 2014 10:30:22 -0700 (PDT)

Hi Micheal,

In another thread "Wrapping CoAP in 6top IE", we are discussing about the possibility to use CoAP-like protocol in 6top-to-6top communication to allow a parent to write its children's MIB. If the CoAP-like protocol can be used in 6top-to-6top, we hope the security related stuff in CoAP can be applied to the 6top-to-6top communication automatically. Make sense?

Thanks
Qin

On Tuesday, March 25, 2014 12:37 AM, Michael Richardson <[email-masked]> wrote:

Qin Wang <[email-masked]> wrote:
    > If the parent can read  its children's MIB or be reported periodically by its
    > children via something like Wrapper IE, I think that the parent can get
    > equivalent information as you mentioned. What do you think?

A question:

Or could this happen by RPL DAO-ACK messages, or
 some such?