Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 21 Mar 2014 13:50:27 +0000

Hi Qin:

A bundle is really the collection of cells that put together create a half-duplex IP link between 2 nodes with a bandwidth that is:
(medium bandwidth) * (nb of cells in the bundle) / (number of cells in the slotframe).

We have chosen to extend that definition for a collection of cells that put together create a half-duplex hop for an end to end track.

Using the same term “bundle” is fine with me but if we have a track that passes between A and, the bundle for that track will be different from the bundle for the IP link between adjacent nodes A and B.

Cells in a bundle should be equivalent for 6top to place the next packet for the track onto the next cell in the bundle for that track, and conversely the next packet to be sent on the next cell in the bundle for the IP link.

I think we should not attempt to group together bundles to form a larger bundle. What purpose would that serve?

PS; I’m ok to cc the ML; what about you all?

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: vendredi 21 mars 2014 14:31
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Hi Maria Rita,

Regarding to the Bundle and Track, my understanding is: bundle is a set of cells to a specific neighbor, i.e. representing a link of some BW; track is a set of cells to a specific neighbor and must be associated with a specific multi-hop path. In another word, from one-hop point of view, a bundle may correspond to more than one tracks. What do you think?

Thanks
Qin

On Friday, March 21, 2014 5:13 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qin, thanks for your detailed email.
I am afraid I am still missing something… concerning bundle and track…
When talking about CellList, you make a difference between getting stat. per bundle or per track.
But shouldn’t a bundle be associated to a specific track, given that each cell (and, thus each cell in the bundle) has a TrackID?
Thanks
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Thursday, March 20, 2014 6:35 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Hi Maria Rita,

I agree that OTF should be able to play on specific Track.

The statistics data is in 4 data structure of MIB.
(1) In CellList. It is per cell statistics, from it upper layer can get per bundle or per track statistics.
(2) In MonitoringStatusList. It is per neighbor & slotframe statistics, from it upper layer can get per bundle overview of scheduling and its performance.
(3) In NeighborList. It is per neighbor statistics, from it upper layer can understand the connectivity of a pair of nodes.
(4) In QueueList. It is per Queue statistics, from it upper layer can know the traffic load.

OTF can combine those statistics to make decision. Make sense?

But, as we discussed before, we may need to clarify the feature of a Queue, corresponding to a slotframe, or a Track, or something else. According to my understanding, Queue should associate with Priority defined in QoS, instead of slotframe or Track. Let's start another thread to discuss the feature of Queue.

Thanks
Qin

On Thursday, March 20, 2014 11:25 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Hello Qin,
OTF will figure out if more or less BDW is needed by using the information that 6top provides, e.g., the stat. about BDW (allocated soft cells, overprovision cells, QoS, NQoS), traffic load on a link, queue length, avg time spent by a pkt in the queue…
Then, which approach shall we use? It is still not so clear to me…but I have the feeling that we should use the specific trackID, and not the Best-effort one. Am I wrong?
Thanks for helping in clarifying that!
Best regards,
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Thursday, March 20, 2014 3:37 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]<mailto:[email-masked]>); Xavier Vilajosana ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF

Hi Maira Rita,

I don't exactly know how OTF figures out the demand of add/delete softcells. In my mind, at least, there are two ways.

(1) The demand is from network point of view, e.g. nodeA wants to create/extend/reduce certain BW to nodeB multi-hop away, then a TrackID should be given. Along the path, OTF will ask 6top to allocate/de-allcoate softcells on the given TrackID.

(2) The demand is from the evaluation of local traffic. In this case, I would like to propose to use Best-effort trackID, i.e. TrackID=(0,0).

What do you think?

Thanks
Qin

On Thursday, March 20, 2014 6:50 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Dear Qin, Xavi (all)

OTF aims to dynamically allocate (de-allocate) soft cells based on the bandwidth (BDW) needed between two neighbor nodes.
After estimating the BDW (and thus the number of soft cells to be added/deleted), OTF delegates to 6top the actual (de)allocation operation.

Given that each soft cell assigned to two neighbor nodes belongs to a specific TRACK, I was wondering how OTF should deal with this.
I mean, shall we suppose that all the traffic in the network belongs to the same TRACK, in order to simply OTF operation?
At the same time, I believe it is not realistic to assume there is only one track, and thus, one flow in the network. But if we assume that we have more than one flow/track, then, we should have several  OTF instances, one for each track.

Do you think that OTF should check the BDW between two nodes per TRACK? Because if checking the overall BDW, then OTF cannot know, on which track the new soft cell should be added.

Looking forward to receiving your advices on how to deal with tracks and OTF soft cells reservation …

Thank you in advance!

Best regards,
Maria Rita

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Qin Wang <[email-masked]>
Date: Fri, 21 Mar 2014 07:17:13 -0700 (PDT)

Hi Pascal,

I'm not sure I understand what you said very well. Do you mean a bundle from nodeA to nodeB must associated one and only one Track? In another word, a bundle is one-hop of a Track. Right?

Thanks
Qin

On Friday, March 21, 2014 9:50 PM, Pascal Thubert (pthubert) <[email-masked]> wrote:
 
Hi Qin:

 

 
 
Pascal
 
From:6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: vendredi 21 mars 2014 14:31
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF
 
Hi Maria Rita,

Thanks
Qin
 
On Friday, March 21, 2014 5:13 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
 
From:Qin Wang [mailto:[email-masked]] 
Sent: Thursday, March 20, 2014 6:35 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF
 
Hi Maria Rita,

 

Thanks
Qin

 
On Thursday, March 20, 2014 11:25 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
Hello Qin,
OTF will figure out if more or less BDW is needed by using the information that 6top provides, e.g., the stat. about BDW (allocated soft cells, overprovision cells, QoS, NQoS), traffic load on a link, queue length, avg time spent by a pkt in the queue…
Then, which approach shall we use? It is still not so clear to me…but I have the feeling that we should use the specific trackID, and not the Best-effort one. Am I wrong?
Thanks for helping in clarifying that!
Best regards,
Maria Rita

 
From:Qin Wang [mailto:[email-masked]] 
Sent: Thursday, March 20, 2014 3:37 PM
To: Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: Re: [6tisch] tracks & soft cells reservation w/ OTF
 
Hi Maira Rita,

 
 
What do you think?
 
Thanks
Qin

On Thursday, March 20, 2014 6:50 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
Dear Qin, Xavi (all)

 

Thank you in advance!
 
Best regards,
Maria Rita

[email-masked]
 
[email-masked]

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 21 Mar 2014 14:24:07 +0000

Qin,
My understanding of bundle is closer to Pascal’s one and it is strictly related to track.
A bundle is a set of cells reserved between two nodes, A and B, with the same scope, and thus on the same track.
I don’t think we can mix up cells belonging to different tracks, even though scheduled between the same two neighbor nodes. This does not make sense to me, because when we will have a pkt in the queue, this will belong to a specific track, and thus it will be transmitted in one of the cells of the bundle that has been reserved for that specific track.
Do you see my point?
Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Friday, March 21, 2014 2:50 PM
To: Qin Wang; Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: RE: [6tisch] tracks & soft cells reservation w/ OTF

Hi Qin:

Pascal

Hi Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

Hi Maira Rita,

What do you think?

Thanks
Qin

Thank you in advance!

Best regards,
Maria Rita

---

From: Qin Wang <[email-masked]>
Date: Fri, 21 Mar 2014 07:37:14 -0700 (PDT)

Maria Rita and Pascal,

I agree the definition of bundle.

Thanks
Qin

On Friday, March 21, 2014 10:24 PM, Maria Rita PALATTELLA <[email-masked]> wrote:

Qin,

From:Pascal Thubert (pthubert) [mailto:[email-masked]] 
Sent: Friday, March 21, 2014 2:50 PM
To: Qin Wang; Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier Vilajosana ([email-masked])
Cc: [email-masked]
Subject: RE: [6tisch] tracks & soft cells reservation w/ OTF
 
Hi Qin:

 

 
 
Pascal

Hi Maria Rita,

Thanks
Qin

 
Hi Maria Rita,

 

Thanks
Qin

 

 
 
Hi Maira Rita,

 
 
What do you think?
 
Thanks
Qin

 

 
 
Thank you in advance!
 
Best regards,
Maria Rita

---

From: Thomas Watteyne <[email-masked]>
Date: Sun, 23 Mar 2014 23:32:39 -0700

Maria Rita,

Could you elaborate a bit of what you envision OTF would be with multiple
concurrent trackIDs? I'm particularly interested in understanding which
entity would created, maintained and destroy tracks.

More generally, I need your help to understand the benefit of multiple
tracks. Sorry :-(. If all tracks are administered by OTF, then I would
argue the network offers a similar same level of QoS in the following cases:
- case 1. several tracks are installed, e.g. one for each node
- case 2. the network operates on one trackid, which carries the sum of
traffic from the first case.

For example, let's assume the following topology

A==>\         /==>E
     \       /
      C====>D
     /       \
B==>/         \==>F

With two flows:
- A-C-D-E
- C-D-C-F

In case 1, there would be 2 independent tracks between C and D, each
carrying half of the traffic.
In case 2, only one track carries all the traffic.

With OTF, the size of the bundle adapts to the traffic being transported. I
would hence argue that the level of QoS is the same for both cases.

Thoughts?

Thomas

On Fri, Mar 21, 2014 at 7:37 AM, Qin Wang <[email-masked]> wrote:

> My understanding of bundle is closer to Pascal's one and it is strictly
> related to track.
> I don't think we can mix up cells belonging to different tracks, even
> though scheduled between the same two neighbor nodes. This does not make
> sense to me, because when we will have a pkt in the queue, this will belong
> to a specific track, and thus it will be transmitted in one of the cells of
> the bundle that has been reserved for that specific track.
> Do you see my point?
> Maria Rita
>
>
>  *From:* Pascal Thubert (pthubert) [mailto:[email-masked]]
> *Sent:* Friday, March 21, 2014 2:50 PM
> *To:* Qin Wang; Maria Rita PALATTELLA; Qin Wang ([email-masked]);
> Xavier Vilajosana ([email-masked])
> *Cc:* [email-masked]
> *Subject:* RE: [6tisch] tracks & soft cells reservation w/ OTF
>
> Hi Qin:
>
> A bundle is really the collection of cells that put together create a
> half-duplex IP link between 2 nodes with a bandwidth that is:
> We have chosen to extend that definition for a collection of cells that
> put together create a half-duplex hop for an end to end track.
>
> Using the same term "bundle" is fine with me but if we have a track that
> passes between A and, the bundle for that track will be different from the
> bundle for the IP link between adjacent nodes A and B.
>
>
> Cells in a bundle should be equivalent for 6top to place the next packet
> for the track onto the next cell in the bundle for that track, and
> conversely the next packet to be sent on the next cell in the bundle for
> the IP link.
>
> PS; I'm ok to cc the ML; what about you all?
>
> Pascal
>
>   *From:* 6tisch [mailto:[email-masked] <[email-masked]>]
> *On Behalf Of *Qin Wang
> *Sent:* vendredi 21 mars 2014 14:31
> *To:* Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier
> Vilajosana ([email-masked])
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] tracks & soft cells reservation w/ OTF
>
>  Hi Maria Rita,
>
>  Regarding to the Bundle and Track, my understanding is: bundle is a set
> of cells to a specific neighbor, i.e. representing a link of some BW; track
> is a set of cells to a specific neighbor and must be associated with a
> specific multi-hop path. In another word, from one-hop point of view, a
> bundle may correspond to more than one tracks. What do you think?
>
>  Thanks
>  Qin
>
>  I am afraid I am still missing something... concerning bundle and track...
>  But shouldn't a bundle be associated to a specific track, given that
> each cell (and, thus each cell in the bundle) has a TrackID?
>  Thanks
>  Maria Rita
>
>    *From:* Qin Wang [mailto:[email-masked] <[email-masked]>]
>
> *Sent:* Thursday, March 20, 2014 6:35 PM
> *To:* Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier
> Vilajosana ([email-masked])
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] tracks & soft cells reservation w/ OTF
>
>   Hi Maria Rita,
>
>   (2) In MonitoringStatusList. It is per neighbor & slotframe statistics,
> from it upper layer can get per bundle overview of scheduling and its
> performance.
>   (3) In NeighborList. It is per neighbor statistics, from it upper layer
> can understand the connectivity of a pair of nodes.
>   But, as we discussed before, we may need to clarify the feature of a
> Queue, corresponding to a slotframe, or a Track, or something else.
> According to my understanding, Queue should associate with Priority defined
> in QoS, instead of slotframe or Track. Let's start another thread to
> discuss the feature of Queue.
>
>   Thanks
>   Qin
>
>
>
>
>   OTF will figure out if more or less BDW is needed by using the
> information that 6top provides, e.g., the stat. about BDW (allocated soft
> cells, overprovision cells, QoS, NQoS), traffic load on a link, queue
> length, avg time spent by a pkt in the queue...
>   Then, which approach shall we use? It is still not so clear to me...but I
> have the feeling that we should use the specific trackID, and not the
> Best-effort one. Am I wrong?
>    *From:* Qin Wang [mailto:[email-masked] <[email-masked]>]
>
> *Sent:* Thursday, March 20, 2014 3:37 PM
> *To:* Maria Rita PALATTELLA; Qin Wang ([email-masked]); Xavier
> Vilajosana ([email-masked])
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] tracks & soft cells reservation w/ OTF
>
>    Hi Maira Rita,
>
>    I don't exactly know how OTF figures out the demand of add/delete
> softcells. In my mind, at least, there are two ways.
>
>    (1) The demand is from network point of view, e.g. nodeA wants to
> create/extend/reduce certain BW to nodeB multi-hop away, then a TrackID
> should be given. Along the path, OTF will ask 6top to allocate/de-allcoate
> softcells on the given TrackID.
>
>    (2) The demand is from the evaluation of local traffic. In this case,
> I would like to propose to use Best-effort trackID, i.e. TrackID=(0,0).
>
>    What do you think?
>
>    Thanks
>    Qin
>
>
>
>    OTF aims to dynamically allocate (de-allocate) soft cells based on the
> bandwidth (BDW) needed between two neighbor nodes.
>    After estimating the BDW (and thus the number of soft cells to be
> added/deleted), OTF delegates to 6top the actual (de)allocation operation.
>
>    Given that each soft cell assigned to two neighbor nodes belongs to a
> specific TRACK, I was wondering how OTF should deal with this.
>    I mean, shall we suppose that all the traffic in the network belongs
> to the same TRACK, in order to simply OTF operation?
>    At the same time, I believe it is not realistic to assume there is
> only one track, and thus, one flow in the network. But if we assume that we
> have more than one flow/track, then, we should have several  OTF instances,
> one for each track.
>
>    Do you think that OTF should check the BDW between two nodes per
> TRACK? Because if checking the overall BDW, then OTF cannot know, on which
> track the new soft cell should be added.
>
>    Looking forward to receiving your advices on how to deal with tracks
> and OTF soft cells reservation ...
>
>    Thank you in advance!
>
>    Best regards,
>    Maria Rita
>
>
>