Subject: [6tisch] Minutes webex 21 March 2014

From: Thomas Watteyne <[email-masked]>
Date: Mon, 24 Mar 2014 11:37:37 -0700

All,

You will find the minutes of the last webex below.

FYI, all the minutes and slides are archived a
https://bitbucket.org/6tisch/meetings/.

Thanks to Xavi and Pascal for taking notes!

As usual, please fix anything we might have missed directly in the e-mail
and reply.

Thomas

---

Minutes Webex 21 March 2014, 6TiSCH WG

Note: timestamps in PDT.
Taking notes *(using Etherpad)*

   1. Xavi Vilajosana
   2. Pascal Thubert
   3. Thomas Watteyne

Present *(alphabetically)*

   1. Diego Dujovne
   2. Geraldine Texier
   3. Giuseppe Piro
   4. Kazushi Muraoka
   5. Maria Rita Palattella
   6. Michael Behringer
   7. Nicola Accettura
   8. Pascal Thubert
   9. Patrick Wetterwald
   10. Paul Duffy
   11. Pouria Zand
   12. Raghuram Sudhaakar
   13. Rouhollah Nabati
   14. Thomas Watteyne
   15. Xavi Vilajosana

Recording

   - Webex recording (audio+slides,streaming)
   -
   https://cisco.webex.com/ciscosales/lsr.php?RCID=a9108987ab094c31b539bf9ee04ad99f
    *[62min]*

Slides

   - slides_140321_webex.ppt<https://bitbucket.org/6tisch/meetings/src/master/140321_webex/slides_140321_webex.ppt>:
   slides shared during the call

Action Items

   - *Qin* to rename 6top-interface draft from
   draft-wang-6tisch-6top-interface-02 to draft-ietf-6tisch-6top-interface-00
   and re-publish. Do no change any text.
   - *Thomas* to publish IETF89 minutes.
   - *Chairs* to start ML discussion about format webex calls.

Agenda

   - Administrivia *[2min]*
      - Approval agenda
      - Approval minutes last call
      - 6top-interface adopted
      - IETF89 minutes adopted
   - OTF discussion *[15min]*
      - summary call
      - summary OTF/6top interface
   - (in-)efficient ND discussion *[20min]*
   - 6top-to-6top protocol *[15min]*
      - summary call
      - proposal
   - AOB *[1min]*

Minutes

   - *[08.05]* Meeting starts
      - recording starts
      - *Pascal* introduces the agenda.
   - *[08.06]* Administrivia
      - Approval agenda

      No issues raised. Agenda approved.

      - Approval minutes last call

      No issues raised. Minutes approved.

      - 6top-interface adopted
         - the draft has been adopted

         Action item: *Qin* to rename 6top-interface draft from
         draft-wang-6tisch-6top-interface-02 to
draft-ietf-6tisch-6top-interface-00
         and re-publish. Do no change any text.

         - IETF89 minutes adopted
         - No comments about draft IETF89 minutes

         Action item: *Thomas* to publish IETF89 minutes.

         - DT, CT updates
         - we have created security DT
         - Lead by Michael Richardson
         - subscription needs to got through chairs or Michael R.
         - Make WG more official: Design team vs Task Group.
         - Smaller calls during the week
      - Thoughts about call format
         - Looking ways to organize small WG to advance on the drafts
         - proposal: 6TiSCH call once every 2 weeks.
         - during the week, have smaller 6TiSCH calls on specific topics
         but focused on particular topics in the group.

         Action item: *Chairs* to start ML discussion about format webex
         calls

         - *[Maria Rita]* The calls should be based on needs, not regular
         but dynamic, not bound to defined groups but for those people
who wants to
         work on a particular topic.
      - *[08.20]* OTF discussion *(Diego)*
      - summary call
         - Call on Wednesday
         - Discussed open issues
         - reviewed 6top commands
         - policy for maintenance commands from 6top
         - Interface to select algorithm parametrizable
         - allocation policy
         - OTF requires 6top to reserve soft cells. Currently out of the
         scope of 6top how cells are chosen.
         - OTF can ask only for soft cells, 6top allocates them without
         control from the point of view of OTF
         - Reservation of Bundles.
         - OTF does not detail the use of chunks. Chunks are devoted to
         hard cells.
         - Policy to delete/create soft cells is out of scope of 6top but
         OTF provides one
         - Useful commands:
            - monitoring
            - statistics
            - queueing
         - *[Pascal]* How do you see a strict relation between chunks and
         hard cells?
         - *[Maria Rita]* chunk is used to avoid interferences
         - *[Thomas]* Let's continue discussion on the mailing list.
         - Use YANG model, use extensions for optional modules.
         - Other issues.
            - stateless algorithm to avoid overloading nodes with states.
            - use fresh data at each run, get it from 6top
         - *[Nicola]* proposes to simplify the notation. Use of chunks to
         better avoid collision. Chunks have been thought for a centralized
         scheduling, but it can be distributed.
      - *[08.36]* Integrating 6LoWPAN ND and RPL *(Pascal)*
      - we use 6LoWPAN and RPL together, but overlaps exist
      - design of how work together was not really done
      - it's 6TiSCH responsibility to explain how they work together, make
      recommendations for 6lo and ROLL
      - we want to allow a LoWPAN node to be a host in a RPL network
      without participating in RPL network.
      - *[Thomas]* the prefix can also be changed.
      - *[Pascal]* in the life of this networks we hace RA and DIOs.
      - we show that we can have a RPL network, and how much of 6LoWPAN ND
      is needed
      - as we reach LBR, how can be attach this root to the backbone to
      have multiple of these radio meshes to have single IPv6 subnet?
      - we showed at IETF89 that we can be use efficient ND. BBR does ND
      proxy
      - 3 interfaces:
         - LP to 6LR, LP can become 6LR
         - RPL between 6LR and 6LBR
         - efficient ND for 6LR to register to 6LBR. 6LBR can do classical
      - context information is carried by RA. LP note for information about
      the context from RA. Also got SLLA of router. question: over time, do we
      need RA between 6LRs?
      - [slide 25] the new node comes in the network
      - we don't register the source, but the target. Same registration
      will happen at different levels, all will indicate the same target.
      - you can use link-local address to register other addresses. you
      cannot use the address which is not registered yet, but you can use your
      link local.
      - we have to include the TID in the NS ARO so we can detect when a
      device moves.
      - for security flow, it could be useful to have SeND. since we have a
      reservation, we could form a single CGA address. we could put the CGA in
      the UID.
      - changes in 6LoWPAN ND:
         - in NA (ARO) register the target rather than the source. So put
         TLLA option
         - in NA (ARO), add the TID. requires retrofit in 6loPWAN-ND
         - we also need to put TID in the DAR message
      - similarly in the response, include the TID and TLLA options. We
      want to add the options to map response to request.
      - once established, periodic re-registration with NS (ARO), but we
      would not need a DAR/DAC. Instead, we transform registration in DAO.
      Creates a routing state down to the LP node down the LLN. We
cannot use RPL
      DOA since we don't have UID in RPL DAO. We can talk to ROLL to
see whether
      we want to add UID in DOA to have a ND-free network.
      - *Pascal* shows flows which show edge cases (collisions).
         - example 1: collision of binding state between 6LBRs
         - example 2: collision of proxy states between 6LBRs
         - example 3: collision between 2 6BBRs. BBR will do classical ND;
         ARO option added to the DAD. NA overrride as answer. Without
ARO option we
         cannot distinguish movement from real override.
      - Realistic examples
         - 6BBR is the 6LBR *same box*. flows of 6LBR collapsed with 6BBR.
         - the RPL root of the network is the same as the proxy. collapses
         LP node and 6LR.
         - the 6BBR maintains the states using the DAR/DAC. collapses 6LBR
         and 6BBR: simple star network, without RPL, only ND. Device
registers to AP
         (6LR+6BBR). We need to decide whether handle mobility at L2 or L3.
      - discussion
         - *[Thomas]* many things that are described are related to 6lo,
         6man, etc.. do you want to create a sub-group (DT) to link to
other WGs
         - *[Pascal]* agrees, on doing something similar as we do with the
         security WG.
         - *[Pascal]* this is part of the architecture of the network. We
         are chartered for that. It is our responsibility to form this
design team
         and invite people from other WG to get them involved.
         - *[Thomas]* proposes to set a dedicated call with ROLL and 6Lo
         people to coordinate, define DTs, etc.. *Samita, Ines, Michael, etc..
         - *[Pascal]* also people from ZigBee IP
         - *[Thomas]* have an official call outside our 6tisch weekly calls.
      - *[09.07]* 6top-to-6top protocol

   moved to future call

   - *[09.07]* AOB

   No other business raised

   - *[09.08]* Meeting ends

---

From: Qin Wang <[email-masked]>
Date: Mon, 24 Mar 2014 14:12:16 -0700 (PDT)

Hi Thomas,

My version of 6top interface draft is draft-wang-6tisch-6top-interface-03, including some modifications according to the discussion in ML (mainly comes from Maria Rita) since IETF89. Can you give me the -02 version?

Thanks
Qin

On Tuesday, March 25, 2014 2:38 AM, Thomas Watteyne <[email-masked]> wrote:
 
All,

FYI, all the minutes and slides are archived a https://bitbucket.org/6tisch/meetings/.

As usual, please fix anything we might have missed directly in the e-mail and reply.

Thomas

---

Minutes Webex 21 March 2014, 6TiSCH WG
Note: timestamps in PDT.
Taking notes (using Etherpad)
	1. Xavi Vilajosana
	2. Pascal Thubert
	3. Thomas Watteyne
Present (alphabetically)
	1. Diego Dujovne
	2. Geraldine Texier
	3. Giuseppe Piro
	4. Kazushi Muraoka
	5. Maria Rita Palattella
	6. Michael Behringer
	7. Nicola Accettura
	8. Pascal Thubert
	9. Patrick Wetterwald
	10. Paul Duffy
	11. Pouria Zand
	12. Raghuram Sudhaakar
	13. Rouhollah Nabati
	14. Thomas Watteyne
	15. Xavi Vilajosana
Recording
	* Webex recording (audio+slides,streaming)
	* https://cisco.webex.com/ciscosales/lsr.php?RCID=a9108987ab094c31b539bf9ee04ad99f [62min]
Slides
	* slides_140321_webex.ppt: slides shared during the call
Action Items
	* Qin to rename 6top-interface draft from draft-wang-6tisch-6top-interface-02 to draft-ietf-6tisch-6top-interface-00 and re-publish. Do no change any text.
	* Thomas to publish IETF89 minutes.
	* Chairs to start ML discussion about format webex calls.
Agenda
	* Administrivia [2min]
	* Approval agenda
	* Approval minutes last call
	* 6top-interface adopted
	* IETF89 minutes adopted
	* OTF discussion [15min]
	* summary call
	* summary OTF/6top interface
	* (in-)efficient ND discussion [20min]
	* 6top-to-6top protocol [15min]
	* summary call
	* proposal
	* AOB [1min]
Minutes
	* [08.05] Meeting starts
	* recording starts
	* Pascal introduces the agenda.
	* [08.06] Administrivia
	* Approval agenda
No issues raised. Agenda approved.
	* Approval minutes last call
No issues raised. Minutes approved.
	* 6top-interface adopted
	* the draft has been adopted
Action item: Qin to rename 6top-interface draft from draft-wang-6tisch-6top-interface-02 to draft-ietf-6tisch-6top-interface-00 and re-publish. Do no change any text.
	* IETF89 minutes adopted
	* No comments about draft IETF89 minutes
Action item: Thomas to publish IETF89 minutes.
	* DT, CT updates
	* we have created security DT
	* Lead by Michael Richardson
	* subscription needs to got through chairs or Michael R.
	* Make WG more official: Design team vs Task Group.
	* Smaller calls during the week
	* Thoughts about call format
	* Looking ways to organize small WG to advance on the drafts
	* proposal: 6TiSCH call once every 2 weeks.
	* during the week, have smaller 6TiSCH calls on specific topics but focused on particular topics in the group.
Action item: Chairs to start ML discussion about format webex calls
	* [Maria Rita] The calls should be based on needs, not regular but dynamic, not bound to defined groups but for those people who wants to work on a particular topic.
	* [08.20] OTF discussion (Diego)
	* summary call
	* Call on Wednesday
	* Discussed open issues
	* reviewed 6top commands
	* policy for maintenance commands from 6top
	* Interface to select algorithm parametrizable
	* allocation policy
	* OTF requires 6top to reserve soft cells. Currently out of the scope of 6top how cells are chosen.
	* OTF can ask only for soft cells, 6top allocates them without control from the point of view of OTF
	* Reservation of Bundles.
	* OTF does not detail the use of chunks. Chunks are devoted to hard cells.
	* Policy to delete/create soft cells is out of scope of 6top but OTF provides one
	* Useful commands:
	* monitoring
	* statistics
	* queueing
	* [Pascal] How do you see a strict relation between chunks and hard cells?
	* [Maria Rita] chunk is used to avoid interferences
	* [Thomas] Let's continue discussion on the mailing list.
	* Use YANG model, use extensions for optional modules.
	* Other issues.
	* stateless algorithm to avoid overloading nodes with states.
	* use fresh data at each run, get it from 6top
	* [Nicola] proposes to simplify the notation. Use of chunks to better avoid collision. Chunks have been thought for a centralized scheduling, but it can be distributed.
	* [08.36] Integrating 6LoWPAN ND and RPL (Pascal)
	* we use 6LoWPAN and RPL together, but overlaps exist
	* design of how work together was not really done
	* it's 6TiSCH responsibility to explain how they work together, make recommendations for 6lo and ROLL
	* we want to allow a LoWPAN node to be a host in a RPL network without participating in RPL network.
	* [Thomas] the prefix can also be changed.
	* [Pascal] in the life of this networks we hace RA and DIOs.
	* we show that we can have a RPL network, and how much of 6LoWPAN ND is needed
	* as we reach LBR, how can be attach this root to the backbone to have multiple of these radio meshes to have single IPv6 subnet?
	* we showed at IETF89 that we can be use efficient ND. BBR does ND proxy
	* 3 interfaces:
	* LP to 6LR, LP can become 6LR
	* RPL between 6LR and 6LBR
	* efficient ND for 6LR to register to 6LBR. 6LBR can do classical
	* context information is carried by RA. LP note for information about the context from RA. Also got SLLA of router. question: over time, do we need RA between 6LRs?
	* [slide 25] the new node comes in the network
	* we don't register the source, but the target. Same registration will happen at different levels, all will indicate the same target.
	* you can use link-local address to register other addresses. you cannot use the address which is not registered yet, but you can use your link local.
	* we have to include the TID in the NS ARO so we can detect when a device moves.
	* for security flow, it could be useful to have SeND. since we have a reservation, we could form a single CGA address. we could put the CGA in the UID.
	* changes in 6LoWPAN ND:
	* in NA (ARO) register the target rather than the source. So put TLLA option
	* in NA (ARO), add the TID. requires retrofit in 6loPWAN-ND
	* we also need to put TID in the DAR message
	* similarly in the response, include the TID and TLLA options. We want to add the options to map response to request.
	* once established, periodic re-registration with NS (ARO), but we would not need a DAR/DAC. Instead, we transform registration in DAO. Creates a routing state down to the LP node down the LLN. We cannot use RPL DOA since we don't have UID in RPL DAO. We can talk to ROLL to see whether we want to add UID in DOA to have a ND-free network.
	* Pascal shows flows which show edge cases (collisions).
	* example 1: collision of binding state between 6LBRs
	* example 2: collision of proxy states between 6LBRs
	* example 3: collision between 2 6BBRs. BBR will do classical ND; ARO option added to the DAD. NA overrride as answer. Without ARO option we cannot distinguish movement from real override.
	* Realistic examples
	* 6BBR is the 6LBR same box. flows of 6LBR collapsed with 6BBR.
	* the RPL root of the network is the same as the proxy. collapses LP node and 6LR.
	* the 6BBR maintains the states using the DAR/DAC. collapses 6LBR and 6BBR: simple star network, without RPL, only ND. Device registers to AP (6LR+6BBR). We need to decide whether handle mobility at L2 or L3.
	* discussion
	* [Thomas] many things that are described are related to 6lo, 6man, etc.. do you want to create a sub-group (DT) to link to other WGs
	* [Pascal] agrees, on doing something similar as we do with the security WG.
	* [Pascal] this is part of the architecture of the network. We are chartered for that. It is our responsibility to form this design team and invite people from other WG to get them involved.
	* [Thomas] proposes to set a dedicated call with ROLL and 6Lo people to coordinate, define DTs, etc.. *Samita, Ines, Michael, etc..
	* [Pascal] also people from ZigBee IP
	* [Thomas] have an official call outside our 6tisch weekly calls.
	* [09.07] 6top-to-6top protocol
moved to future call
	* [09.07] AOB
No other business raised
	* [09.08] Meeting ends
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 25 Mar 2014 18:11:08 -0700

Qin,
Yes, please publish the exact same version that was published already (i.e.
http://tools.ietf.org/html/draft-wang-6tisch-6top-interface-02).
Allow me to coordinate offline with you.
Thomas

On Mon, Mar 24, 2014 at 2:12 PM, Qin Wang <[email-masked]> wrote:

> Hi Thomas,
>
> My version of 6top interface draft is draft-wang-6tisch-6top-interface-03,
> including some modifications according to the discussion in ML (mainly
> comes from Maria Rita) since IETF89. Can you give me the -02 version?
>
> Thanks
> Qin
>
>
>          but dynamic, not bound to defined groups but for those people who wants to
>       - it's 6TiSCH responsibility to explain how they work together,
>       make recommendations for 6lo and ROLL
>       - we show that we can have a RPL network, and how much of 6LoWPAN
>       ND is needed
>       - context information is carried by RA. LP note for information
>       about the context from RA. Also got SLLA of router. question: over time, do
>       we need RA between 6LRs?
>       - for security flow, it could be useful to have SeND. since we have
>       a reservation, we could form a single CGA address. we could put the CGA in
>       the UID.
>       - changes in 6LoWPAN ND:
>       Creates a routing state down to the LP node down the LLN. We cannot use RPL
>       DOA since we don't have UID in RPL DAO. We can talk to ROLL to see whether
>          - example 3: collision between 2 6BBRs. BBR will do classical
>          ND; ARO option added to the DAD. NA overrride as answer. Without ARO option
>          we cannot distinguish movement from real override.
>       - Realistic examples
>          - the RPL root of the network is the same as the proxy.
>          collapses LP node and 6LR.
>          - the 6BBR maintains the states using the DAR/DAC. collapses
>          6LBR and 6BBR: simple star network, without RPL, only ND. Device registers
>          to AP (6LR+6BBR). We need to decide whether handle mobility at L2 or L3.
>       - discussion
>          6man, etc.. do you want to create a sub-group (DT) to link to other WGs
>          - *[Pascal]* agrees, on doing something similar as we do with
>          the security WG.
>          are chartered for that. It is our responsibility to form this design team

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 25 Mar 2014 18:16:42 -0700

All,
Fixed some typos highlighted by Maria Rita (thanks!). Latest version at
https://bitbucket.org/6tisch/meetings/wiki/140321_webex, also copy-pasted
below.
Thomas

----

Note: timestamps in PDT.

   1. Xavi Vilajosana
   2. Pascal Thubert
   3. Thomas Watteyne

   1. Diego Dujovne
   2. Geraldine Texier
   3. Giuseppe Piro
   4. Kazushi Muraoka
   5. Maria Rita Palattella
   6. Michael Behringer
   7. Nicola Accettura
   8. Pascal Thubert
   9. Patrick Wetterwald
   10. Paul Duffy
   11. Pouria Zand
   12. Raghuram Sudhaakar
   13. Rouhollah Nabati
   14. Thomas Watteyne
   15. Xavi Vilajosana

Recording

Slides

Action Items

Agenda

   - Administrivia *[2min]*
      - Approval agenda

Minutes

      - 6top-interface adopted

         - IETF89 minutes adopted

         - DT, CT updates

         - *[Maria Rita]* OTF requires 6top to reserve soft cells.
         Currently out of the scope of 6top how cells are chosen.
         - *[Maria Rita]* chunk is used to avoid interference. And
         according to current 6top draft, only HARDcell can be
allocated within a
         chunk.
         - *[Diego]* Use YANG model, use extensions for optional modules.

   moved to future call

   - *[09.07]* AOB

   No other business raised

   - *[09.08]* Meeting ends

On Tue, Mar 25, 2014 at 6:11 PM, Thomas Watteyne <[email-masked]
> wrote:

> Qin,
> Yes, please publish the exact same version that was published already
> (i.e. http://tools.ietf.org/html/draft-wang-6tisch-6top-interface-02).
>>          - *[Maria Rita]* The calls should be based on needs, not
>>          regular but dynamic, not bound to defined groups but for those people who
>>          wants to work on a particular topic.
>>          - Policy to delete/create soft cells is out of scope of 6top
>>          but OTF provides one
>>          - Useful commands:
>>             - monitoring
>>             - statistics
>>             - queueing
>>          - *[Pascal]* How do you see a strict relation between chunks
>>          and hard cells?
>>          - *[Nicola]* proposes to simplify the notation. Use of chunks
>>          to better avoid collision. Chunks have been thought for a centralized
>>       - for security flow, it could be useful to have SeND. since we
>>       have a reservation, we could form a single CGA address. we could put the
>>       CGA in the UID.
>>       - changes in 6LoWPAN ND:
>>          - in NA (ARO) register the target rather than the source. So
>>          put TLLA option
>>          - *[Pascal]* this is part of the architecture of the network.
>>          We are chartered for that. It is our responsibility to form this design
>>          team and invite people from other WG to get them involved.