Subject: [6tisch] positionning 6LoWPAN ND, RPL and efficient ND within the 6TiSCH architecture

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 5 Mar 2014 16:42:32 +0000

Dear all :

At the plugfest and then the WG meetings tomorrow, I'll be introducing work to be done on ND and RPL to enable the 6TiSCH multilink subnet Architecture.

I produced a number of slides that illustrate the kind of flows and interfaces that would enable to separate:

- The plain LLN host from a 6LR that connects to the RPL network. That would be 6LowPAN ND but with some additions, at least the TID, from efficient ND.
- The 6LR and the 6LBR. That would be the DAR/DAC and then RPL (DAO). Seems that it makes sense that the 6LBR is also the RPL root, since it is often implemented by the same vendor as the 6LR.
- The 6LBR and the 6BBR. That would be efficient ND again, as an abstract interface for the 6LBR to advertise which IPv6 addresses are connected to its mesh. Efficient ND is a simple abstraction to advertise all the addresses attached to the mesh, regardless what the mesh is (IOW this can be used to connect existing mesh solutions).
- The 6BBR and other 6BBRs or any classical IPv6 nodes over the Ethernet backbone. This can be a routing protocol, or proxy ND.

https://bitbucket.org/6tisch/meetings/src/89276d8bd8897b5bfc0d809e112ec67ef216e172/140306_ietf89_plugfest_london/6TiSCH_Backbone_Router.ppt?at=master

As I went through the exercise of drawing those flows, I found that the definitions we have in the terminology should be revised. The 6LBR would become the 6LoWPAN 6LBR plus the RPL root, whereas the 6BBR would be the proxy that turns efficient ND into classical ND and back.

Note that the last slides show how the 6LBR and the 6BBR can be collapsed into what the backbone router draft describes, and that would be a kind of Layer-3 AP.
Then the slides show how the host and the L6BR can be collapsed, and if there is no RPL at all, then the same flow can be used to cover WiFi mobility.

See you tomorrow!

Pascal

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Wed, 5 Mar 2014 17:05:48 +0000

>>>As I went through the exercise of drawing those flows, I found that the definitions we have in the terminology should be revised. The 6LBR would become the 6LoWPAN 6LBR plus the RPL root, whereas the 6BBR would be the proxy that turns efficient >>>ND into classical ND and back.
>>>Pascal

We will fix this in the terminology, now that the issue has shown up.
Maria Rita