Subject: [6tisch] some comments on draft-ietf-6tisch-terminology-01

From: <[email-masked]>
Date: Thu, 13 Mar 2014 14:30:14 +0000

Hello Maria-Rita, all,

Reading draft-ietf-6tisch-terminology-01 again, I have the following comments/questions:
- CDU matrix: the description is unclear to me. I understand that it has channels as rows. I don't see clearly described what is represented along the columns. The TSCH schedule is better described in that respect.
- TSCH schedule: I gather that the TSCH schedule is global to the network, i.e. it collects information about all nodes. Am I correct so far? Assuming I am: if some nodes have multiple slotframes, as seem to be allowed, what is the "width of the matrix" of the TSCH schedule? Do we need multiple TSCH schedules to represent the network? Do we need a matrix of size the minimum common multiple of all slotframe size?

Also, a typo in "Scheduled cell": timeskeeping -> timekeeping

Best regards,

Dominique

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 13 Mar 2014 15:04:54 +0000

Hello Dominique,

First of all many thanks for having read the draft again.

Here are my answers to your questions:

-        CUD matrix. I do agree that maybe we need to re-shape a bit more the definition for making the concept clearer. Such matrix has channel (offset) as rows and timeslot as columns (exactly as the TSCH schedule, the intersection of a row and a column is still a cell). BUT, while the TSCH schedule contains all the scheduled cells, the CUD matrix contains all the chunks, i.e., groups of cells (not scheduled yet) that will be managed by different (parent) nodes.

@Pascal: please feel free to jump in the discussion  if something is wrong.

-        TSCH schedule. Yes, the TSCH schedule is global and include all the scheduled cells for all the nodes in all the active slotframes.  In the network we can have multiple slotframes, but a single common TSCH schedule. When a single slotframe is active, than the width of the TSCH schedule is equal to the slotframe size, but if there are several active slotframes, then, as you pointed out the size should be the minimum common multiple of all slotframe size.

Best regards,
Maria Rita

From: 6tisch [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, March 13, 2014 3:30 PM
To: [email-masked]
Subject: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 13 Mar 2014 15:09:02 +0000

Hum;

This is not serving us well then. The schedule is like a partition. Every musician has its own. The PCE is like the conductor with visibility n many partitions,  though with RPL there may be a few jazz players in the band...
So no the schedule is not global, but the CDU-MX should be.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: jeudi 13 mars 2014 07:30
To: [email-masked]
Subject: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 13 Mar 2014 15:13:07 +0000

Hello Maria-Rita:

This shows how important terminology work can be!

I thought we agree that the schedule was now the node local view, whereas the CDU -MX was the global thing where all the time slots exist whether this node uses them or not...

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: jeudi 13 mars 2014 08:05
To: [email-masked]; [email-masked]
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Hello Dominique,

Best regards,
Maria Rita

From: 6tisch [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, March 13, 2014 3:30 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 13 Mar 2014 15:23:57 +0000

Uhmmm...
I have just checked what is defined in the IEEE802.15.4e std, and also read again what we wrote in the 6tisch-tsch draft, and I do believe that I was talking about the Network TSCH schedule (that is the one that the PCE should own - and the one to which the definition in the draft refers) and you are talking about the node TSCH schedule that is exchanged between neighbors (including only the cells reserved to these nodes).
Maybe we should clarify this concept, once we agree that we are aligned.
For sure the CDU matrix is global.
Thank you!
Maria Rita

From: 6tisch [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, March 13, 2014 4:09 PM
To: [email-masked]; [email-masked]
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Hum;

Cheers,

Pascal

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 13 Mar 2014 15:26:26 +0000

Well,
I can see that terminology sometime can be tricky and create confusion...

As I stated in the previous email, then, if we want the local view, we should talk of node TSCH schedule, and differentiate it from the network TSCH schedule (that ONLY the PCE owns)

What do you think?
Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Thursday, March 13, 2014 4:13 PM
To: Maria Rita PALATTELLA; [email-masked]; [email-masked]; Qin Wang ([email-masked])
Subject: RE: some comments on draft-ietf-6tisch-terminology-01

Hello Maria-Rita:

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: jeudi 13 mars 2014 08:05
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Hello Dominique,

Best regards,
Maria Rita

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 13 Mar 2014 15:30:13 +0000

I like this proposal. What do others think?

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: jeudi 13 mars 2014 08:26
To: Pascal Thubert (pthubert); [email-masked]; [email-masked]; Qin Wang ([email-masked])
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Well,

What do you think?
Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Thursday, March 13, 2014 4:13 PM
To: Maria Rita PALATTELLA; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Qin Wang ([email-masked]<mailto:[email-masked]>)
Subject: RE: some comments on draft-ietf-6tisch-terminology-01

Hello Maria-Rita:

Cheers,

Pascal

Hello Dominique,

Best regards,
Maria Rita

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: Alfredo Grieco <[email-masked]>
Date: Thu, 13 Mar 2014 16:34:38 +0100

+1
Al
Il 3/13/2014 4:30 PM, Pascal Thubert (pthubert) ha scritto:
> *From:*6tisch [mailto:[email-masked]] *On Behalf Of *Maria 
> Rita PALATTELLA
> *Sent:* jeudi 13 mars 2014 08:26
> *To:* Pascal Thubert (pthubert); [email-masked]; 
> [email-masked]; Qin Wang ([email-masked])
> *Subject:* Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01
>
> Well,
>
> As I stated in the previous email, then, if we want the _local view_, 
> we should talk of _node TSCH schedule_, and differentiate it from the 
> network TSCH schedule (that ONLY the PCE owns)
>
> What do you think?
>
> Maria Rita
>
> *From:*Pascal Thubert (pthubert) [mailto:[email-masked]]
> *Sent:* Thursday, March 13, 2014 4:13 PM
> *To:* Maria Rita PALATTELLA; [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>; Qin Wang ([email-masked] 
> <mailto:[email-masked]>)
> *Subject:* RE: some comments on draft-ietf-6tisch-terminology-01
>
> Hello Maria-Rita:
>
> I thought we agree that the schedule was now the node local view, 
> whereas the CDU --MX was the global thing where all the time slots 
> exist whether this node uses them or not...
>
> Cheers,
>
> Pascal
>
> *From:*6tisch [mailto:[email-masked]] *On Behalf Of *Maria 
> Rita PALATTELLA
> *Sent:* jeudi 13 mars 2014 08:05
> *To:* [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> *Subject:* Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01
>
> Hello Dominique,
>
> -*CUD matrix.*I do agree that maybe we need to re-shape a bit more the 
> definition for making the concept clearer. Such matrix has channel 
> (offset) as rows and timeslot as columns (exactly as the TSCH 
> schedule, the intersection of a row and a column is still a cell). 
> BUT, while the TSCH schedule contains all the scheduled cells, the CUD 
> matrix contains all the chunks, i.e., groups of cells (not scheduled 
> yet) that will be managed by different (parent) nodes.
>
> /@Pascal: please feel free to jump in the discussion  if something is 
> wrong./
>
> -*TSCH schedule. *Yes, the TSCH schedule is global and include all the 
> scheduled cells for all the nodes in all the active slotframes.  In 
> the network we can have multiple slotframes, but a single common TSCH 
> schedule. When a single slotframe is active, than the width of the 
> TSCH schedule is equal to the slotframe size, but if there are several 
> active slotframes, then, as you pointed out the size should be the 
> minimum common multiple of all slotframe size.
>
> Best regards,
>
> Maria Rita
>
> *From:*6tisch [mailto:[email-masked]] *On Behalf Of 
> [email-masked] <mailto:[email-masked]>
> *Sent:* Thursday, March 13, 2014 3:30 PM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [6tisch] some comments on draft-ietf-6tisch-terminology-01
>
> Hello Maria-Rita, all,
>
> - CDU matrix: the description is unclear to me. I understand that it 
> has channels as rows. I don't see clearly described what is 
> represented along the columns. The TSCH schedule is better described 
> in that respect.
>
> - TSCH schedule: I gather that the TSCH schedule is global to the 
> network, i.e. it collects information about all nodes. Am I correct so 
> far? Assuming I am: if some nodes have multiple slotframes, as seem to 
> be allowed, what is the "width of the matrix" of the TSCH schedule? Do 
> we need multiple TSCH schedules to represent the network? Do we need a 
> matrix of size the minimum common multiple of all slotframe size?
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch

-- 
Luigi Alfredo Grieco, PhD
Assistant Professor
Dep. of Electrical and Information Engineering (DEI)
Politecnico di Bari
Via Orabona, 4
70125 - Bari - Italy
Phone: +39 080 5963 911
url: telematics.poliba.it
mail: [email-masked]

---

From: Pat Kinney <[email-masked]>
Date: Thu, 13 Mar 2014 11:08:20 -0500

I believe that Maria Rita's proposal resolves the ambiguity, hence I am for it.

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]

On Mar 13, 2014, at 10:30 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:

Cheers,
 
Pascal

Well,
I can see that terminology sometime can be tricky and create confusion…

What do you think?
Maria Rita

Hello Maria-Rita:

I thought we agree that the schedule was now the node local view, whereas the CDU –MX was the global thing where all the time slots exist whether this node uses them or not…
 
Cheers,
 
Pascal

Hello Dominique,

 

Best regards,
Maria Rita

Hello Maria-Rita, all,
 
Reading draft-ietf-6tisch-terminology-01 again, I have the following comments/questions:
- CDU matrix: the description is unclear to me. I understand that it has channels as rows. I don’t see clearly described what is represented along the columns. The TSCH schedule is better described in that respect.
- TSCH schedule: I gather that the TSCH schedule is global to the network, i.e. it collects information about all nodes. Am I correct so far? Assuming I am: if some nodes have multiple slotframes, as seem to be allowed, what is the “width of the matrix” of the TSCH schedule? Do we need multiple TSCH schedules to represent the network? Do we need a matrix of size the minimum common multiple of all slotframe size?
 
Also, a typo in “Scheduled cell”: timeskeeping -> timekeeping
 
Best regards,
 
Dominique

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Thu, 13 Mar 2014 13:46:40 -0300

I do agree on Maria Rita's proposal: using "node" fits better
than local, and it is clear that "network" is PCE's view.
Regards,

                             Diego

2014-03-13 13:08 GMT-03:00 Pat Kinney <[email-masked]>:

> *Kinney Consulting LLC*
> *From:* 6tisch [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Maria Rita PALATTELLA
> As I stated in the previous email, then, if we want the *local view*, we
> should talk of *node TSCH schedule*, and differentiate it from the
> *From:* Pascal Thubert (pthubert) [mailto:[email-masked]<[email-masked]>]
>
> *To:* Maria Rita PALATTELLA; [email-masked]; [email-masked];
> Qin Wang ([email-masked])
> I thought we agree that the schedule was now the node local view, whereas
> the CDU -MX was the global thing where all the time slots exist whether
> this node uses them or not...
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* 6tisch [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Maria Rita PALATTELLA
> *To:* [email-masked]; [email-masked]
> -        *CUD matrix.* I do agree that maybe we need to re-shape a bit
> more the definition for making the concept clearer. Such matrix has channel
> (offset) as rows and timeslot as columns (exactly as the TSCH schedule, the
> intersection of a row and a column is still a cell). BUT, while the TSCH
> schedule contains all the scheduled cells, the CUD matrix contains all the
> chunks, i.e., groups of cells (not scheduled yet) that will be managed by
> different (parent) nodes.
>
> *@Pascal: please feel free to jump in the discussion  if something is
> wrong.*
>
>
>
> -        *TSCH schedule. *Yes, the TSCH schedule is global and include
> all the scheduled cells for all the nodes in all the active slotframes.  In
> schedule. When a single slotframe is active, than the width of the TSCH
> schedule is equal to the slotframe size, but if there are several active
> slotframes, then, as you pointed out the size should be the minimum common
> multiple of all slotframe size.
>
>
>
> Best regards,
>
> Maria Rita
>
>
>
> *From:* 6tisch [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of [email-masked]
> *To:* [email-masked]
> - CDU matrix: the description is unclear to me. I understand that it has
> channels as rows. I don't see clearly described what is represented along
> the columns. The TSCH schedule is better described in that respect.
>
> - TSCH schedule: I gather that the TSCH schedule is global to the network,
> i.e. it collects information about all nodes. Am I correct so far? Assuming
> I am: if some nodes have multiple slotframes, as seem to be allowed, what
> is the "width of the matrix" of the TSCH schedule? Do we need multiple TSCH
> schedules to represent the network? Do we need a matrix of size the minimum
> common multiple of all slotframe size?
>
>
>

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: <[email-masked]>
Date: Thu, 13 Mar 2014 17:01:15 +0000

Sounds good to me.
Thanks for the clarification !

Dominique

De : Prof. Diego Dujovne [mailto:[email-masked]]
Envoyé : jeudi 13 mars 2014 17:47
À : Pat Kinney
Cc : Thubert Pascal; Maria Rita PALATTELLA; [email-masked]; Qin Wang ([email-masked]); BARTHEL Dominique IMT/OLPS
Objet : Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01

2014-03-13 13:08 GMT-03:00 Pat Kinney <[email-masked]<mailto:[email-masked]>>:
I believe that Maria Rita's proposal resolves the ambiguity, hence I am for it.

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715<tel:%2B1.847.960.3715>
[email-masked]<mailto:[email-masked]>

On Mar 13, 2014, at 10:30 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: jeudi 13 mars 2014 08:26
To: Pascal Thubert (pthubert); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Qin Wang ([email-masked]<mailto:[email-masked]>)
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Well,

What do you think?
Maria Rita

Hello Maria-Rita:

Cheers,

Pascal

Hello Dominique,

Best regards,
Maria Rita

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

---

From: Qin Wang <[email-masked]>
Date: Thu, 13 Mar 2014 10:04:05 -0700 (PDT)

On Friday, March 14, 2014 1:02 AM, Qin Wang <[email-masked]> wrote:
 
Hi Maria Rita and all,

Regarding to TSCH schedule, I think it is impossible to have a global TSCH schedule, even the scheduling process is conducted by PCE. The reason is as follows.  TSCH schedule consists of scheduled cells. In the Terminology draft, Scheduled cell is defined as " A cell which is assigned a neighbor MAC address (broadcast address is also possible), and one or more of the following flags: TX, RX, shared, timekeeping...... " , that means a specific (slotOffset, channelOffset) will associated with a pair of addresses and other features after it is scheduled.  From network point of view, a cell can associate with more than one pairs of nodes. Thus, I think we can not build a network wide TSCH schedule by definition. In another word, a TSCH schedule should be same as a node TSCH schedule.

Regarding CDU matrix, I think it is a network wide data structure. CDU represents the total communication resource used repeatedly in a network. Thus, it is a matrix of [MinimumCommonMultipleOfAlllSlotframeSize, NumberOfChannel]. 

What do you think?

Thanks
Qin

On Friday, March 14, 2014 12:08 AM, Pat Kinney <[email-masked]> wrote:

Pat

Pat Kinney
Kinney Consulting LLC

 
Cheers,
 
Pascal
 
From:6tisch [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: jeudi 13 mars 2014 08:26
To: Pascal Thubert (pthubert); [email-masked]; [email-masked]; Qin Wang ([email-masked])
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01
 
Well,

What do you think?
Maria Rita

From:Pascal Thubert (pthubert) [mailto:[email-masked]] 
Sent: Thursday, March 13, 2014 4:13 PM
To: Maria Rita PALATTELLA; [email-masked]; [email-masked]; Qin Wang ([email-masked])
Subject: RE: some comments on draft-ietf-6tisch-terminology-01
 
Hello Maria-Rita:

 
Cheers,
 
Pascal
 
From:6tisch [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: jeudi 13 mars 2014 08:05
To: [email-masked]; [email-masked]
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01
 
Hello Dominique,

 
-        CUD matrix.I do agree that maybe we need to re-shape a bit more the definition for making the concept clearer. Such matrix has channel (offset) as rows and timeslot as columns (exactly as the TSCH schedule, the intersection of a row and a column is still a cell). BUT, while the TSCH schedule contains all the scheduled cells, the CUD matrix contains all the chunks, i.e., groups of cells (not scheduled yet) that will be managed by different (parent) nodes. 
@Pascal: please feel free to jump in the discussion  if something is wrong.

Best regards,
Maria Rita
 
From:6tisch [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, March 13, 2014 3:30 PM
To: [email-masked]
Subject: [6tisch] some comments on draft-ietf-6tisch-terminology-01
 
Hello Maria-Rita, all,

 
Best regards,
 
Dominique

---

From: <[email-masked]>
Date: Thu, 13 Mar 2014 17:11:58 +0000

Do you mean, a « network-wide TSCH schedule » should be a 3D array?
In fact, how would you store the outcome of the centralized PCE computation?
By the way, is there a difference between the layering of the “node TSCH schedules” and the PCE view of the network, when a PCE is in use?

Dominique

De : 6tisch [mailto:[email-masked]] De la part de Qin Wang
Envoyé : jeudi 13 mars 2014 18:04
À : [email-masked]
Objet : [6tisch] Fw: some comments on draft-ietf-6tisch-terminology-01

On Friday, March 14, 2014 1:02 AM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:
Hi Maria Rita and all,

What do you think?

Thanks
Qin

On Friday, March 14, 2014 12:08 AM, Pat Kinney <[email-masked]<mailto:[email-masked]>> wrote:
I believe that Maria Rita's proposal resolves the ambiguity, hence I am for it.

Pat

Pat Kinney
Kinney Consulting LLC

Cheers,

Pascal

Well,

What do you think?
Maria Rita

Hello Maria-Rita:

Cheers,

Pascal

Hello Dominique,

Best regards,
Maria Rita

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Thu, 13 Mar 2014 14:27:12 -0300

Dominique,
                 I was thinking on the same idea: a 3D schedule or a similar
structure could include most of the individual (node) schedules from the
network.
In fact, a scheduled cell is (AFAIK) limited by the interference domain of
each pair
of neighbours involved.
Regards,

                                Diego

2014-03-13 14:11 GMT-03:00 <[email-masked]>:

>  Do you mean, a << network-wide TSCH schedule >> should be a 3D array?
>
> By the way, is there a difference between the layering of the "node TSCH
> schedules" and the PCE view of the network, when a PCE is in use?
>
>
>
> Dominique
>
>
>
> *De :* 6tisch [mailto:[email-masked]] *De la part de* Qin Wang
> *Envoyé :* jeudi 13 mars 2014 18:04
> *À :* [email-masked]
> *Objet :* [6tisch] Fw: some comments on draft-ietf-6tisch-terminology-01
>
>
>
>
>
> Regarding to TSCH schedule, I think it is impossible to have a global TSCH
> schedule, even the scheduling process is conducted by PCE. The reason is as
> follows.  TSCH schedule consists of scheduled cells. In the Terminology
> draft, Scheduled cell is defined as " A cell which is assigned a neighbor
> MAC address (broadcast address is also possible), and one or more of the
> following flags: TX, RX, shared, timekeeping...... " , that means a
> specific (slotOffset, channelOffset) will associated with a pair of
> addresses and other features after it is scheduled.  From network point of
> view, a cell can associate with more than one pairs of nodes. Thus, I think
> we can not build a network wide TSCH schedule by definition. In another
> word, a TSCH schedule should be same as a node TSCH schedule.
>
>
>
> Regarding CDU matrix, I think it is a network wide data structure. CDU
> represents the total communication resource used repeatedly in a network.
> Thus, it is a matrix of [MinimumCommonMultipleOfAlllSlotframeSize,
> NumberOfChannel].
>
>
>
> What do you think?
>
>
>
> Thanks
>
> Qin
>
>
>
>
>
>
>
> On Friday, March 14, 2014 12:08 AM, Pat Kinney <
> [email-masked]> wrote:
>

---

From: Qin Wang <[email-masked]>
Date: Thu, 13 Mar 2014 10:33:34 -0700 (PDT)

Hi Dominique,

let me put it in another way. TSCH schedule is used by TSCH, so, it should be per node. PCE can run its scheduling algorithm and generate some data structure stored in PCE, and then PUT it to nodes as their TSCH schedule. But the data structure is not TSCH schedule.

Thought?

Qin

On Friday, March 14, 2014 1:12 AM, "[email-masked]" <[email-masked]> wrote:

Dominique
 
De :6tisch [mailto:[email-masked]] De la part de Qin Wang
Envoyé : jeudi 13 mars 2014 18:04
À : [email-masked]
Objet : [6tisch] Fw: some comments on draft-ietf-6tisch-terminology-01

 
 
What do you think?
 
Thanks
Qin

 
Pat
 
Pat Kinney
Kinney Consulting LLC

 
 
Cheers,
 
Pascal

Well,

What do you think?
Maria Rita

Hello Maria-Rita:

 
Cheers,
 
Pascal

Hello Dominique,

 

Best regards,
Maria Rita

Hello Maria-Rita, all,

 
Best regards,
 
Dominique

 

_________________________________________________________________________________________________________________________ Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci. This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 13 Mar 2014 17:49:42 +0000

Seems partition is not the word I thought; what I mean was, I'm told, a musical score.
The PCE has visibility on multiple scores for various instruments.
But it has only a limited visibility on cells that are locally administered by a RPL parent.

Cheers,

Pascal

From: Pascal Thubert (pthubert)
Sent: jeudi 13 mars 2014 08:08
To: [email-masked]'; [email-masked]
Subject: RE: some comments on draft-ietf-6tisch-terminology-01

Hum;

Cheers,

Pascal

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 14 Mar 2014 07:25:48 +0000

Hello Qin, all,
Thanks for your effort in trying to make concepts clearer.
I do agree that TSCH should be per node, but still the PCE should store the data related to all the node schedule into a network structure…maybe the 3D one you were talking about.
In other words, we should clarify what structure we have from a node and a network perspective.
Do you agree?
Maria Rita

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: Thursday, March 13, 2014 6:34 PM
To: [email-masked]; [email-masked]
Subject: Re: [6tisch] Fw: some comments on draft-ietf-6tisch-terminology-01

Hi Dominique,

Thought?

Qin

On Friday, March 14, 2014 1:12 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:
Do you mean, a « network-wide TSCH schedule » should be a 3D array?
In fact, how would you store the outcome of the centralized PCE computation?
By the way, is there a difference between the layering of the “node TSCH schedules” and the PCE view of the network, when a PCE is in use?

Dominique

De : 6tisch [mailto:[email-masked]] De la part de Qin Wang
Envoyé : jeudi 13 mars 2014 18:04
À : [email-masked]<mailto:[email-masked]>
Objet : [6tisch] Fw: some comments on draft-ietf-6tisch-terminology-01

What do you think?

Thanks
Qin

Pat

Pat Kinney
Kinney Consulting LLC

Cheers,

Pascal

Well,

What do you think?
Maria Rita

Hello Maria-Rita:

Cheers,

Pascal

Hello Dominique,

Best regards,
Maria Rita

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 14 Mar 2014 07:28:10 +0000

Pascal, I am not sure I got what you meant...
For sure the PCE should have a global network view...and thus have visibility on the schedule of all the nodes in the network.
I guess you are thinking about chunk when you talk about cells that are locally administrated by a RPL parent...
In that case, it is the parent to be responsible of the schedule built for its children.
Maria Rita

From: 6tisch [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, March 13, 2014 6:50 PM
To: [email-masked]; [email-masked]
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Cheers,

Pascal

From: Pascal Thubert (pthubert)
Sent: jeudi 13 mars 2014 08:08
To: [email-masked]'; [email-masked]<mailto:[email-masked]>
Subject: RE: some comments on draft-ietf-6tisch-terminology-01

Hum;

Cheers,

Pascal

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 14 Mar 2014 10:59:57 +0000

Hello Maria Rita:

I'm referring to the schedule actually, sorry for being unclear. My image is that of a symphonic orchestra:

-        Every musician has his own musical score which tells him when to play his instrument. That score is local to the musician. The node schedule is just like this, specific to the node. Just like a musician expects the other musician to play their own piece of the music, and the node plays its schedule with the expectation that the other nodes play their own in perfect sync.

-        In a fully controlled world, the PCE is like the conductor of the orchestra. It has visibility on multiple scores for various instruments. You'll note that the conductor also beats the time for the orchestra, acting as a global time source. As Qin said, the conductor does not play the music, and does not have a schedule for himself, but it has visibility on the aggregation (the calcs) of all the schedules of all nodes.

-        With RPL, nodes get the capability to manage their own time slots. The PCE will have visibility on which chunks are being used but a limited one on how they are being used. As the network grows beyond a single interference domain and chunks are being reused, there will not be a simple "3D" calc superposition of all schedules, and the abstraction in the PCE will become more complex.

Is that more clear ?

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: vendredi 14 mars 2014 00:28
To: Pascal Thubert (pthubert); [email-masked]; [email-masked]
Subject: RE: some comments on draft-ietf-6tisch-terminology-01

Cheers,

Pascal

Hum;

Cheers,

Pascal

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 14 Mar 2014 10:05:08 -0300

Pascal,
          As a consequence, a more complex structure (than a 3D
superposition of schedules)
will be required. Should that structure be defined on the terminology or
should it
be left for the implementer to deal with it?

                                                            Diego

2014-03-14 7:59 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]>:

> -        Every musician has his own musical score which tells him when to
> play his instrument. That score is local to the musician. The node schedule
> is just like this, specific to the node. Just like a musician expects the
> other musician to play their own piece of the music, and the node plays its
> schedule with the expectation that the other nodes play their own in
> perfect sync.
>
> -        In a fully controlled world, the PCE is like the conductor of
> the orchestra. It has visibility on multiple scores for various
> instruments. You'll note that the conductor also beats the time for the
> orchestra, acting as a global time source. As Qin said, the conductor does
> not play the music, and does not have a schedule for himself, but it has
> visibility on the aggregation (the calcs) of all the schedules of all nodes.
>
> -        With RPL, nodes get the capability to manage their own time
> slots. The PCE will have visibility on which chunks are being used but a
> limited one on how they are being used. As the network grows beyond a
> single interference domain and chunks are being reused, there will not be a
> simple "3D" calc superposition of all schedules, and the abstraction in the
> PCE will become more complex.
>
>
>
> Is that more clear ?
>
>
>
> Pascal
>
>
>
> *From:* Maria Rita PALATTELLA [mailto:[email-masked]]
> *Sent:* vendredi 14 mars 2014 00:28
> For sure the PCE should have a global network view...and thus have
> visibility on the schedule of all the nodes in the network.
>
> Behalf Of *Pascal Thubert (pthubert)
> *Sent:* Thursday, March 13, 2014 6:50 PM
> *From:* Pascal Thubert (pthubert)
> *Sent:* jeudi 13 mars 2014 08:08
> *To:* [email-masked]'; [email-masked]
> This is not serving us well then. The schedule is like a partition. Every
> musician has its own. The PCE is like the conductor with visibility n many
> partitions,  though with RPL there may be a few jazz players in the band...
>
> *Sent:* jeudi 13 mars 2014 07:30
> *To:* [email-masked]

---

From: Qin Wang <[email-masked]>
Date: Fri, 14 Mar 2014 06:19:49 -0700 (PDT)

Hi Diego and all,

I think the data structure to express the overall schedule in PCE will be scheduling algorithm related. We can add a terminology, something like Schedule view, but not define its structure.

What do you think?

Thanks
Qin

On Friday, March 14, 2014 9:05 PM, Prof. Diego Dujovne <[email-masked]> wrote:
 
Pascal,
          As a consequence, a more complex structure (than a 3D superposition of schedules) 
will be required. Should that structure be defined on the terminology or should it
be left for the implementer to deal with it?

                                                            Diego

Hello Maria Rita:
> 
>I’m referring to the schedule actually, sorry for being unclear. My image is that of a symphonic orchestra:
>-        In a fully controlled world, the PCE is like the conductor of the orchestra. It has visibility on multiple scores for various instruments. You’ll note that the conductor also beats the time for the orchestra, acting as a global time source. As Qin said, the conductor does not play the music, and does not have a schedule for himself, but it has visibility on the aggregation (the calcs) of all the schedules of all nodes.
>-        With RPL, nodes get the capability to manage their own time slots. The PCE will have visibility on which chunks are being used but a limited one on how they are being used. As the network grows beyond a single interference domain and chunks are being reused, there will not be a simple “3D” calc superposition of all schedules, and the abstraction in the PCE will become more complex.
> 
>Is that more clear ?
> 
>Pascal
> 
>From:Maria Rita PALATTELLA [mailto:[email-masked]] 
>Pascal, I am not sure I got what you meant…
>For sure the PCE should have a global network view…and thus have visibility on the schedule of all the nodes in the network.
>I guess you are thinking about chunk when you talk about cells that are locally administrated by a RPL parent…
>From:6tisch [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
>Seems partition is not the word I thought; what I mean was, I’m told, a musical score.
>From:Pascal Thubert (pthubert) 
>This is not serving us well then. The schedule is like a partition. Every musician has its own. The PCE is like the conductor with visibility n many partitions,  though with RPL there may be a few jazz players in the band…

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 14 Mar 2014 13:37:13 +0000

Hi Pascal,
yes, now it is much more clear and I really love the similarity you presented with the orchestra :)
It is very nice, and explain well all the concepts.
Then, I would suggest that we just make clear in the terminology draft that we are talking of NODE TSCH schedule.
What do you think?
Maria Rita

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Friday, March 14, 2014 12:00 PM
To: Maria Rita PALATTELLA; [email-masked]; [email-masked]
Subject: RE: some comments on draft-ietf-6tisch-terminology-01

Hello Maria Rita:

Is that more clear ?

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: vendredi 14 mars 2014 00:28
To: Pascal Thubert (pthubert); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: some comments on draft-ietf-6tisch-terminology-01

Cheers,

Pascal

Hum;

Cheers,

Pascal

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 14 Mar 2014 13:40:55 +0000

Hi Qin,
As I was saying to Pascal, maybe it is the case to define only the NODE TSCH schedule that is actually use by TSCH.
And do not introduce any definition from the network prospective.
As you and Pascal pointed out, the structure will be a functions of several parameters: algorithms used for building the schedule of each node, use or not use of chunks, etc.
We just need to specify (as it is done already) that the PCE has a global network view, without providing details on the way used for storing the information. What do you think?
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Friday, March 14, 2014 2:20 PM
To: Prof. Diego Dujovne; Pascal Thubert (pthubert)
Cc: Maria Rita PALATTELLA; [email-masked]; [email-masked]
Subject: Re: [6tisch] some comments on draft-ietf-6tisch-terminology-01

Hi Diego and all,

What do you think?

Thanks
Qin

On Friday, March 14, 2014 9:05 PM, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> wrote:
Pascal,
          As a consequence, a more complex structure (than a 3D superposition of schedules)
will be required. Should that structure be defined on the terminology or should it
be left for the implementer to deal with it?

                                                            Diego

2014-03-14 7:59 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>:
Hello Maria Rita:

Is that more clear ?

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]<mailto:[email-masked]>]
Sent: vendredi 14 mars 2014 00:28
To: Pascal Thubert (pthubert); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Cheers,

Pascal

From: Pascal Thubert (pthubert)
Sent: jeudi 13 mars 2014 08:08
To: [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>
Subject: RE: some comments on draft-ietf-6tisch-terminology-01

Hum;

Cheers,

Pascal

Hello Maria-Rita, all,

Best regards,

Dominique

Thank you.

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl/>
(56 2) 676 8125

---

From: Qin Wang <[email-masked]>
Date: Fri, 14 Mar 2014 07:02:30 -0700 (PDT)

Hi Maria Rita,

I agree with you. 

Thanks
Qin

On Friday, March 14, 2014 9:41 PM, Maria Rita PALATTELLA <[email-masked]> wrote:
 
Hi Qin,
 
From:Qin Wang [mailto:[email-masked]] 
 
Hi Diego and all,

What do you think?
 
Thanks
Qin

                                                            Diego

 
Is that more clear ?
 
Pascal

 

 
Cheers,
 
Pascal

Hum;

Cheers,
 
Pascal

Hello Maria-Rita, all,

 
Best regards,
 
Dominique

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 17 Mar 2014 00:02:11 +0100

All,
My personal opinion is to avoid adding terms in the terminology draft which
are specific to a way of using the network. I would keep the term TSCH
schedule (or node schedule, whatever you think is most appropriate), and
not add a term for the internal representation the PCE might have of the
union of all node schedules. This is because (1) it is really an
implementation issue, and a 3D matrix is just an option and (2) this is
very specific to the PCE case, not as generic as, say, the term schedule.
Thomas

On Friday, March 14, 2014, Qin Wang <[email-masked]> wrote:

> As I was saying to Pascal, maybe it is the case to define only the NODE
> TSCH schedule that is actually use by TSCH.
> As you and Pascal pointed out, the structure will be a functions of
> several parameters: algorithms used for building the schedule of each node,
> use or not use of chunks, etc.
> We just need to specify (as it is done already) that the PCE has a global
> network view, without providing details on the way used for storing the
> information. What do you think?
> Maria Rita
>
>  *From:* Qin Wang [mailto:[email-masked]]
> *Sent:* Friday, March 14, 2014 2:20 PM
> *To:* Prof. Diego Dujovne; Pascal Thubert (pthubert)
> *Cc:* Maria Rita PALATTELLA; [email-masked]; [email-masked]
>  I think the data structure to express the overall schedule in PCE will
> be scheduling algorithm related. We can add a terminology, something like
> Schedule view, but not define its structure.
>
>  What do you think?
>
>  Thanks
>  Qin
>