Subject: Re: [6tisch] minimal and beyond

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 30 May 2014 14:19:18 +0000

Hi Kris:

I agree that the quack exchange is necessary; nodes need to agree on what they can do and what they will do.
This is also the essence of the control bits I was alluding to. SNA had done that quite well if not a bit chattily with the XID with negotiable and non-negotiable fields.
I like the term quack better as long as there are not too many of them : )

Can we consider that the initial well known key is the first quack?

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Kris Pister
Sent: mardi 27 mai 2014 22:28
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] minimal and beyond

I think that they are both good questions.  I'm reminded of the Far Side cartoon
of the scientist speaking to a duck.
"Parlez vous Francais?"  <blank stare>
"Sprechen Sie Deutsch?" <blank stare>
"Quack?"                         "Quack! Quack quack quack!"

It's important that motes A, B,C know when to give a blank stare, but it's also
useful to have an efficient mechanism to enumerate which protocols are
supported, much like TLS cipher suite negotiation.  Perhaps something like
a "client hello" message?

ksjp
On 5/27/2014 12:04 PM, Michael Richardson wrote:

Thomas Watteyne <[email-masked]><mailto:[email-masked]> wrote:

    > One question this raises is whether/how entities in network discover

    > their capabilities. Do [R2,X,Y,Z] know [R1,A,B,C] only speak minimal?

    > Does X, upon joining, announce "I know about PNP"?

Again, it's the wrong question.

The correct question is:

    What does A do when confronted with a schedule that contains schedule

    descriptions which go beyond minimal.  The answer may be "ignore that

    entry", or it be, "return an error to sender".

X, upon joining, simply speaks "PNP", and may find that "A" says, "huh".

--

Michael Richardson <[email-masked]><mailto:[email-masked]>, Sandelman Software Works

 -= IPv6 IoT consulting =-

_______________________________________________

6tisch mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/6tisch

---

From: Kris Pister <[email-masked]>
Date: Fri, 30 May 2014 08:10:26 -0700

quACK

:)

ksjp

On 5/30/2014 7:19 AM, Pascal Thubert (pthubert) wrote:
> This is also the essence of the control bits I was alluding to. SNA 
> had done that quite well if not a bit chattily with the XID with 
> negotiable and non-negotiable fields.
>
> *From:*6tisch [mailto:[email-masked]] *On Behalf Of *Kris Pister
> *Sent:* mardi 27 mai 2014 22:28
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [6tisch] minimal and beyond
>
>     Thomas Watteyne<[email-masked]>  <mailto:[email-masked]>  wrote:
>
>     Michael Richardson<[email-masked]>  <mailto:[email-masked]>, Sandelman Software Works
>
>     [email-masked]  <mailto:[email-masked]>
>