Subject: [6tisch] Fw: Is CoAP IE a MAC header IE or MAC payload IE

From: Qin Wang <[email-masked]>
Date: Tue, 8 Jul 2014 14:44:20 -0700

On Wednesday, July 9, 2014 5:40 AM, Qin Wang <[email-masked]> wrote:

Hi Thomas,

In the section 5.2.4.1 of IEEE802154e, the difference between MAC header IE and payload IE is described as follows.

"IEs may be either part of the MAC Header or MAC payload. Header IEs are used by the MAC to process the
frame immediately, i.e., they cover security, addressing, etc., and are part of the MAC Header. Payload IEs
are destined for another layer or SAP and are part of the MAC payload (but like command IDs they may not
be encrypted). If IEs are contained in a frame, they always occur before other unstructured MAC payload
elements."

I think CoAP IE, and also other 6top IEs if defined, should be payload IE because they are in 6top, the upper layer of MAC. Actually, even TSCH, all of its IEs are payload IE. I guess one reason is that they are not used to process the MAC header; and another reason is that they want to be protected by encryption and MIC. CoAP IE is similar.

What do you think?

Thanks
Qin

On Wednesday, July 9, 2014 5:04 AM, Thomas Watteyne <[email-masked]> wrote:

Qin,
This is a very important question, and the answer isn't obvious at all, so I believe this is a good discussion to have on the ML. What do you think? Of course, I can contribute with a lengthy argumentation once we decide where to put this thread.
Thomas

On Tue, Jul 8, 2014 at 1:46 PM, Qin Wang <[email-masked]> wrote:

Hi all,
>
>
>In the coapie draft, CoAP IE is expected as part of MAC header, which implies that CoAP  IE will be a MAC header IE. It is different from TSCH IEs and the 6top IEs defined before, all of them are MAC payload IE. Is there any special reason for it? If not, I would suggest to use payload IE for CoAP IE also, because it may make the interface with IEEE802.15.4 group simple, i.e. one IE code.
>
>
>What do you think?
>
>
>Thanks
>Qin
>
>

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 8 Jul 2014 16:24:14 -0700

I see 2 differences between header and payload IEs:
- header IEs are meant to be consumed by the MAC layer, payload IE by the
upper layer (e.g. 6top)
- header IEs are in the MAC header, payload IE are part of the MAC payload;
they hence be authenticated/encrypted differently (see Table 53 in
IEEE802.15.4-2011).:

I believe it's a good idea to have the CoAP IE be a payload IE.

On Tue, Jul 8, 2014 at 2:44 PM, Qin Wang <[email-masked]> wrote:

> In the section 5.2.4.1 of IEEE802154e, the difference between MAC header
> IE and payload IE is described as follows.
>
> I think CoAP IE, and also other 6top IEs if defined, should be payload IE
> because they are in 6top, the upper layer of MAC. Actually, even TSCH, all
> of its IEs are payload IE. I guess one reason is that they are not used to
> process the MAC header; and another reason is that they want to be
> protected by encryption and MIC. CoAP IE is similar.
>
> What do you think?
>
> Thanks
> Qin
>
>
>
> This is a very important question, and the answer isn't obvious at all, so
> I believe this is a good discussion to have on the ML. What do you think?
> Of course, I can contribute with a lengthy argumentation once we decide
> where to put this thread.
> Thomas
>
>
> In the coapie draft, CoAP IE is expected as part of MAC header, which
> implies that CoAP  IE will be a MAC header IE. It is different from TSCH
> IEs and the 6top IEs defined before, all of them are MAC payload IE. Is
> there any special reason for it? If not, I would suggest to use payload IE
> for CoAP IE also, because it may make the interface with IEEE802.15.4 group
> simple, i.e. one IE code.
>
> What do you think?
>
> Thanks
> Qin
>
>
>
>
>
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: Xavier Vilajosana <[email-masked]>
Date: Wed, 9 Jul 2014 09:29:39 +0200

+1 for Payload IE as it has to be processed by 6top layer and not 15.4e.
Besides we want to be able to support encrypted information as this is
critical for the network operation.

2014-07-09 1:24 GMT+02:00 Thomas Watteyne <[email-masked]>:

> - header IEs are in the MAC header, payload IE are part of the MAC
> payload; they hence be authenticated/encrypted differently (see Table 53 in
> IEEE802.15.4-2011).:
>
>> This is a very important question, and the answer isn't obvious at all,
>> so I believe this is a good discussion to have on the ML. What do you
>> think? Of course, I can contribute with a lengthy argumentation once we
>> decide where to put this thread.
>> Thomas
>>
>>

---

From: "Raghuram Sudhaakar (rsudhaak)" <[email-masked]>
Date: Wed, 9 Jul 2014 17:45:15 +0000

Based on sec 5.2.4.1 and the table 53 cited below, I agree with the assessment that the CoAP IE must be a payload IE.

I also suggest that we address  (for clarity) the encryption methodology of the CoAP IE in the draft.

-raghuram

From: Xavier Vilajosana <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 9, 2014 at 12:29 AM
To: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [6tisch] Fw: Is CoAP IE a MAC header IE or MAC payload IE

+1 for Payload IE as it has to be processed by 6top layer and not 15.4e. Besides we want to be able to support encrypted information as this is critical for the network operation.

2014-07-09 1:24 GMT+02:00 Thomas Watteyne <[email-masked]<mailto:[email-masked]>>:
I see 2 differences between header and payload IEs:
- header IEs are meant to be consumed by the MAC layer, payload IE by the upper layer (e.g. 6top)
- header IEs are in the MAC header, payload IE are part of the MAC payload; they hence be authenticated/encrypted differently (see Table 53 in IEEE802.15.4-2011).:

On Tue, Jul 8, 2014 at 2:44 PM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:

On Wednesday, July 9, 2014 5:40 AM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:

Hi Thomas,

What do you think?

Thanks
Qin

On Wednesday, July 9, 2014 5:04 AM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:

Qin,

On Tue, Jul 8, 2014 at 1:46 PM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

What do you think?

Thanks
Qin

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 10 Jul 2014 09:08:50 +0000

+1

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Raghuram Sudhaakar (rsudhaak)
Sent: mercredi 9 juillet 2014 19:45
To: Xavier Vilajosana; Thomas Watteyne
Cc: [email-masked]
Subject: Re: [6tisch] Fw: Is CoAP IE a MAC header IE or MAC payload IE

-raghuram

Hi Thomas,

What do you think?

Thanks
Qin

Qin,

What do you think?

Thanks
Qin

---

From: Michael Richardson <[email-masked]>
Date: Thu, 10 Jul 2014 09:13:32 -0400

Raghuram Sudhaakar (rsudhaak) <[email-masked]> wrote:
    > Based on sec 5.2.4.1 and the table 53 cited below, I agree with the
    > assessment that the CoAP IE must be a payload IE. 

    > methodology of the CoAP IE in the draft. 

"The message will be encrypted using whatever key material is used
for regular IPv6 traffic between those two nodes" 

Beyond that is inappropriate, and belongs in the security implementation
document.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-