Subject: [6tisch] FW: [OPSAWG] Coman Drafts v02

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 12 Aug 2014 17:11:05 +0000

Dear all,

Please find my review on coman use cases 02 below

Cheers,

Pascal

From: Pascal Thubert (pthubert)
Sent: samedi 9 août 2014 14:42
To: Raghuram Sudhaakar (rsudhaak)
Cc: [email-masked]; Thomas Watteyne; [email-masked]
Subject: Re: [OPSAWG] Coman Drafts v02

Dear all:

On coman use cases 02

Really excellent work! Fits my own understanding in every scenario I am familiar with.

Issues:

The security section is absent yet security concerns are correctly discussed throughout. As it goes, security concerns for management flows are correctly expressed but often apply to many other use cases where the question is not discussed. Maybe a table in the security section could summarize case by case who manages the network and the devices, and what kind of security is in place.

There is a great discussion on light bulbs commissioning in the building section. I was actually missing that same discussion in the factory automation section.

Who manages the network during the factory setup/commissioning? Specific threats are associated to the transition to operational/trusted, and the process of handover exists in multiple scenarios.

Thanks again for this great document. Really useful, and I support its publication.

Pascal

Le 8 août 2014 à 20:10, "Raghuram Sudhaakar (rsudhaak)" <[email-masked]<mailto:[email-masked]>> a écrit :
Dear ML users,
I read both the documents your mentioned below. Both are well written and address their scope quite well.
Only a few minor typos here and there.

On a general note, both these documents do not address the actual management protocol. It seems to me that these documents will typically be referenced by some other drafts (like our draft-ietf-6tisch-coap) that specify the protocol.

-raghuram

From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, August 5, 2014 at 11:15 PM
To: raghuram sudhaakar <[email-masked]<mailto:[email-masked]>>
Subject: Fwd: [6lo] Fwd: [OPSAWG] Coman Drafts v02

Raghuram,
These drafts, which introduce the use cases and problem statement for constrained management, are very related to the CoAP draft you co-authored. I believe it would be very useful if you could review them and submit your review to the OPSAWG ML, as detailed below. Would that be possible?
Thomas

---------- Forwarded message ----------
From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: Sat, Jul 26, 2014 at 10:32 PM
Subject: Fwd: [6lo] Fwd: [OPSAWG] Coman Drafts v02
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

All,

The OPSWAG chairs have kindly agreed to extend the WGLC period for the following drafts [1] to August 11:

http://tools.ietf.org/html/draft-ietf-opsawg-coman-use-cases-02
http://tools.ietf.org/html/draft-ietf-opsawg-coman-probstate-reqs-01

Pascal and myself believe those two drafts to be important for the ongoing work on managing a 6TiSCH network, and directly in line with e.g. draft-ietf-6tisch-coap. We therefore ask authors of draft-ietf-6tisch-coap, draft-ietf-6tisch-6top-interface, and any other 6TiSCH WG member to send reviews of this document to OPSAWG ML [2].

Thomas

[1] http://www.ietf.org/mail-archive/web/6tisch/current/msg02465.html
[2] https://www.ietf.org/mailman/listinfo/opsawg

---------- Forwarded message ----------
From: Warren Kumari <[email-masked]<mailto:[email-masked]>>
Date: Fri, Jul 25, 2014 at 3:03 PM
Subject: Re: [coman] FW: [OPSAWG] Coman Drafts v02
To: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>"
<[email-masked]<mailto:[email-masked]>>

Hi all.

With apologies to the authors...

The chairs of 6LoWPAN and 6TSCH have asked if we can delay the end of
this WGLC so that their communities can review and comment on these 2
documents.

As we have not received very much feedback, this seems relevant to
their WGs, and they asked nicely, we have decided to extend the
deadline to August 11th.

Now, many folk will be traveling back to their homes over the next few
days - this probably means a few, or many hours on an airplane. May I
suggest copying these documents on your computer or reading device of
choice and reviewing the documents on the way home?

Thanks,
W
_______________________________________________
6lo mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6lo

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 12 Aug 2014 17:12:04 +0000

Dear all,

Please find my review on coman probstate/req below:

Cheers,

Pascal

From: Pascal Thubert (pthubert)
Sent: dimanche 10 août 2014 18:48
To: [email-masked]
Cc: Raghuram Sudhaakar (rsudhaak); Thomas Watteyne
Subject: Re: [OPSAWG] Coman Drafts v02

Dear all:

About probstate/req.

This is a very complete and well written document, and I agree it is ripe for IESG.

Before submittung, though, I'd suggest to add text relevant to (radio) link and resources management.

The draft only discusses reporting a topology. In a radio mesh, it is important to assess reachability and interference domains so as to allow spatial reuse of.

Because some resources are shared there is a need to claim some and a need for arbitration/push from the network management down to the frequencies and in the case of TSCH, time slots.

6TiSCH has also isolated the need for traffic engineering (eg for industrial control loops) and though the network component is a PCE, I'd think that the requirement is still a management one.

Finally I'm not sure there is enough text on operator IoT networks (multi tenant management) eg a citywide IoAt backbone operated by an ISP or the city itself, or a home network with share mesh resources but multiple sinks for various utilities.

Cheers,

Pascal

-raghuram

Raghuram,

---------- Forwarded message ----------
From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: Sat, Jul 26, 2014 at 10:32 PM
Subject: Fwd: [6lo] Fwd: [OPSAWG] Coman Drafts v02
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

All,

Thomas

---------- Forwarded message ----------
From: Warren Kumari <[email-masked]<mailto:[email-masked]>>
Date: Fri, Jul 25, 2014 at 3:03 PM
Subject: Re: [coman] FW: [OPSAWG] Coman Drafts v02
To: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>"

Hi all.

Thanks,
W