Subject: [6tisch] Action item on join priority

From: Pat Kinney <[email-masked]>
Date: Tue, 14 Oct 2014 21:26:07 -0500

I took an action item on Friday, 10 October to look into the 15.4 standard and send an e-mail to the ML about whether a node is required to join the node which advertises the lowest priority.

Here is the pertinent text from the 15.4 revision draft (approved by letter ballot):
"The Join Priority field shall contain the beaconing devices join priority, which shall be set to the lowest join priority heard when it joined the network plus one. The PAN coordinator’s join priority shall be set to zero. A lower value of join priority indicates that connection to the beaconing device is the preferred."  

So, even though the join priority only indicates that the lowest value is preferred, there is no mandate to join that device.

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 15 Oct 2014 07:24:16 +0000

This is interesting, Pat:

During the IEEE interim in Athens, I looked at one of the proposals at 802.15.10 and ( my understanding is that) that proposal falls in a related pitfall: the set of parents is taken from the minimum priority, which means that the proposal builds a routing DAG based on hop count. Not too surprisingly, they found that hop count leads to very poor routing performances, and now evaluate routing via siblings for the retries.

6TiSCH, OTOH, uses RPL and its Rank computation by an OF to form a loop-less graph that is used for both time distribution and routing. Because the OF is aware of the transmission medium and the performance constraints, RPL builds and maintains an optimal graph, with modern poisoning and diffusion methods.

This time again, I suggested that the group considers using RPL at Layer-2, just like 802.1 L2R uses IS-IS and Layer-2, or at least that they document when and why their approach diverges from RPL. We are not there yet...

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Pat Kinney
Sent: mercredi 15 octobre 2014 04:26
To: [email-masked]
Subject: [6tisch] Action item on join priority

Here is the pertinent text from the 15.4 revision draft (approved by letter ballot):
"The Join Priority field shall contain the beaconing devices join priority, which shall be set to the lowest join priority heard when it joined the network plus one. The PAN coordinator's join priority shall be set to zero. A lower value of join priority indicates that connection to the beaconing device is the preferred."

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]<mailto:[email-masked]>

---

From: Pat Kinney <[email-masked]>
Date: Wed, 15 Oct 2014 08:43:29 -0500

Good points Pascal;

This is why I believe it is best to keep communication protocols unbiased as to routing protocols.  The MAC TSCH shouldn't mandate specific criteria for building the network, rather it should state how each device implements the join mechanics and leave the decision as to which device to join up to another protocol such as RPL, or whatever.

BTW: 802.15.10 is separate from 802.15.4 and currently is a "Recommended Practice' not a Standard

Pat

Pat Kinney
Kinney Consulting LLC

On Oct 15, 2014, at 2:24 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:

 
 
This time again, I suggested that the group considers using RPL at Layer-2, just like 802.1 L2R uses IS-IS and Layer-2, or at least that they document when and why their approach diverges from RPL. We are not there yet…
 
Cheers,
 
Pascal

 

 
Pat Kinney
Kinney Consulting LLC

 
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch