Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt

From: [email-masked]
Date: Sun, 26 Oct 2014 21:17:07 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IPv6 over the TSCH mode of IEEE 802.15.4e Working Group of the IETF.

        Title           : Minimal 6TiSCH Configuration
        Authors         : Xavier Vilajosana
                          Kris Pister
	Filename        : draft-ietf-6tisch-minimal-03.txt
	Pages           : 22
	Date            : 2014-10-26

Abstract:
   This document describes the minimal set of rules to operate a
   [IEEE802154e] Timeslotted Channel Hopping (TSCH) network.  This
   minimal mode of operation can be used during network bootstrap, as a
   fall-back mode of operation when no dynamic scheduling solution is
   available or functioning, or during early interoperability testing
   and development.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6tisch-minimal/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-6tisch-minimal-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-6tisch-minimal-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Xavier Vilajosana <[email-masked]>
Date: Mon, 27 Oct 2014 05:20:10 +0100

All, I just published the new version of minimal. It includes a security
section as discussed last call and some changes to the default timing to be
according to 15.4 tsch default values.

regards,
Xavi

---------- Forwarded message ----------
From: <[email-masked]>
Date: 2014-10-27 5:17 GMT+01:00
Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt
To: [email-masked]
Cc: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
 This draft is a work item of the IPv6 over the TSCH mode of IEEE 802.15.4e
Working Group of the IETF.

Abstract:

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Turner, Randy" <[email-masked]>
Date: Mon, 27 Oct 2014 10:57:38 +0000

Hi

Regarding the "minimal" draft, are we using the same definition of "minimal" used in other IETF publications?  Is "minimal" meant to say that this document is a"mandatory" profile of 6tisch, and if something is not in this document, then it's optional?

Thanks
Randy

On Oct 27, 2014, at 12:20 AM, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> wrote:

All, I just published the new version of minimal. It includes a security section as discussed last call and some changes to the default timing to be according to 15.4 tsch default values.

regards,
Xavi

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: 2014-10-27 5:17 GMT+01:00
Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 27 Oct 2014 12:26:30 -0700

Randy,

The dratf uses the word "minimal" to refer to the absolute simplest way of
using a IEEE802.15.4e TSCH MAC with a [6LoWPAN|RPL]-based upper stack. As
explained in the intro, an example use case is an interop event. People
have brought up use cases where minimal can be used in products. It is also
possible to use minimal as a base for a dynamic scheduling solution, but
that's not a MUST.

Thomas

On Mon, Oct 27, 2014 at 3:57 AM, Turner, Randy <[email-masked]>
wrote:

>  Hi
>
>  Regarding the "minimal" draft, are we using the same definition of
> "minimal" used in other IETF publications?  Is "minimal" meant to say that
> this document is a"mandatory" profile of 6tisch, and if something is not in
> this document, then it's optional?
>
>  Thanks
> Randy
>
>
>
> On Oct 27, 2014, at 12:20 AM, Xavier Vilajosana <
> [email-masked]> wrote:
>
>   All, I just published the new version of minimal. It includes a
> security section as discussed last call and some changes to the default
> timing to be according to 15.4 tsch default values.
>
>  regards,
> Xavi
>
> This e-mail (including any attachments) is confidential and may be legally
> privileged. If you are not an intended recipient or an authorized
> representative of an intended recipient, you are prohibited from using,
> copying or distributing the information in this e-mail or its attachments.
> If you have received this e-mail in error, please notify the sender
> immediately by return e-mail and delete all copies of this message and any
> attachments. Thank you.
>

---

From: Xavier Vilajosana <[email-masked]>
Date: Mon, 27 Oct 2014 20:59:22 +0100

thanks Thomas for your clarification, I was going to say exactly that.
Minimal means most simple configuration. Note that 15.4e TSCH allows a wide
set of configurations and if we want interop we need a minimal set of rules
so nodes can talk. Also when a network fails or reboots it needs a basic
mode of operation, i.e a well known configuration to start with, that can
be minimal. As said also, this is absolutely not a MUST but a
RECOMMENDATION.

regards,
Xavi

2014-10-27 20:26 GMT+01:00 Thomas Watteyne <[email-masked]>:

> On Mon, Oct 27, 2014 at 3:57 AM, Turner, Randy <[email-masked]
> > wrote:
>
>>  Hi
>>
>> This e-mail (including any attachments) is confidential and may be
>> legally privileged. If you are not an intended recipient or an authorized

---

From: "Brett, Patricia (PA62)" <[email-masked]>
Date: Mon, 27 Oct 2014 22:35:08 +0000

Given it is a recommendation, may I suggest using a different term than “Minimal”?

In particular, this suggestion is to call this something either non-descriptive (e.g. Profile number 1), or something  more descriptive which would be indicative of the actual technical content.

Adjectives of quantity, or quality, or adjectives which are comparative or superlative seem inappropriate for a profile title in particular as there is nothing defined against which it may be compared.

Regards,
Pat

From: 6tisch [mailto:[email-masked]] On Behalf Of Xavier Vilajosana
Sent: Monday, October 27, 2014 3:59 PM
To: Thomas Watteyne
Cc: [email-masked]; Turner, Randy
Subject: Re: [6tisch] Fwd: I-D Action: draft-ietf-6tisch-minimal-03.txt

thanks Thomas for your clarification, I was going to say exactly that.
Minimal means most simple configuration. Note that 15.4e TSCH allows a wide set of configurations and if we want interop we need a minimal set of rules so nodes can talk. Also when a network fails or reboots it needs a basic mode of operation, i.e a well known configuration to start with, that can be minimal. As said also, this is absolutely not a MUST but a RECOMMENDATION.

regards,
Xavi

2014-10-27 20:26 GMT+01:00 Thomas Watteyne <[email-masked]<mailto:[email-masked]>>:
Randy,

The dratf uses the word "minimal" to refer to the absolute simplest way of using a IEEE802.15.4e TSCH MAC with a [6LoWPAN|RPL]-based upper stack. As explained in the intro, an example use case is an interop event. People have brought up use cases where minimal can be used in products. It is also possible to use minimal as a base for a dynamic scheduling solution, but that's not a MUST.

Thomas

On Mon, Oct 27, 2014 at 3:57 AM, Turner, Randy <[email-masked]<mailto:[email-masked]>> wrote:
Hi

Thanks
Randy

regards,
Xavi

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: 2014-10-27 5:17 GMT+01:00
Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-03.txt
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>

Abstract: