Subject: [6tisch] reflect upcomming 15.4 changes to minimal

From: Xavier Vilajosana <[email-masked]>
Date: Wed, 10 Dec 2014 05:30:33 +0100

All, after last week WG meeting, I'm wondering if the minimal draft should
reflect some of the new features that are being developed at 15.4. For
example, the default mac layer timing is changing:

*macTsRxOffset –changed from 1120 µs to 1116 µs to align center of
macTsRxWait with macTsTxOffset*

Should the minimal draft recommend the new value instead of the old one?

I think that as we have the advantage of knowing what 15.4 is doing, might
be interesting to consider the new features, although the risk is that they
are not definitive.

An alternative is to not explicitly indicate any value at minimal but
redirect to the default at 15.4.

thanks for your opinion!
regards,
Xavi

---

From: Pat Kinney <[email-masked]>
Date: Tue, 9 Dec 2014 22:33:25 -0600

I prefer the last option, to not explicitly indicate any value at minimal but redirect to the default at 15.4.  Remember, if you are not using default values then you need to include all values in the IE

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked] <mailto:[email-masked]>

On 9, Dec2014, at 22:30, Xavier Vilajosana <[email-masked]> wrote:

All, after last week WG meeting, I'm wondering if the minimal draft should reflect some of the new features that are being developed at 15.4. For example, the default mac layer timing is changing:

macTsRxOffset –changed from 1120 µs to 1116 µs to align center of macTsRxWait with macTsTxOffset

I think that as we have the advantage of knowing what 15.4 is doing, might be interesting to consider the new features, although the risk is that they are not definitive.

An alternative is to not explicitly indicate any value at minimal but redirect to the default at 15.4. 

thanks for your opinion!
regards,
Xavi
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 10 Dec 2014 06:48:29 +0000

Hi Pat

And by "15.4"  you mean 15.4-2015 ?

Randy

On Dec 9, 2014, at 8:33 PM, Pat Kinney <[email-masked]<mailto:[email-masked]>> wrote:

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]<mailto:[email-masked]>

On 9, Dec2014, at 22:30, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> wrote:

macTsRxOffset -changed from 1120 ?s to 1116 ?s to align center of macTsRxWait with macTsTxOffset

thanks for your opinion!
regards,
Xavi
_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.

---

From: Pat Kinney <[email-masked]>
Date: Wed, 10 Dec 2014 07:54:10 -0600

Yes, when it takes effect.  But right now 802.15.4 means 802.15.4-2011 plus all approved amendments, I.e 4e, 4f,4g,4j,4k,4m, and 4p.

Patrick Kinney
Kinney Consulting
+1.847.960.3715
[email-masked]

> On Dec 10, 2014, at 00:48, Turner, Randy <[email-masked]> wrote:
> 
> Hi Pat
> 
> On Dec 9, 2014, at 8:33 PM, Pat Kinney <[email-masked]> wrote:
> 
>> [email-masked]
>> 
>> 
>> 
>> 
>> 
>>

---

From: Rene Struik <[email-masked]>
Date: Wed, 10 Dec 2014 09:33:06 -0500

The current charter calls out 802.15.4e-2012, so that is the reference 
point.

https://datatracker.ietf.org/wg/6tisch/charter/

On 12/10/2014 8:54 AM, Pat Kinney wrote:
> Yes, when it takes effect.  But right now 802.15.4 means 802.15.4-2011 
> plus all approved amendments, I.e 4e, 4f,4g,4j,4k,4m, and 4p.
>
> Patrick Kinney
> Kinney Consulting
> +1.847.960.3715
> <mailto:[email-masked]>
>
> On Dec 10, 2014, at 00:48, Turner, Randy <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>> Hi Pat
>>
>> On Dec 9, 2014, at 8:33 PM, Pat Kinney 
>> <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>> I prefer the last option, to not explicitly indicate any value at 
>>> minimal but redirect to the default at 15.4.  Remember, if you are 
>>> not using default values then you need to include all values in the IE
>>>
>>> Pat Kinney
>>> */Kinney Consulting LLC/*
>>> <mailto:[email-masked]>
>>>
>>>
>>>
>>>
>>>
>>>
>>> On 9, Dec2014, at 22:30, Xavier Vilajosana 
>>> <[email-masked] 
>>> <mailto:[email-masked]>> wrote:
>>>
>>> All, after last week WG meeting, I'm wondering if the minimal draft 
>>> should reflect some of the new features that are being developed at 
>>> 15.4. For example, the default mac layer timing is changing:
>>>
>>> /macTsRxOffset –changed from 1120 µs to 1116 µs to align center of 
>>> macTsRxWait with macTsTxOffset/
>>>
>>> I think that as we have the advantage of knowing what 15.4 is doing, 
>>> might be interesting to consider the new features, although the risk 
>>> is that they are not definitive.
>>>
>>> [email-masked] <mailto:[email-masked]>
>>> [email-masked] <mailto:[email-masked]>
>> This e-mail (including any attachments) is confidential and may be 
>> legally privileged. If you are not an intended recipient or an 
>> authorized representative of an intended recipient, you are 
>> prohibited from using, copying or distributing the information in 
>> this e-mail or its attachments. If you have received this e-mail in 
>> error, please notify the sender immediately by return e-mail and 
>> delete all copies of this message and any attachments. Thank you.
>>
>
>

-- 
email: [email-masked] | Skype: rstruik
cell: +1 (647) 867-5658 | US: +1 (415) 690-7363

---

From: Pat Kinney <[email-masked]>
Date: Wed, 10 Dec 2014 08:55:51 -0600

I understand Rene’s point but 802.15.4e-2012 is not a standalone document, it is an amendment to 802.15.4-2011.  All IEEE standards are maintained through a number of processes. Restricting 6tisch to 802.15.4-2011 as amended by 802.15.4e-2012 seems very short-sighted, since there could be no corrections as errors were found and nor would 6tisch be applied to sub-GHz variations such as SUN devices.  

I believe that it is prudent to state 802.15.4 and allow IEEE 802 to correct and enhance the standard.

Pat Kinney
Kinney Consulting LLC

On 10, Dec2014, at 8:33, Rene Struik <[email-masked]> wrote:

The current charter calls out 802.15.4e-2012, so that is the reference point.

https://datatracker.ietf.org/wg/6tisch/charter/ <https://datatracker.ietf.org/wg/6tisch/charter/>

On 12/10/2014 8:54 AM, Pat Kinney wrote:
> On Dec 10, 2014, at 00:48, Turner, Randy <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi Pat
>> 
>> On Dec 9, 2014, at 8:33 PM, Pat Kinney <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> On 9, Dec2014, at 22:30, Xavier Vilajosana <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> https://www.ietf.org/mailman/listinfo/6tisch <https://www.ietf.org/mailman/listinfo/6tisch>
>>> 
>>> https://www.ietf.org/mailman/listinfo/6tisch <https://www.ietf.org/mailman/listinfo/6tisch>
>> 
> https://www.ietf.org/mailman/listinfo/6tisch <https://www.ietf.org/mailman/listinfo/6tisch>

-- 
email: [email-masked] <mailto:[email-masked]> | Skype: rstruik
cell: +1 (647) 867-5658 | US: +1 (415) 690-7363
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Rene Struik <[email-masked]>
Date: Wed, 10 Dec 2014 10:10:27 -0500

We need to have a stable reference point, which 802.15.4e-2012 is and a 
draft that is heavily in flux and that many in 6tisch have not had the 
chance to see is not.

Or, are you suggesting we put 6tisch on hold till we have such a stable 
reference?

Rene

On 12/10/2014 9:55 AM, Pat Kinney wrote:
> I understand Rene’s point but 802.15.4e-2012 is not a standalone 
> document, it is an amendment to 802.15.4-2011.  All IEEE standards are 
> maintained through a number of processes. Restricting 6tisch to 
> 802.15.4-2011 as amended by 802.15.4e-2012 seems very short-sighted, 
> since there could be no corrections as errors were found and nor would 
> 6tisch be applied to sub-GHz variations such as SUN devices.
>
> On 10, Dec2014, at 8:33, Rene Struik <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>> Yes, when it takes effect.  But right now 802.15.4 means 
>> 802.15.4-2011 plus all approved amendments, I.e 4e, 4f,4g,4j,4k,4m, 
>> and 4p.
>>
>> Patrick Kinney
>> Kinney Consulting
>> +1.847.960.3715
>>>> I think that as we have the advantage of knowing what 15.4 is 
>>>> doing, might be interesting to consider the new features, although 
>>>> the risk is that they are not definitive.
>>>>
> email:[email-masked]  | Skype: rstruik

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 10 Dec 2014 15:18:47 +0000

Hi Rene

We should define what we mean by "stable" for a reference point and I think our schedule for completion of the 6tisch document family may dovetail with a stable version of 15.4-2015 a it sure would be nice to point to 1 document for future implementers

Randy

On Dec 10, 2014, at 7:10 AM, Rene Struik <[email-masked]<mailto:[email-masked]>> wrote:

We need to have a stable reference point, which 802.15.4e-2012 is and a draft that is heavily in flux and that many in 6tisch have not had the chance to see is not.

Or, are you suggesting we put 6tisch on hold till we have such a stable reference?

Rene

On 12/10/2014 9:55 AM, Pat Kinney wrote:
I understand Rene's point but 802.15.4e-2012 is not a standalone document, it is an amendment to 802.15.4-2011.  All IEEE standards are maintained through a number of processes. Restricting 6tisch to 802.15.4-2011 as amended by 802.15.4e-2012 seems very short-sighted, since there could be no corrections as errors were found and nor would 6tisch be applied to sub-GHz variations such as SUN devices.

Pat Kinney
Kinney Consulting LLC

On 10, Dec2014, at 8:33, Rene Struik <[email-masked]<mailto:[email-masked]>> wrote:

Patrick Kinney
Kinney Consulting
+1.847.960.3715

On Dec 10, 2014, at 00:48, Turner, Randy <[email-masked]<mailto:[email-masked]>> wrote:

Hi Pat

Randy

Pat Kinney
Kinney Consulting LLC

thanks for your opinion!
regards,
Xavi

--
email: [email-masked]<mailto:[email-masked]> | Skype: rstruik
cell: +1 (647) 867-5658 | US: +1 (415) 690-7363

--
email: [email-masked]<mailto:[email-masked]> | Skype: rstruik
cell: +1 (647) 867-5658 | US: +1 (415) 690-7363

---

From: Pat Kinney <[email-masked]>
Date: Wed, 10 Dec 2014 09:32:06 -0600

Indeed Rene, the only publicized standards are 802.15.4-2011 and the amendments.  But my earlier statement is still valid, fixing 6tisch to a specific document has long-term issues. Once again, it seems prudent to me to develop 6tisch using released standards, but to not restrict the endproduct, i.e. IETF RFC 6tisch to a soon to be deprecated document.

Once again, is the sky really falling? To what technical problems are we aware that are not being addressed by IEEE 802.15?  Are we going to spend time on a subject that may or may not be a problem?  Or do we devote our efforts to completing 6tisch in our current manner?

After the 802.15.4 revision completes its work group comment resolution effort it will go into a sponsor ballot.  Anybody can join this sponsor ballot (in fact all are encouraged to join to give the ballot diversity).  Sponsor ballot members have the opportunity to review the draft and then vote for approval or non-approval with comments stating what changes must occur to change their vote to approve.  I suspect that 802.15.4 revision will go to sponsor ballot after March 2015.

In summary, there are procedures and processes that can be counted upon to resolve real problems once they are found.

Pat Kinney
Kinney Consulting LLC

On 10, Dec2014, at 9:10, Rene Struik <[email-masked]> wrote:

Rene

On 12/10/2014 9:55 AM, Pat Kinney wrote:
> On 10, Dec2014, at 8:33, Rene Struik <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 10 Dec 2014 20:45:14 +0000

I think we discussed that In Hawaii, René, and I can dig for minutes.

The main point is ETSI compliance. We need ETSI compliance in 6TiSCH without having to add tons of words on how that is achieved.
So we discussed referring to IEEE802.15.4-2015 in all drafts. Our drafts may stay in editor queue till IEEE802.15.4-2015 is published, but then how long is that?

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Rene Struik
Sent: mercredi 10 décembre 2014 08:33
To: Pat Kinney; Turner, Randy
Cc: [email-masked]; Xavier Vilajosana
Subject: Re: [6tisch] reflect upcomming 15.4 changes to minimal

Patrick Kinney
Kinney Consulting
+1.847.960.3715

Randy

Pat Kinney
Kinney Consulting LLC

macTsRxOffset -changed from 1120 µs to 1116 µs to align center of macTsRxWait with macTsTxOffset

thanks for your opinion!
regards,
Xavi

6tisch mailing list

--

---

From: Kris Pister <[email-masked]>
Date: Wed, 10 Dec 2014 17:04:47 -0800

I am supportive of the idea of having specs appear exactly once, in a 
single location,
and having everything else point to them.
One downside to this approach is that the set of specs needed to 
implement minimal
is distributed widely among a number of documents, and even inside 15.4e you
have to spend a lot of time hunting down the details.  Hopping sequence 
is a good
example: you can certainly figure it out from that document, but it sure 
saves time
to have us write it down for the system implementer.

I'm not advocating one way or the other.  I'm of two minds myself.

ksjp

On 12/9/2014 8:33 PM, Pat Kinney wrote:
> minimal but redirect to the default at 15.4.  Remember, if you are not 
> using default values then you need to include all values in the IE
>
> Pat Kinney
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
> /macTsRxOffset --changed from 1120 µs to 1116 µs to align center of