Subject: [6tisch] Minutes, 23 January 2015 interim, 6TiSCH WG

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 26 Jan 2015 17:05:01 +0000

Note: timestamps in PST.
Connection details

  *   Webex: https://ciscosales.webex.com/ciscosales/j.php?ED=219615007&UID=481905242&PW=NZTRkNDAwOTE1&RT=MiMyMw%3D%3D
  *   Etherpad: http://etherpad.tools.ietf.org:9000/p/6tisch?useMonospaceFont=true
  *   Topic: 6TiSCH Bi-Weekly
  *   Time: 8:00 am, Pacific Daylight Time (San Francisco, GMT-07:00)
  *   Meeting Number: 206 802 913
  *   Meeting Password: sixtus
  *   CCM: +14085256800x206802913
Resources

  *   Webex recording: https://cisco.webex.com/ciscosales/lsr.php?RCID=41d6ba8265e441bab0ffb9fc4c6b35fc
  *   Wiki: https://bitbucket.org/6tisch/meetings/wiki/150123_webex
  *   Slides: https://bitbucket.org/6tisch/meetings/src/master/140123_webex/slides_150123_webex.ppt
Are the slides for this part uploaded somewhere?
Taking notes (using Etherpad)

  1.  xavi vilajosana
Present (alphabetically)

  1.  Thomas Watteyne
  2.  Pascal Thubert
  3.  Chonggang Wang
  4.  Diego Dujovne
  5.  Georgios Exarchakos
  6.  Giuseppe Piro
  7.  Guillaume Gaillard
  8.  Maria Rita Palattella
  9.  Michael Richardson
  10. Nicola Accettura
  11. Patrick Wetterwald
  12. Pouria Zand
  13. Rene Struik
  14. Xavi Vilajosana
  15. Zhuo Chen
Action Items

  1.  Diego Add graph describe OTF-OTF communication on the OTF draft
  2.  Pascal Incorporate security text in the architecture and publish for last call
Agenda

  *   Administrivia (2min)
  *   draft-dujovne-6tisch-on-the-fly-04 [Diego Dujovne] [20min]
  *   draft-piro-6tisch-security-issues [Giuseppe Piro] [20min]
  *   Security Architecture text [René Struik] [5min]
  *   announcement ROLL interim meeting [Michael Richardson] [5min]
  *   Draft minimal delay discussion [Chairs] [5min]
Minutes

  *   [08.05] Meeting starts
     *   recording starts
     *   last call minutes are approved
     *   agenda is approved. Discussion on delaying minimal till after ROLL interim
     *   Xavi V.: points out the need to reach consensus on the Minimal draft
     *   Thomas W.: also points out the need to reach some agreements for the ETSI interop event which needs to be prepared soon.
     *   Xavi V.: discussion about minimal draft,
     *   Pascal T.: suggest to take that topic as part of interim discussion
  *   [08.10] draft-dujovne-6tisch-on-the-fly-04 [Diego Dujovne]
     *   OTF new version v04
     *   L3 mechanism used to adapt and dynamically allocate BW to nodes.
     *   used to allocate cells on the Best effort track. No other. Can co-exist with other scheduling mechanisms.
     *   Collisions are possible.
     *   3 elements are defined:
        *   scheduled cells
        *   required cells
        *   OTF threshold
     *   Separation between mechanism and policy.
     *   Trade-off between scheduled cells and required cells. Adds and removes them according to a threshold.

        *   Threshold creates over-provisioning of nodes which can be compensated by the reduction of churn to constantly add/remove cells.
     *   Use cells and bundles.
        *   One bundle per track.
        *   When OTF requires a cell this cell is always within a Bundle.
     *   Thomas W.: is there a way to query the algorithm that the motes are using? Is there a management entity that can configure the algorithm to be used?
     *   Diego D: Yes.
     *   Chonggang Wang: Asks if a graph can be added within the draft to describe OTF-OTF communication. <todo item added for Diego>
  *   [08.34] draft-piro-6tisch-security-issues [Giuseppe Piro]
     *   update on the draft. Security aspects. MAC Layer security. Aim to better understand the MAC layer security requirements and identify issues.
     *   addresses
        *   definition of keys
        *   configuration
        *   and lightweight key management scheme
     *   3 types of keys
        *   master key: is the initial secret shared by the devices in the network. Configured at pre-deployment. E.g by the manufacturer; working to adapt the draft to be inline the assumptions discussed in the Sec. WG
        *   production network key: secret shared between all authorized nodes and obtained during the join procedure
        *   per-peer L2 Key. negotiated only between peers through a KMP.
     *   Master key is used to protect EBs and msgs during the join process.
     *   production network ... ?
     *   different security configurations.
        *   fully secure
        *   unsecure
        *   partially secure
     *   L2 security link is setup in several phases:
        *   setup phase
        *   bootstrap phase
        *   join phase
        *   key negotiation phase
     *   key negotiation phase uses IEs to exchange information
     *   the process is composed of 6 steps where nodes exchange signatures computed using initial information.
     *   this steps require peer-wise communication between peers.
     *   the draft also identifies and tries to resolve some issues related to 15.4e std.
     *   Rene Struik: summarizes the security text that is proposed for addition to the architecture document.
     *   Thursday (security design team call) concluded the text that needs to be merged to the architecture d
     *   Todo for Pascal T.: Incorporate that text in the architecture and publish for last call.
     *   Pascal T.: after next version of the document (architecture draft) there will be the 2 weeks last call for reviews before submitting to th IESG
  *   [08.52] announcement ROLL interim meeting
     *   ROLL interim call 10 Feb 2015 at the ROLL WG. 16h UTC
     *   invited 6lo, 6man, 6tisch
     *   A 3h virtual meeting
     *   call for 00 drafts for proposals on how to do this. Explain the situations.
  *   ETSI interop.
     *   they want to start the process of writing the specs.
     *   we need to find a firm date.
     *   when the work starts we need a spec out so the work can start using an status base.
     *   the goal is to start working on stable draft.
     *   Thomas W.: what about security? What minimal draft says about security? what we expect for the interop in terms of security.
     *   Pascal T.: minimal says that Layer-2 security is needed. But it starts assuming that keys are there. There can be multiple ways to get the keys, and that's ouut of scope for minimal.
     *   Thomas W.: I agree with that.
     *   Michael R.: comments related to the terminology draft. We should agree if we incorporate them.
     *   Michael R.: answered to Rene, and we need to make sure we all agree.
     *   Pascal T.: let's agree on the ML.
     *   Maria-Rita P.: We need to decided what we do on the terminology. If it is normative reference it will block other references.
     *   Pascal T.: we depend on terminology normative reference for other drafts to be published.
     *   Pascal T.: suggestion to publish right now the terminology.
     *   Thomas W.: I agree with that.
  *   AOB
     *   Thomas W.: Time Change for the next meeting! Next meeting 6th feb 7AM pct 3pm UTC 4PM CET.
  *   [09.05] Meeting ends

Thomas and Pascal

---

From: Michael Richardson <[email-masked]>
Date: Mon, 26 Jan 2015 14:46:38 -0500

I've read the minutes, and the jive with what I heard.
It is good that we have converged on some terms for different kinds of keys.

It is unfortunate that we do not have more input from implementations as to
what extent they really adhere to the letter of the 802.15.4(e) spec,
vs the spririt of it when it comes to understanding if one can process beacons
for which one does not have the authentication key.  My review of available
sources suggests that there are no problems on any of the open source
platforms; none of the receive state machine logic is hard coded.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-