Subject: [6tisch] 6top and transmit power control

From: SVR Anand <[email-masked]>
Date: Thu, 4 Jun 2015 16:45:55 +0530 (IST)

Dear All,

A slight digression from the ongoing ML discussions. Hope the timing is OK!

As we all know, transmit power control is one of the powerful knobs that can be
used to minimize the interference and thereby improve the wireless network
performance and also provide deterministic network. Cell breathing technique
used in WLANs comes to our mind. When it comes to 6tisch, one might argue that
with 16 channels at our disposal, the interference can be avoided through smart
6top cell management interface without worrying much about transmit power
control.  However, there can be scenarios where transmit power control might be
required, for instance, (i) large scale dense deployments with heavy traffic
demands (ii) Co-existing WiFi reducing available non-overlapping channels for
15.4 (iii) prevent wireless leaks beyond the periphery of the deployement
region and (iv) OTF scheduling where nodes make local decisions for managing
cells, may be more.

One possibility is to leave the power management to the nodes. We are then
leaving this to implementors to device their own algorithms to handle
interference. Alternatively, a centralised controller (NME) knowing the
information about conflicting links can adaptively and optimally adjust the
operating transmit power of the nodes to avoid the interference and maximize
the wireless network performance.

If we treat transmit power as one of the controllable parameters along with the
cell management parameters, wondering if 6tisch 6top interface MIB is the place
to define this. Or this parameter is beyond the scope of 6tisch.

Any suggestions ?

Anand

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: [email-masked]
Date: Sat, 6 Jun 2015 12:20:12 +0530

Hi Kris,

Thanks!

I was not sure if and how such a parameter can be accommodated in the
current scheme of things, although it could be a useful control parameter
from the operator's perspective.

Anand

> seems like a good idea.
>
> ksjp
>
> On 6/4/2015 4:15 AM, SVR Anand wrote:
>> Dear All,
>>

---

From: Qin Wang <[email-masked]>
Date: Mon, 8 Jun 2015 15:07:35 +0000 (UTC)

Hi Anand,
Regarding to power management, there is a parameter in the IEEE802.15.4 PIB, i.e. phyTXPower. You can control the transmitting power by changing its value. Is that what you want? If so, I think 6tisch MIB will provide the interface to access phyTXPower, which will be defined in the 6tisch-interface draft.
ThanksQin  

     On Saturday, June 6, 2015 2:50 PM, "[email-masked]" <[email-masked]> wrote:

 Hi Kris,

Thanks!

Anand

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Michel Veillette <[email-masked]>
Date: Mon, 8 Jun 2015 15:33:21 +0000

Hi Anand and Qin

I’ll like to introduce the idea of supporting the option of adding the “phyTXPower” value in an IE within BEACON frames.
Provisioning the “phyTXPower” can be an issue when targeting multiple markets with different output power limits.
Including the “phyTXPower” within BEACON frames will enable joining nodes to adjust dynamically their output power based on a value managed at the PAN coordinator.

Michel Veillette
System Architecture Director
Trilliant Inc.
Tel: 450-375-0556 ext. 237
[email-masked]<mailto:[email-masked]>
www.trilliantinc.com<http://www.trilliantinc.com/>

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: 8 juin 2015 11:08
To: [email-masked]; Kris Pister
Cc: [email-masked]
Subject: Re: [6tisch] 6top and transmit power control

Hi Anand,

Thanks
Qin

On Saturday, June 6, 2015 2:50 PM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Kris,

Thanks!

Anand

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Pat Kinney <[email-masked]>
Date: Mon, 8 Jun 2015 12:19:20 -0500

Reducing transmit power may seem like a great idea but it creates havoc in many systems due to the “hidden node” problem.  A reduction in transmit power will often degrade the effectiveness of the CSMA mechanism which is used in shared timeslots.  The reduced effectiveness frequently appears as lost packets, requiring retransmissions, requiring more energy than that saved by reduction of transmit power.  However, since the CSMA is not required for TX only timeslots, changing TX power in these timeslots may be done with fewer ill effects.

Pat
Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked] <mailto:[email-masked]>

On 8, Jun2015, at 10:33, Michel Veillette <[email-masked]> wrote:

Hi Anand and Qin

Michel Veillette
System Architecture Director
Trilliant Inc.
Tel: 450-375-0556 ext. 237
[email-masked] <mailto:[email-masked]>
www.trilliantinc.com <http://www.trilliantinc.com/>  

Hi Anand,

Thanks
Qin

On Saturday, June 6, 2015 2:50 PM, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>> wrote:

Hi Kris,

Thanks!

Anand

_______________________________________________
6tisch mailing list
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch <https://www.ietf.org/mailman/listinfo/6tisch>

---

From: Michel Veillette <[email-masked]>
Date: Mon, 8 Jun 2015 17:35:25 +0000

Hi Pat

I totally agree with your comment, adjusting dynamically power level within a mesh network have marginal benefits and can potentially create issues.

My comment was about a static power level shared by all nodes within the PAN. Instead of pre-configuring, I propose to add an IE within BEACON frames to advertise this information. This value can be managed by the PAN coordinator and can be acquired by joining nodes during the joining process.

This way, networks can be deployed at different power levels without the need to set this value in each node prior installation.

Michel Veillette

From: Pat Kinney [mailto:[email-masked]]
Sent: 8 juin 2015 13:19
To: Michel Veillette
Cc: Qin Wang; [email-masked]; Kris Pister; [email-masked]
Subject: Re: [6tisch] 6top and transmit power control

Pat
Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]<mailto:[email-masked]>

On 8, Jun2015, at 10:33, Michel Veillette <[email-masked]<mailto:[email-masked]>> wrote:

Hi Anand and Qin

Michel Veillette

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: 8 juin 2015 11:08
To: [email-masked]<mailto:[email-masked]>; Kris Pister
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] 6top and transmit power control

Hi Anand,

Thanks
Qin

Hi Kris,

Thanks!

Anand

---

From: "S.V.R. Anand" <[email-masked]>
Date: Mon, 08 Jun 2015 23:57:19 +0530

Hi Qin,

Yes, if 6tisch MIB can provide the interface to access the phyTXPower, a 
centralized controller can make use of it in a  way that can enhance the 
performance of the 6tisch network.

The reason for specifically delegating this to a controller is because, 
we expect that  it has the required network statistics and link 
information for it to come up with appropriate power levels. The 
decisions can be based on certain short/long term measurements. It is 
hard to expect such an intelligence with nodes in the network.

Anand

On 08/06/2015 20:37, Qin Wang wrote:
> Hi Anand,
>
> Regarding to power management, there is a parameter in the 
> IEEE802.15.4 PIB, i.e. phyTXPower. You can control the transmitting 
> power by changing its value. Is that what you want? If so, I think 
> 6tisch MIB will provide the interface to access phyTXPower, which will 
> be defined in the 6tisch-interface draft.
>
> Thanks
> Qin
>
>
>
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.

---

From: "S.V.R.Anand" <[email-masked]>
Date: Tue, 09 Jun 2015 12:33:28 +0530

Hi Michel,

The idea is very interesting since the nodes are provisioned with the right
value upfront via BEACON IE so that they start using the power that is
appropriate, as determined by the PAN coordinator. In the absence of 
this, the
nodes might start-off with arbitrary power levels that can potentially 
result
in unpredictable network behaviour for the existing flows. I would 
assume, the
coordinator will have an ability to manage these power levels by
re-provisioning them depending on the state of the network in a way that the
hidden and exposed node problems are avoided.

One more thought. Does it make sense to use the BEACON IE approach when the
node joins the network and let an external centralized controller (NME), use
the 6top MIB interface to subsequently manage the phyTXPower ? The 
assumption
is that the interface provides the output power limit of the node as well.

Am I missing something here ?

Anand

On Monday 08 June 2015 09:03 PM, Michel Veillette wrote:
>
 > Hi Anand and Qin
 >
 >
 >
 > Ill like to introduce the idea of supporting the option of 
adding the phyTXPower value in an IE within BEACON frames.
 >
 > Provisioning the phyTXPower can be an issue when targeting multiple 
markets with different output power limits.
 >
 > Including the phyTXPower within BEACON frames will enable joining 
nodes to adjust dynamically their output power based on a value managed 
at the PAN coordinator.
 > [email-masked]
 >
 > www.trilliantinc.com
 >
 >
 >
 >
 >

---

From: "S.V.R.Anand" <[email-masked]>
Date: Tue, 09 Jun 2015 13:20:47 +0530

Hi Pat,

Thanks a lot for the insightful comments!

The main theme of my mail is to use transmit power control is to enable 
better
spatial re-use of the channels, managed by an external controller. The 
focus is
not much on the power savings. With respect to the effect of power 
control on
CSMA behaviour for the shared timeslots, one comes across literature 
that talks
about optimal power control that trades-off between hidden node and exposed
node problems. The latter is for better spatial re-use. As Michel 
pointed out
in his mail, the  nodes can use different output power levels. Left to them,
this could lead to unpredictable the contention regions, and all the 
associated
unfairness issues as well.

A well provisioned power levels managed by a centralized controller can also
help support more "deterministic"  tracks that use dedicated TX 
timeslots. For
reasons I cited in my earlier mail, don't you think a handle to transmit 
power
control helps in managing the network better, at least in the case of 
non-CSMA
timeslots ?

Anand

On Monday 08 June 2015 10:49 PM, Pat Kinney wrote:
> Reducing transmit power may  seem like a great idea but it creates havoc in many systems due to 
the hidden node problem.  A reduction in transmit power will often 
degrade the effectiveness of the CSMA mechanism which is used in shared 
timeslots.  The reduced effectiveness frequently appears as lost 
packets, requiring retransmissions, requiring more energy than that 
saved by reduction of transmit power.  However, since the CSMA is not 
required for TX only timeslots, changing TX power in these timeslots may 
be done with fewer ill effects.
 > [email-masked]
 >
 >
 >
 >
 >
 >
 > On 8, Jun2015, at 10:33, Michel Veillette

---

From: Pat Kinney <[email-masked]>
Date: Tue, 9 Jun 2015 07:44:27 -0500

Anand;

You raise valid points and in a professionally installed system, the installers would have made sure that the transmit power levels were appropriate.  My concerns are for non-professionally installed systems and/or systems with low duty cycle mobile end nodes.  Normally, in professional installations we ensure a 20 dB signal margin for end nodes, and populate routers to minimize “choke” points and maximize spectrum reuse.  However, in non-professional installs, we cannot assume these nodes will be properly set up.  Also, I am concerned that the IEEE 802.15.4 standard for the O-QPSK PHY in the 2450 MHz band does not require transmit power leveling nor multiple power set points, so any use of transmit power control would depend upon proprietary capabilities.  Finally, although phyTxPower is not marked as a read-only attribute, it is not described as an attribute that actively controls transmit power, hence its use as such would be proprietary.

Pat

Pat Kinney
Kinney Consulting LLC

On 9, Jun2015, at 2:50, S.V.R.Anand <[email-masked]> wrote:

Hi Pat,

The main theme of my mail is to use transmit power control is to enable better
spatial re-use of the channels, managed by an external controller. The focus is
not much on the power savings. With respect to the effect of power control on
CSMA behaviour for the shared timeslots, one comes across literature that talks
about optimal power control that trades-off between hidden node and exposed
node problems. The latter is for better spatial re-use. As Michel pointed out
in his mail, the  nodes can use different output power levels. Left to them,
this could lead to unpredictable the contention regions, and all the associated
unfairness issues as well.

A well provisioned power levels managed by a centralized controller can also
help support more "deterministic"  tracks that use dedicated TX timeslots. For
reasons I cited in my earlier mail, don't you think a handle to transmit power
control helps in managing the network better, at least in the case of non-CSMA
timeslots ?

Anand

On Monday 08 June 2015 10:49 PM, Pat Kinney wrote:
> Reducing transmit power may
      seem like a great idea but it creates havoc in many systems due to
      the hidden node problem.  A reduction in transmit power will
      often degrade the effectiveness of the CSMA mechanism which is
      used in shared timeslots.  The reduced effectiveness frequently
      appears as lost packets, requiring retransmissions, requiring more
      energy than that saved by reduction of transmit power.  However,
      since the CSMA is not required for TX only timeslots, changing TX
      power in these timeslots may be done with fewer ill effects.

      <[email-masked]> <mailto:[email-masked]> wrote:

      > Provisioning the phyTXPower can be an issue when targeting
      multiple markets with different output power limits.

      > Including the phyTXPower within BEACON frames will enable
      joining nodes to adjust dynamically their output power based on a
      value managed at the PAN coordinator.

      > From: 6tisch [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of
      Qin Wang

      > To: [email-masked] <mailto:[email-masked]>; Kris Pister

      > Cc: [email-masked] <mailto:[email-masked]>

      > Regarding to power management, there is a parameter in the
      IEEE802.15.4 PIB, i.e. phyTXPower. You can control the
      transmitting power by changing its value. Is that what you want?
      If so, I think 6tisch MIB will provide the interface to access
      phyTXPower, which will be defined in the 6tisch-interface draft.

      > On Saturday, June 6, 2015 2:50 PM, "[email-masked]" <mailto:[email-masked]>
      <[email-masked]> <mailto:[email-masked]> wrote:

      > >> A slight digression from the ongoing ML discussions.
      Hope the timing

      > >> is OK!

      > >> As we all know, transmit power control is one of the
      powerful knobs

      > >> that can be

      > >> used to minimize the interference and thereby
      improve the wireless

      > >> network

      > >> performance and also provide deterministic network.
      Cell breathing

      > >> technique

      > >> used in WLANs comes to our mind. When it comes to
      6tisch, one might

      > >> argue that

      > >> with 16 channels at our disposal, the interference
      can be avoided

      > >> through smart

      > >> 6top cell management interface without worrying much
      about transmit

      > >> control.  However, there can be scenarios where
      transmit power control

      > >> might be

      > >> required, for instance, (i) large scale dense
      deployments with heavy

      > >> traffic

      > >> demands (ii) Co-existing WiFi reducing available
      non-overlapping

      > >> channels for

      > >> 15.4 (iii) prevent wireless leaks beyond the
      periphery of the

      > >> deployement

      > >> region and (iv) OTF scheduling where nodes make
      local decisions for

      > >> managing

      > >> One possibility is to leave the power management to
      the nodes. We are

      > >> then

      > >> information about conflicting links can adaptively
      and optimally

      > >> adjust the

      > >> operating transmit power of the nodes to avoid the
      interference and

      > >> maximize

      > >> If we treat transmit power as one of the
      controllable parameters along

      > >> with the

      > >> cell management parameters, wondering if 6tisch 6top
      interface MIB is

      > >> the place

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/>, and is 
believed to be clean.

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 9 Jun 2015 21:31:14 +0200

Anand,
Possibly useful, and I believe a small change to the 6top interface.
Thomas

---

From: Michel Veillette <[email-masked]>
Date: Tue, 9 Jun 2015 19:49:33 +0000

Hi Anand

About "Does it make sense to use the BEACON IE approach when the node joins the network and let an external centralized controller (NME), use the 6top MIB interface to subsequently manage the phyTXPower ?"

Sound good to me.

The value received during the joining process in a beacon IE is more about not exceeding the output power allowed by the local regulation. This feature probably make more sense for IEEE 802.15.4g which support multiple RF bands with lot of regional variations for the allowed maximum output power. This is certainly also applicable for the different bands supported by IEEE 802.15.4-2011 (868-868.6 MHz, 902-928 MHz and 2400-2483.5 MHz bands).

The configuration of the phyTXPower after joining is more about performance optimization (e.g. enable better spatial re-use).

Michel Veillette

From: S.V.R.Anand [mailto:[email-masked]]
Sent: 9 juin 2015 03:03
To: Michel Veillette; Qin Wang; Kris Pister
Cc: [email-masked]
Subject: Re: [6tisch] 6top and transmit power control

Hi Michel,

The idea is very interesting since the nodes are provisioned with the right
value upfront via BEACON IE so that they start using the power that is
appropriate, as determined by the PAN coordinator. In the absence of this, the
nodes might start-off with arbitrary power levels that can potentially result
in unpredictable network behaviour for the existing flows. I would assume, the
coordinator will have an ability to manage these power levels by
re-provisioning them depending on the state of the network in a way that the
hidden and exposed node problems are avoided.

One more thought. Does it make sense to use the BEACON IE approach when the
node joins the network and let an external centralized controller (NME), use
the 6top MIB interface to subsequently manage the phyTXPower ? The assumption
is that the interface provides the output power limit of the node as well.

Anand

On Monday 08 June 2015 09:03 PM, Michel Veillette wrote:

      > www.trilliantinc.com<http://www.trilliantinc.com>

      > On Saturday, June 6, 2015 2:50 PM, "[email-masked]"<mailto:[email-masked]>
      <[email-masked]><mailto:[email-masked]> wrote:

      Hope the timing

      powerful knobs

      improve the wireless

      Cell breathing

      6tisch, one might

      can be avoided

      about transmit

      transmit power control

      deployments with heavy

      non-overlapping

      periphery of the

      local decisions for

      the nodes. We are

      and optimally

      interference and

      interface MIB is

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.

---

From: SVR Anand <[email-masked]>
Date: Wed, 10 Jun 2015 15:00:44 +0530 (IST)

Hi Michel,

Yes, I agree with you.

Thanks!

Anand

---

From: SVR Anand <[email-masked]>
Date: Wed, 10 Jun 2015 15:28:03 +0530 (IST)

Thomas,

Yes. I would think a change to the 6top interface MIB should do. Michel's
idea of using BEACON IE for the joining nodes is very interesting to pursue.

Anand

---

From: SVR Anand <[email-masked]>
Date: Wed, 10 Jun 2015 15:47:56 +0530 (IST)

Hi Pat,

Thanks! I see your concerns.

Let us hope we will have advanced IoT controllers, similar to WLAN controllers,
which manage and provide a deterministic and efficient 6tisch network!

Anand