Subject: [6tisch] draft-dujovne-6tisch-on-the-fly-05

From: Michel Veillette <[email-masked]>
Date: Tue, 30 Jun 2015 15:13:53 +0000

Hi Diego

It's my first reading of the "6TiSCH On-the-Fly Scheduling" (and I'm not completely done yet) and I wandering if the concept of on the fly, in a single exchange, temporary allocation of a soft cell have already been discussed. For example, a node can use the Frame Pending subfield (IEEE 802.15.4-2006 section 7.2.1.1.3) to indicate the presence of packets ready to be transmitted. Based on that knowledge, the target may add an IE in an enhanced acknowledgment to allocate a temporary soft cell (e.g. single cell). Each subsequent transmission may further re-allocate a temporary soft cell. It's important to note that the default delay for a TSCH Acknowledgment is 1ms (macTsTxAckDelay) which seem sufficient for the processing of this new IE.

This scheme is very reactive and may help dealing with non-predictable communication patterns.
What do you things?

Michel Veillette
System Architecture Director
Trilliant Inc.
Tel: 450-375-0556 ext. 237
[email-masked]<mailto:[email-masked]>
www.trilliantinc.com<http://www.trilliantinc.com/>

---

From: Nicola Accettura <[email-masked]>
Date: Tue, 30 Jun 2015 13:03:12 -0700

Hi Michel,

your proposal is very interesting.

However, OTF does not allocate cells directly: it just computes the
estimated number of cells to add or delete into the schedule, and then
sends this information to 6top. 6top is then in charge of negotiating cells
among neighbors, and meybe perform the scheme you are proposing.

So, your proposal seems fitting more the 6top-to-6top communication.

Am I missing something? What others think about?

Sincerely
Nicola

2015-06-30 8:13 GMT-07:00 Michel Veillette <
[email-masked]>:

>  Hi Diego
>
>
>
> It’s my first reading of the “6TiSCH On-the-Fly Scheduling” (and I’m not
> completely done yet) and I wandering if the concept of on the fly, in a
> single exchange, temporary allocation of a soft cell have already been
> discussed. For example, a node can use the Frame Pending subfield (IEEE
> 802.15.4-2006 section 7.2.1.1.3) to indicate the presence of packets ready
> to be transmitted. Based on that knowledge, the target may add an IE in an
> enhanced acknowledgment to allocate a temporary soft cell (e.g. single
> cell). Each subsequent transmission may further re-allocate a temporary
> soft cell. It’s important to note that the default delay for a TSCH
> Acknowledgment is 1ms (macTsTxAckDelay) which seem sufficient for the
> processing of this new IE.
>
>
>
>
>
> [email-masked]
>
> www.trilliantinc.com
>
>
>
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>