Subject: [6tisch] Example for minimal with security enabled

From: Malisa Vucinic <[email-masked]>
Date: Mon, 8 Jun 2015 12:13:07 -0700

All,

As per the interim call last Friday, attached is an example I suggest to be included in draft-ietf-6tisch-minimal. 

Summary:
- Uses KeyIdMode ’01' for both K1 and K2 as a tradeoff between flexibility and overhead. (Option 2 from http://www.ietf.org/mail-archive/web/6tisch/current/msg03579.html)
- Elides frame counter from the frame, as per TSCH mode (cf. Sec 7.3.2 of 154E std)
- Uses implicit frame counter size of 5 bytes, and nonce creation from 5 byte ASN, as per TSCH mode (cf. Sec 7.4.1.4 of 15.4E std)

Mališa

=====================

NEW:

10.4.  Example 4.  Auxiliary Security Header 

   The example illustrates content of the Auxiliary Security Header as mandated by 
   this draft, if security is enabled. Security Level in the example is set to ENC-MIC-32 (5).

                        1
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |L = 5|M=1|1|1|0|Key Index = KID|
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   Stream of bytes (in LSB format) that derive from the schematic header:

   6D KID#0

   Description of the fields in the example:

   #Security Control (1 byte)
   L = Security Level ENC-MIC-32 (5)
   M = Key Identifier Mode (0x01)
   Frame Counter Suppression = 1 (omitting Frame Counter field)
   Frame Counter Size = 1 (construct Nonce from 5 byte ASN)
   Reserved = 0

   #Key Identifier (1 byte)
   Key Index = KID (deployment-specific KeyIndex parameter that identifies the cryptographic key)

---

From: Xavier Vilajosana <[email-masked]>
Date: Mon, 8 Jun 2015 23:39:50 +0200

Dear Malisa,

thanks. I will wait for consensus on this example and if approved I will
add it to the examples section in minimal.

Others, if there is any objection please say it during the week so we can
move forward on our plans to publish v7 of the draft by the end of the week.

regards,
Xavi

2015-06-08 21:13 GMT+02:00 Malisa Vucinic <[email-masked]>:

> All,
>
> As per the interim call last Friday, attached is an example I suggest to
> be included in draft-ietf-6tisch-minimal.
>
> Summary:
> - Uses KeyIdMode ’01' for both K1 and K2 as a tradeoff between flexibility
> and overhead. (Option 2 from
> http://www.ietf.org/mail-archive/web/6tisch/current/msg03579.html)
> - Uses implicit frame counter size of 5 bytes, and nonce creation from 5
> byte ASN, as per TSCH mode (cf. Sec 7.4.1.4 of 15.4E std)
>
> Mališa
>
> =====================
>
> NEW:
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

---

From: Robert Cragie <[email-masked]>
Date: Tue, 9 Jun 2015 08:36:49 +0100

It's a minor point but using KID is slightly confusing as it suggests "Key
ID" and thus "Key Identifier". I would suggest using "IDX" or something to
represent a specific Key Index (which forms the whole of the Key Identifier
field in the case of Key ID mode 1)

Also, I think the octet stream should be:

AD IDX#0

Robert

On 8 June 2015 at 22:39, Xavier Vilajosana <[email-masked]>
wrote:

>> - Uses KeyIdMode ’01' for both K1 and K2 as a tradeoff between
>> flexibility and overhead. (Option 2 from

---

From: Giuseppe Piro <[email-masked]>
Date: Tue, 9 Jun 2015 15:06:01 +0200

+1

Malisa proposal works fine with me, with the modification about KID
suggested by Robert.

Note that the usage of Key Id Mode = 1 for identifying shared keys is
also implemented within the OpenWSN extension we are implementing
(from POLIBA team) and that will be released soon:
https://github.com/openwsn-berkeley/openwsn-fw/pull/167/

Giuseppe

-- 
Giuseppe Piro, PhD
Post Doc Researcher
DEI, Politecnico di Bari
via Orabona 4 - 70125 (Bari), Italy.
email: [email-masked]
phone: +39 080 5963301
web: telematics.poliba.it/piro

---

From: Malisa Vucinic <[email-masked]>
Date: Tue, 9 Jun 2015 11:11:22 -0700

> On 09 Jun 2015, at 00:36, Robert Cragie <[email-masked]> wrote:
> 
> It's a minor point but using KID is slightly confusing as it suggests "Key ID" and thus "Key Identifier". I would suggest using "IDX" or something to represent a specific Key Index (which forms the whole of the Key Identifier field in the case of Key ID mode 1)

+1, IDX should be more clear.

> Also, I think the octet stream should be:

Here are the fields broken down in LSB order, please correct me if I am wrong:

L = 0b101 (ENC-MIC-32)
M = 0b10 (M=1)
Frame Counter Suppression = 0b1
Frame Counter Size = 0b1
Reserved = 0b0

Octet in LSB: 0b 101 10 1 1 0
Octet in MSB: 0b 01101101

And thus 0x6D, no? 

Mališa

---

From: <[email-masked]>
Date: Tue, 9 Jun 2015 23:23:47 +0000

Agreed.

Yoshihiro Ohba

-----Original Message-----
From: 6tisch [mailto:[email-masked]] On Behalf Of Giuseppe Piro
Sent: Tuesday, June 09, 2015 10:06 PM
To: Malisa Vucinic; Xavier Vilajosana
Cc: [email-masked]; [email-masked]
Subject: Re: [6tisch] Example for minimal with security enabled

+1

Malisa proposal works fine with me, with the modification about KID suggested by Robert.

Note that the usage of Key Id Mode = 1 for identifying shared keys is also implemented within the OpenWSN extension we are implementing (from POLIBA team) and that will be released soon:
https://github.com/openwsn-berkeley/openwsn-fw/pull/167/

Giuseppe

On Tue, Jun 9, 2015 at 9:36 AM, Robert Cragie <[email-masked]> wrote:
> It's a minor point but using KID is slightly confusing as it suggests 
> "Key ID" and thus "Key Identifier". I would suggest using "IDX" or 
> something to represent a specific Key Index (which forms the whole of 
> the Key Identifier field in the case of Key ID mode 1)
>
>> thanks. I will wait for consensus on this example and if approved I 
>> will add it to the examples section in minimal.
>>
>> Others, if there is any objection please say it during the week so we 
>> can move forward on our plans to publish v7 of the draft by the end of the week.
>>
>> regards,
>> Xavi
>>
>>> As per the interim call last Friday, attached is an example I 
>>> suggest to be included in draft-ietf-6tisch-minimal.
>>>
>>> Summary:
>>> - Uses implicit frame counter size of 5 bytes, and nonce creation 
>>> from 5 byte ASN, as per TSCH mode (cf. Sec 7.4.1.4 of 15.4E std)
>>>
>>> Mališa
>>>
>>> =====================
>>>
>>> NEW:
>>>