Subject: [6tisch] OTF: IP or not IP?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 9 Oct 2015 15:48:45 +0000

Dear all:

Following up on the comments at the interim, My suggestion is to update item 3 as follows:

3. Produce an "On-the-fly" (OTF) specification to enable a distributed dynamic
scheduling of time slots with the capability for IoT routers to appropriate
chunks of the matrix without starving, or interfering with, other 6TiSCH nodes.
This particular work will focus on IP traffic since the work on tracks is not
yet advanced enough to specify their requirements for OTF operations.

I remove the 'for IP traffic' within the main text to indicate that the initial focus is
N IP traffic but I hope that now it is more clear that future work on tracks is not precluded.
Does that address the comment?

Cheers,

Pascal

---

From: Pat Kinney <[email-masked]>
Date: Fri, 9 Oct 2015 10:53:18 -0500

Pascal;

I agree with your change, but I wonder why we need to consider only IoT routers?  Shouldn’t we removed the IoT constraint?

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, SC chair
ISA100 co-chair, ISA100.20 chair
O: +1.847.960.3715
[email-masked] <mailto:[email-masked]>

On 9, Oct2015, at 10:48, Pascal Thubert (pthubert) <[email-masked]> wrote:

Dear all:

3. Produce an “On-the-fly" (OTF) specification to enable a distributed dynamic
 
I remove the ‘for IP traffic’ within the main text to indicate that the initial focus is
N IP traffic but I hope that now it is more clear that future work on tracks is not precluded.
Does that address the comment?
 
Cheers,
 
Pascal
 
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 9 Oct 2015 15:59:45 +0000

Good point Pat.
I found it strange as well as I was rereading this.
Should I say 6TiSCH routers?

Cheers,

Pascal

From: Pat Kinney [mailto:[email-masked]]
Sent: vendredi 9 octobre 2015 17:53
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: [email-masked]
Subject: Re: [6tisch] OTF: IP or not IP?

Pascal;

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, SC chair
ISA100 co-chair, ISA100.20 chair
O: +1.847.960.3715
[email-masked]<mailto:[email-masked]>

On 9, Oct2015, at 10:48, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:

Dear all:

Cheers,

Pascal

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 9 Oct 2015 16:33:22 -0300

Pascal, Pat:
                  Sounds good to me "6tisch routers".
Regards,

                          Diego

2015-10-09 12:59 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]>:

> *From:* Pat Kinney [mailto:[email-masked]]
> *Sent:* vendredi 9 octobre 2015 17:53
> *To:* Pascal Thubert (pthubert) <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] OTF: IP or not IP?
>
>
>
> Pascal;
>
>
>
> I agree with your change, but I wonder why we need to consider only IoT
> routers?  Shouldn’t we removed the IoT constraint?
>
>
>
> Pat
>
>
>
> Pat Kinney
>
> *Kinney Consulting LLC*
>
> [email-masked]
>
>
>

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Qin Wang <[email-masked]>
Date: Fri, 9 Oct 2015 19:51:04 +0000 (UTC)

Hi Pascal and all,
I don't understand the meaning of  "with the capability for IoT routers to appropriatechunks of the matrix without starving, or interfering with, other 6TiSCH nodes." (even IoT routers is replaced with "6tisch router"). I cannot figure out what the capability is. Can you explain it more?
ThanksQin

     On Friday, October 9, 2015 3:33 PM, Prof. Diego Dujovne <[email-masked]> wrote:

 Pascal, Pat:

                          Diego

Good point Pat. I found it strange as well as I was rereading this.Should I say 6TiSCH routers?   Cheers, Pascal From: Pat Kinney [mailto:[email-masked]]
Sent: vendredi 9 octobre 2015 17:53
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: [email-masked]
Subject: Re: [6tisch] OTF: IP or not IP? Pascal; I agree with your change, but I wonder why we need to consider only IoT routers?  Shouldn’t we removed the IoT constraint? Pat Pat KinneyKinney Consulting LLCIEEE 802.15 WG vice chair, SC chairISA100 co-chair, ISA100.20 chairO: [email-masked] On 9, Oct2015, at 10:48, Pascal Thubert (pthubert) <[email-masked]> wrote: Dear all: Following up on the comments at the interim, My suggestion is to update item 3 as follows:  3. Produce an “On-the-fly" (OTF) specification to enable a distributed dynamicscheduling of time slots with the capability for IoT routers to appropriatechunks of the matrix without starving, or interfering with, other 6TiSCH nodes.This particular work will focus on IP traffic since the work on tracks is notyet advanced enough to specify their requirements for OTF operations. I remove the ‘for IP traffic’ within the main text to indicate that the initial focus isN IP traffic but I hope that now it is more clear that future work on tracks is not precluded.Does that address the comment? Cheers, Pascal _______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch 
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 9 Oct 2015 17:00:39 -0300

Qin,
      I see this more like an ability or a feature, than a capability.
Regards,

                       Diego

2015-10-09 16:51 GMT-03:00 Qin Wang <[email-masked]>:

> Hi Pascal and all,
>
> I don't understand the meaning of  "with the capability for IoT routers
> to appropriate
> chunks of the matrix without starving, or interfering with, other 6TiSCH
> nodes." (even IoT routers is replaced with "6tisch router"). I cannot
> figure out what the capability is. Can you explain it more?
>
> Thanks
> Qin
>
>
>
>
>
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 10 Oct 2015 05:38:50 +0000

Hello Qin

There is a need to distribute fairly the cells in the network. Without control, some parents may be using many slots and that would prevent possibly better parent to get cells and act as parents.

This text opens the work on chunks that we have discussed at our calls and in the architecture...

Take care,

Pascal

Le 9 oct. 2015 ? 21:51, Qin Wang <[email-masked]<mailto:[email-masked]>> a ?crit :

Hi Pascal and all,

I don't understand the meaning of  "with the capability for IoT routers to appropriate
chunks of the matrix without starving, or interfering with, other 6TiSCH nodes." (even IoT routers is replaced with "6tisch router"). I cannot figure out what the capability is. Can you explain it more?

Thanks
Qin

On Friday, October 9, 2015 3:33 PM, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> wrote:

Pascal, Pat:

                          Diego

2015-10-09 12:59 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>:
Good point Pat.
I found it strange as well as I was rereading this.
Should I say 6TiSCH routers?

Cheers,

Pascal

From: Pat Kinney [mailto:[email-masked]<mailto:[email-masked]>]
Sent: vendredi 9 octobre 2015 17:53
To: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] OTF: IP or not IP?

Pascal;

I agree with your change, but I wonder why we need to consider only IoT routers?  Shouldn't we removed the IoT constraint?

Pat

Pat Kinney
Kinney Consulting LLC

Dear all:

Cheers,

Pascal

--
DIEGO DUJOVNE
Acad?mico Escuela de Ingenier?a en Inform?tica y Telecomunicaciones
Facultad de Ingenier?a UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl/>
(56 2) 676 8125

---

From: "Wang, Chonggang" <[email-masked]>
Date: Tue, 13 Oct 2015 13:45:34 +0000

Hi Pascal,

"This particular work will focus on IP traffic since the work on tracks is not
yet advanced enough to specify their requirements for OTF operations.
"
It seems we still limit OTF to IP traffic. My previous concern still holds and I tend to disagree with the sentence above from charter2.0 description for the following reasons:

*         First, in 6tisch architecture draft, it is mentioned that a track can be built on soft cells.

*         Second, if OTF is limited to IP traffic, OTF appears to me a purely layer-3 (or IP layer) mechanism. Then, why 6TiSCH WG handles IP-layer-only mechanism? Should it be beyond the scope of 6TiSCH WG?

*         Third, Charter2.0 implies some work to be done and/or work-in-progress. I feel whether we can use "this work is not fully done" as a reason to exclude it from the charter 2.0.

Just my 2 cents.

Thanks,
Chonggang

From: 6tisch [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Friday, October 09, 2015 11:49 AM
To: [email-masked]
Subject: [6tisch] OTF: IP or not IP?

Dear all:

Cheers,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 14 Oct 2015 10:03:48 +0000

Hello ChongGang:

Please see below

·        First, in 6tisch architecture draft, it is mentioned that a track can be built on soft cells.

Ø    I do not remember writing or incorporating text that would say that. Please elaborate… There are possibilities to employ soft cells to, say, improve dynamically the ARQ operation, but so far I do not remember that we really made any decision there.

·        Second, if OTF is limited to IP traffic, OTF appears to me a purely layer-3 (or IP layer) mechanism. Then, why 6TiSCH WG handles IP-layer-only mechanism? Should it be beyond the scope of 6TiSCH WG?

Ø   This is not a L3 mechanism. This is a Link Layer operation which aims to provide a variable bandwidth link for IP. The Work Item in the charter is a commitment for people writing the draft that they will cover the subject given. The problem statement for IP (Track0) is well-known because OTF has to work on an IP link. So people may commit to define methods that provide the required service. But they can hardly commit to produce the additional work to cover tracks as well as long as we have not defined tracks more precisely. And waiting for that definition would delay the current OTF work, which is not something we want. We’d rather stage and produce things that we can interop-test in an agile fashion.

·        Third, Charter2.0 implies some work to be done and/or work-in-progress. I feel whether we can use “this work is not fully done” as a reason to exclude it from the charter 2.0.

Ø    We have a very high level concept of track in the architecture but what it is in more details has still to be debated, e.g. for packet replication over multiple paths vs. ARQ. Let us work on  defining that and we’ll see if the OTF work applies. It that is the case, we’ll mention that capability in the track work as an extension to the IP case, giving rules and applicability. If that is not the case, we’ll charter additional work if that appears to be needed. Note that this does not prevent the discussion on OTF for tracks, just that the previous charter did not prevent OTF work to happen. It’s more like we do not commit *yet* to produce a stable specification in a short period of time.

Cheers,

Pascal

Just my 2 cents.

Thanks,
Chonggang

Chonggang Wang
Member Technical Staff
InterDigital Communications, Inc.
781 Third Ave
King of Prussia, PA 19406
T: +1 610.878.5731
[email-masked]<mailto:[email-masked]>
www.InterDigital.com<http://www.interdigital.com>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

From: 6tisch [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Friday, October 09, 2015 11:49 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [6tisch] OTF: IP or not IP?

Dear all:

Cheers,

Pascal

---

From: "Wang, Chonggang" <[email-masked]>
Date: Wed, 14 Oct 2015 14:25:51 +0000

Pascal,

This is the sentence from pp. 24 – section 8.1.4 from architecture draft ver08

“A node can reserve a track to a destination node multiple hops away by installing soft cells at each intermediate node. This forms a track of soft cells.
”

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Wednesday, October 14, 2015 6:04 AM
To: Wang, Chonggang <[email-masked]>; [email-masked]
Subject: RE: OTF: IP or not IP?

Hello ChongGang:

Please see below

Cheers,

Pascal

Just my 2 cents.

Thanks,
Chonggang

Chonggang Wang
Member Technical Staff

Dear all:

Cheers,

Pascal