Subject: [6tisch] Types of RPI 6LoRH

From: Tengfei Chang <[email-masked]>
Date: Thu, 7 Jan 2016 21:02:20 +0100

Dear all,

I have a question about the types of RPI 6LoRH. Please let me know if this
is a duplicate question.

In the draft: https://tools.ietf.org/html/draft-ietf-6lo-routing-dispatch-00
>From figure 9 to figure 12 starting from page 13, it shows different
combination of I and K in RPI 6LoRH and the Type is set to 5.

In figure 13 (see below), there are 4 types value in RPI-6LoRH to indicate
the different value of I and K.

     +-----------+-------+-------+
     |   Type    |   I   |   K   |
     +-----------+-------+-------+
     |     5     |   0   |   0   |
     |     6     |   0   |   1   |
     |     7     |   1   |   0   |
     |     8     |   1   |   1   |
     +-----------+-------+-------+

This confused me that which is the used to identify the value of I and K. I
guess we still use the bit I and K itself and use type 5 to indicate RPI
6LoRH . If so, I don't understand the use cases of other value of types.

Maybe I misunderstand something, please correct me if I did. Thanks!

Tengfei

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 Jan 2016 14:50:59 +0000

You’re correct TengFei, thanks for catching this!

This table is an edition leftover. Please ignore it, it will be removed.

Take care,

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of Tengfei Chang
Sent: jeudi 7 janvier 2016 21:02
To: [email-masked]; [email-masked]
Subject: [6lo] Types of RPI 6LoRH

Dear all,

I have a question about the types of RPI 6LoRH. Please let me know if this is a duplicate question.

In the draft: https://tools.ietf.org/html/draft-ietf-6lo-routing-dispatch-00
From figure 9 to figure 12 starting from page 13, it shows different combination of I and K in RPI 6LoRH and the Type is set to 5.

In figure 13 (see below), there are 4 types value in RPI-6LoRH to indicate the different value of I and K.

     |   Type    |   I   |   K   |

     |     5     |   0   |   0   |

     |     6     |   0   |   1   |

     |     7     |   1   |   0   |

     |     8     |   1   |   1   |

This confused me that which is the used to identify the value of I and K. I guess we still use the bit I and K itself and use type 5 to indicate RPI 6LoRH . If so, I don't understand the use cases of other value of types.

Tengfei

---

From: Tengfei Chang <[email-masked]>
Date: Fri, 8 Jan 2016 16:03:15 +0100

Great to hear that! Talk to you on the call!

Tengfei

On Fri, Jan 8, 2016 at 3:50 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> *From:* 6lo [mailto:[email-masked]] *On Behalf Of *Tengfei Chang
> *Sent:* jeudi 7 janvier 2016 21:02
> *To:* [email-masked]; [email-masked]
> *Subject:* [6lo] Types of RPI 6LoRH
>
>
>
> Dear all,
>
>
>
> In the draft:
> https://tools.ietf.org/html/draft-ietf-6lo-routing-dispatch-00
>
> This confused me that which is the used to identify the value of I and K.
> I guess we still use the bit I and K itself and use type 5 to indicate RPI