Subject: [6tisch] information model or data model in the new charter

From: Qin Wang <[email-masked]>
Date: Fri, 22 Jan 2016 20:30:09 +0000 (UTC)

Dear all,
In today's Webex meeting, we were talking about the feedback from Bonoit about the new Charter, see [6tisch] Benoit Claise's No Objection on charter-ietf-6tisch-01-00: (with COMMENT), and want to continue the discussion in the ML. 
The question is what is exactly we want to do with Yang model, and how to make the paragraph about Yang model in the new Charter more accurate. 
Any comments and suggestion is welcome.
ThanksQin

---

From: Brian Haberman <[email-masked]>
Date: Mon, 25 Jan 2016 08:11:03 -0500

Hi Qin,

On 1/22/16 3:30 PM, Qin Wang wrote:
> Dear all, In today's Webex meeting, we were talking about the
> feedback from Bonoit about the new Charter, see [6tisch] Benoit
> Claise's No Objection on charter-ietf-6tisch-01-00: (with COMMENT),
> and want to continue the discussion in the ML. The question is what
> is exactly we want to do with Yang model, and how to make the
> paragraph about Yang model in the new Charter more accurate. Any
> comments and suggestion is welcome. ThanksQin
> 

This issue needs to get resolved before I will release the charter for
external review. Benoit's point illustrated an issue in the charter
where it is not clear as to whether the WG is interested in an
information model or a data model.

Regards,
Brian

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 27 Jan 2016 19:38:31 +0000

Hello Brian and Qin:

We discussed that at the time of the first charter, using RFC 3444 as our reference; it is my understanding that we aimed the 6top interface document https://tools.ietf.org/html/draft-ietf-6tisch-6top-interface at providing a Yang Data model to manage the 6top layer in a device. It is my understanding that some form of information model in natural language would be present in the 6top draft, but my reading of the 6top interface is that there is some degree of information model there too, that explains the data model. If so, is that a problem?

Cheers,

Pascal

> -----Original Message-----
> From: 6tisch [mailto:[email-masked]] On Behalf Of Brian Haberman
> Sent: lundi 25 janvier 2016 14:11
> To: [email-masked]
> Subject: Re: [6tisch] information model or data model in the new charter
> 
> Hi Qin,
> 
> > Dear all, In today's Webex meeting, we were talking about the feedback
> > from Bonoit about the new Charter, see [6tisch] Benoit Claise's No
> > Objection on charter-ietf-6tisch-01-00: (with COMMENT), and want to
> > continue the discussion in the ML. The question is what is exactly we
> > want to do with Yang model, and how to make the paragraph about Yang
> > model in the new Charter more accurate. Any comments and suggestion is
> > welcome. ThanksQin
> >
> 
> This issue needs to get resolved before I will release the charter for external
> review. Benoit's point illustrated an issue in the charter where it is not clear
> as to whether the WG is interested in an information model or a data
> model.
> 
> Regards,
> Brian

---

From: Brian Haberman <[email-masked]>
Date: Wed, 27 Jan 2016 14:48:26 -0500

Hi Pascal,

On 1/27/16 2:38 PM, Pascal Thubert (pthubert) wrote:
> Hello Brian and Qin:
> 
> We discussed that at the time of the first charter, using RFC 3444 as
> our reference; it is my understanding that we aimed the 6top
> interface document
> https://tools.ietf.org/html/draft-ietf-6tisch-6top-interface at
> providing a Yang Data model to manage the 6top layer in a device. It
> is my understanding that some form of information model in natural
> language would be present in the 6top draft, but my reading of the
> 6top interface is that there is some degree of information model
> there too, that explains the data model. If so, is that a problem?

I don't think the problem is in a *document*. Benoit is questioning the
wording of the proposed charter.  I would suggest reviewing his comments
in light of the current wording of the new charter text.

https://datatracker.ietf.org/doc/charter-ietf-6tisch/
https://datatracker.ietf.org/doc/charter-ietf-6tisch/ballot/#benoit-claise

Regards,
Brian

> 
> Cheers,
> 
> Pascal
> 
>> -----Original Message----- From: 6tisch
>> [mailto:[email-masked]] On Behalf Of Brian Haberman Sent:
>> lundi 25 janvier 2016 14:11 To: [email-masked] Subject: Re:
>> [6tisch] information model or data model in the new charter
>> 
>> Hi Qin,
>> 
>>> Claise's No Objection on charter-ietf-6tisch-01-00: (with
>>> COMMENT), and want to continue the discussion in the ML. The
>>> question is what is exactly we want to do with Yang model, and
>>> how to make the paragraph about Yang model in the new Charter
>>> more accurate. Any comments and suggestion is welcome. ThanksQin
>>> 
>> 
>> This issue needs to get resolved before I will release the charter
>> for external review. Benoit's point illustrated an issue in the
>> charter where it is not clear as to whether the WG is interested in
>> an information model or a data model.
>> 
>> Regards, Brian

---

From: Qin Wang <[email-masked]>
Date: Fri, 29 Jan 2016 15:48:57 +0000 (UTC)

Hi Brain, Pascal and all,
I think both what we actually did in the current 6top-interface draft, and what we are going to redo as Thomas and Xavi suggested in the last Webex, are Yang date model of 6top, instead of information model. Thus, I think we need to re-word the Charter accordingly. Make sense? 
In addition, the attached file presents clear definition on both interface model and Yang model.
ThanksQin 

    On Wednesday, January 27, 2016 2:48 PM, Brian Haberman <[email-masked]> wrote:

 Hi Pascal,

Regards,
Brian

>> an information model or a data model.

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 29 Jan 2016 16:50:04 +0000

I agree Qin;

“Produce an Information Model containing the management requirements
of a 6TiSCH node. A data model mapping for an existing protocol (such as Concise
Binary Object Representation (CBOR) over the Constrained Application …”

Would become
“Produce a Data Model expressed in Yand and enabling the management
of the 6top sublayer. A mapping for an existing protocol (such as Concise
Binary Object Representation (CBOR) over the Constrained Application …
“

Note that I reduced the scope of the data model to the 6ttop piece.

Is that what we want ?

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: vendredi 29 janvier 2016 16:49
To: Brian Haberman <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: Re: [6tisch] information model or data model in the new charter

Thanks
Qin

On Wednesday, January 27, 2016 2:48 PM, Brian Haberman <[email-masked]<mailto:[email-masked]>> wrote:

Hi Pascal,

Regards,

Brian

>> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian Haberman Sent:
>> lundi 25 janvier 2016 14:11 To: [email-masked]<mailto:[email-masked]> Subject: Re:

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch