Subject: [6tisch] Typeof sixtop subIE:short or long

From: Tengfei Chang <[email-masked]>
Date: Fri, 8 Jan 2016 17:14:17 +0100

Hello all,

As I mentioned on the Call, the 6top sublayer draft seems didn't  define
the type of subIE used by 6P command ,long or short type?  Let me know if I
missed it from the draft! Thanks you!

Regard,
Tengfei

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 8 Jan 2016 10:25:12 -0600

Tengfei;

The IEEE 802.15 IG 6T recommended a format for sub-IEs in document 15-15-0939-02 sent to this reflector on 30 November 2015.  The following is an excerpt from that document:
"Accordingly, the IEEE 802.15 IG 6T recommends that the IETF use an alternate scheme that restricts each Payload IE to only one sub-type ID and content, i.e. no nesting.  The advantages of this recommended scheme is that it eliminates one octet from the total Payload IE, it allows a full 256 sub-type IDs, and each sub-type length can be up to 2046 octets.”

Therefore, if 6tisch adopts the above recommendation, there would be no long or short types.

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, SC chair
ISA100 co-chair, ISA100.20 chair
O: +1.847.960.3715
[email-masked] <mailto:[email-masked]>

On 8, Jan2016, at 10:14, Tengfei Chang <[email-masked]> wrote:

Hello all, 

As I mentioned on the Call, the 6top sublayer draft seems didn't  define the type of subIE used by 6P command ,long or short type?  Let me know if I missed it from the draft! Thanks you!  

Regard, 
Tengfei
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Tengfei Chang <[email-masked]>
Date: Fri, 8 Jan 2016 17:56:13 +0100

I see. Thanks a lot Pat for the information! I found the document you
mentioned. I will update the format in the Golden Images.

Have a good day!
Tengfei

On Fri, Jan 8, 2016 at 5:25 PM, [email-masked] <
[email-masked]> wrote:

> Tengfei;
>
> The IEEE 802.15 IG 6T recommended a format for sub-IEs in document
> 15-15-0939-02 sent to this reflector on 30 November 2015.  The following is
> an excerpt from that document:
>
> "Accordingly, the IEEE 802.15 IG 6T recommends that the IETF use an
> alternate scheme that restricts each Payload IE to only one sub-type ID and
> content, i.e. no nesting.  The advantages of this recommended scheme is
> that it eliminates one octet from the total Payload IE, it allows a full
> 256 sub-type IDs, and each sub-type length can be up to 2046 octets.”
>
> *Kinney Consulting LLC*
> [email-masked]
>

---

From: Tengfei Chang <[email-masked]>
Date: Mon, 11 Jan 2016 16:19:54 +0100

Hi Pat, all,

I would like to make sure whether this format will be the right format for
the plugtest and everyone will agree. The attached is the document
15-15-0939-02.

There are two options for the format we will use in the plugtest:

1. we use what defined in
https://tools.ietf.org/html/draft-wang-6tisch-6top-sublayer-04, which use
the format defined in
IEEE802.15.4e-2012, section 5.2.4.3 (page 81). If we decide to use this
one, we need short/ long type of the subIE.

*Bits: 0-10*

*11-14*

*15*

*Octets: 2*

*32-35*

*36-39*

*40-47*

*Octets*

*Bits: 0-10*

*11-14*

*15*

Payload IE Content Length

Group ID

Type (0b1)

Length

Sub-type ID

Type

Ver

Code

SFID

other field

Length
(0x00)

Group ID (0xf)

Type (0b1)

Payload IE

Payload IE Content

Payload Termination IE

2. we use what define in document 15-15-0939-02, which use the format
defined in last page of the document:
For example the 6P command defined in sublayer draft:

the payload will be:

*Bits: 0-10*

*11-14*

*15*

*16-23*

*24-27*

*28-31*

*32-39*

*octets*

*Bits: 0-10*

*11-14*

*15*

Payload IE Content Length

Group ID

Type (0b1)

Sub-type ID

Ver

Code

SFID

other field

Length
(0x00)

Group ID (0xf)

Type (0b1)

Payload IE

Payload IE Content

Payload Termination IE

Do we agree on the second one?

Tengfei

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 11 Jan 2016 10:17:46 -0600

Thank you for the figures, I agree on both, especially the second one.  The advantages of the recommended approach are: one octet shorter for case of single subtype ID and 256 available subtype ID addresses for any length.

Sincerely, Pat

On 11, Jan2016, at 9:19, Tengfei Chang <[email-masked]> wrote:

Hi Pat, all,

I would like to make sure whether this format will be the right format for the plugtest and everyone will agree. The attached is the document 15-15-0939-02.

1. we use what defined in https://tools.ietf.org/html/draft-wang-6tisch-6top-sublayer-04 <https://tools.ietf.org/html/draft-wang-6tisch-6top-sublayer-04>, which use the format defined in 
IEEE802.15.4e-2012, section 5.2.4.3 (page 81). If we decide to use this one, we need short/ long type of the subIE.

Bits: 0-10

11-14

15

Octets: 2

32-35

36-39

40-47

Octets

Bits: 0-10

11-14

15

Group ID

Type (0b1)

Length

Sub-type ID

Type

Ver

Code

SFID

other field

Length 
(0x00)

Group ID (0xf)

Type (0b1)

Payload IE

Payload IE Content

Payload Termination IE

2. we use what define in document 15-15-0939-02, which use the format defined in last page of the document:
For example the 6P command defined in sublayer draft:

the payload will be:

Bits: 0-10

11-14

15

16-23

24-27

28-31

32-39

octets

Bits: 0-10

11-14

15

Group ID

Type (0b1)

Sub-type ID

Ver

Code

SFID

other field

Length 
(0x00)

Group ID (0xf)

Type (0b1)

Payload IE

Payload IE Content

Payload Termination IE

Tengfei

On Fri, Jan 8, 2016 at 5:56 PM, Tengfei Chang <[email-masked] <mailto:[email-masked]>> wrote:
I see. Thanks a lot Pat for the information! I found the document you mentioned. I will update the format in the Golden Images. 

Have a good day!
Tengfei

On Fri, Jan 8, 2016 at 5:25 PM, [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>> wrote:
Tengfei;

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, SC chair
ISA100 co-chair, ISA100.20 chair
O: +1.847.960.3715 <tel:%2B1.847.960.3715>
[email-masked] <mailto:[email-masked]>

On 8, Jan2016, at 10:14, Tengfei Chang <[email-masked] <mailto:[email-masked]>> wrote:

Hello all, 

Regard, 
Tengfei
_______________________________________________
6tisch mailing list
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch <https://www.ietf.org/mailman/listinfo/6tisch>

<15-15-0939-02-0000-IETF_6tisch_IE_Information.docx>

---

From: Qin Wang <[email-masked]>
Date: Mon, 11 Jan 2016 21:04:43 +0000 (UTC)

I think both of the two format are fine. But, if IEEE802.15 recommends the second one, I think we should choose the second.
ThanksQin 

    On Monday, January 11, 2016 11:17 AM, "[email-masked]" <[email-masked]> wrote:

1. we use what defined in https://tools.ietf.org/html/draft-wang-6tisch-6top-sublayer-04, which use the format defined in IEEE802.15.4e-2012, section 5.2.4.3 (page 81). If we decide to use this one, we need short/ long type of the subIE.

| Bits: 0-10 | 11-14 | 15 | Octets: 2 | 32-35 | 36-39 | 40-47 | Octets | Bits: 0-10 | 11-14 | 15 |
| Payload IE Content Length | Group ID | Type (0b1) | Length | Sub-type ID | Type | Ver | Code | SFID | other field
 | Length 
(0x00) | Group ID (0xf) | Type (0b1) |
| Payload IE | Payload IE Content | Payload Termination IE |

2. we use what define in document 15-15-0939-02, which use the format defined in last page of the document:For example the 6P command defined in sublayer draft:
the payload will be:

| Bits: 0-10 | 11-14 | 15 | 16-23 | 24-27 | 28-31 | 32-39 | octets | Bits: 0-10 | 11-14 | 15 |
| Payload IE Content Length | Group ID | Type (0b1) | Sub-type ID | Ver | Code | SFID | other field | Length 
(0x00) | Group ID (0xf) | Type (0b1) |
| Payload IE | Payload IE Content | Payload Termination IE |

Do we agree on the second one?
Tengfei
On Fri, Jan 8, 2016 at 5:56 PM, Tengfei Chang <[email-masked]> wrote:

I see. Thanks a lot Pat for the information! I found the document you mentioned. I will update the format in the Golden Images. 
Have a good day!Tengfei
On Fri, Jan 8, 2016 at 5:25 PM, [email-masked] <[email-masked]> wrote:

Tengfei;
The IEEE 802.15 IG 6T recommended a format for sub-IEs in document 15-15-0939-02 sent to this reflector on 30 November 2015.  The following is an excerpt from that document:"Accordingly,the IEEE 802.15 IG 6T recommends that the IETF use an alternate scheme that restrictseach Payload IE to only one sub-type ID and content, i.e. no nesting.  The advantages of this recommended scheme is thatit eliminates one octet from the total Payload IE, it allows a full 256sub-type IDs, and each sub-type length can be up to 2046 octets.”Therefore, if 6tisch adopts the above recommendation, there would be no long or short types.
Pat
Pat KinneyKinney Consulting LLCIEEE 802.15 WG vice chair, SC chairISA100 co-chair, ISA100.20 chairO: [email-masked]
On 8, Jan2016, at 10:14, Tengfei Chang <[email-masked]> wrote:
Hello all, 
As I mentioned on the Call, the 6top sublayer draft seems didn't  define the type of subIE used by 6P command ,long or short type?  Let me know if I missed it from the draft! Thanks you!  
Regard, Tengfei
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Tengfei Chang <[email-masked]>
Date: Sun, 17 Jan 2016 20:50:56 +0100

Thanks all for the comments! Then we will use the recommended format
(second one) on the plugtest!

Tengfei

On Mon, Jan 11, 2016 at 10:04 PM, Qin Wang <[email-masked]> wrote:

> I think both of the two format are fine. But, if IEEE802.15 recommends the
> second one, I think we should choose the second.
>
> Thanks
> Qin
>
>
> On Monday, January 11, 2016 11:17 AM, "[email-masked]"
> <[email-masked]> wrote:
>
>
> Thank you for the figures, I agree on both, especially the second one.
> The advantages of the recommended approach are: one octet shorter for case
> of single subtype ID and 256 available subtype ID addresses for any length.
>
> Sincerely, Pat
>

---

From: Tengfei Chang <[email-masked]>
Date: Mon, 18 Jan 2016 20:19:39 +0100

Hi all,

Sorry to ask question again on the recommends document! I still have a
question about why the payload IE is terminated by a termination IE?

According to the IEEE802.15.4e-2012 on section 5.2.4.22.

*5.2.4.22 IE List Termination IE*
*......*
* If an unformatted payload follows the Payload IE list, then the payload
IE list is terminated with a list termination IE (ID = 0xf) that has a
content length of zero. Otherwise the terminator may be omitted*

Since there is no payload following the 6P payload IE, the terminator
may be omitted. Is there specific reason why we don't do that?
Let me know if this is already discussed somewhere so I can refer to.
Thanks!

Regard,
Tengfei

On Sun, Jan 17, 2016 at 8:50 PM, Tengfei Chang <[email-masked]>
wrote:

>> I think both of the two format are fine. But, if IEEE802.15 recommends
>> the second one, I think we should choose the second.
>>
>> Thanks
>> Qin
>>
>>
>> I would like to make sure whether this format will be the right format
>> for the plugtest and everyone will agree. The attached is the document
>> 15-15-0939-02.
>>
>> https://tools.ietf.org/html/draft-wang-6tisch-6top-sublayer-04, which
>> use the format defined in

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 18 Jan 2016 13:40:07 -0600

As per 802.15.4-2015, the only time the Payload Termination IE is required is when both the Payload IE and Data Payload are present.  Given that there is no payload following the 6P payload IE, the terminator may be omitted.

Pat

On 18, Jan2016, at 13:19, Tengfei Chang <[email-masked]> wrote:

Hi all,

Sorry to ask question again on the recommends document! I still have a question about why the payload IE is terminated by a termination IE?

5.2.4.22 IE List Termination IE
......
 If an unformatted payload follows the Payload IE list, then the payload IE list is terminated with a list termination IE (ID = 0xf) that has a content length of zero. Otherwise the terminator may be omitted

Since there is no payload following the 6P payload IE, the terminator may be omitted. Is there specific reason why we don't do that?
Let me know if this is already discussed somewhere so I can refer to. Thanks!

Regard,
Tengfei

On Sun, Jan 17, 2016 at 8:50 PM, Tengfei Chang <[email-masked] <mailto:[email-masked]>> wrote:
Thanks all for the comments! Then we will use the recommended format (second one) on the plugtest!

Tengfei

On Mon, Jan 11, 2016 at 10:04 PM, Qin Wang <[email-masked] <mailto:[email-masked]>> wrote:
I think both of the two format are fine. But, if IEEE802.15 recommends the second one, I think we should choose the second.

Thanks
Qin

On Monday, January 11, 2016 11:17 AM, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>> wrote:

Sincerely, Pat

On 11, Jan2016, at 9:19, Tengfei Chang <[email-masked] <mailto:[email-masked]>> wrote:

Hi Pat, all,

Bits: 0-10
11-14
15
Octets: 2
32-35
36-39
40-47
Octets
Bits: 0-10
11-14
15

the payload will be:

Bits: 0-10
11-14
15
16-23
24-27
28-31
32-39
octets
Bits: 0-10
11-14
15

Tengfei

Have a good day!
Tengfei

Pat

Pat Kinney
Kinney Consulting LLC
O: +1.847.960.3715 <>

Hello all, 

Regard, 
Tengfei

---

From: Tengfei Chang <[email-masked]>
Date: Mon, 18 Jan 2016 23:50:15 +0100

Hi Pat, thanks for the clarifying this!

If so, I would like to suggest we use the option that omitting the
terminator to make it easier for the plugtest. The format of 6P will be :

*Bits: 0-10*

*11-14*

*15*

*16-23*

*24-27*

*28-31*

*32-39*

*octets*

Group ID

Type (0b1)

Sub-type ID

Ver

Code

SFID

Other field

Payload IE

Payload IE Content

Does everyone agree with it? Please let me know if you have any suggestion
on it. Thanks!

Tengfei

On Mon, Jan 18, 2016 at 8:40 PM, [email-masked] <
[email-masked]> wrote:

> As per 802.15.4-2015, the only time the Payload Termination IE is required
> is when both the Payload IE and Data Payload are present.  Given that there
> is no payload following the 6P payload IE, the terminator may be omitted.
>
> Pat
>
>
>
>>> On Monday, January 11, 2016 11:17 AM, "
>>> [email-masked]" <[email-masked]>
>>> wrote:
>>>
>>>