Subject: [6tisch] 6P and Sf0 issue: Statistics for SFs and Relocation

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Thu, 3 Mar 2016 16:25:31 -0300

Dear all,
           Given the requirements to build SFs exposed
in the 6tisch sublayer draft, there is no specification
on how to obtain the statistics and calculate and build
the metrics used to decide when to add/delete/relocate
cells. The draft asks only for the set of rules.
          SF0 defines an algorithm using specific values
as thresholds and rules for adding/removing cells and
uses PDR and a simple decision rule to decide which
cell to relocate.  However, this may not be the case
for the other (possibly more complex) SFs, where
metrics based on statistics could be included.
           Shall we include a section on the description
of how to calculate the specific statistics used on each
SF, or just leave this out of scope to the implementer?
My point of view is that statistics should be specified
in order to be able to interoperate between different
implementations of the same SF.
            What do you think?
            Thank you,

                                  Diego Dujovne

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 4 Mar 2016 11:21:18 +0000

I’d support that, Diego

If the visible operation of the device depends on it and that influences the interoperation, it is good to document a base way of doing things.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Prof. Diego Dujovne
Sent: jeudi 3 mars 2016 20:26
To: [email-masked]
Subject: [6tisch] 6P and Sf0 issue: Statistics for SFs and Relocation

Dear all,

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Thu, 10 Mar 2016 20:15:30 -0300

Pascal,
           Agreed. Then we should add a
new SHOULD item at the end of the

"4.2.  Requirements for an SF"

section on the 6TiSCH Operation Sublayer (6top) draft
to include statistics.

Regards,

                  Diego

2016-03-04 8:21 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]>:

> I’d support that, Diego
>
>
>
> If the visible operation of the device depends on it and that influences
> the interoperation, it is good to document a base way of doing things.
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Prof.
> Diego Dujovne
> *Sent:* jeudi 3 mars 2016 20:26
> *To:* [email-masked]
> *Subject:* [6tisch] 6P and Sf0 issue: Statistics for SFs and Relocation
>
>
>
> Dear all,
>

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 11 Mar 2016 15:23:10 +0100

+1

On Friday, March 11, 2016, Prof. Diego Dujovne <[email-masked]>
wrote:

> 2016-03-04 8:21 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>:
>
>> I’d support that, Diego
>>
>>
>>
>> *From:* 6tisch [mailto:[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>] *On Behalf Of
>> *Prof. Diego Dujovne
>> *To:* [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Xavier Vilajosana <[email-masked]>
Date: Fri, 11 Mar 2016 15:36:32 +0100

Hi Diego,

will that sentence work?

SHOULD provide a list of metrics and statistical operations used for the
proper operation of the SF

regards,
Xavi

2016-03-11 15:23 GMT+01:00 Thomas Watteyne <[email-masked]>:

> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>