Subject: [6tisch] 6P and Sf0 issue: 6top protocol behaviour at boot

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Thu, 3 Mar 2016 13:12:18 -0300

Dear all,
            Although it was discussed, there is no specification
on the 6top behaviour at boot. The discussion point here is if the
6top messages shall be transmitted on minimal cells until
the slotframe 1 (SFR1) has been populated enough to support
the transactions.
          - The use of minimal is optional. In case minimal is used,
the decision on when to switch is out of scope?
          - In case minimal is not used, shall we specify another
mechanism to enable 6top to transmit messages?
Thanks!
Regards,

                                             Diego Dujovne

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 4 Mar 2016 10:55:11 +0000

Hello Diego:

One suggestion would be that when a node attempts to join, the parent immediately grants a set of cells for the join process from a limited pool (to avoid DDOS). These cells are to be released at the end of the join and are there to boost the bandwidth for that critical phase.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Prof. Diego Dujovne
Sent: jeudi 3 mars 2016 17:12
To: [email-masked]
Subject: [6tisch] 6P and Sf0 issue: 6top protocol behaviour at boot

Dear all,

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Thu, 10 Mar 2016 20:25:48 -0300

Pascal,
          I was thinking of a worst-case condition: all neighbours are
willing to join. A limited pool would satisfy only a part of them, thus
putting the rest of the nodes in a join queue. Am I correct?
Regards,

                      Diego

2016-03-04 7:55 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]>:

> Hello Diego:
>
>
>
> One suggestion would be that when a node attempts to join, the parent
> immediately grants a set of cells for the join process from a limited pool
> (to avoid DDOS). These cells are to be released at the end of the join and
> are there to boost the bandwidth for that critical phase.
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Prof.
> Diego Dujovne
> *Sent:* jeudi 3 mars 2016 17:12
> *To:* [email-masked]
> *Subject:* [6tisch] 6P and Sf0 issue: 6top protocol behaviour at boot
>
>
>
> Dear all,
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 10 Mar 2016 23:46:58 +0000

Correct Diego

And that's a desired effect so that a node gets a lot of bandwidth to complete its join. You better complete a few at a time then have hundreds half way through and none fully done.

We may actually reject a join if the queue is too long, exhausting=sleep well and come back in 10

Take care,

Pascal

Le 11 mars 2016 ? 00:25, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> a ?crit :

Pascal,

                      Diego

2016-03-04 7:55 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>:
Hello Diego:

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Prof. Diego Dujovne
Sent: jeudi 3 mars 2016 17:12
To: [email-masked]<mailto:[email-masked]>
Subject: [6tisch] 6P and Sf0 issue: 6top protocol behaviour at boot

Dear all,

--
DIEGO DUJOVNE
Acad?mico Escuela de Ingenier?a en Inform?tica y Telecomunicaciones
Facultad de Ingenier?a UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

--
DIEGO DUJOVNE
Acad?mico Escuela de Ingenier?a en Inform?tica y Telecomunicaciones
Facultad de Ingenier?a UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125