Subject: [6tisch] Minutes, 22 Avril 2016 interim, 6TiSCH WG

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 22 Apr 2016 16:00:13 +0000

Note: timestamps in PST.

Connection details

  *   Date: 7-8am Pacific: http://www.worldtimebuddy.com/?qm=1&lid=100,12,5392171,1850147&h=100&date=2016-04-22&sln=14-15
  *   Webex link: https://cisco.webex.com/ciscosales/j.php?MTID=md64a0958ae4154c0553f056bf42b756a
  *   Webex recording: https://cisco.webex.com/ciscosales/lsr.php?RCID=23d221459a7548dd9ae90f91a54a130f Recording password: tDm2jtS3
  *   Meeting Slides: https://bitbucket.org/6tisch/meetings/
  *   Wiki: https://bitbucket.org/6tisch/meetings/wiki/160422_webex
  *   Slides: https://bitbucket.org/6tisch/meetings/src/master/160422_webex/slides_160422_webex.ppt

Taking notes (using Etherpad)

  1.  Thomas Watteyne
  2.  Pascal Thubert
  3.  Diego Dujovne

Present

  1.  Thomas Watteyne
  2.  Pascal Thubert
  3.  Alex Pelov
  4.  Chonggang Wang
  5.  Diego Dujovne
  6.  John Mattson
  7.  Lohith Y S
  8.  Ludwig Seitz
  9.  Maria Rita Palattella
  10. Michael Richardson
  11. Nicola Accettura
  12. Pat Kinney
  13. Rashid Sangi
  14. Qin Wang
  15. Robert Cragie
  16. S.V.R. Anand
  17. Savio Sciancalepore
  18. Sedat Gormus
  19. Seema Kumar
  20. Xavi Vilajosana
  21. Zhuo Chen

Action Items

  *   Pascal to clean up the mailing list based on voluntary participation
  *   Authors of 6P and SF0 drafts to publish 00
  *   Authors of OSCOAP to join the security DT ML

Agenda

  *   Administrivia [2min]
     *   Approval agenda
     *   Approval minutes IETF 95
  *   Pending WG doc Adoptions
  *   Security Bootstrap Michael Richardson [10mn]
  *   OSCOAP Goran Selander [40mn]
  *   AOB [1min]

Minutes

*        Administrivia [2min]

     *   Approval agenda
     *   Approval minutes minutes IETF 95

No issues raised. Agenda and Minutes Approved

*        Pending WG doc Adoptions

     *   New draft close to adoption - address protection associate unique id on the 6lopwan registration
     *   Call for adoption for SF0 and 6P nothing against them.
     *   Pascal asks Raise hands? Against?
     *   Michael Richardson: For the adoption. Afterwards, other SFs can be created.
     *   Chonggang Wang: I sent comments on metadata on 6P, should be addressed. Section 6: TODO Metadata Definition.
     *   Pascal Thubert: The working group must decide what to be done.
     *   Opposition to adoption? No. Both drafts are adopted.
     *   Republish on IETF with the ietf name change
     *   Do not make any changes.

*        Security Bootstrap Michael Richardson [10mn]

     *   we should restart with the security ML
     *   Michael will indicate on the sec-ML who is on there
     *   If people want to join the ML, let Michael know
     *   Michael: to Alex Pelov: Send invitation to the ML. I will reach you.

*        OSCOAP Goran Selander [40mn]

     *   John Mattson: Object Security solution not standardized yet in CoSe for CBOR.
     *   Can be used between one or intermediate proxies.
     *   COSE object to create a new COAP option called security. Independent from transport. Small footprint.
     *   Small messages. End-to-End security, shared key, small number of exchanges. Current plan to ask for adoption in CORE WG in Berlin.
     *   COSE is binary JSON. Add this object to the COAP header. Does not rely on any other identifiers to encrypt or decrypt.
     *   Example (Slide 13) Both in the request and in the response.
     *   Low footprint. Computing overhead low, message overhead low.
     *   Alex Pelov: How to add support on COAP
     *   Need base COAP plus this option.
     *   IDENTIFIER (variable length) 1 byte sequence number (variable length) 2-3bytes COSE encoding 7-8 bytes message integrity CCM 8 bytes missing last item)
     *   Ludwig Seitz from chat: Transaction identifier 5 bytes, AES-CCM-8 tag 8 bytes COSE overhead 9 bytes.
     *   PT: integrity check allowed by 6lowpan. you can save two bytes on UDP.
     *   CW: Comparison of this solution from DTLS?
     *   John: Processing message size, number of round-trips, computational complexity. TODO. Will send it to the ML.
     *   John Mattson: New Security requirements scenario 1 and 2. Scenario 2 node doing caching.
     *   Ludwig Seitz: Master students working. California library C code for embedded still under work release May 10th. People to maintain this code.
     *   Thomas Watteyne: Why not CCM-4? MAc layer CCM-4 tag. 8 bytes may be too much. Security risk?
     *   Alex Pelov: Have the possibility to have a 4 byte tag?
     *   The only difference is how many packets to brute force before obtaining access. CCM-8? 1 out of 4 billion
     *   PT: Can we make the L2 security less expensive if we have this?
     *   Thomas Watteyne: MIC: Auxiliary security DSN and MIC at the end. 4 to 10 bytes.
     *   Robert Cragie: I think CCM_8 comes from TLS. We suggested use of 4 byte tags for CCM AEAD cipher suites but the authors did not want to use that. GCM AEAD cipher suites don't even specify the _8 option. Using a 4 byte MIC on a link layer in a confined network is a different use case to Application layer security.
     *   Michael: Layer3 (meaning and above NOTNT) Only one per packet. Payload is already 1000 bytes layer 2 on every packet. not reduce layer 2 security, repeat it on every fragment. Cannot eliminate in that layer.
     *   Michael Richardson: DTLS can set that up?
     *   John Mattson Need to implement heavy DTLS, it would be better to define this preset key exchange
     *   Thomas Watteyne: How to securely bootstrap a network without DTLS.
     *   John Mattson: Slide 18, graph incomplete.
     *   Robert Cragie: In answer to Michael's question whether you could use DTLS to establish security context for COSE - I guess you could. You would have to export the master key and then close the DTLS session. However, there is no obvious binding between the established key and its use in subsequent COSE-based security.
     *   Michael Richardson: Simultaneously multiple transactions?
     *   John Mattson: Can be (?)
     *   Michael Richardson: 15.4 IE or on IP?
     *   John Mattson: Can run on IEs, where COAP runs, it runs.
     *   Robert Cragie: Only encryption: never. Only integrity check: Possibly
     *   Thomas Watteyne: (Missed question)
     *   Thomas Watteyne: Very good summary on Appendix A, examples.
     *   John Mattson: This will help with my work on 6tisch ML

# Thomas shares screen:

     *   We discussed with Goran in Buenos Aires. The idea leverages a central Join coordination entity and PSK, each key associated to a node; a joining node talks to a Join Assistant and through it sends a POST, with an opaque that is sent to the JCE. The JCE validates the encrypted content and authorizes.
     *   Thomas Watteyne: Now that JCE knows the device is there. Now there is a need for key K2 for data. THere may be a preprovision. But the JCE could also post K2 to the device using OSCOAP and the device is now operational for data.
     *   Michael: Happy that the OSCOAP is that far along
     *   Thomas Watteyne: authors please join 6TiSCH security design team. Note that there is not much 6TiSCH specific Apart from mentioning K2.
     *   John Mattson: Very happy to hear feedback and hope this is adopted in 6tisch. We will join the security design team.
     *   Robert Cragie: Re. OSCOAP on 6tisch slide: I think you would need at least a 3-way challenge-response handshake at the beginning. Request/response is not probably not enough

*        AOB [1min]

     *   Thomas Watteyne: next call in 3 weeks. May 13th.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 22 Apr 2016 13:02:22 -0400

Pascal Thubert (pthubert) <[email-masked]> wrote:
    > * Michael: Layer3 (meaning and above NOTNT) Only one per
    > packet. Payload is
    > already 1000 bytes layer 2 on every packet. not reduce layer 2 security,
    > repeat it on every fragment. Cannot eliminate in that layer.

To clarify.

If one has a 1000 byte CoAP packet, split up into 8 layer-2 fragments, the
layer-3 security will be applied once.  So the overhead of the layer-3
security may be much lower *on average* than the layer-2 security.

The layer-2 security will get repeated on each of the 8 layer-2 fragments.
It would be wonderful if that layer-3 security could be used to eliminate the
overhead of the layer-2 security, but that would open up our LLNs to being
used to carry bogus traffic.

(The OSCOAP layer-3 security can not be checked on a hop-by-hop basis without
sharing the session key everywhere)

Obviously, if one has an 80-byte CoAP packet, this calculation is not the
same.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 22 Apr 2016 14:06:56 -0300

Michael,
             Thank you!

                          Diego

2016-04-22 14:02 GMT-03:00 Michael Richardson <[email-masked]>:

> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 27 Apr 2016 07:33:39 +0200

Michael,
I hadn't fully understood your comment on Friday. I do now, thanks.
Thomas

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 27 Apr 2016 05:45:05 +0000

I took the liberty to include the above layers in the minuted text indicating that it was my interpretation of Michael's words. Point is we are rarely using L3 security but rather transport.

Regards,

Pascal

Le 27 avr. 2016 ? 07:34, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> a ?crit :

Michael,

On Fri, Apr 22, 2016 at 7:06 PM, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> wrote:
Michael,
             Thank you!

                          Diego

2016-04-22 14:02 GMT-03:00 Michael Richardson <[email-masked]<mailto:[email-masked]>>:

To clarify.

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>, Sandelman Software Works
 -= IPv6 IoT consulting =-

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

--
DIEGO DUJOVNE
Acad?mico Escuela de Ingenier?a en Inform?tica y Telecomunicaciones
Facultad de Ingenier?a UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________
_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch