Subject: [6tisch] converging on some common terminology

From: Michael Richardson <[email-masked]>
Date: Fri, 20 Jan 2017 10:26:07 -0500

At the 6tisch-security design team call and then on the anima bootstrap call
on Tuesday, we discussed merging of terminology as an important step to
getting all the bootstrap ideas together.

These are the terms which we have concluded on:

1) PLEDGE.      replaces Joining Node and "New Node"
2) JOIN PROXY.  replaces Join Assistant and bare "Proxy"
3) JOIN REGISTRAR (and Coordinator). Replaces bare "Registrar", and JCE.
                   The "Coordinator" part is considered a seperate,
                   co-located, but optional role.

4) MASA.        remains the same.
5) vendor provided interface that MASA uses to talk to remains unnamed.

Here are the proposals therefore:

ANIMA, dtbootstrap document.
        was already using PLEDGE. (KEEP IT)
        PROXY -> JOIN PROXY.
        REGISTRAR -> officially, "Join Registrar", maybe be shortened
                     in the text to "Registrar" where this is unambiguous.

6tisch-dtsecurity ("Phase one") and 6tisch-minimal security ("One-Touch/Phase two"):

Was using Joining Node    --> Pledge.
Was using Join Assistant  --> Join Proxy
Was using Joint Coordination Entity (JCE)  -> Join Registrar and Coordinator.
Adds term MASA.

Additional terms which we need to import:

  1) "drop ship"
  2) "imprint",
  3) "enrollment",
  4) "audit token", "ownership token"  <- from draft-ietf-anima-voucher.

There also some discussion about the terminology used by 802.15.10:
      "mesh root"  <- has a coordinator role and a registrar role as I
      understand it.

We asked if: Registrar and Coordinator always co-located?
We thought so, but there could be exceptions, and it might be out of scope.

ACTION ITEMS
============
1) ANIMA documents to update terms, and be authoritative for terms.
2) 6tisch documents to update terms, pointing at ANIMA and 6tisch terminology.
3) 6tisch terminology document to include the terms as being imported from ANIMA.
4) netconf: probably just adjust terminology to point at when they terms are
            the same as ANIMA, or when they are different.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 20 Jan 2017 17:15:27 +0000

Thanks a lot Michael!

I do support this convergence which will help people working at the intersection of IOT and ANIMA, which hopefully is quite extensive.

Take care,

Pascal

-----Original Message-----
From: 6tisch [mailto:[email-masked]] On Behalf Of Michael Richardson
Sent: vendredi 20 janvier 2017 16:26
To: [email-masked]; [email-masked]
Cc: anima-bootstrap <[email-masked]>; [email-masked]; [email-masked]
Subject: [6tisch] converging on some common terminology

At the 6tisch-security design team call and then on the anima bootstrap call on Tuesday, we discussed merging of terminology as an important step to getting all the bootstrap ideas together.

Was using Joining Node    --> Pledge.
Was using Join Assistant  --> Join Proxy Was using Joint Coordination Entity (JCE)  -> Join Registrar and Coordinator.
Adds term MASA.

  1) "drop ship"
  2) "imprint",
  3) "enrollment",

ACTION ITEMS
============

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 22 Jan 2017 10:42:42 +1300

So, we should adopt this terminology for the GRASP objectives,
I guess. We also need to make them correspond to the latest thinking
in other ways too. Any more comments on draft-carpenter-anima-ani-objectives
before we update it?

Regards
   Brian

On 21/01/2017 04:26, Michael Richardson wrote:
> _______________________________________________
> Anima-bootstrap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima-bootstrap
>