Subject: [6tisch] Fwd: I-D Action: draft-ietf-6tisch-minimal-19.txt

From: Xavi Vilajosana Guillen <[email-masked]>
Date: Wed, 25 Jan 2017 09:39:41 +0100

Dear all,

we have submitted a new version of minimal addressing the last comments
received during the call last Friday. Main changes affect the security
section where Tero's comments have been taken into consideration.

thanks everybody who contributed and kind regards,
Xavi

---------- Forwarded message ----------
From: <[email-masked]>
Date: 2017-01-25 9:36 GMT+01:00
Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-19.txt
To: [email-masked]
Cc: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IPv6 over the TSCH mode of IEEE 802.15.4e
of the IETF.

        Title           : Minimal 6TiSCH Configuration
        Authors         : Xavier Vilajosana
                          Kris Pister
                          Thomas Watteyne
        Filename        : draft-ietf-6tisch-minimal-19.txt
        Pages           : 26
        Date            : 2017-01-25

Abstract:
   This document describes a minimal mode of operation for a 6TiSCH
   Network.  A minimal mode of operation is a baseline set of protocols,
   recommended configurations and modes of operation sufficient to
   enable a 6TiSCH functional network.  6TiSCH provides IPv6
   connectivity over a Time Synchronized Channel Hopping (TSCH) mesh
   composed of IEEE Std 802.15.4 TSCH links.  This minimal mode uses a
   collection of protocols with the respective configurations, including
   the 6LoWPAN framework, enabling interoperable IPv6 connectivity over
   IEEE Std 802.15.4 TSCH.  This minimal configuration provides the
   necessary bandwidth for network and security bootstrap, and defines
   the proper link between the IETF protocols that interface to IEEE Std
   802.15.4 TSCH.  This minimal mode of operation should be implemented
   by all 6TiSCH compliant devices.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6tisch-minimal/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-6tisch-minimal-19

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-6tisch-minimal-19

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

-- 
Dr. Xavier Vilajosana
Wireless Networks Lab

*Internet Interdisciplinary Institute (IN3)Professor*
(+34) 646 633 681
[email-masked] <[email-masked]>
http://xvilajosana.org
http://wine.rdi.uoc.edu
Parc Mediterrani de la Tecnologia
Av Carl Friedrich Gauss 5, B3 Building
08860 Castelldefels (Barcelona). Catalonia. Spain

---

From: Qin Wang <[email-masked]>
Date: Wed, 25 Jan 2017 19:04:21 +0000 (UTC)

Hi Xavi,
I have just read minimal v19, and the difference between v18 and v19. I have some comments as follows.(1) In section 8, K2 is used to replace KL in the sentence "Provisioning a network with a fixed link key K2 is not secure." I wonder if it should be K1 instead of K2 to be used to replace KL.
(2) In section 8 there is a discussion about "the impact these fake EBs can have, depending on what key(s) are pre-provisioned". I think that case 1 (K1 and K2 are pre-provisioned) and case 2 (K1 is pre-provisioned) have same problem with fake EBs as case 3 (neither K1 nor K2 is pre-provisioned) in term of security. Attacker can make fake EBs with the pre-provisioned K1, because K1 is very easy to get. But, if other networks instead of attackers are our concern, I will agree that a node has more chance to join in correct network in case 1 and case 2.
What do you think?
ThanksQin

    On Wednesday, January 25, 2017 3:39 AM, Xavi Vilajosana Guillen <[email-masked]> wrote:

 Dear all,
we have submitted a new version of minimal addressing the last comments received during the call last Friday. Main changes affect the security section where Tero's comments have been taken into consideration.
thanks everybody who contributed and kind regards,Xavi

---------- Forwarded message ----------
From:  <[email-masked]>
Date: 2017-01-25 9:36 GMT+01:00
Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-19.txt
To: [email-masked]
Cc: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 over the TSCH mode of IEEE 802.15.4e of the IETF.

        Title           : Minimal 6TiSCH Configuration
        Authors         : Xavier Vilajosana
                          Kris Pister
                          Thomas Watteyne
        Filename        : draft-ietf-6tisch-minimal-19. txt
        Pages           : 26
        Date            : 2017-01-25

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/ doc/draft-ietf-6tisch-minimal/

There's also a htmlized version available at:
https://tools.ietf.org/html/ draft-ietf-6tisch-minimal-19

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff? url2=draft-ietf-6tisch- minimal-19

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet- drafts/

______________________________ _________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/ listinfo/6tisch

-- 

| Dr. Xavier Vilajosana
Wireless Networks Lab
Internet Interdisciplinary Institute (IN3)
Professor
(+34) 646 633 681
[email-masked]
http://xvilajosana.org
http://wine.rdi.uoc.edu
 |
| Parc Mediterrani de la Tecnologia 
Av Carl Friedrich Gauss 5, B3 Building
08860 Castelldefels (Barcelona). Catalonia. Spain |

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 25 Jan 2017 22:29:56 +0000

Hi Xavi,
  Thanks for addressing the reviews. I have placed this version on the Feb 16 2017 telechat so Tero, Ralph and Brian will have a chance to chime in by then.

Regards
Suresh

On 1/25/17, 3:39 AM, "6tisch on behalf of Xavi Vilajosana Guillen" <[email-masked] on behalf of [email-masked]> wrote:

    Dear all,

    
    ---------- Forwarded message ----------
    From: <[email-masked]>
    Date: 2017-01-25 9:36 GMT+01:00
    Subject: [6tisch] I-D Action: draft-ietf-6tisch-minimal-19.txt
    To: [email-masked]
    Cc: [email-masked]

    
    
    Abstract:

    

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at 
    tools.ietf.org <http://tools.ietf.org>.

    

    [email-masked] <mailto:[email-masked]>