Subject: [6tisch] Working with DetNet

From: Randy Turner <[email-masked]>
Date: Mon, 10 Apr 2017 11:04:01 -0400 (EDT)

Hi All,

The DetNet charter indicates they will "work with" 6TiSCH in some manner - I looked at our current document list on the IETF website, and I didn't see anything related to DetNet (yet). There is a mention of DetNet requirements in the "SF1" draft, but the draft I was referring to would have "DetNet" in the title, and be more of a higher layer document.  I was curious if the list believes that some specific DetNet-related  draft would be needed that provides input to the DetNet group detailing how to achieve DetNet requirements/semantics using 6TiSCH ? Apologies if I missed an earlier discussion on this topic.

Thanks!
Randy

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 11 Apr 2017 11:33:50 +0000

Hello Randy :

Apparently, yes, the current work at DetNet is focused on pseudowire encapsulation and mostly related to TSN. So it might look that 6TiSCH is not considered.

But in fact, there’s a lot of cross connection.

It started with https://tools.ietf.org/html/draft-thubert-6tisch-4detnet-01 which implements a 6TiSCH charter item to
” - Produce requirements to the DetNet WG, detailing 6TiSCH chunks and tracks, and the data models to manipulate them from an external controller such as a PCE.”

This work was incorporated and adapted in https://datatracker.ietf.org/doc/html/draft-ietf-detnet-use-cases#section-5

The discussion on the capability of 6TiSCH Tracks to support (DetNet) replication and elimination was incorporated in the 6TiSCH architecture https://datatracker.ietf.org/doc/html/draft-ietf-6tisch-architecture#section-4.5

So far, the 2 groups appear to be in sync, though the capabilities may differ, in particular with the intermediate elimination that is quite easy with 6TiSCH and quite difficult in the general DetNet case.

Take care,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Randy Turner
Sent: lundi 10 avril 2017 17:04
To: [email-masked]
Subject: [6tisch] Working with DetNet

Hi All,

Thanks!
Randy