Subject: [6tisch] DETNET use cases

From: Randy Turner <[email-masked]>
Date: Mon, 17 Apr 2017 14:52:59 -0400 (EDT)

Hi All,

Regarding the recent call minutes and my action item, I did a quick glance at the use-cases defined in the DETNET use-cases document - I looked across all the use-cases, but particularly the electrical/smart-grid use-cases. The use-cases appear to be valid, however, It looks to me (you guys can correct me if you feel differently) that the problem statements and the latencies mentioned, are not approachable by wireless/RF networks.  I'm not saying that deterministic methods (PCE scheduling, track switching, anything "MPLS-like or switching" on a mesh) wouldn't help, I just couldn't find any use-cases that could be addressed using the types of 6tisch networks (large/several-hops, lossy, 50Kbps - 1 Mbps) that I routinely deal with.  The DETNET use-case document (as Pascal may have suggested in the past) seems to be describing problems that could be approached with "wired" DETNET methods only. The smart grid use-cases specifically call for 50msec latency across a grid network - any RF segment along this end-to-end link wouldn't necessarily be able to "guarantee" this. At least from my experience.  Basically, the current use-case document appears to be a "wired" network use-case document.

Randy

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 17 Apr 2017 20:31:16 +0000

Hello Randy :)

Section 5 is probably the one we care about most; the text derives from the 6TiSCH 4 detnet draft...

Regards;

Pascal

Le 17 avr. 2017 ? 20:53, Randy Turner <[email-masked]<mailto:[email-masked]>> a ?crit :

Hi All,

Randy

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Randy Turner <[email-masked]>
Date: Tue, 18 Apr 2017 11:54:39 -0400 (EDT)

Hi Pascal,

I did look at section 5, and while there is a good discussion on how 6tisch works and/or how 6tisch mechanisms may be used to accomplish deterministic networking, I didn't see any concrete use-cases, similar to other sections of the document...i.e.,

"The BMS polls each LC at a maximum measurement interval of 100ms (for
example to draw a historical chart of 1 second granularity with a 10x
sampling interval) and then performs the operations as specified by
the operator. Each LC needs to measure each of its several hundred
sensors once per measurement interval. Latency is not critical in
this scenario as long as all sensor values are completed in the
measurement interval."

That being said, I can use some of this text, it would just be nice to show an example concrete use-case using the features of 6tisch as described in the document.

Thanks!
Randy

On April 17, 2017 at 4:31 PM "Pascal Thubert (pthubert)" <[email-masked]> wrote:

Hello Randy :)

Regards;

Pascal

Le 17 avr. 2017 à 20:53, Randy Turner <[email-masked]> a écrit :

Hi All,

Randy

[email-masked]

[email-masked]

---

From: peter van der Stok <[email-masked]>
Date: Wed, 19 Apr 2017 09:14:07 +0200

Each LC needs to measure each of its several hundred
> this scenario as long as all sensor values are completed in the

The above looks like a self contained contradiction.
"Completed within the measurement interval" means a deadline.
So latency is important, the only conclusion is that the latency may be 
relatively long.

In real-time we discern types of deadline:
soft deadline: delivering the result after the deadline has a 
diminishing value for the application
hard deadline: delivering the result after the deadline means end of 
application (e.g plane crash)

It might be helpful to see how this terminology can be used within 
6tisch use cases.

Peter

---

From: Randy Turner <[email-masked]>
Date: Wed, 19 Apr 2017 08:12:12 -0400

Hi Peter,

Yes, it may very well be as you said…I just snipped the example text from other use-case sections in the DETNET use-case document.

I agree that DETNET doesn’t mean high or low latency - just whatever latency is necessary to be reliable and predictable.

R.

> On Apr 19, 2017, at 3:14 AM, peter van der Stok <[email-masked]> wrote:
> 
> So latency is important, the only conclusion is that the latency may be relatively long.
> 
> soft deadline: delivering the result after the deadline has a diminishing value for the application
> hard deadline: delivering the result after the deadline means end of application (e.g plane crash)
> 
> It might be helpful to see how this terminology can be used within 6tisch use cases.
> 
> Peter
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 19 Apr 2017 15:46:01 +0000

Hello Randy :

We are lacking real deployments and could only use values derived from the practice of other TSCH-based standards.
But I do not have access on such figures. Hearsay is that those radios are rarely used in control loop operation and find more application in monitoring.

If you have more or have a source of such information, then we could improve the detnet draft : )

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Randy Turner
Sent: mardi 18 avril 2017 17:55
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: [email-masked]
Subject: Re: [6tisch] DETNET use cases

Hi Pascal,

Thanks!
Randy

On April 17, 2017 at 4:31 PM "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>> wrote:
Hello Randy :)

Regards;

Pascal

Le 17 avr. 2017 à 20:53, Randy Turner <[email-masked]<mailto:[email-masked]>> a écrit :

Hi All,

Randy

---

From: Randy Turner <[email-masked]>
Date: Wed, 19 Apr 2017 12:07:07 -0400

Yes, I’m trying to come up with some of our smart grid use-cases that would be improved by 6tisch-style DETNET features…

Will seek input on these soon…

Thx!

R.

On Apr 19, 2017, at 11:46 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:

Hello Randy :

Pascal

Hi Pascal,

Thanks!
Randy

Hello Randy :)

Regards;

Pascal

Hi All,

Randy