Subject: [6tisch] Minutes, 14 April 2017 interim, 6TiSCH WG

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 14 Apr 2017 15:20:41 +0000

Note: timestamps in PDT.

Connection details

  *   Date: 7-8am Pacific: http://www.worldtimebuddy.com/?qm=1&lid=100,12,5392171,1850147&h=100&date=2017-04-14&sln=14-15
  *   Webex link: https://cisco.webex.com/ciscosales/j.php?MTID=mcdbbe3a4e38d97d986b507ec12a1f9b1
  *   Webex Recording: https://cisco.webex.com/ciscosales/lsr.php?RCID=e2af5ee417154126b2ab9cba81ab6fb4
     *   Recording password: JkJp3Qce
  *   Material link: https://bitbucket.org/6tisch/meetings/raw/master/170414_webex/slides_170414_webex.ppt

Taking notes (using Etherpad)
Present (alphabetically)

  1.  Benjamin Damm
  2.  Charlie Perkins
  3.  Diego Dujovne
  4.  Dominique Barthel
  5.  Malisa Vucinic
  6.  Mark ??? <- connected without audio; is this a real person ???
  7.  Michael Richardson
  8.  Pascal Thubert
  9.  Randy Turner
  10. Rashid Sangi
  11. Remy Leone
  12. Sedat Gormus
  13. Yasuyuki Tanaka

Action Items

Randy to check IETF documents on 6TiSCH vs. DetNet (https://tools.ietf.org/html/draft-ietf-detnet-use-cases-12 and https://tools.ietf.org/html/draft-ietf-6tisch-architecture-11) and come back to us on whether there is a need to maintain another document, if so whether https://tools.ietf.org/html/draft-thubert-6tisch-4detnet-01 is a good start

Agenda

*        Administrivia [ 2min]

     *   Agenda bashing
     *   Approval minutes from last meeting

*        Status of drafts (chairs) [15min]

     *   Adoption of Michael's drafts on security - co authors?
     *   Terminology draft
     *   6TiSCH for detnet
     *   6P and SF0 - launching last calls?
  *   6P finalization (Thomas, Qin) [10min]
  *   Update on security (Michael/Malisa) [10min]
  *   Research Liaison Task Force (Thomas) [15min]
  *   AOB [ 3min]

Minutes

*        [07:05]Administrivia [ 2min]

     *   Agenda bashing

o   Approval minutes from last meeting

o   Minutes of last meeting; this agenda approval => all Approved

*        [07:07] ETSI plugtest (Thomas)

     *   Thomas Watteyne: discusses the ETSI plugtest at IETF 99.
     *   Would start Friday afternoon and then all of saturday prior to IETF in Prague. We are discussing with ETSI to use their tool for reporting. Also with 6lo about co-locating the event.
     *   TW: First step: agree on the scope: all the pieces defined.
     *   Coverage: minimal draft, 6P, SF0, as well as minimal security
     *   MCR: make sure with ETSI to avoid the NDA issue. NDA says that we agree to never reverse engineer other people's work.
     *   Thomas asks if anyone opposes removing the NDA. No one shows up. Thomas will ask ETSI if that is a problem
     *   Remy: have a list of all 6TiSCH tests, matching merging all the interop tests, up to date compilation that is still valid today.
     *   Thomas: we'll define such document. Things have changed since last interops so would be useful to have an updated version reflecting what should work today. This should live in a bitbucket
     *   Remy: you are reading my mind
     *   Thomas: need to look at IPR with ETSI as well, then. Can we freely publish the testcases on the bitbucket?
     *   Remy: we will upgrade the wireshark dissector to support 6P and generate json.

*        [7:18]Status of drafts (chairs)

     *   Adoption of Michael's drafts on security - co authors?
        *   Diego volunteers for EB draft
        *   Peter volunteers for rekey draft
        *   Pascal: we will ask for review+adoption for EB, wait for rekey
     *   Terminology draft
        *   key as I-D, will publish "last" in first set to RFC are done
     *   6TiSCH for detnet
        *   Randy: IEEE 802.24, other groups were looking for composite document which shows how IETF 6TiSCH applies to their application domain
        *   Randy: looking for use cases, and what is teh difference between wired and wireless (with technical details)
        *   Pascal: please look at https://tools.ietf.org/html/draft-thubert-6tisch-4detnet-01, does that cover the requirements?
        *   Randy: will include this in landscape analysis
        *   Pascal: please come back to us on whethet there is interest in this document, on top of:
           *   draft-ietf-detnet-use-cases-12
           *   6TiSCH architecture
     *   6P and SF0 - launching last calls?
     *   SF0 to be experimental
     *   [7:32] 6P finalization (Thomas, Qin) [10min]
     *   Charlie: 2 pages of technical comments, this is the first one.
     *   Charlie: I sent comments to the ML, editorial and small things in a file.
     *   Charlie: Terminology section: more terms needed: NumCandCells (candidate cells)
     *   Charlie: proposed changes to the cell table; will not go over that now.
     *   Charlie: ERREOL case is listed as an error and that is not appropriate; either that or make the error hanling less complicated.
     *   Charlie: Negotiation to delete cells: why negotiate?
     *   Thomas: Yes, should be plainly accepted by node B
     *   Charlie: Candidate cells, Relocate cells: no way to count the number of cells on the list. Does not represent the message format.
     *   Charlie: combining the role of generation number and sequence number. Seem they are increased together. The function could be combined, thus more bits and longer rollover
     *   Thomas: for list and count commands, these are additional transaction and the seq number is incremented but not the gen.
     *   Charlie: That is just a suggestion; I can develop further if you like. I'm usually in favor of minimizing the number of concepts to handle.
     *   Charlie: section mandates certain things from SF specification. I made editorial comments in the text attached. But the text says that SF should manadte the behaviour at boot. But there are many things done at boot, some of which do not fall in SF. Which things should be configured and initialized by SF should be specified more specifically.
     *   Charlie: in IOT there is going to be huge number of applications. How to say unambiguously what the applicaiton domain is seems difficult. Better may be to pass what's the maximum nb of cell, or max latency in that the
     *   Thomas: The idea is to have multiple SFs option to implement any of them. e.g. the requirement of a certai was created to favor latency, other criteria robustness...
     *   Charlie: Seems to have more editorial in recent additions. Why do we need list and count? the motivation for those commands is missing.
     *   Charlie: How to abort the confirmation in a 3 step appears to be missing.
     *   Thomas: missing 3P ack for that
     *   Charlie: and numcells is missing in relocate response.
     *   Thomas: Revision code goes in IE that has a length so it can be inferred from that
     *   Pascal: Is really about the future, if someone adds stuff to the frame the length will not be an indicator of the number of cells an lore. The dray .
     *
     *   [7:50] Update on security (Michael/Malisa) [10min]
     *   Michael: Design Team resumed at 15:00 UTC, there was a meeting this week
     *   Michael: Goal to advance 6TiSCH minimal to WG LC by IETF 99 and the zerotouch soon after. Minimal is plugTestable. Dependencies on EDHOC which needs a WG, likely ACE, waiting for the chairs/ADs.

*        [7:56] 6TiSCH simulator (Malisa) [ 3min]

  *   Extended downward traffic downward predict performance fast of network, during standardization process. Security uses? how to shape the protocol using. Good Research tool. Written in Python, events scheduled on the timeslot boundary. Slotted aloha cell downward routing and on the fly scheduling, with generic number of nodes?.
  *   Metrics: Energy, Performance of Slotted Aloha, Reliability, Latency, Join process duration, ++
  *   CDF of join times on the network, as more nodes join, it more it takes to the last node to join, since lots of beacons are transmitted.
  *   [12:01] AOB?
  *   Diego: There is a recent paper from external authors proposing a new SF variant, where SF0 performances are exposed.
     *   Pascal: Can you please provide a link on the ML?
     *   Diego: Will share the link on the ML.
  *   First step: agree on the scope

[12:05] Meeting adjourned, people may stay for a demo by Malisa.

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 14 Apr 2017 09:23:19 -0700

Hello Pascal,

One change to the minutes:

  * If ERR_EOL is maintained as an error, then the error-handling text
    in the specification will have to be made *more* complicated, not
    less complicated.

Regards,
Charlie P.

PS. Is it legitimate to make error corrections on Etherpad after the end 
of the meeting?

On 4/14/2017 8:20 AM, Pascal Thubert (pthubert) wrote:
>
> Note: timestamps in PDT.
>
>
>     Connection details
>
>   * Date: 7-8am Pacific:
>     http://www.worldtimebuddy.com/?qm=1&lid=100,12,5392171,1850147&h=100&date=2017-04-14&sln=14-15
>   * Webex link:
>     https://cisco.webex.com/ciscosales/j.php?MTID=mcdbbe3a4e38d97d986b507ec12a1f9b1
>   * Webex Recording:
>     https://cisco.webex.com/ciscosales/lsr.php?RCID=e2af5ee417154126b2ab9cba81ab6fb4
>       o Recording password: JkJp3Qce
>   * Material link:
>     https://bitbucket.org/6tisch/meetings/raw/master/170414_webex/slides_170414_webex.ppt
>
>
>     Taking notes /(using Etherpad)/
>
>
>     Present /(alphabetically)/
>
>  1. Benjamin Damm
>  2. Charlie Perkins
>  3. Diego Dujovne
>  4. Dominique Barthel
>  5. Malisa Vucinic
> Randy to check IETF documents on 6TiSCH vs. DetNet 
> (https://tools.ietf.org/html/draft-ietf-detnet-use-cases-12 and 
> https://tools.ietf.org/html/draft-ietf-6tisch-architecture-11) and 
> come back to us on whether there is a need to maintain another 
> document, if so whether 
> https://tools.ietf.org/html/draft-thubert-6tisch-4detnet-01 is a good 
> start
>
>
>     Agenda
>
> ·Administrivia [ 2min]
>
>       o Agenda bashing
> ·Status of drafts (chairs) [15min]
>
>       o Adoption of Michael’s drafts on security – co authors?
>       o Terminology draft
>       o 6TiSCH for detnet
>       o 6P and SF0 – launching last calls?
> ·[07:05]Administrivia [ 2min]
>
>       o Agenda bashing
>
> oApproval minutes from last meeting
>
> oMinutes of last meeting; this agenda approval => all Approved
>
> ·[07:07] ETSI plugtest (Thomas)
>
>       o Thomas Watteyne: discusses the ETSI plugtest at IETF 99.
>       o Would start Friday afternoon and then all of saturday prior to
>         IETF in Prague. We are discussing with ETSI to use their tool
>         for reporting. Also with 6lo about co-locating the event.
>       o TW: First step: agree on the scope: all the pieces defined.
>       o Coverage: minimal draft, 6P, SF0, as well as minimal security
>       o MCR: make sure with ETSI to avoid the NDA issue. NDA says that
>         we agree to never reverse engineer other people's work.
>       o Thomas asks if anyone opposes removing the NDA. No one shows
>         up. Thomas will ask ETSI if that is a problem
>       o Remy: have a list of all 6TiSCH tests, matching merging all
>         the interop tests, up to date compilation that is still valid
>         today.
>       o Thomas: we'll define such document. Things have changed since
>         last interops so would be useful to have an updated version
>         reflecting what should work today. This should live in a bitbucket
>       o Remy: you are reading my mind
>       o Thomas: need to look at IPR with ETSI as well, then. Can we
>         freely publish the testcases on the bitbucket?
>       o Remy: we will upgrade the wireshark dissector to support 6P
>         and generate json.
>
> ·[7:18]Status of drafts (chairs)
>
>       o Adoption of Michael’s drafts on security – co authors?
>           + Diego volunteers for EB draft
>           + Peter volunteers for rekey draft
>           + Pascal: we will ask for review+adoption for EB, wait for rekey
>       o Terminology draft
>           + key as I-D, will publish "last" in first set to RFC are done
>       o 6TiSCH for detnet
>           + Randy: IEEE 802.24, other groups were looking for
>             composite document which shows how IETF 6TiSCH applies to
>             their application domain
>           + Randy: looking for use cases, and what is teh difference
>             between wired and wireless (with technical details)
>           + Pascal: please look at
>             https://tools.ietf.org/html/draft-thubert-6tisch-4detnet-01,
>             does that cover the requirements?
>           + Randy: will include this in landscape analysis
>           + Pascal: please come back to us on whethet there is
>             interest in this document, on top of:
>               # draft-ietf-detnet-use-cases-12
>               # 6TiSCH architecture
>       o 6P and SF0 – launching last calls?
>       o SF0 to be experimental
>       o [7:32] 6P finalization (Thomas, Qin) [10min]
>       o Charlie: 2 pages of technical comments, this is the first one.
>       o Charlie: I sent comments to the ML, editorial and small things
>         in a file.
>       o Charlie: Terminology section: more terms needed: NumCandCells
>         (candidate cells)
>       o Charlie: proposed changes to the cell table; will not go over
>         that now.
>       o Charlie: ERREOL case is listed as an error and that is not
>         appropriate; either that or make the error hanling less
>         complicated.
>       o Charlie: Negotiation to delete cells: why negotiate?
>       o Thomas: Yes, should be plainly accepted by node B
>       o Charlie: Candidate cells, Relocate cells: no way to count the
>         number of cells on the list. Does not represent the message
>         format.
>       o Charlie: combining the role of generation number and sequence
>         number. Seem they are increased together. The function could
>         be combined, thus more bits and longer rollover
>       o Thomas: for list and count commands, these are additional
>         transaction and the seq number is incremented but not the gen.
>       o Charlie: That is just a suggestion; I can develop further if
>         you like. I'm usually in favor of minimizing the number of
>         concepts to handle.
>       o Charlie: section mandates certain things from SF
>         specification. I made editorial comments in the text attached.
>         But the text says that SF should manadte the behaviour at
>         boot. But there are many things done at boot, some of which do
>         not fall in SF. Which things should be configured and
>         initialized by SF should be specified more specifically.
>       o Charlie: in IOT there is going to be huge number of
>         applications. How to say unambiguously what the applicaiton
>         domain is seems difficult. Better may be to pass what's the
>         maximum nb of cell, or max latency in that the
>       o Thomas: The idea is to have multiple SFs option to implement
>         any of them. e.g. the requirement of a certai was created to
>         favor latency, other criteria robustness...
>       o Charlie: Seems to have more editorial in recent additions. Why
>         do we need list and count? the motivation for those commands
>         is missing.
>       o Charlie: How to abort the confirmation in a 3 step appears to
>         be missing.
>       o Thomas: missing 3P ack for that
>       o Charlie: and numcells is missing in relocate response.
>       o Thomas: Revision code goes in IE that has a length so it can
>         be inferred from that
>       o Pascal: Is really about the future, if someone adds stuff to
>         the frame the length will not be an indicator of the number of
>         cells an lore. The dray .
>      o
>       o [7:50] Update on security (Michael/Malisa) [10min]
>       o Michael: Design Team resumed at 15:00 UTC, there was a meeting
>         this week
>       o Michael: Goal to advance 6TiSCH minimal to WG LC by IETF 99
>         and the zerotouch soon after. Minimal is plugTestable.
>         Dependencies on EDHOC which needs a WG, likely ACE, waiting
>         for the chairs/ADs.
>
> ·[7:56] 6TiSCH simulator (Malisa) [ 3min]
>
>   * Extended downward traffic downward predict performance fast of
>     network, during standardization process. Security uses? how to
>     shape the protocol using. Good Research tool. Written in Python,
>     events scheduled on the timeslot boundary. Slotted aloha cell
>     downward routing and on the fly scheduling, with generic number of
>     nodes?.
>   * CDF of join times on the network, as more nodes join, it more it
>     takes to the last node to join, since lots of beacons are transmitted.
>   * [12:01] AOB?
>   * Diego: There is a recent paper from external authors proposing a
>     new SF variant, where SF0 performances are exposed.
>       o Pascal: Can you please provide a link on the ML?
>       o Diego: Will share the link on the ML.
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 18 Apr 2017 11:51:38 +0000

Thanks for the catch, Charlie.

I corrected the posted minutes at https://www.ietf.org/proceedings/interim-2017-6tisch-08/minutes/minutes-interim-2017-6tisch-08-201704140700-01

Take care,

Pascal

From: Charlie Perkins [mailto:[email-masked]]
Sent: vendredi 14 avril 2017 18:23
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: Re: [6tisch] Minutes, 14 April 2017 interim, 6TiSCH WG

Hello Pascal,

One change to the minutes:
*        If ERR_EOL is maintained as an error, then the error-handling text in the specification will have to be made *more* complicated, not less complicated.

Regards,
Charlie P.

PS. Is it legitimate to make error corrections on Etherpad after the end of the meeting?

Note: timestamps in PDT.

Connection details

Agenda

*        Administrivia [ 2min]
o   Agenda bashing

*        Status of drafts (chairs) [15min]
o   Adoption of Michael's drafts on security - co authors?
o   Terminology draft
o   6TiSCH for detnet
o   6P and SF0 - launching last calls?
*        6P finalization (Thomas, Qin) [10min]
*        Update on security (Michael/Malisa) [10min]
*        Research Liaison Task Force (Thomas) [15min]
*        AOB [ 3min]
Minutes

*        [07:07] ETSI plugtest (Thomas)
o   Thomas Watteyne: discusses the ETSI plugtest at IETF 99.
o   Would start Friday afternoon and then all of saturday prior to IETF in Prague. We are discussing with ETSI to use their tool for reporting. Also with 6lo about co-locating the event.
o   TW: First step: agree on the scope: all the pieces defined.
o   Coverage: minimal draft, 6P, SF0, as well as minimal security
o   MCR: make sure with ETSI to avoid the NDA issue. NDA says that we agree to never reverse engineer other people's work.
o   Thomas asks if anyone opposes removing the NDA. No one shows up. Thomas will ask ETSI if that is a problem
o   Remy: have a list of all 6TiSCH tests, matching merging all the interop tests, up to date compilation that is still valid today.
o   Thomas: we'll define such document. Things have changed since last interops so would be useful to have an updated version reflecting what should work today. This should live in a bitbucket
o   Remy: you are reading my mind
o   Thomas: need to look at IPR with ETSI as well, then. Can we freely publish the testcases on the bitbucket?
o   Remy: we will upgrade the wireshark dissector to support 6P and generate json.

*        [7:18]Status of drafts (chairs)
o   Adoption of Michael's drafts on security - co authors?
?  Diego volunteers for EB draft
?  Peter volunteers for rekey draft
?  Pascal: we will ask for review+adoption for EB, wait for rekey
o   Terminology draft
?  key as I-D, will publish "last" in first set to RFC are done
o   6TiSCH for detnet
?  Randy: IEEE 802.24, other groups were looking for composite document which shows how IETF 6TiSCH applies to their application domain
?  Randy: looking for use cases, and what is teh difference between wired and wireless (with technical details)
?  Pascal: please look at https://tools.ietf.org/html/draft-thubert-6tisch-4detnet-01, does that cover the requirements?
?  Randy: will include this in landscape analysis
?  Pascal: please come back to us on whethet there is interest in this document, on top of:
?  draft-ietf-detnet-use-cases-12
?  6TiSCH architecture
o   6P and SF0 - launching last calls?
o   SF0 to be experimental
o   [7:32] 6P finalization (Thomas, Qin) [10min]
o   Charlie: 2 pages of technical comments, this is the first one.
o   Charlie: I sent comments to the ML, editorial and small things in a file.
o   Charlie: Terminology section: more terms needed: NumCandCells (candidate cells)
o   Charlie: proposed changes to the cell table; will not go over that now.
o   Charlie: ERREOL case is listed as an error and that is not appropriate; either that or make the error hanling less complicated.
o   Charlie: Negotiation to delete cells: why negotiate?
o   Thomas: Yes, should be plainly accepted by node B
o   Charlie: Candidate cells, Relocate cells: no way to count the number of cells on the list. Does not represent the message format.
o   Charlie: combining the role of generation number and sequence number. Seem they are increased together. The function could be combined, thus more bits and longer rollover
o   Thomas: for list and count commands, these are additional transaction and the seq number is incremented but not the gen.
o   Charlie: That is just a suggestion; I can develop further if you like. I'm usually in favor of minimizing the number of concepts to handle.
o   Charlie: section mandates certain things from SF specification. I made editorial comments in the text attached. But the text says that SF should manadte the behaviour at boot. But there are many things done at boot, some of which do not fall in SF. Which things should be configured and initialized by SF should be specified more specifically.
o   Charlie: in IOT there is going to be huge number of applications. How to say unambiguously what the applicaiton domain is seems difficult. Better may be to pass what's the maximum nb of cell, or max latency in that the
o   Thomas: The idea is to have multiple SFs option to implement any of them. e.g. the requirement of a certai was created to favor latency, other criteria robustness...
o   Charlie: Seems to have more editorial in recent additions. Why do we need list and count? the motivation for those commands is missing.
o   Charlie: How to abort the confirmation in a 3 step appears to be missing.
o   Thomas: missing 3P ack for that
o   Charlie: and numcells is missing in relocate response.
o   Thomas: Revision code goes in IE that has a length so it can be inferred from that
o   Pascal: Is really about the future, if someone adds stuff to the frame the length will not be an indicator of the number of cells an lore. The dray .
o
o   [7:50] Update on security (Michael/Malisa) [10min]
o   Michael: Design Team resumed at 15:00 UTC, there was a meeting this week
o   Michael: Goal to advance 6TiSCH minimal to WG LC by IETF 99 and the zerotouch soon after. Minimal is plugTestable. Dependencies on EDHOC which needs a WG, likely ACE, waiting for the chairs/ADs.

6tisch mailing list

[email-masked]<mailto:[email-masked]>