Subject: [6tisch] Minutes, 23 June 2017 interim, 6TiSCH WG

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 23 Jun 2017 15:39:02 +0000

Note: timestamps in PDT.

Connection details

  *   Date: 23 June 2017 7-8am Pacific
  *   Webex recording: https://cisco.webex.com/ciscosales/lsr.php?RCID=62c414a096554327ae6c44ac6d76b1d2
     *   Password : GevaM4ma
  *   Material link: https://bitbucket.org/6tisch/meetings/raw/master/170623_webex/slides_170623_webex.ppt

Present

  1.  Thomas Watteyne
  2.  Pascal Thubert
  3.  Qin Wang
  4.  Remy Leone
  5.  Tengfei Chang
  6.  Xavi Vilajosana
  7.  Malisa Vucinic
  8.  Michael Richardson
  9.  Dominique Barthel
  10. Diego Dujovne
  11. Maria Rita Palattella
  12. Lijo Thomas
  13. Jonathan Munoz
  14. Pedro Gomes
  15. Shalu R.

Taking notes (using Etherpad)

  1.  Xavi Vilajosana
  2.  Pascal Thubert
  3.

Action Items

  *   chairs to contact ADs about EDHOC discussion
  *   Maria Rita to set a meeting on the 3rd over plugTest ML
  *   Pascal to check status of fragmentation I-D with 6lo chairs

Agenda

  *   Administrivia [10min]
     *   Agenda bashing
     *   Approval minutes from last meeting
     *   Addressing todo's from last time
     *   Announcements
        *   TEE webinar
        *   Maria-Rita's non WG forming BoF
     *   IETF99, getting ready
  *   draft-ietf-6tisch-terminology-09 [5min] [Maria Rita]
  *   draft-ietf-6tisch-6top-protocol (Xavi, Qin) [10min]
  *   Security DT Update [10min]
     *   draft-ietf-6tisch-minimal-security-03 [Malisa]
     *   Other news [Michael]
  *   Plutests Update [15min]
     *   admin [Thomas]
     *   update TD [Maria Rita]
     *   update golden image [Tengfei]
     *   update tools [Remy]
  *   AOB [10min]
     *   hackathon: OpenWSN, ...?
     *   draft-lijo-6lo-expiration-time-03

Minutes

*        Administrivia [10min]

o   Agenda bashing

        *   last meeting before IETF meeting in Prague.
        *   thomas proposes a change to the agenda
        *   Lijo 's presentation will be first.
        *   Agenda and last call minutes are approved.
           *   Approval minutes from last meeting
           *   Addressing todo's from last time
           *   Announcements
        *   TEE webinar
           *   webinars at the IETF about TEEP. (Trusted Execution Environments). Links to the webinars in the slides.
        *   Maria-Rita's non WG forming BoF
           *   Info session about M2MSAT at ESA. Study the performance of M2M protocol
           *   to use them in satelite networks.
           *   targeting CoAP and MQTT.
           *   simulated environment.
           *   OpenSand is used.
           *   session after 6TiSCH meeting.

o   IETF99, getting ready

        *   activities around 6TiSCH
        *   plugtest friday afternoon and saturday.
        *   6tisch meeting will not change.
        *   11 days until draft cut-off.
        *   Agenda for the meeting will be published right after that.

*        draft-ietf-6tisch-terminology-09 [5min] [Maria Rita]

     *   published 19th June.
     *   main change related to security terminology. Update with the new security drafts.
     *   updated reference.

*        draft-ietf-6tisch-6top-protocol (Xavi, Qin) [10min]

     *   Xavi presents. 06 published, forgot to update the references so a 07 will be needed soon.
     *   07 published next week
     *   Jonathan comments being addressed
        *   a MAY is changed to a "are"
        *   same type of error returning different values

*        Security DT Update [10min]

     *   draft-ietf-6tisch-minimal-security-03 [Malisa]
     *   added an optional ack from the JRC so the JRC can wait other messages
     *   how JRC learns the JP address
        *   communications happens at IP.
        *   JP forwards directly to JRC
        *   Join response contains the address.
        *   the dagroot is preconfigured with JRC address before the network can boostrap.
        *   Mandatory to implement AEAD Algorithm. Uses the COSE registry
        *   implementing it with PSK.
        *   Thomas: What is missing? is it ready, are there todos?
        *   Malisa: Details in the proxy mechanism. As of now, fine for 6TiSCH but not generic for CoAP use case, make the proxy option decryptable for others.
        *   Malisa: Biggest issue is status of EDHOC draft.

*        Plutests Update [15min]

o   admin [Thomas]

        *   start 2pm Friday 14 July
        *   room open all day
        *   saturday all day
        *   agree on a date with the participants to synchronize.
        *   Monday 3rd works for key players to sync?
        *   seems answer is yes
        *   MR to send a mail to the plugtest ML
        *   just supporting the page 1 switch in case there is no RPL
        *   Pascal= link local communication do not have RPL artifacts; for now they can live on page 0, that's true for ICMP e.g. ping and most RPL (but not non storing DAO)

o   update TD [Maria Rita + Thomas]

        *   Thomas shows the latest test description.
        *   The document specifies the default parameters
        *   5 categories, synch, test about minimal (formats), security (join),
        *   sec join is just one part of the test, people can still participate to the plugTest without that implementation
        *   If you pass all these test you can make a demo of aproduct that works in the general case
        *   Supporting RFC8138 for those that do not have it can be easily done by just; supporting the dispacth value for page 1 as page 0 and page 1 is the same.

o   for the ICMP,(ping) if they are link local then the RPL artifacts are not needed and hence 6LoRH do not apply.

o   this points are useful for those implementations not implementing the whole set of protocols.

o   update golden image [Tengfei]

        *   updated 6P protocol to be compliant to v5.
        *   uses openwsn.
        *   there is a command to trigger a 6P command.
        *   the wiki page of the plugtest has a guide for the commands to be used.

o   update tools [Remy]

     *   soon the tools will be ready. Remy will do a run through on the tools at the beginning of the PT.

*        AOB [10min]

o   hackathon: OpenWSN, ...?

o   draft-lijo-6lo-expiration-time-03

        *   this item is discussed first:
        *   document draft-lijo-6lo-expiration-time
           *   packet expiration time in 6lowpan routing header
           *   motivation is to support delay sensitive M2M IoT Applications
           *   interest on including packet expiration time in IPv6 header
           *   Updates:
              *   including the Network ASN in the IP header
              *   ..
           *   Uses 6LoRH. Provides an elective header to transport the packet expiration time.
           *   Next step is to develop an SF that exploits that functionality.
           *   Thomas: should we account for the delay in the device before passing to the stack?
           *   Xavi: you are assuming 6TiSCH but the draft is sent to 6lo. Why not submit to 6TiSCH?
           *   Lijo: 6TiSCH is the use case
           *   Pascal: Agree with Xavi
           *   Thomas: Yes 6TiSCH is a good place
     *   activity around 3 drafts:
        *   6775 update
        *   BBR
        *   address protection
        *   pay attention to WGLC, basis of our work, review and support

---

From: Michael Richardson <[email-masked]>
Date: Tue, 27 Jun 2017 08:36:07 -0400

> * Malisa: Details in the proxy mechanism. As of now, fine for 6TiSCH
    > but not generic for CoAP use case, make the proxy option
    > decryptable for others.

    > * Malisa: Biggest issue is status of EDHOC draft.

we anticipate a possible phone call before IETF99, with a meeting at IETF99
to resolve things.  Apparently, re-opening COSE WG has been considered.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-