Subject: [6tisch] Fw: Qin comments on SF0

From: Qin Wang <[email-masked]>
Date: Fri, 9 Jun 2017 15:02:16 +0000 (UTC)

Hi Diego,
I'm not sure if you got this email. So, I re-send it.
ThanksQin

     On Monday, May 1, 2017 5:22 PM, Qin Wang <[email-masked]> wrote:

 Dear authors,
I read through SF0 (v4). The following is my comments.
2. Introduction ü   “The Scheduling Algorithmcollects the cell allocation/deletionrequests from the   neighbors and thenumber of cells which are currently under usage.” ==> addition/deletion? allocation/deallocation? 4. SF0 Triggering Eventsü  What is “cell allocation/deallocation process with the neighbor”?The trigger event is not clear. 5. SF0 Cell Estimation Algorithmü  What is incoming cells and outgoing cells? Are they Rx cells and Txcells, respectively?ü  What is “used cells”? Is it same as “scheduled cells”? If not, howto count used cells. 6. SF0 Allocation Policyü  “The number of cells to be scheduled/deleted”==> “added/deleted”?ü  “3. If SCHEDULEDCELLS<=REQUIREDCELLS,add one or more cells.” ==> “3. If SCHEDULEDCELLS<REQUIREDCELLS, add oneor more cells.”ü  When and how the initial value of SCHEDULEDCELLS will be set? Theinitialization should include not only setting SCHDULEDCELLS equal to SOFTHRESH,but also adding SOFTHRESH cells into schedule for starting the state machine describedin Fig.1. 7. Rules for CellListü  “verifying that the slot offset and channel offset are not occupied andchoose channelOffset randomly for each cell” ==> “verifying that the slotoffset is not occupied and choose channelOffset randomly for each cell” 10. Node Behavior at Bootü  Should the initialization of SCHEDULEDCELLS happen at boot? If you have any question regarding it, please feel free to contact me.
ThanksQin_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 21 Jun 2017 14:13:03 +0200

Diego,
Can you confirm you got this e-mail? One thing that has worked well in the
past is to track issue raised in either the IETF issue tracker, or the
tracker part of the repo of our draft.
Just wanting to make sure we are not forgetting about comments.
Thomas

On Fri, Jun 9, 2017 at 5:02 PM, Qin Wang <[email-masked]> wrote:

> Thanks
> Qin
> 2. Introduction
> ü   “The Scheduling Algorithm collects the cell *allocation/deletion*
> requests from the   neighbors and the number of cells which are currently
> under usage.” ==> addition/deletion? allocation/deallocation?
>
> 4.  SF0 Triggering Events
> ü  What is “cell allocation/deallocation process with the neighbor”? The
> trigger event is not clear.
>
> 5.  SF0 Cell Estimation Algorithm
> ü  What is incoming cells and outgoing cells? Are they Rx cells and Tx
> cells, respectively?
> ü  What is “used cells”? Is it same as “scheduled cells”? If not, how to
> count used cells.
>
> 6.  SF0 Allocation Policy
> ü  “The number of cells to be *scheduled/deleted*” ==> “added/deleted”?
> ü  “3. If SCHEDULEDCELLS*<=*REQUIREDCELLS, add one or more cells.” ==>
> “3. If SCHEDULEDCELLS<REQUIREDCELLS, add one or more cells.”
> ü  When and how the initial value of SCHEDULEDCELLS will be set? The
> initialization should include not only setting SCHDULEDCELLS equal to
> SOFTHRESH, but also adding SOFTHRESH cells into schedule for starting the
> state machine described in Fig.1.
>
> 7.  Rules for CellList
> ü  “verifying that the slot offset and channel offset are not occupied
> and choose channelOffset randomly for each cell” ==> “verifying that the
> slot offset is not occupied and choose channelOffset randomly for each cell”
>
> 10.  Node Behavior at Boot
> ü  Should the initialization of SCHEDULEDCELLS happen at boot?
>
> If you have any question regarding it, please feel free to contact me.
>
> Thanks
> Qin
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> _______________________________________________
> 6tisch mailing list
> [email-masked]

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Wed, 21 Jun 2017 08:26:35 -0400

Thomas,
              Yes, I got this e-mail (June 9th).
Regards,

                         Diego

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 21 Jun 2017 14:29:10 +0200

Perfect, thanks!

On Wed, Jun 21, 2017 at 2:26 PM, Prof. Diego Dujovne <
[email-masked]> wrote:

>> Can you confirm you got this e-mail? One thing that has worked well in
>> the past is to track issue raised in either the IETF issue tracker, or the
>>> ü  What is “cell allocation/deallocation process with the neighbor”?
>>> The trigger event is not clear.
>>>
>>> ü  What is “used cells”? Is it same as “scheduled cells”? If not, how
>>> to count used cells.
>>>
>>> 6.  SF0 Allocation Policy

Thomas Watteyne, PhD

www.thomaswatteyne.com