Subject: [6tisch] First version of 4th 6TiSCH plugfest test description

From: Remy Leone <[email-masked]>
Date: Wed, 07 Jun 2017 14:37:26 +0000

Hello,

I created a pull request containing the test descriptions program for the
next plugfest.

https://bitbucket.org/6tisch/td-6tisch/pull-requests/5/ietf99/diff

It's the first draft.
It will be discussed on Friday and the final one will be published on June
15th.

Once this list of test description is approved I will merge it, tag this
commit (ietf99_plugfest) and release it.

@all: Could you take a look at the list of tasks presented and tell me what
you think. Find attached in this email the list of tests in a PDF file.

Best regards

Rémy

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 7 Jun 2017 16:39:55 +0200

Thanks Remy for putting together such a comprehensive list of tests.
With Pascal, we have set aside time during the interim on Friday [1] to
discuss this.
Thomas

[1] https://www.ietf.org/mail-archive/web/6tisch/current/msg05340.html

On Wed, Jun 7, 2017 at 4:37 PM, Remy Leone <[email-masked]> wrote:

> @all: Could you take a look at the list of tasks presented and tell me
> what you think. Find attached in this email the list of tests in a PDF file.
>
> Best regards
>
> Rémy
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Remy Leone <[email-masked]>
Date: Fri, 09 Jun 2017 13:24:14 +0000

Hello,

Please find an updated version of the test description joined. As always,
the source is here: https://bitbucket.org/6tisch/td-6tisch/src

All comments are welcomed.

Best regards

Rémy

Le mer. 7 juin 2017 à 16:40, Thomas Watteyne <[email-masked]> a
écrit :

>> It will be discussed on Friday and the final one will be published on
>> June 15th.
>>

---

From: Tengfei Chang <[email-masked]>
Date: Fri, 9 Jun 2017 15:47:28 +0200

Remy,

The draft looks great! Thanks for updating!

I have reviewed the draft and have one comment on the test:
TD_6TiSCH_FORMAT_02

It says a ping echo request packet is used to test the timing template.
I think we shouldn't use layer 3 packets to test layer 2 behaviors.

What other layer 2 packet can we use for this test? keep alive packet can
be used for testing from 6N->Dagroot.
But there is no layer 2 packet from Dagroot to 6N requiring ACK.

What do you think?
Tengfei

On Fri, Jun 9, 2017 at 3:24 PM, Remy Leone <[email-masked]> wrote:

>>> I created a pull request containing the test descriptions program for
>>> the next plugfest.
>>>

-- 
Chang Tengfei,
Pre-Postdoctoral Research Engineer, Inria

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 9 Jun 2017 15:50:29 +0200

Tengfei,

I'm afraid I don't quite follow.

Any traffic (ping, EB, etc) will result is frames being exchanged between
neighbor, which allows us to verify timing inside the timeslot, no?

Probably missing something,

Thomas

On Fri, Jun 9, 2017 at 3:47 PM, Tengfei Chang <[email-masked]>
wrote:

>> Le mer. 7 juin 2017 à 16:40, Thomas Watteyne <[email-masked]>
>> a écrit :
>>
>>>> Once this list of test description is approved I will merge it, tag
>>>> this commit (ietf99_plugfest) and release it.
>>>>

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Tengfei Chang <[email-masked]>
Date: Fri, 9 Jun 2017 15:52:24 +0200

If a vendor implements the timing template correctly but doesn't support
ping echo request, the vendor can't pass the test.

Tengfei

On Fri, Jun 9, 2017 at 3:50 PM, Thomas Watteyne <[email-masked]>
wrote:

>>> Please find an updated version of the test description joined. As
>>> always, the source is here: https://bitbucket.org/6tisch/td-6tisch/src
>>>

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 9 Jun 2017 15:59:24 +0200

yep, that's what I was missing. I now understand your point.

One important advantage of ping is that you create, with one command
downstream data (root->mote) then upstream data (mote->root) with an ACK
for every packet. This allows you to have a full record of every case in
one go. Using another method (e.g. 6P) would be less immediate.

Would you (or anyone else) agree that mandating the implementation of
ICMPv6 echo request/reply is a realistic requirement?

Thomas

On Fri, Jun 9, 2017 at 3:52 PM, Tengfei Chang <[email-masked]>
wrote:

>>> What other layer 2 packet can we use for this test? keep alive packet
>>> can be used for testing from 6N->Dagroot.
>>>>> With Pascal, we have set aside time during the interim on Friday [1]
>>>>> to discuss this.
>>>>> Thomas
>>>>>
>>>>>> @all: Could you take a look at the list of tasks presented and tell
>>>>>> me what you think. Find attached in this email the list of tests in a PDF
>>>>>> file.
>>>>>>
>>>>>> Best regards
>>>>>>
>>>>>> Rémy
>>>>>>

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Remy Leone <[email-masked]>
Date: Fri, 09 Jun 2017 14:09:45 +0000

I agree that this is a realistic requirement.

Le ven. 9 juin 2017 à 15:59, Thomas Watteyne <[email-masked]> a
écrit :

>> On Fri, Jun 9, 2017 at 3:50 PM, Thomas Watteyne <[email-masked]
>> > wrote:
>>
>>> Tengfei,
>>>
>>> Any traffic (ping, EB, etc) will result is frames being exchanged
>>> between neighbor, which allows us to verify timing inside the timeslot, no?
>>>
>>>>>> [1]
>>>>>> https://www.ietf.org/mail-archive/web/6tisch/current/msg05340.html
>>>>>>
>>>>>>> I created a pull request containing the test descriptions program
>>>>>>> for the next plugfest.
>>>>>>>
>>>>>>> It will be discussed on Friday and the final one will be published
>>>>>>> on June 15th.
>>>>>>>

---

From: Tengfei Chang <[email-masked]>
Date: Fri, 9 Jun 2017 16:17:17 +0200

I agree ICMPv6 echo request/reply is mandatory to be implemented.

Another point is the ICMPv6 may use the 6LoRH format or not, which also
need to be tested at some point.
If two vendors implement different format or implement not properly, they
can't test the timing template also.

Tengfei