Subject: [6tisch] consolidating 6P/6LoRH Wireshark dissectors

From: Thomas Watteyne <[email-masked]>
Date: Fri, 23 Jun 2017 08:56:48 +0200

All,

I'm starting this thread to try to understand the state of the different
Wireshark dissectors. Through the last plugtests, we have had contribution
of several of you with Wireshark dissectors for 6P and 6LoRH. These
dissectors were used extensively during plugtest, and as a base to put
together https://tools.ietf.org/html/draft-munoz-6tisch-examples-00.

Per https://tools.ietf.org/html/draft-munoz-6tisch-examples-00#section-1,
we last used dissectors from the OpenWSN project, which were integrated in
a "private" build of Wiresharkyou can download at
http://builder.openwsn.org/job/6TiSCH%20Wireshark/.

Drafts have evolved, and some of the dissectors have been pushed to the
official Wireshark build. I understand that the state is now:
- the latest official Wireshark build contains reasonably-up-to-date
dissectors of 6P, no 6LoRH
- the OpenWSN dissectors contain an up-to-date 6LoRH implementation

I'd like to make sure the latest build of the official Wireshark is
completely up-to-date, i.e. both 6P and 6LoRH.

If you have an update about dissectors, please let this thread know. We
will also discuss this at the 6TiSCH interim latest today [1], so join if
you are working on this.

Thomas

[1] https://www.ietf.org/mail-archive/web/6tisch/current/msg05379.html

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Fri, 23 Jun 2017 17:09:46 +0900

Hello Thomas,

As far as I know, the latest official Wireshark stable release, v2.2.7, 
doesn't contain the 6P dissector.

> - the latest official Wireshark build contains reasonably-up-to-date dissectors of 6P, no 6LoRH

Development versions would have; they are available at the following page.

https://www.wireshark.org/download/automated/

While I'm working on draft-05 support, slow progress... By the way, I 
notice the newer draft, draft-06, is released.

 > We will also discuss this at the 6TiSCH interim latest today [1],
 > so join if you are working on this.
I'm not sure I can make it...

Best,
Yatch

On 2017/06/23 15:56, Thomas Watteyne wrote:
> Wireshark dissectors. Through the last plugtests, we have had 
> contribution of several of you with Wireshark dissectors for 6P and 
> 6LoRH. These dissectors were used extensively during plugtest, and as a 
> base to put together 
> https://tools.ietf.org/html/draft-munoz-6tisch-examples-00.
> 
> Per 
> https://tools.ietf.org/html/draft-munoz-6tisch-examples-00#section-1, we 
> last used dissectors from the OpenWSN project, which were integrated in 
> will also discuss this at the 6TiSCH interim latest today [1], so join 
> if you are working on this.
> 
> Thomas
> 
> www.thomaswatteyne.com <http://www.thomaswatteyne.com>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

---

From: Remy Leone <[email-masked]>
Date: Fri, 23 Jun 2017 08:12:45 +0000

Hello,

I've started extract the main function for dissecting 6LoRH from the
private repo and started working on a patch.
https://github.com/sieben/wireshark/commit/5025e6d991cf0fcc0b093ca014e18064f0d1a770

At the moment, this code doesn't compile. It's a WIP to prepare a patch
later on.
I'm already working full time on 6TiSCH F-Interop test tool so help is more
than welcome to work on this patch.

Best regards

Rémy

Le ven. 23 juin 2017 à 08:57, Thomas Watteyne <[email-masked]> a

---

From: Remy Leone <[email-masked]>
Date: Fri, 23 Jun 2017 08:14:18 +0000

Hello Yasuyuki,

> https://www.wireshark.org/download/automated/

Thanks :-) I didn't know this existed :-)

---

From: Xavi Vilajosana Guillen <[email-masked]>
Date: Fri, 23 Jun 2017 11:12:35 +0200

Hi Yatch,

v6 has been released with very very minor changes (basically naming of some
Error codes) and few cosmetic corrections. Important things have not
changed.

regards,
X

-- 
Dr. Xavier Vilajosana
Wireless Networks Lab

*Internet Interdisciplinary Institute (IN3)Professor*
(+34) 646 633 681
[email-masked] <[email-masked]>
http://xvilajosana.org
http://wine.rdi.uoc.edu
Parc Mediterrani de la Tecnologia
Av Carl Friedrich Gauss 5, B3 Building
08860 Castelldefels (Barcelona). Catalonia. Spain

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Fri, 23 Jun 2017 18:17:20 +0900

Thank you, Xavi!

> Important things have not changed.I see; I won't make an excuse with the draft-06 release... (>_<)

Best,
Yatch