Subject: [6tisch] Question/Comment on draft-chang-6tisch-6top-msf

From: john rubis <[email-masked]>
Date: Tue, 14 Nov 2017 23:34:45 +0000

I think the MSF draft states/infers this, but I wanted to verify.

In the case a node has a valid preferred parent and wishes to switch to a new one then:

Dedicated link(s) to its current parent initially remain in place. This way, while dedicated link(s) are being setup with the new, I’ll call it the ‘Candidate Parent’, the node and its possible children remain connected and reachable. During this period, the node also maintains its rank and time synchronization to the current parent, not the candidate parent. Once dedicated link(s) are established to the new parent, the node updates its rank and time syncs to the new parent. All up stream packets now are routed through the new parent and link(s) to the old parent are cleared.

It has been observed in our system,  that the links to the new parent can take some time to setup over the single minimal cell. Especially in dense networks. This may cause a node to desync or loose connectivity for an extended period of time.

Thank  you,

John Rubis

---

From: Tengfei Chang <[email-masked]>
Date: Wed, 15 Nov 2017 09:30:59 +0100

Hi John,

Before switching parent, the node still can keep synchronized to it's old
parent through the TXRXSHARED cell. That cell is only shared between the
node and its parent.
The keepalive on TXRXSHARED cell should be able to keep the node
synchronized.

Tengfei

On Wed, Nov 15, 2017 at 12:34 AM, john rubis <[email-masked]> wrote:

> Dedicated link(s) to its current parent initially remain in place. This
> way, while dedicated link(s) are being setup with the new, I’ll call it the
> ‘Candidate Parent’, the node and its possible children remain connected and
> reachable. During this period, the node also maintains its rank and time
> synchronization to the current parent, not the candidate parent. Once
> dedicated link(s) are established to the new parent, the node updates its
> rank and time syncs to the new parent. All up stream packets now are routed
> through the new parent and link(s) to the old parent are cleared.
>
>
>
> It has been observed in our system,  that the links to the new parent can
> take some time to setup over the single minimal cell. Especially in dense
> networks. This may cause a node to desync or loose connectivity for an
> extended period of time.
>
>
>
> Thank  you,
>
>
>
> John Rubis
>
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
Chang Tengfei,
Pre-Postdoctoral Research Engineer, Inria

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 15 Nov 2017 09:43:17 +0100

John,

What you describe is the intended behavior.

Thomas

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: john rubis <[email-masked]>
Date: Wed, 15 Nov 2017 22:48:56 +0000

OK. Thank you for confirming.

John

From: Thomas Watteyne [mailto:[email-masked]]
Sent: Wednesday, November 15, 2017 3:43 AM
To: Tengfei Chang <[email-masked]>
Cc: john rubis <[email-masked]>; [email-masked]
Subject: Re: [6tisch] Question/Comment on draft-chang-6tisch-6top-msf

John,

Thomas

On Wed, Nov 15, 2017 at 9:30 AM, Tengfei Chang <[email-masked]<mailto:[email-masked]>> wrote:
Hi John,

Before switching parent, the node still can keep synchronized to it's old parent through the TXRXSHARED cell. That cell is only shared between the node and its parent.
The keepalive on TXRXSHARED cell should be able to keep the node synchronized.

Tengfei

On Wed, Nov 15, 2017 at 12:34 AM, john rubis <[email-masked]<mailto:[email-masked]>> wrote:
I think the MSF draft states/infers this, but I wanted to verify.

Thank  you,

John Rubis

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2F6tisch&data=02%7C01%7Cjohn.rubis%40hotmail.com%7C9b3191bb11f64c8d546608d52c04f87a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636463322211034155&sdata=o8myjc00nARA%2BOGIFt8ezd8LzoLWTyGS2r4hEP7L0lw%3D&reserved=0>

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2F6tisch&data=02%7C01%7Cjohn.rubis%40hotmail.com%7C9b3191bb11f64c8d546608d52c04f87a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636463322211034155&sdata=o8myjc00nARA%2BOGIFt8ezd8LzoLWTyGS2r4hEP7L0lw%3D&reserved=0>

Thomas Watteyne, PhD

www.thomaswatteyne.com<https://eur03.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.thomaswatteyne.com&data=02%7C01%7Cjohn.rubis%40hotmail.com%7C9b3191bb11f64c8d546608d52c04f87a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636463322211034155&sdata=aoReNgMT9kyTShjIPCNIbNDshV6kU11acA214E5l5tE%3D&reserved=0>
_______________________________________