Subject: [6tisch] Wireshark 6P Dissector updated to draft-ietf-6tisch-6top-protocol-10

From: Yasuyuki Tanaka <[email-masked]>
Date: Thu, 22 Mar 2018 09:54:11 +0000

Hi all,

The patch to support draft-ietf-6tisch-6top-protocol-10 has been merged into the master branch of Wireshark. As you can see in the attached picture, a SIGNAL Request is presented in Wireshark. The latest "Bleeding Edge" images having "2.5.2" in their version numbers  should contain this patch. You can download them at:

  https://www.wireshark.org/download/automated/

A sample pcap file containing 6P packets in draft-10 formats is available at the following link:

  https://bugs.wireshark.org/bugzilla/attachment.cgi?id=16227

Note that, at this moment, Payload field in a SIGNAL Response may not be shown as you expect since each 6P packet is dissected in a stateless manner. 

Best,
Yatch

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 22 Mar 2018 11:02:03 +0100

Yatch,
This is great, thanks of the update.
Definitely something we will use at the next interop event!
Thomas

On Thu, Mar 22, 2018 at 10:54 AM, Yasuyuki Tanaka <[email-masked]>
wrote:

> Hi all,
>
> The patch to support draft-ietf-6tisch-6top-protocol-10 has been merged
> into the master branch of Wireshark. As you can see in the attached
> picture, a SIGNAL Request is presented in Wireshark. The latest "Bleeding
> Edge" images having "2.5.2" in their version numbers  should contain this
> patch. You can download them at:
>
> Note that, at this moment, Payload field in a SIGNAL Response may not be
> shown as you expect since each 6P packet is dissected in a stateless
> manner.
>
> Best,
> Yatch
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
________________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Analog Devices
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
________________________________________