Subject: [6tsch] minutes WebEx 8 March 2013

From: Thomas Watteyne <[email-masked]>
Date: Fri, 8 Mar 2013 09:40:11 -0800

All,
Notes of today's meeting below. Please correct inline and reply.
Thomas

---

*** Timestamps in PST. ***

Present:
- Herman Storey
- Maria Rita Palattella
- Norman Finn
- Pascal Thubert
- Qin Wang
- Shitanshu Shah
- Thomas Watteyne
- Tina Tsou
- Tom Phinney
- Xavi Vilajosana

Agenda:
- Introduction to the terminology draft [10min] [Maria Rita]
- Diffserv Recommendations for LLN class of traffic [5min] [Shitanshu]
   -
http://datatracker.ietf.org/doc/draft-svshah-tsvwg-lln-diffserv-recommendations/
- Agenda for new week meetings [10min] [Pascal]
- Changes in other drafts [10min]
   - draft-watteyne-6tsch-tsch-lln-context [Thomas]
   - draft-wang-6tsch-6tus [Qin]
   - draft-thubert-6tsch-architecture [Pascal]
- Mailing list discussions [30min]
   - DSCPs and priorities [Thomas]
   - imux/mux [Qin]

Minutes:
- [08.04] meeting starts
- [08.05] Introduction to the new terminology draft [Maria Rita]
   - [Pascal] This draft extends ROLL and autoconf terminology, which are
included as references.
   - [Maria Rita] Presents slides.
   - [Maria Rita] draft was triggered by the fact that "link" and "path"
have different meaning in TSCH and IETF parlance.
   - [Maria Rita] "Cell": Single element in the TSCH schedule. Replaces
"link" term in TSCH.
   - [Maria Rita] "Bundle": A group of equivalent scheduled cells. Replaces
(although not exactly) "path" term in TSCH.
   - [Maria Rita] Draft there to avoid confusion, we will include other
terms as work progresses.
   - [Maria Rita] Draft will be published on Monday.
- [08.14] Diffserv Recommendations for LLN class of traffic [Shitanshu]
   - draft at
http://datatracker.ietf.org/doc/draft-svshah-tsvwg-lln-diffserv-recommendations/
   - Shitanshu presents slides.
   - Context: this draft was presented at the last IETF meeting in Atlanta.
   - Goal: using Diffserv in context of LLN
   - Motivation: RFC4594 is well documented recommendation for traditional
classes of traffic. Yet, does not cover LLN. What this draft does it:
      - categorize LLN
      - lists explicit recommendations for LLN
      - always keeping RFC4594 as a reference
   - source points to mark appropriate DSCP code point
   - LLN Traffic Classes identified from ROLL requirement drafts
      - 6 categories: alerts/alarms, control signals, deterministic control
signals, Video Monitoring/feed, Query-based data, Periodic Reporting/log &
software downloads.
      - each class characterized in terms of loss, delay and jitter. Some
classes are different from RFC4594, justifying the need for this new draft.
Example: deterministic control signals.
   - [Tom] Alerts/Alarms traffic are bursty because multiple network
elements can signal the same physical events (e.g. explosion).
   - [Herman] You don't want to loose any alert/alarm packets
   - [Shitanshu] Agreed, will update draft.
   - [Herman] Is there a class for network management?
   - [Pascal] In some cases, network control needs to be the highest
priority since network falls apart when no network control packets can be
transmitted.
   - [Pascal] DSCP will play key role in packet priority. There is no DSCP
for flow priority.
   - [Pascal] PHB means "per hop behavior"
   - [Shitanshu] Draft proposed code-point EF
   - [Herman] Why are emergency action outside of IP networks?
   - [Shitanshu] Other techniques are used which are not IP.
   - [Herman] There are IP-based solutions. Operate as dedicated network,
not connected to complete Internet (non routable subnet), but use IP
address.
   - [Shitanshu] We can remove the term IP.
- [08.35] Agenda for new week meetings [Pascal]
   - Tuesday (Caribbean 2):
      - admin
         - we will have 5-10min during the ROLL meeting to present 6tsch
         - 6tsch meeting follows ROLL meeting, same room
         - we need to leave 15min before end to set up next meeting, so we
will really only have one hour.
         - we will have projector, not clear whether we will be able to
provide live online feed.
      - Goal: prepare for successful BoF in Berlin
      - Scope: the backbone with PCE (Path Computation Entity) and one or
more LLN running 6LoWPAN, 6TSCH, RPL.
      - we use draft-phinney-roll-rpl-industrial-applicability as a
starting point.
      - goals and deliverables:
         - informational: LLN context, architecture, terminology
         - new: 6tus, protocol for reserving track
         - adapt existing: OF for RPL, fragment forwarding (problems
because don't have DSCP)
         - extern docs: backbone router (from 6MAN), PCE (is a WG, need to
coordinate)
      - dependencies and liaison:
         - IEEE 802.1TSN (Norman)
         - ISA100.20 are defining arbstraction for management layer to
manage the managers (e.g. blacklist channels). We could use same formats.
         - IoT6. European project. They use very similar architecture as
ours.
   - Wednesday (Boca 2)
      - admin:
         - in Boca 2, which we can stay in past 1pm.
      - we will go over different drafts
         - draft-phinney-roll-rpl-industrial-applicability.
            - published at
http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02
            - [Tom] Analysis of classifications of types of communications
that occur. Applies to all automation systems, worked out over years by
many people.
            - [Pascal] Good source of inspiration.
         - draft-watteyne-6tsch-tsch-lln-context
            - published at
http://tools.ietf.org/html/draft-watteyne-6tsch-tsch-lln-context-01
            - [Thomas] do not expect -02 for Orlando, but will need
rewording for new terminology.
         - draft-wang-6tsch-6tus
            - [Pascal] Caution, we cannot reinvent MPLS.
            - [Xavi] will be published on Monday.
         - draft-palattella-6tsch-terminology
            - see presentation above
            - will be published on Monday.
         - draft-thubert-6tsch-architecture
            - [Pascal] will be work-in-progress for a long time, since
incorporates changes/concepts from other drafts.
            - [Pascal] More text to follow: network synchronization, 6tus,
management, etc.
            - [Thomas] Can be seen a index for other drafts, could serve as
first draft to read when familiarizing with 6tsch.
- [08.55] Priority discussion
   - [Thomas] We don't have much time left, so instead of starting
discussion, will prepare slides for Wednesday meeting.
   - [Pascal] Will add slot for Wednesday meeting.
   - [Pascal] Pascal will meet with Shitanshu on Monday morning, Thomas
will meet with Pascal on Monday evening and Tuesday.
- [10.00]
   - [Thomas] Will be meeting stay at this time?
   - [Tom,Pascal] For the moment yes
   - [Pascal] There is not call next week because of IETF meeting.
- [10.05] Meeting ends.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Mar 2013 14:09:29 -0500

>>>>> "Thomas" == Thomas Watteyne <[email-masked]> writes:
    Thomas> Tuesday (Caribbean 2): - admin - we will have 5-10min during
    Thomas> the ROLL meeting to present 6tsch - 6tsch meeting follows
    Thomas> ROLL meeting, same room 

Further, the 6tsch is *last* on the ROLL agenda, and I do not think that
ROLL will fill the entire 2.5 hours allocated.

    Thomas> - we need to leave 15min before end
    Thomas> to set up next meeting, so we will really only have one
    Thomas> hour.  - we will have projector, not clear whether we will
    Thomas> be able to provide live online feed.  - Goal: prepare for

generally, the microphones stay on (and live) through-out lunch.
It's often fun to listen after a session ends, as most people chatting
near the chair's table don't know the mic is on...  the things you can
learn...

    Thomas> (Norman) - ISA100.20 are defining arbstraction for
    Thomas> management layer to manage the managers (e.g. blacklist
    Thomas> channels). We could use same formats.  - IoT6. European
    Thomas> project. They use very similar architecture as ours.  -

Does ISA100.20 include a protocol for communication with a PCE?

    Thomas> in past 1pm.  - we will go over different drafts -
    Thomas> draft-phinney-roll-rpl-industrial-applicability.  -
    Thomas> published at
    Thomas> http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02

will become draft-ietf-roll-industrial-applicability soon.
Note that ID document submission tool *opens* again on Monday morning,
but do not assume anyone has read new documents.

-- 
Michael Richardson
-on the road-