Subject: [6tsch] IEEE considering proposed changes to 802.15.4e

From: Robert Assimiti <[email-masked]>
Date: Wed, 10 Apr 2013 21:26:15 +0000

Just wanted to let everyone know that IEEE has received an ETSI request to change various things in the IEEE 802.15.4e spec.

These changes would most definitely render IEEE 802.15.4e not backward compatible.

Please see the e-mail below.

Robert Assimiti

From: ***** IEEE stds-802-15 General List ***** [mailto:[email-masked]] On Behalf Of Bob Heile
Sent: Saturday, April 06, 2013 2:27 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [802.15-GENERAL-LIST] Proposed Changes to 15.4e submitted by ETSI TC ERM

Dear 802.15 Participants and Interested Parties--

As a result of input received from ETSI TC ERM, the IEEE 802.15 Work Group (WG) is in the process of considering a number of significant changes to IEEE 802.15.4, Low-Rate Wireless Personal Area Networks (LR-WPANs).  Since these proposed changes impact backward compatibility for some uses of IEEE 802.15.4e-2012, the Working Group is soliciting input from Standard Development Organizations (SDOs), Industry Associations, businesses, and individuals that may have an interest in the outcome, before deciding on a course of action.

The proposed changes are summarized here:
*         Use a Frame Type ID value, as an extension, to indicate that the following bits are new Frame types,
*         Restructure Information Element IDs to allow IDs to be assigned to external SDOs
*         Change the order of the Information Element Length and Type fields.

The latter two are the ones potentially affecting backward compatibility. Further information on this matter can be found in document 15-13-0220-02-0000<https://mentor.ieee.org/802.15/dcn/13/15-13-0220-02-0000-802-15-wg-request-for-participation.docx>. (https://mentor.ieee.org/802.15
/dcn/13/15-13-0220-02-0000-802-15-wg-request-for-participation.docx)

Anybody who believes they would be impacted, either because these changes were implemented or not implemented, is invited to register, attend, and present their opinion for discussion and debate at the May IEEE 802.15 Meeting.  Alternatively, if attendance and direct participation is not possible, commenters are invited to submit a document, declaring their stance and how the changes, either implemented or not, impact their use of IEEE 802.15.4. These should be sent to Bob Heile, Chair 802.15 and/or Pat Kinney, Vice Chair 802.15 ([email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>)

The IEEE 802.15 Working Group's next meeting will be May 12-17, 2013 at the Hilton Waikoloa Village, Big Island, HI, USA.  More information on this meeting can be found at http://grouper.ieee.org/groups/802/15/pub/Meeting_Plan.html).

Bob Heile, Ph.D
Chairman Emeritus & Chief Technologist, ZigBee Alliance
Chair, IEEE 802.15 Working Group on Wireless Personal Area Networks
Co-Chair IEEE P2030 Task Force 3 on Smartgrid Communications
11 Robert Toner Blvd
Suite 5-301
North Attleboro, MA  02763   USA
Mobile: +1-781-929-4832
email:   [email-masked]<mailto:[email-masked]>

---

From: Thomas Herbst <[email-masked]>
Date: Thu, 11 Apr 2013 23:06:02 +0000

People should review and comment to IEEE.

The frame id changes would be backward compatible — this work should have been done some time ago (IMHO).

Identifying the IE's can be done in a backwards compatible manner, though people may have used unregistered or managed IE's that could be impacted.

The third issue may be larger for existing implementations that use e4 ie's – there is disagreement as the appropriate ordering of the parameters.

Larry Taylor's presentation is at -

https://mentor.ieee.org/802.15/dcn/13/15-13-0194-01-0mag-802-15-4-use-by-external-sdos.pdf

Now resuming your regular IETF content -

tom

From: Robert Assimiti <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 10, 2013 2:26 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [6tsch] IEEE considering proposed changes to 802.15.4e

Robert Assimiti

The proposed changes are summarized here:
·         Use a Frame Type ID value, as an extension, to indicate that the following bits are new Frame types,
·         Restructure Information Element IDs to allow IDs to be assigned to external SDOs
·         Change the order of the Information Element Length and Type fields.

Bob Heile, Ph.D

---

From: Kris Pister <[email-masked]>
Date: Thu, 11 Apr 2013 17:04:11 -0700

Tom - I'm surprised the you seem to be in favor of this.  I agree that 
there are some things in 4e that should have been done some time ago.  
But the fact is that they weren't.  No standard is perfect.  If these 
were really egregious errors they would have been fixed earlier.
In fact, it's clear that none of these things *needs* to be changed.  
It's just a question of convenience - the convenience of another 
standards body that doesn't see things exactly the same way as the group 
that voted on 4e.  Some of the suggested changes are just plain bad.  
They will re-open long arguments that don't need to be re-opened, and 
once again retard the ever-so-gentle swell of momentum that we seem to 
be experiencing.

I am opposed to changing 4e in any way.  It was the work of many people 
over five years, and it's done.  It should stay done.

ksjp

On 4/11/2013 4:06 PM, Thomas Herbst wrote:
> The frame id changes would be backward compatible --- this work should 
> have been done some time ago (IMHO).
>
> Identifying the IE's can be done in a backwards compatible manner, 
> though people may have used unregistered or managed IE's that could be 
> impacted.
>
> The third issue may be larger for existing implementations that use e4 
> ie's -- there is disagreement as the appropriate ordering of the 
> parameters.
>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> Just wanted to let everyone know that IEEE has received an ETSI 
> request to change various things in the IEEE 802.15.4e spec.
>
> *Robert Assimiti*
> *From:****** IEEE stds-802-15 General List ***** 
> [mailto:[email-masked]] *On Behalf Of *Bob Heile
> *Sent:* Saturday, April 06, 2013 2:27 AM
> *To:* [email-masked] 
> <mailto:[email-masked]>
> *Subject:* [802.15-GENERAL-LIST] Proposed Changes to 15.4e submitted 
> by ETSI TC ERM
>
> As a result of input received from ETSI TC ERM, the IEEE 802.15 Work 
> Group (WG) is in the process of considering a number of significant 
> changes to IEEE 802.15.4, Low-Rate Wireless Personal Area Networks 
> (LR-WPANs). Since these proposed changes impact backward compatibility 
> for some uses of IEEE 802.15.4e-2012, the Working Group is soliciting 
> input from Standard Development Organizations (SDOs), Industry 
> Associations, businesses, and individuals that may have an interest in 
> the outcome, before deciding on a course of action.
>
> ·         Change the order of the Information Element /Length/ and 
> /Type/ fields.
>
> The latter two are the ones potentially affecting backward 
> compatibility. Further information on this matter can be found in 
> document 15-13-0220-02-0000 
> <https://mentor.ieee.org/802.15/dcn/13/15-13-0220-02-0000-802-15-wg-request-for-participation.docx>. 
> (/https://mentor.ieee.org/802.15
> /dcn/13/15-13-0220-02-0000-802-15-wg-request-for-participation.docx/)
>
> Anybody who believes they would be impacted, either because these 
> changes were implemented or not implemented, is invited to register, 
> attend, and present their opinion for discussion and debate at the May 
> IEEE 802.15 Meeting.  Alternatively, if attendance and direct 
> participation is not possible, commenters are invited to submit a 
> document, declaring their stance and how the changes, either 
> implemented or not, impact their use of IEEE 802.15.4. These should be 
> sent to Bob Heile, Chair 802.15 and/or Pat Kinney, Vice Chair 802.15 
> ([email-masked] <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>)
>
> The IEEE 802.15 Working Group's next meeting will be May 12-17, 2013 
> at the Hilton Waikoloa Village, Big Island, HI, USA.  More information 
> on this meeting can be found at 
> http://grouper.ieee.org/groups/802/15/pub/Meeting_Plan.html) 
> <http://grouper.ieee.org/groups/802/15/pub/Meeting_Plan.html%29>.
>
>
> Bob Heile, Ph.D
> email: [email-masked] <mailto:[email-masked]>
>
>
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch

---

From: Thomas Herbst <[email-masked]>
Date: Fri, 12 Apr 2013 02:10:38 +0000

Again, I think this is and IEEE discussion, not an IETF discussion, but I'll bite.
I would encourage you (and others) to submit those opinions for the May 802 meeting.

The frame type change is needed just for IEEE work - the last free bit was just allocated.
Doing nothing is not really an option here and (imho) this should have been done long ago.

Managing the IE's in a way that others could get allocation is minor.

We could live with the TLV that are LTV's, but would like the issue decided one way or another as quickly as possible.

tom
________________________________
From: [email-masked] [[email-masked]] on behalf of Kris Pister [[email-masked]]
Sent: Thursday, April 11, 2013 5:04 PM
To: [email-masked]
Subject: Re: [6tsch] IEEE considering proposed changes to 802.15.4e

Tom - I'm surprised the you seem to be in favor of this.  I agree that there are some things in 4e that should have been done some time ago.  But the fact is that they weren't.  No standard is perfect.  If these were really egregious errors they would have been fixed earlier.
In fact, it's clear that none of these things *needs* to be changed.  It's just a question of convenience - the convenience of another standards body that doesn't see things exactly the same way as the group that voted on 4e.  Some of the suggested changes are just plain bad.  They will re-open long arguments that don't need to be re-opened, and once again retard the ever-so-gentle swell of momentum that we seem to be experiencing.

I am opposed to changing 4e in any way.  It was the work of many people over five years, and it's done.  It should stay done.

ksjp

tom

Robert Assimiti

The IEEE 802.15 Working Group's next meeting will be May 12-17, 2013 at the Hilton Waikoloa Village, Big Island, HI, USA.  More information on this meeting can be found at http://grouper.ieee.org/groups/802/15/pub/Meeting_Plan.html)<http://grouper.ieee.org/groups/802/15/pub/Meeting_Plan.html%29>.

Bob Heile, Ph.D

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch