Subject: [6tsch] draft agenda for call on April 12

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 11 Apr 2013 17:04:24 +0000

Dear all:

Please find a draft agenda for the 6TSCH call Friday.

The focus will be on the preparation of a charter, with a discussion on the current draft:

  *   update work on PANA [Yoshi]                          5mn
  *   Conclude work on NSIS [Xavi, John]                 5mn
  *   Review / finalize archi 01 [Pascal]                  5mn
  *   discuss charter:                                              45mn
Note: the charter WIP came be found here: https://bitbucket.org/6tsch/charter-ietf-6tsch/src
Please let us know if you wish to add / change stuff in this list,
... and remember that the call will be recorded ...
Cheers;
Thomas and Pascal

Call info :

Topic:    6TSCH Weekly

Date:     Every Friday, from Friday, April 5, 2013 to Friday, March 7, 2014

Time:     8:00 am, Pacific Daylight Time (San Francisco, GMT-07:00)

Meeting Number:           206 802 913

Meeting Password:         sixtus

-------------------------------------------------------
To start the online meeting
-------------------------------------------------------

1.   Go to https://cisco.webex.com/cisco/j.php?ED=219615007&UID=481905242&PW=NZTRkNDAwOTE1&RT=MiM0

2.   Log in to your account.

3.   Click "Start Now".

4.   Follow the instructions that appear on your screen.

----------------------------------------------------------------
ALERT:Toll-Free Dial Restrictions for (408) and (919) Area Codes
----------------------------------------------------------------

The affected toll free numbers are: (866) 432-9903 for the San Jose/Milpitas area and (866) 349-3520 for the RTP area.

Please dial the local access number for your area from the list below:

*         San Jose/Milpitas (408) area:  525-6800

*         RTP (919) area:  392-3330

-------------------------------------------------------
To join the teleconference only
-------------------------------------------------------
1.         Dial into Cisco WebEx (view all Global Access Numbers at
http://cisco.com/en/US/about/doing_business/conferencing/index.html <http://cisco.com/en/US/about/doing_business/conferencing/index.html%20%0d2>
2<http://cisco.com/en/US/about/doing_business/conferencing/index.html%20%0d2>.         Follow the prompts to enter the Meeting Number (listed above) or Access Code followed by the # sign.

San Jose, CA: +1.408.525.6800  RTP: +1.919.392.3330

US/Canada: +1.866.432.9903  United Kingdom: +44.20.8824.0117

India: +91.80.4350.1111  Germany: +49.619.6773.9002

Japan: +81.3.5763.9394  China: +86.10.8515.5666

To check whether you have the appropriate players installed for UCF (Universal Communications Format) rich media files, go to https://cisco.webex.com/cisco/systemdiagnosis.php.

CCM:+14085256800x206802913#

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 11 Apr 2013 21:29:12 -0700

All,

I'm attaching the slides we can use to discuss the draft charter during the
call tomorrow, as well as the text itself.

As pointed out in the previous e-mail, please note that the latest versions
of both are available at https://bitbucket.org/6tsch/charter-ietf-6tsch/src.

Thomas

On Thu, Apr 11, 2013 at 10:04 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Dear all:****
>
> ** **
>
> Please find a draft agenda for the 6TSCH call Friday. ****
>
> ** **
>
> The focus will be on the preparation of a charter, with a discussion on
> the current draft:****
>
>    - update work on PANA [Yoshi]             *             *5mn ****
>    - Conclude work on NSIS [Xavi, John]                 5mn  ****
>    - Review / finalize archi 01 [Pascal]                  5mn  ****
>    - discuss charter:           **
>    45mn  ****
>
> Note: the charter WIP came be found here:
> https://bitbucket.org/6tsch/charter-ietf-6tsch/src ****
>
> Please let us know if you wish to add / change stuff in this list,****
>
> … and remember that the call will be recorded …****
>
> Cheers;****
>
> Thomas and Pascal****
>
> ** **
>
> Call info : ****
>
> Topic:    6TSCH Weekly****
>
> ****
> Time:     8:00 am, Pacific Daylight Time (San Francisco, GMT-07:00)****
>
> Meeting Number:           206 802 913****
>
> Meeting Password:         sixtus****
>
> ** **
>
> -------------------------------------------------------****
>  To start the online meeting****
>
> -------------------------------------------------------****
>
> 1.   Go to
> https://cisco.webex.com/cisco/j.php?ED=219615007&UID=481905242&PW=NZTRkNDAwOTE1&RT=MiM0
> ****
>
> 2.   Log in to your account.****
>
> 3.   Click “Start Now”.****
>
> 4.   Follow the instructions that appear on your screen.****
>
> ** **
>
> ----------------------------------------------------------------****
>  ALERT:Toll-Free Dial Restrictions for (408) and (919) Area Codes****
>
> ----------------------------------------------------------------****
>
> ** **
>
> The affected toll free numbers are: (866) 432-9903 for the San
> Jose/Milpitas area and (866) 349-3520 for the RTP area.****
>
> Please dial the local access number for your area from the list below:****
>
> **·         **San Jose/Milpitas (408) area:  525-6800****
>
> **·         **RTP (919) area:  392-3330****
>
> ** **
>
> ------------------------------------------------------- ****
> To join the teleconference only ****
>
> ------------------------------------------------------- ****
> 1.         Dial into Cisco WebEx (view all Global Access Numbers at **** http://cisco.com/en/US/about/doing_business/conferencing/index.html
>
> <http://cisco.com/en/US/about/doing_business/conferencing/index.html%20%0d2>
> **** 2<http://cisco.com/en/US/about/doing_business/conferencing/index.html%20%0d2>.
> Follow the prompts to enter the Meeting Number (listed above) or Access
> Code followed by the # sign. ****
>
> ** **
>
> San Jose, CA: +1.408.525.6800  RTP: +1.919.392.3330 ****
>
> US/Canada: +1.866.432.9903  United Kingdom: +44.20.8824.0117 ****
>
> India: +91.80.4350.1111  Germany: +49.619.6773.9002 ****
>
> Japan: +81.3.5763.9394  China: +86.10.8515.5666****
>
> To check whether you have the appropriate players installed for UCF
> (Universal Communications Format) rich media files, go to
> https://cisco.webex.com/cisco/systemdiagnosis.php.****
>
> CCM:+14085256800x206802913# ****
>
> ** **
>

---

From: Michael Richardson <[email-masked]>
Date: Fri, 12 Apr 2013 09:21:53 -0400

I have read the slides.  I don't know if I'll make the call today or
not. I am pleased by the progress and the very clear focus presented in
the slides.

slide 9:

"This document (or documents) will define how to bootstrap a 6TSCH
 network, "

I think that this might be too big a statement.  I don't think that
6TSCH proposes to solve the *security* bootstraping, but rather the
bootstrapping of the schedule.  Perhaps that's implied by saying *6TSCH*
network, but it's easy to miss that.

I suggest changing this to:

 "This document (or documents) will define how to bootstrap the 6TSCH
  aspects of the LLN and the IPv6 transit links"

<WG CO-CHAIR HAT ON>
***
*** Given the dependancy that draft-ietf-roll-rpl-industrial-applicability-00 
*** has on this work, I wonder if this "BOF" effort would like to suggest
*** text changes to the charter of the ROLL WG to the IESG.
***
*** Would this WG like to adopt the above work item?  
***
</WG>

I suggest not setting milestone dates until after primary authors for 
each work item have been found, and until chairs are selected.

As for the question about security:  I recommend that the initial
charter make security *solutions* out of scope.  Why? because we have
many solutions and many related problems and the various technologies
proposed (NSIS, RSVP, PCE3, etc) may have their own security solutions
already.   

Then plan to recharter after the technologies are chosen in the
architecture, but before things are fully baked.

Every document will have a Security Considerations section, and this
needs to be written with the rest of the document, and should ask many
questions. 

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 12 Apr 2013 07:50:41 -0700

Michael,
Thanks for going through the material. I'll make sure we discuss them in
today's call.
Thomas

On Fri, Apr 12, 2013 at 6:21 AM, Michael Richardson
<[email-masked]>wrote:

> *** Given the dependancy that
> draft-ietf-roll-rpl-industrial-applicability-00
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: Michael Richardson <[email-masked]>
Date: Fri, 12 Apr 2013 12:57:51 -0400

On the 6tsch I wrote:

** Given the apparent dependancy that
   draft-ietf-roll-rpl-industrial-applicability-00 
   has on the 6tsch work, I wonder if this "BOF" effort would like to
   suggest text changes to the charter of the ROLL WG to the IESG.

** Would the 6tsch WG/BOF like to adopt the above work item?

In further thinking this morning while unblock the shower drain, I
realized that there are a number of additional options.

From draft-ietf-roll-rpl-industrial-applicability-00:

>   It appears from the above sections that whether and the way RPL can
>   be applied for a given flow depends both on the deployment scenario
>   and on the class of application / traffic.  At a high level, this can
>   be summarized by the following matrix:
>
>
>+---------------------+------------------------------------------------+
>|   Phase \  Class    |   0       1       2       3       4       5    |
>+=====================+================================================+
>|   Construction      |                   X       X       X       X    |
>+---------------------+------------------------------------------------+
>|   Planned startup   |                   X       X       X       X    |
>+---------------------+------------------------------------------------+
>|   Normal operation  |                           ?       ?       ?    |
>+---------------------+------------------------------------------------+
>|   Planned shutdown  |                   X       X       X       X    |
>+---------------------+------------------------------------------------+
>|Plant decommissioning|                   X       X       X       X    |
>+---------------------+------------------------------------------------+
>| Recovery and repair |   X       X       X       X       X       X    |
>+---------------------+------------------------------------------------+
>
> ? : typically usable for all but higher-rate classes 0,1 PS traffic
>
>                    Figure 1: RPL applicability matrix

my understanding is that "Normal Operation" is when the 6tsch schedules
are really necessary.  The rest of the time a non-timeslotted system
might be perfectedly acceptable.

So additional options would be for 
   draft-ietf-roll-rpl-industrial-applicability
to become
   draft-ietf-roll-rpl-industrial-nonnormal-applicability

and for a new document:
   draft-ietf-6tsch-rpl-industrial-normal-applicability

to come to exist.

This would mean that the current document would essentially declare
normal operation to be out of scope (punt at 6tsch for this), and for
the document to get finished.

That would remove 6tsch as a blocker for this document.
It's not the only option on how to do things.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [