Subject: [6tsch] Questions on 802.15.4e MAC

From: <[email-masked]>
Date: Mon, 10 Jun 2013 10:29:55 +0000

Hi,

I am working on Security Considerations section of 6tsch-security document, and I have a couple of questions on 802.15.4e MAC.

I think TSCH-specific information elements (IEs) contained in enhanced Beacon frames must be integrity protected but must be sent in clear text.  The reason is that not only nodes that already have joined the TSCH network (and thus have link-layer keys) but also newly joining nodes that do not have link-layer keys yet will have to know the content of the TSCH-specific IEs in order to know the timeslots available for exchanging authentication and key management messages to securely join the TSCH network.  

I have two questions:

- Is the above observation correct?

- Are 802.15.4e header and payload IEs excluded from the encrypted part of 802.15.4e MAC frame even when MAC security is used with encryption enabled?

Best Regards,
Yoshihiro Ohba

---

From: Pat Kinney <[email-masked]>
Date: Mon, 10 Jun 2013 09:23:26 -0500

header IEs are excluded from the 15.4 encryption, while payload IEs are included; hence the rationale for having both

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]

On Jun 10, 2013, at 5:29 AM, <[email-masked]> wrote:

Hi,

I have two questions:

Best Regards,
Yoshihiro Ohba

_______________________________________________
6tsch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tsch

---

From: "Qin Wang" <[email-masked]>
Date: Mon, 10 Jun 2013 08:09:54 -0700

Hi Pat,

In IEEE802.15.4e, the EB of TSCH consists of four IEs, i.e. TSCH
Synchronization IE, TSCH Slotframe and Link IE, TSCH Timeslot IE, and
Channel Hopping Sequence IE. All of the four IEs are in payload-IE.

So, it means that the EB of TSCH is included when MAC security is used
with encryption enabled. Correct?

Thanks
Qin

> header IEs are excluded from the 15.4 encryption, while payload IEs are
> included; hence the rationale for having both
>
> Pat
>
> Pat Kinney
> Kinney Consulting LLC
> I am working on Security Considerations section of 6tsch-security
> document, and I have a couple of questions on 802.15.4e MAC.
>
> I think TSCH-specific information elements (IEs) contained in enhanced
> Beacon frames must be integrity protected but must be sent in clear text.
> The reason is that not only nodes that already have joined the TSCH
> network (and thus have link-layer keys) but also newly joining nodes that
> do not have link-layer keys yet will have to know the content of the
> TSCH-specific IEs in order to know the timeslots available for exchanging
> authentication and key management messages to securely join the TSCH
> network.
>
> I have two questions:
>
> - Are 802.15.4e header and payload IEs excluded from the encrypted part of
> 802.15.4e MAC frame even when MAC security is used with encryption
> enabled?
>
> Best Regards,
> Yoshihiro Ohba
>
>

---

From: <[email-masked]>
Date: Tue, 11 Jun 2013 10:20:04 +0000

Even if those IEs in the enhanced Beacon frame are not encrypted, if they are integrity protected, then 802.15.4 MAC would discard the before processing the IEs since it does not have a key to verify the integrity of the frame.

If this is the case, then it would mean that enhanced Beacon frames for TSCH MAC have to be unsecured anyways so that joining nodes who do not have keys can process the frames.  I think this could be a security issue for TSCH.

Regards,
Yoshihiro Ohba

-----Original Message-----
From: Qin Wang [mailto:[email-masked]] 
Sent: Tuesday, June 11, 2013 12:10 AM
To: Pat Kinney
Cc: ohba yoshihiro(大場 義洋 ○ＲＤＣ□ＮＳＬ); [email-masked]
Subject: Re: [6tsch] Questions on 802.15.4e MAC

Hi Pat,

In IEEE802.15.4e, the EB of TSCH consists of four IEs, i.e. TSCH Synchronization IE, TSCH Slotframe and Link IE, TSCH Timeslot IE, and Channel Hopping Sequence IE. All of the four IEs are in payload-IE.

So, it means that the EB of TSCH is included when MAC security is used with encryption enabled. Correct?

Thanks
Qin

> header IEs are excluded from the 15.4 encryption, while payload IEs 
> are included; hence the rationale for having both
>
> Pat
>
> Pat Kinney
> Kinney Consulting LLC
> network (and thus have link-layer keys) but also newly joining nodes 
> that do not have link-layer keys yet will have to know the content of 
> the TSCH-specific IEs in order to know the timeslots available for 
> exchanging authentication and key management messages to securely join 
> the TSCH network.
>
> I have two questions:
>
> - Are 802.15.4e header and payload IEs excluded from the encrypted 
> part of 802.15.4e MAC frame even when MAC security is used with 
> encryption enabled?
>
> Best Regards,
> Yoshihiro Ohba
>
>

---

From: Jonathan Simon <[email-masked]>
Date: Wed, 12 Jun 2013 12:02:26 -0700

In our 4e stack we define a pre-shared key used to authenticate enhanced beacons.  4e allows you to elide the key index in the auxiliary security header, but 15.4 defines a number of ways to indicate what key (from a pre-defined list) is used to authenticate a particular frame.

-- 
Jonathan Simon, Ph. D
Director of Systems Engineering
Linear Technology, Dust Networks product group
30695 Huntwood Ave
Hayward, CA 94544-7021
(510) 400-2936
(510) 489-3799 FAX
[email-masked]

**LINEAR TECHNOLOGY CORPORATION** 
*****Internet Email Confidentiality Notice***** 
 This e-mail transmission, and any documents, files or previous e-mail messages attached to it may contain confidential information that is legally privileged. If you are not the intended recipient, or a person responsible for delivering it to the intended recipient, you are hereby notified that any disclosure, copying, distribution or use of any of the information contained in or attached to this transmission is STRICTLY PROHIBITED. If you have received this transmission in error, please immediately notify me by reply e-mail, or by telephone at (510) 400-2936, and destroy the original transmission and its attachments without reading or saving in any manner. Thank you.