Subject: [6tsch] rank, Dagrank(rank) and Join Priority

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Mon, 7 Oct 2013 12:51:17 -0700

Hi,

I am reviewing the minimal draft and I want to clarify one thing:

according to RFC6550

DAGRank(rank) = floor(rank/MinHopRankIncrease)

the RFC does not specify whether DAGRank(rank) is a 16bit integer or a 8bit
integer (or another type) but if MinHopRankIncrease is 256, then for sure
that the result of DAGRank(rank) will be smaller than 256 and hence will
fit in an 8bit variable.

If that is the case then the join priority field can be exactly
DAGRank(rank) and we do not need to do this shifting that we've been
discussing so far.

Now the minimal draft states that Join Priority == DAGRank(rank)

should I clarify there that this assumes that DAGRank(rank) is an 8bit
integer. In case it is not an 8bit integer then we need to shift it to
consider the most significant 8 bits.

Do you agree on that?

sorry to come back again to the topic but I want to close it asap :-)
X

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 7 Oct 2013 22:25:15 +0000

Hello Xavi

Yes you can safely insist that the floor is one octet because we force min increae to 256, no problem there, in fact it is a design point 😊

Cheers

Pascal

> Le 7 oct. 2013 à 21:52, "Xavier Vilajosana Guillen" <[email-masked]> a écrit :
> 
> Hi,
> 
> the RFC does not specify whether DAGRank(rank) is a 16bit integer or a 8bit integer (or another type) but if MinHopRankIncrease is 256, then for sure that the result of DAGRank(rank) will be smaller than 256 and hence will fit in an 8bit variable.
> 
> If that is the case then the join priority field can be exactly DAGRank(rank) and we do not need to do this shifting that we've been discussing so far.
> 
> should I clarify there that this assumes that DAGRank(rank) is an 8bit integer. In case it is not an 8bit integer then we need to shift it to consider the most significant 8 bits. 
> 
> Do you agree on that? 
> 
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch