Subject: [74attendees] Meeting calendar in iCal?

From: Franck Martin <[email-masked]>
Date: Thu, 19 Mar 2009 15:40:45 +1200 (ANAT)

Is there a way to export meetings into iCal format?

---

From: Richard Barnes <[email-masked]>
Date: Wed, 18 Mar 2009 23:42:36 -0400

<http://tools.ietf.org/agenda/74/calendar>

On Wed, Mar 18, 2009 at 11:40 PM, Franck Martin <[email-masked]> wrote:
> _______________________________________________
> 74attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/74attendees
>
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 19 Mar 2009 00:18:00 -0400

If you generate a calendar with time zone information and open it with
Outlook, the events are one hour too late. Perhaps there's a DST bug?

Cheers,
Andy

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 19 Mar 2009 07:44:19 +0100

> Outlook, the events are one hour too late. Perhaps there's a DST bug?

Everything is fine in iCal on the Mac.

You are aware that the US is already in DST but Europe isn't, right?  
(Although that would make everything an hour earlier.)

---

From: Tony Li <[email-masked]>
Date: Wed, 18 Mar 2009 22:53:47 -0700

> <http://tools.ietf.org/agenda/74/calendar>

Has anyone found a calendar that can properly deal with the result? 
I've tried Outlook, Thunderbird and Sunbird.  All fail in various ways.

Tony

---

From: Joe Touch <[email-masked]>
Date: Thu, 19 Mar 2009 03:53:09 -0700

Tony Li wrote:
> Has anyone found a calendar that can properly deal with the result? I've
> tried Outlook, Thunderbird and Sunbird.  All fail in various ways.

Hi, Tony,

I downloaded an ICS without timezones, and it worked fine in Outlook.
Are you having problems with timezones, or something else?

Joe

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 19 Mar 2009 08:15:47 -0400

Joe,

Are you on Pacific Time?

I'm going to try to wait until I'm in California and then import a
calendar without timezones, so everything should by synced with local
time.

Tony, I know that you're on Pacific time. It's funny that you and Joe
get different results.

Cheers,
Andy

On Thu, Mar 19, 2009 at 6:53 AM, Joe Touch <[email-masked]> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
>
>
> Tony Li wrote:
>> Richard Barnes wrote:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (MingW32)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
> iEYEARECAAYFAknCJBQACgkQE5f5cImnZru/EgCZAU/7xU3xKkcVnVBkGJBsPIU2
> NKIAoLIU6mq+10XS2ekG96irFwO3F4Cf
> =OCs2
> -----END PGP SIGNATURE-----

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 19 Mar 2009 09:03:50 -0400

I've got another data point. I'm currently on US east coast time. I
just subscribed to the generated .ics with timezone infomation using
iCal on my Mac (OS X 10.5.6), and that worked perfectly - everything
is offset by the expected three hours. So perhaps it's an Outlook 2007
problem rather than a problem with the generated .ics. When I tried
the same with Outlook 2007 under Windows, the offset is four hours.

Cheers,
Andy

---

From: Joe Touch <[email-masked]>
Date: Thu, 19 Mar 2009 06:13:25 -0700

> Are you on Pacific Time?

Actually, I'm on CET (central europe) today, but I always import entries
without timzones.

> Tony, I know that you're on Pacific time. It's funny that you and Joe

I'm running Vista/Outlook 2007, FYI, and syncing to an iPhone. It all
works fine.

Joe

---

From: "David B Harrington" <[email-masked]>
Date: Thu, 19 Mar 2009 10:34:46 -0400

Hi,

I'm using outlook 2003 on XP and had a similar problem.
I do not seem to have the problem now. 
I apparently solved it, but I'm not sure what caused it.

Make sure your sytem clock timezone settings include "adjust for
daylight savings"
 
I import the agenda with timezones, and have two timezones showing on
my Calendar Day view. If you click above the timezone area, you will
get a popup menu that includes "change timezone". Go to that submenu.
I selected "adjust for Daylight Savings" on EST, but not for PST, and
that seems to get it straight. 

It doesn't seem like it should, though. Someplace there's a problem
that this just offsets.

David Harrington
[email-masked]
[email-masked]
[email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andrew G. Malis
> Sent: Thursday, March 19, 2009 9:04 AM
> To: Joe Touch
> Cc: Richard Barnes; [email-masked]
> Subject: Re: [74attendees] Meeting calendar in iCal?
>

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 19 Mar 2009 11:46:50 -0400

> I'm using outlook 2003 on XP and had a similar problem.

There used to be a very odd Outlook treatment of the 2 week period of  
the "new" extension of Daylight savings
time in the US. It worked, as long as you didn't have to compare times  
with anyone not using Outlook.

Once you were back into the "normal" (i.e., old) DST period, things  
went back to normal.

I don't know if this is still an issue or not.

Marshall

>>>> -----END PGP SIGNATURE-----

Marshall Eubanks
CTO / Iformata Communications
[email-masked]

---

From: "David B Harrington" <[email-masked]>
Date: Thu, 19 Mar 2009 11:57:32 -0400

Hi,

I know I applied a patch to handle this for 2008. I haven't checked
whether another patch is need to handle this for 2009.

dbh 

> From: Marshall Eubanks [mailto:[email-masked]] 
> Sent: Thursday, March 19, 2009 11:47 AM
> To: David B Harrington
> Cc: 'Andrew G. Malis'; 'Joe Touch'; 'Richard Barnes'; 
> [email-masked]

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 19 Mar 2009 21:05:40 +0100

On 19 mrt 2009, at 10:52, Franck Martin wrote:

> Is that because timezone support on OS X is poor?

You mean that it works without problems because there is a bug? Seems  
unlikely. I'm also reasonably sure that pacific time is one of the  
better tested time zones in MacOS.

> I know about 3-4 timezones that do not exists on mac

> I have tried to report this issue but I'm at a loss on where to file  
> this bug

If you sign up as a developer at developer.apple.com, you can file  
bugs in Apple's bugreporter. They don't always fix bugs but at least  
you can be sure that it will be looked at.

---

From: Richard Bennett <[email-masked]>
Date: Thu, 19 Mar 2009 13:24:45 -0700

Doesn't anybody in IETF use open source? I imported a time zone 
info-bearing .ics file for Thunderbird/Lightning and it was an hour 
late; downloading the no time zone file was cool, but I'm in PDT anyhow.

It's a cool tool, BTW.

RB

-- 
Richard Bennett

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 19 Mar 2009 21:35:15 +0100

On 19 mrt 2009, at 21:24, Richard Bennett wrote:

> Doesn't anybody in IETF use open source? I imported a time zone info- 
> bearing .ics file for Thunderbird/Lightning and it was an hour late;  
> downloading the no time zone file was cool, but I'm in PDT anyhow.

Well, I had a look at the .ics file. Seems strange that the TZNAME for  
STANDARD is PST and for DAYLIGHT it's CDT.

BEGIN:VTIMEZONE
TZID:US/Pacific
BEGIN:STANDARD
TZOFFSETFROM:-0800
TZOFFSETTO:-0900
TZNAME:PST
DTSTART:20070311T020000
RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=11
END:STANDARD
BEGIN:DAYLIGHT
TZOFFSETFROM:-0900
TZOFFSETTO:-0800
TZNAME:CDT
DTSTART:20070311T020000
RRULE:FREQ=YEARLY;BYDAY=2SU;BYMONTH=3
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
DTSTART;TZID="US/Pacific":20090322T150000
DTEND;TZID="US/Pacific":20090322T165000
DTSTAMP:20090319T211707Z

---

From: Richard Bennett <[email-masked]>
Date: Thu, 19 Mar 2009 13:38:59 -0700

Aha! it's easy to edit these files, BTW.

-- 
Richard Bennett

---

From: Tony Li <[email-masked]>
Date: Thu, 19 Mar 2009 08:55:11 -0700

> Are you having problems with timezones, or something else?

Outlook 2003 complains that the "input file may be corrupt".

Tony

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Sun, 22 Mar 2009 11:56:18 -0700

> (Although that would make everything an hour earlier.)

Also, it just occurs to me that unlike what the ics file suggests,  
Pacific time isn't actually UTC-8 / UTC-9: it's normally UTC-8 but  
with DST in effect it's now UTC-7. (And strange that "CDT" is in there.)

EGIN:VCALENDAR
CALSCALE:GREGORIAN
PRODID:-//Henrik Levkowetz//ietf-agenda-ical 1.03//EN
VERSION:2.0
METHOD:PUBLISH
BEGIN:VTIMEZONE
TZID:US/Pacific
BEGIN:STANDARD
TZOFFSETFROM:-0800
TZOFFSETTO:-0900
TZNAME:PST
DTSTART:20070311T020000
RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=11
END:STANDARD
BEGIN:DAYLIGHT
TZOFFSETFROM:-0900
TZOFFSETTO:-0800
TZNAME:CDT

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 22 Mar 2009 12:26:37 -0700

Oops.  Mea culpa.  I've fixed the timezone definition, should be OK
on the next update.

	Henrik