Subject: [81attendees] Mac OS X on the "ietf-v6only" network?

From: Ross Finlayson <[email-masked]>
Date: Sun, 24 Jul 2011 21:39:03 -0400

I'm eager to try out the "ietf-v6only" wireless network, but I find 
that my Macbook - running Mac OS X 10.6.8 - doesn't work on this 
network, apparently because it doesn't have a DHCPv6 client.

Does anyone know how to get DHCPv6 client functionality working on 
Mac OS X?  (Would I get it automatically if I were to upgrade to the 
new Mac OS X "Lion"?)

	Ross.

---

From: Marc Blanchet <[email-masked]>
Date: Sun, 24 Jul 2011 23:36:30 -0400

Le 11-07-24 21:39, Ross Finlayson a écrit :
> I'm eager to try out the "ietf-v6only" wireless network, but I find that
> my Macbook - running Mac OS X 10.6.8 - doesn't work on this network,
> apparently because it doesn't have a DHCPv6 client.
>
> Does anyone know how to get DHCPv6 client functionality working on Mac
> OS X? (Would I get it automatically if I were to upgrade to the new Mac
> OS X "Lion"?)

yes. Lion includes a dhcpv6 client.

Marc.

>
> Ross.
> _______________________________________________
> 81attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/81attendees

---

From: Bob Hinden <[email-masked]>
Date: Mon, 25 Jul 2011 07:39:06 -0400

Ross,

I tried the v6only wireless network and IPv6 auto-configuratin is working.  There is also DHCPv6, but auto-config should work.

Bob

On Jul 24, 2011, at 9:39 PM, Ross Finlayson wrote:

> I'm eager to try out the "ietf-v6only" wireless network, but I find that my Macbook - running Mac OS X 10.6.8 - doesn't work on this network, apparently because it doesn't have a DHCPv6 client.
> 
> Does anyone know how to get DHCPv6 client functionality working on Mac OS X?  (Would I get it automatically if I were to upgrade to the new Mac OS X "Lion"?)
> 
> 	Ross.

---

From: "Gunter Van de Velde (gvandeve)" <[email-masked]>
Date: Mon, 25 Jul 2011 14:07:25 +0200

Only thing is that without DNS info it is sort of useless. Obviously one
can manually provide the OS that info.
(or run Lion to get that info from DHCPv6)

G/

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Bob Hinden
Sent: 25 July 2011 07:39
To: Ross Finlayson
Cc: [email-masked]
Subject: Re: [81attendees] Mac OS X on the "ietf-v6only" network?

Ross,

I tried the v6only wireless network and IPv6 auto-configuratin is
working.  There is also DHCPv6, but auto-config should work.

Bob

---

From: Tim Chown <[email-masked]>
Date: Mon, 25 Jul 2011 09:15:37 -0400

I selected the IPv6 only network just now using MacOS X Lion.

It appears that Lion has autoconfigured a SLAAC address (in that the address doesn't look like one assigned from a DHCP pool), and a privacy address, and has got DNS resolvers via DHCPv6 (just the two v6 resolvers, where DHCPv4 gives two IPv4 and two IPv6 resolver addresses).

With this configuration I can read/send mail on my home university account using Mac Mail with secure IMAP/smtp, and of course read my university and other (e.g. IETF) web content just fine.

So it turns out that the IPv6 only network here is now a pretty nice way to focus on work without being tempted to visit some non work-related legacy IPv4 site ;)

Tim

---

From: Tim Chown <[email-masked]>
Date: Mon, 25 Jul 2011 09:24:08 -0400

> So it turns out that the IPv6 only network here is now a pretty nice way to focus on work without being tempted to visit some non work-related legacy IPv4 site ;)

And here is the SMTP trail for this email, showing my Lion Mac sending from its IETF v6ONLY wireless network privacy address to my home university SMTP server using TLS, and from there our servers sending the mail on to the IETF list servers, all with IPv6 transport:

I'm sure to many people this shouldn't be a surprise, but useful to highlight that it just works.

Tim

---

From: Mattia Rossi <[email-masked]>
Date: Mon, 25 Jul 2011 10:47:46 -0400

> It appears that Lion has autoconfigured a SLAAC address (in that the address doesn't look like one assigned from a DHCP pool), and a privacy address, and has got DNS resolvers via DHCPv6 (just the…

This is an "interesting" solution.. Anyhow, how do I get a DNS on my 
Linux where I don't have dhcpv6 because it's not considered stable or 
even working?

I guess I'll see you at the homenet WG..

Mat

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 25 Jul 2011 12:28:12 -0400

Try Dibbler. Works for me most of the time. 

Carlos

Sent from a mobile device
Enviado desde un dispositivo movil

On Jul 25, 2011, at 10:47 AM, Mattia Rossi <[email-masked]> wrote:

> This is an "interesting" solution.. Anyhow, how do I get a DNS on my Linux where I don't have dhcpv6 because it's not considered stable or even working?
>

---

From: Jason Thomas Castonguay <[email-masked]>
Date: Mon, 25 Jul 2011 12:31:37 -0400

Or dhcp6c.  It should be included in an optional package for debian, redhat, ubuntu, and others.

-- 
Jason
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Carlos M. Martinez [[email-masked]]
Sent: Monday, July 25, 2011 12:28 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [81attendees] Mac OS X on the "ietf-v6only" network?

Carlos

---

From: Ted Lemon <[email-masked]>
Date: Mon, 25 Jul 2011 12:40:15 -0400

> Try Dibbler. Works for me most of the time. 

I haven't had any woes with the ISC client either.   I suspect by "not stable," what they mean is "nobody's using it, so we don't have any basis for asserting that it is stable."  This is a bit unfortunate, if true.

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 25 Jul 2011 12:42:01 -0400

Also, I don't know if they are using the RDNSS option for SLAAC here in
the ietf-ipv6-only network. If so, there is a small daemon for Linux,
which works as a plugin for the "resolvconf" subsystem that listens for
RDNSS advertisements and configures your /etc/resolv.conf accordingly.

cheers!

Carlos

On 7/25/11 10:47 AM, Mattia Rossi wrote:
>> It appears that Lion has autoconfigured a SLAAC address (in that the
>> address doesn't look like one assigned from a DHCP pool), and a
>> privacy address, and has got DNS resolvers via DHCPv6 (just the two
>> v6 resolvers, where DHCPv4 gives two IPv4 and two IPv6 resolver
>> addresses).
>>
>

-- 
Carlos M. Martinez
LACNIC I+D
PGP KeyID 0xD51507A2
Phone: +598-2604-2222 ext. 4419

---

From: james woodyatt <[email-masked]>
Date: Mon, 25 Jul 2011 13:18:26 -0400

> RDNSS advertisements and configures your /etc/resolv.conf accordingly.

p1. I just did a tcpdump and it doesn't look like there RDNSS options in the router advertisements messages.

p2. If there were, Lion and iOS 4 would be merging them with the ones found with DHCPv6.

--
james woodyatt <[email-masked]>
member of technical staff, core os networking

---

From: Mattia Rossi <[email-masked]>
Date: Tue, 26 Jul 2011 03:43:54 -0400

On 25/07/11 12:40, Ted Lemon wrote:
> I haven't had any woes with the ISC client either. I suspect by "not
> stable," what they mean is "nobody's using it, so we don't have any
> basis for asserting that it is stable." This is a bit unfortunate, if true.
>

Dibbler is the tip of the day :-) thanks. Dhcp6c is not available, and I 
believe the reasoning behind the ISC client is exactly as Ted pointed out.

Mat

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 25 Jul 2011 18:17:38 +0000

I am using nat64  ssid  in iOS and it seems to be  working well, even with Skype :).

Behcet

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ted Lemon
Sent: Monday, July 25, 2011 11:40 AM
To: Carlos M. Martinez
Cc: [email-masked]
Subject: Re: [81attendees] Mac OS X on the "ietf-v6only" network?

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 25 Jul 2011 18:36:25 +0000

No, it did not work with Skype.
Most applications work like CNN, stocks, etc. Skype is not working on both v6only and nat64.
I don't know why?

From: Behcet Sarikaya
Sent: Monday, July 25, 2011 1:18 PM
To: 'Ted Lemon'; Carlos M. Martinez
Cc: [email-masked]
Subject: RE: [81attendees] Mac OS X on the "ietf-v6only" network?

Behcet

---

From: Dan Wing <[email-masked]>
Date: Mon, 25 Jul 2011 14:47:59 -0400

On 7/25/2011 2:36 PM, Behcet Sarikaya wrote:
> I don’t know why?

Skype does not support IPv6, so it can't work on an IPv6-only network
no matter if there is NAT64 or there isn't NAT64.

-d

> *From:*Behcet Sarikaya
> *Sent:* Monday, July 25, 2011 1:18 PM
> *To:* 'Ted Lemon'; Carlos M. Martinez
> *Cc:* [email-masked]
> *Subject:* RE: [81attendees] Mac OS X on the "ietf-v6only" network?
>
> I am using nat64 ssid in iOS and it seems to be working well, even with
> Skype J.
>
> Behcet
>
> *From:[email-masked]
> [mailto:[email-masked]] *On Behalf Of *Ted Lemon
> *Sent:* Monday, July 25, 2011 11:40 AM
> *To:* Carlos M. Martinez
> *Cc:* [email-masked]
> *Subject:* Re: [81attendees] Mac OS X on the "ietf-v6only" network?
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 25 Jul 2011 20:50:37 +0200

Except perhaps if the OS does NAT46 transparently for all IPv4-onky applications?

Typed on a small keyboard sorry for lack of ponctuation and French accented letters.

----- Original Message -----
From: Dan Wing [mailto:[email-masked]]
Sent: Monday, July 25, 2011 08:47 PM
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [81attendees] Mac OS X on the "ietf-v6only" network?

-d

---

From: Matthew Kaufman <[email-masked]>
Date: Mon, 25 Jul 2011 14:53:28 -0400

> no matter if there is NAT64 or there isn't NAT64.

Skype doesn't support IPv6.

And even if it did, NAT64 doesn't support applications that use IPv4 literals, so you couldn't use Skype to talk to anything on IPv4 via NAT64 anyway.

Matthew Kaufman

---

From: Dan Wing <[email-masked]>
Date: Mon, 25 Jul 2011 14:54:21 -0400

> Except perhaps if the OS does NAT46 transparently for all IPv4-onky applications?

Yes, Skype works with an implementation of draft-ietf-behave-v4v6-bih, 
if the implementation of draft-ietf-behave-v4v6-bih includes some 
extensions that are not permitted by that I-D.  But 
draft-ietf-behave-v4v6-bih is not implemented in OSX Lion or Windows 7.

-d

> To: Behcet Sarikaya<[email-masked]>
> Cc: [email-masked]<[email-masked]>

---

From: james woodyatt <[email-masked]>
Date: Mon, 25 Jul 2011 15:25:57 -0400

> Except perhaps if the OS does NAT46 transparently for all IPv4-onky applications?

Since this was in the context of iOS 4, I think I can safely say the OS in question does not.

---

From: Tomasz Mrugalski <[email-masked]>
Date: Mon, 25 Jul 2011 17:19:54 -0400

> Try Dibbler. Works for me most of the time. 
I'd like to hear about cases when it doesn't. Please mail me off the list.

I also recommend ISC DHCP. It supports Mac OS.

Tomek Mrugalski
ISC DHCP Engineer
Dibbler author