Subject: [82attendees] request for someone coming from US who hasn't left yet

From: Joe Touch <[email-masked]>
Date: Sat, 12 Nov 2011 16:01:27 -0800

Hi, all,

If anyone has not yet left the US and can do me a small favor, please 
contact me off-list. I forgot a small item that is hard to find overseas.

Thanks,

Joe

---

From: Joe Touch <[email-masked]>
Date: Sun, 13 Nov 2011 12:12:29 +0900

Hi all, 

Many thank to those who replied. I'm all set. 

Joe

On Nov 13, 2011, at 9:01 AM, Joe Touch <[email-masked]> wrote:

> Hi, all,
> 
> If anyone has not yet left the US and can do me a small favor, please contact me off-list. I forgot a small item that is hard to find overseas.
> 
> Thanks,
> 
> Joe