Subject: [95attendees] The usual laundry question

From: [email-masked]
Date: 1 Apr 2016 16:46:54 -0000

I'll be in B.A. for 10 days and I don't think I can cram that much
underwear into my carry-on.

Any suggstions for laundries?  Ideal would be a place within walking
distance of the Hilton where we can drop off a bag one day and pick it
up washed and folded the next.

Tnx,
John

---

From: Robert Moskowitz <[email-masked]>
Date: Sun, 3 Apr 2016 07:27:56 -0400

Any update on laundry?  Would save me a bit of bulk...

On 04/01/2016 12:46 PM, [email-masked] wrote:
> _______________________________________________
> 95attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/95attendees
>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit