Subject: Re: [95attendees] IETFers app update

From: Tom Pusateri <[email-masked]>
Date: Sat, 2 Apr 2016 15:49:56 -0300

As a follow up, I have submitted a new version and it is waiting review by Apple. This can take anywhere from 2 days to 8 days.

Thanks,
Tom

> On Mar 24, 2016, at 3:27 PM, Tom Pusateri <[email-masked]> wrote:
> 
> Mike,
> 	That was not intentional. There should be a timeout (although it might be too long). I will test it and get an update out.
> 
> Thanks,
> Tom
> 
> 
>> On Mar 24, 2016, at 1:51 PM, Michael StJohns <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> On 3/24/2016 9:28 AM, Tom Pusateri wrote:
>> 
>> Hi Tom -
>> 
>> Thanks as always for the update, but I really wish you'd have provided this as a new app/separate beta given how much has changed.  I've already found one issue that's very problematic - if you have no network access, the app blocks trying to load - even if it has a reasonably current database.   That means no access in airplane mode.  It also means that if you disable the app's access to cellular data (e.g. to avoid roaming charges),  and you're not on Wifi - again, no access.
>> 
>> As far as I can tell, there's no timeout set for the network check either.
>> 
>> Or am I missing some settings somewhere?
>> 
>> Later, Mike
>> 
>> 
>> 
>>> The new update of the IETFers app is ready to download. As you will see in the release notes, this one has been rewritten to synchronize with the IETF database. The first time you run it, it will take some time so be patient. Also, it will not automatically switch meetings, you have to do that in Settings. The first time you switch to a new meeting, it also will have a noticeable delay. We will work to make these delays shorter.
>>> 
>>> On the bright side, this app will work for future meetings. As soon as the new meetings and sessions are published, it will discover them.
>>> 
>>> There are certain features that I wasn’t able to replicate using the database including audio streaming and playback, jabber log synchronization, and maps. If you would like to see missing features brought back, let me know and I will work with the tools team to make it possible.
>>> 
>>> The import favorites from previous meeting also got left out due to time pressure to get this version released. It will be back in the next release.
>>> 
>>> Thanks,
>>> Tom
>>> 
>>> 
>>> 
>>> 
>>> _______________________________________________
>>> 95attendees mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/95attendees <https://www.ietf.org/mailman/listinfo/95attendees>
>> 
>> _______________________________________________
>> 95attendees mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/95attendees
>

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 4 Apr 2016 21:26:30 -0300

The new version 2.0.1 is available in the app store if you haven’t already noticed.

Thanks,
Tom

> On Apr 2, 2016, at 3:49 PM, Tom Pusateri <[email-masked]> wrote:
> 
>> On Mar 24, 2016, at 3:27 PM, Tom Pusateri <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Mike,

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 4 Apr 2016 23:03:01 -0300

I got 2.0.1.2, huge improvement!

Thanks,
Andy

On Mon, Apr 4, 2016 at 9:26 PM, Tom Pusateri <[email-masked]> wrote:

> As a follow up, I have submitted a new version and it is waiting review by
> Apple. This can take anywhere from 2 days to 8 days.
>
> Thanks,
> Tom
>
> That was not intentional. There should be a timeout (although it might be
> too long). I will test it and get an update out.
>
> Thanks,
> Tom
>
>
> On Mar 24, 2016, at 1:51 PM, Michael StJohns <[email-masked]>
> wrote:
>
> Thanks as always for the update, but I really wish you'd have provided
> this as a new app/separate beta given how much has changed.  I've already
> found one issue that's very problematic - if you have no network access,
> the app blocks trying to load - even if it has a reasonably current
> database.   That means no access in airplane mode.  It also means that if
> you disable the app's access to cellular data (e.g. to avoid roaming
> charges),  and you're not on Wifi - again, no access.
>
> 95attendees mailing [email-masked]://www.ietf.org/mailman/listinfo/95attendees
>
>
> [email-masked]
> [email-masked]

---

From: William Denniss <[email-masked]>
Date: Tue, 05 Apr 2016 02:51:09 +0000

Great update. Thanks for the work!
On Mon, Apr 4, 2016 at 11:12 PM Andrew G. Malis <[email-masked]> wrote:

>> As a follow up, I have submitted a new version and it is waiting review
>> by Apple. This can take anywhere from 2 days to 8 days.
>>
>> Thanks,
>> Tom
>>

---

From: Jim Fenton <[email-masked]>
Date: Mon, 4 Apr 2016 21:06:59 -0700

Hmm. Since the update, mine (iPhone 6) seems to crash every time I
change views (switching from Monday's to Tuesday's sessions, for
example). Still, not a huge deal to restart the app.

-Jim

On 4/4/16 7:51 PM, William Denniss wrote:
> On Mon, Apr 4, 2016 at 11:12 PM Andrew G. Malis <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     On Mon, Apr 4, 2016 at 9:26 PM, Tom Pusateri <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>>         On Apr 2, 2016, at 3:49 PM, Tom Pusateri <[email-masked]
>>         <mailto:[email-masked]>> wrote:
>>
>>         As a follow up, I have submitted a new version and it is
>>         waiting review by Apple. This can take anywhere from 2 days
>>         to 8 days.
>>
>>         Thanks,
>>         Tom
>>
>>>         On Mar 24, 2016, at 3:27 PM, Tom Pusateri
>>>         <[email-masked] <mailto:[email-masked]>> wrote:
>>>
>>>         Mike,
>>>         That was not intentional. There should be a timeout
>>>         (although it might be too long). I will test it and get an
>>>         update out.
>>>
>>>         Thanks,
>>>         Tom
>>>
>>>
>>>>         On Mar 24, 2016, at 1:51 PM, Michael StJohns
>>>>         <[email-masked] <mailto:[email-masked]>> wrote:
>>>>
>>>>         Thanks as always for the update, but I really wish you'd
>>>>         have provided this as a new app/separate beta given how
>>>>         much has changed.  I've already found one issue that's very
>>>>         problematic - if you have no network access, the app blocks
>>>>         trying to load - even if it has a reasonably current
>>>>         database.   That means no access in airplane mode.  It also
>>>>         means that if you disable the app's access to cellular data
>>>>         (e.g. to avoid roaming charges),  and you're not on Wifi -
>>>>         again, no access.
>>>>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 5 Apr 2016 08:39:19 -0300

Jim,

It can’t hurt to restart the phone and see if crashing continues.

Cheers,
Andy

On Tue, Apr 5, 2016 at 1:06 AM, Jim Fenton <[email-masked]> wrote:

> Hmm. Since the update, mine (iPhone 6) seems to crash every time I change
> views (switching from Monday's to Tuesday's sessions, for example). Still,
> not a huge deal to restart the app.
>
> -Jim
>
>
>>> On Mar 24, 2016, at 3:27 PM, Tom Pusateri < <[email-masked]>
>>> [email-masked]> wrote:
>>>
>>> Mike,
>>> That was not intentional. There should be a timeout (although it might
>>> be too long). I will test it and get an update out.
>>>
>>> Thanks,
>>> Tom
>>>
>>>
>>> On Mar 24, 2016, at 1:51 PM, Michael StJohns < <[email-masked]>
>>> [email-masked]> wrote:
>>>
>>> <[email-masked]>[email-masked]
>>> <https://www.ietf.org/mailman/listinfo/95attendees>

---

From: Nicolas Antoniello <[email-masked]>
Date: Tue, 5 Apr 2016 08:44:30 -0300

Just in case, if you did not updated to the latest IOS version there is a
bug that has to do (among others I believe) with some apps crashing, solved
in Version 9.3.1 (also recommend to restart again the phone once updated...
some of the universe's mysteries)  :)

Regards,
Nicolas

---

From: "Marc Blanchet" <[email-masked]>
Date: Tue, 05 Apr 2016 08:46:54 -0300

On 5 Apr 2016, at 8:44, Nicolas Antoniello wrote:

> in Version 9.3.1

yes. 9.3 was almost unusable.

Marc.

> (also recommend to restart again the phone once updated...

>>> change
>>>>> The new version 2.0.1 is available in the app store if you 
>>>>> haven’t
>>>>> already noticed.
>>>>>
>>>>> Thanks,
>>>>> Tom
>>>>>
>>>>>
>>>>> The new update of the IETFers app is ready to download. As you 
>>>>> will see in the release notes, this one has been rewritten to 
>>>>> synchronize with the IETF database. The first time you run it, it 
>>>>> will take some time so be patient. Also, it will not automatically 
>>>>> switch meetings, you have to do that in Settings. The first time 
>>>>> you switch to a new meeting, it also will have a noticeable delay. 
>>>>> We will work to make these delays shorter.
>>>>>
>>>>> On the bright side, this app will work for future meetings. As 
>>>>> soon as the new meetings and sessions are published, it will 
>>>>> discover them.
>>>>>
>>>>> There are certain features that I wasn’t able to replicate using 
>>>>> the database including audio streaming and playback, jabber log 
>>>>> synchronization, and maps. If you would like to see missing 
>>>>> features brought back, let me know and I will work with the tools 
>>>>> team to make it possible.
>>>>>
>>>>> The import favorites from previous meeting also got left out due 
>>>>> to time pressure to get this version released. It will be back in 
>>>>> the next release.
>>>>>
>>>>> Thanks,
>>>>> Tom
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> 95attendees mailing 
>>>>> [email-masked]://www.ietf.org/mailman/listinfo/95attendees
>>>>>
>>>>>
>>> 95attendees mailing 
>>> [email-masked]://www.ietf.org/mailman/listinfo/95attendees
>>>
>>>
>>>

---

From: Jim Fenton <[email-masked]>
Date: Tue, 5 Apr 2016 05:27:36 -0700

Good thought and I hadn't, but rebooting the phone didn't help,
unfortunately.

iOS 9.3.1, by the way.

-Jim

On 4/5/16 4:39 AM, Andrew G. Malis wrote:
> On Tue, Apr 5, 2016 at 1:06 AM, Jim Fenton <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>>     On Mon, Apr 4, 2016 at 11:12 PM Andrew G. Malis
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         On Mon, Apr 4, 2016 at 9:26 PM, Tom Pusateri
>>>             On Apr 2, 2016, at 3:49 PM, Tom Pusateri
>>>             waiting review by Apple. This can take anywhere from 2
>>>             days to 8 days.
>>>
>>>             Thanks,
>>>             Tom
>>>
>>>>             (although it might be too long). I will test it and get
>>>>             an update out.
>>>>
>>>>             Thanks,
>>>>             Tom
>>>>
>>>>
>>>>>             Thanks as always for the update, but I really wish
>>>>>             you'd have provided this as a new app/separate beta
>>>>>             given how much has changed.  I've already found one
>>>>>             issue that's very problematic - if you have no network
>>>>>             access, the app blocks trying to load - even if it has
>>>>>             a reasonably current database.   That means no access
>>>>>             in airplane mode.  It also means that if you disable
>>>>>             the app's access to cellular data (e.g. to avoid
>>>>>             roaming charges),  and you're not on Wifi - again, no
>>>>>             access.
>>>>>

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 5 Apr 2016 09:29:59 -0300

Did you delete the app and re-download it from the app store? if it still crashes after that, we can hook it up to the debugger if you have time.

Tom

> On Apr 5, 2016, at 9:27 AM, Jim Fenton <[email-masked]> wrote:
> 
> Good thought and I hadn't, but rebooting the phone didn't help, unfortunately.
> 
> iOS 9.3.1, by the way.
> 
> -Jim
> 
>> On Tue, Apr 5, 2016 at 1:06 AM, Jim Fenton <[email-masked] <mailto:[email-masked]>> wrote:
>> Hmm. Since the update, mine (iPhone 6) seems to crash every time I change views (switching from Monday's to Tuesday's sessions, for example). Still, not a huge deal to restart the app.
>> 
>> -Jim
>> 
>> 
>>> On Mon, Apr 4, 2016 at 11:12 PM Andrew G. Malis <[email-masked] <mailto:[email-masked]>> wrote:
>>> On Mon, Apr 4, 2016 at 9:26 PM, Tom Pusateri < <mailto:[email-masked]>[email-masked] <mailto:[email-masked]>> wrote:
>>>> On Apr 2, 2016, at 3:49 PM, Tom Pusateri < <mailto:[email-masked]>[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>>> On Mar 24, 2016, at 3:27 PM, Tom Pusateri < <mailto:[email-masked]>[email-masked] <mailto:[email-masked]>> wrote:
>>>>> 
>>>>> Mike,
>>>>>> On Mar 24, 2016, at 1:51 PM, Michael StJohns < <mailto:[email-masked]>[email-masked] <mailto:[email-masked]>> wrote:
>>>>>>

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Tue, 5 Apr 2016 13:00:06 +0000

Uninstall and re-install the APP worked for me

Regards,

Patrice

   [http://www.cisco.com/web/europe/images/email/signature/est2014/logo_06.png?ct=1406640631632]

Patrice Brissette
TECHNICAL LEADER.ENGINEERING

[email-masked]<mailto:[email-masked]>
Phone: +1 613 254 3336

Cisco Systems Canada Co. / Les Systemes Cisco Canada CIE
Canada
Cisco.com<http://www.cisco.com/global/CA/>

[http://www.cisco.com/assets/swa/img/thinkbeforeyouprint.gif] Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Please click here<http://www.cisco.com/web/about/doing_business/legal/cri/index.html> for Company Registration Information.

From: 95attendees <[email-masked]<mailto:[email-masked]>> on behalf of Tom Pusateri <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 5, 2016 at 8:29 AM
To: Jim Fenton <[email-masked]<mailto:[email-masked]>>
Cc: 95 Attendees <[email-masked]<mailto:[email-masked]>>
Subject: Re: [95attendees] IETFers app update

Tom

On Apr 5, 2016, at 9:27 AM, Jim Fenton <[email-masked]<mailto:[email-masked]>> wrote:

iOS 9.3.1, by the way.

-Jim

It can't hurt to restart the phone and see if crashing continues.

Cheers,
Andy

On Tue, Apr 5, 2016 at 1:06 AM, Jim Fenton <[email-masked]<mailto:[email-masked]>> wrote:
Hmm. Since the update, mine (iPhone 6) seems to crash every time I change views (switching from Monday's to Tuesday's sessions, for example). Still, not a huge deal to restart the app.

-Jim

On 4/4/16 7:51 PM, William Denniss wrote:
Great update. Thanks for the work!
On Mon, Apr 4, 2016 at 11:12 PM Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:
I got 2.0.1.2, huge improvement!

Thanks,
Andy

On Mon, Apr 4, 2016 at 9:26 PM, Tom Pusateri <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:
The new version 2.0.1 is available in the app store if you haven't already noticed.

Thanks,
Tom

On Apr 2, 2016, at 3:49 PM, Tom Pusateri <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Tom

On Mar 24, 2016, at 3:27 PM, Tom Pusateri <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:

Mike,

Thanks,
Tom

On Mar 24, 2016, at 1:51 PM, Michael StJohns <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:

Hi Tom -

Later, Mike

There are certain features that I wasn't able to replicate using the database including audio streaming and playback, jabber log synchronization, and maps. If you would like to see missing features brought back, let me know and I will work with the tools team to make it possible.

Thanks,
Tom

_______________________________________________
95attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/95attendees

---

From: Jim Fenton <[email-masked]>
Date: Tue, 5 Apr 2016 06:11:57 -0700

Sure enough, deleting and re-installing the app did the trick.  I should
have thought of that too; thanks.

-Jim

On 4/5/16 5:29 AM, Tom Pusateri wrote:
> Did you delete the app and re-download it from the app store? if it
> still crashes after that, we can hook it up to the debugger if you
> have time.
>
> Tom
>
>>>     Hmm. Since the update, mine (iPhone 6) seems to crash every time
>>>     I change views (switching from Monday's to Tuesday's sessions,
>>>     for example). Still, not a huge deal to restart the app.
>>>
>>>     -Jim
>>>
>>>
>>>>         <[email-masked]> wrote:
>>>>
>>>>>             <[email-masked]> wrote:
>>>>>
>>>>>             As a follow up, I have submitted a new version and it
>>>>>             is waiting review by Apple. This can take anywhere
>>>>>             from 2 days to 8 days.
>>>>>
>>>>>             Thanks,
>>>>>             Tom
>>>>>
>>>>>>             <[email-masked]> wrote:
>>>>>>
>>>>>>             Mike,
>>>>>>             (although it might be too long). I will test it and
>>>>>>             get an update out.
>>>>>>
>>>>>>             Thanks,
>>>>>>             Tom
>>>>>>
>>>>>>
>>>>>>>             <[email-masked]> wrote:
>>>>>>>
>>>>>>>             issue that's very problematic - if you have no
>>>>>>>             network access, the app blocks trying to load - even
>>>>>>>             if it has a reasonably current database.   That
>>>>>>>             means no access in airplane mode.  It also means
>>>>>>>             that if you disable the app's access to cellular
>>>>>>>             data (e.g. to avoid roaming charges),  and you're
>>>>>>>             not on Wifi - again, no access.
>>>>>>>

---

From: Paul Wouters <[email-masked]>
Date: Tue, 5 Apr 2016 09:17:57 -0400 (EDT)

> Uninstall and re-install the APP worked for me

I am seeing blanc entries which are also different between different
devices. For example, the tls meeting shows up on one device, but
is a blanc entry on another device.

The update did not fix it but a re-install fixes it.

Paul

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 5 Apr 2016 10:34:47 -0300

The IETF servers are returning 403 errors and when that happens, the app stops trying to sync. When the app starts to sync again, it does so by the date of the last item it downloaded. Unfortunately, the objects aren’t sorted by date. That means you end up with missing entries.

Reinstalling gives it another chance at getting all of the data.

This was a misunderstanding of how the API works in combination with some weird Apache issue on the servers.

I will be making additional changes to better handle the 403 errors.

Tom

> On Apr 5, 2016, at 10:17 AM, Paul Wouters <[email-masked]> wrote:
>

---

From: Phil Hunt <[email-masked]>
Date: Tue, 5 Apr 2016 10:42:23 -0300

Running into a problem where if the calendar setting is set to an external caldav server, the IETF app will crash immediately.

Only way to fix is to delete, re-install and not set the calendar to a non-local calendar. 

This wasn’t happening in the previous version of the IETFers app.

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Apr 5, 2016, at 10:34 AM, Tom Pusateri <[email-masked]> wrote:
>

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 5 Apr 2016 10:50:00 -0300

Ok, I did make changes to fix an issue where it wouldn’t remember your Calendar after an upgrade.  iCloud calendars seem to work. I can try a Google calendar. If I can’t reproduce it and you want to connect it to the debugger, we can figure it out.

Tom

> On Apr 5, 2016, at 10:42 AM, Phil Hunt <[email-masked]> wrote:
> 
>> On Apr 5, 2016, at 10:34 AM, Tom Pusateri <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> On Apr 5, 2016, at 10:17 AM, Paul Wouters <[email-masked] <mailto:[email-masked]>> wrote:
>>>

---

From: Jim Fenton <[email-masked]>
Date: Tue, 5 Apr 2016 06:56:12 -0700

I'm also using an external CalDAV server, but not running into the issue
Phil is reporting.  I have added and deleted several favorites, both
with and without alarms enabled.

-Jim

On 4/5/16 6:50 AM, Tom Pusateri wrote:
> Ok, I did make changes to fix an issue where it wouldn’t remember your
> Calendar after an upgrade.  iCloud calendars seem to work. I can try a
> Google calendar. If I can’t reproduce it and you want to connect it to
> the debugger, we can figure it out.
>
> Tom
>
>> On Apr 5, 2016, at 10:42 AM, Phil Hunt <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> Running into a problem where if the calendar setting is set to an
>> external caldav server, the IETF app will crash immediately.
>>
>> www.independentid.com <http://www.independentid.com/>
>> [email-masked] <mailto:[email-masked]>
>>
>>
>>
>>
>>
>>> The IETF servers are returning 403 errors and when that happens, the
>>> app stops trying to sync. When the app starts to sync again, it does
>>> so by the date of the last item it downloaded. Unfortunately, the
>>> objects aren’t sorted by date. That means you end up with missing
>>> entries.
>>>

---

From: Tim Chown <[email-masked]>
Date: Tue, 5 Apr 2016 14:08:22 +0000

On 5 Apr 2016, at 14:11, Jim Fenton <[email-masked]<mailto:[email-masked]>> wrote:

Sure enough, deleting and re-installing the app did the trick.  I should have thought of that too; thanks.

Ditto.

Tim

-Jim

Tom

On Apr 5, 2016, at 9:27 AM, Jim Fenton <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:

iOS 9.3.1, by the way.

-Jim

Cheers,
Andy

On Tue, Apr 5, 2016 at 1:06 AM, Jim Fenton <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:
Hmm. Since the update, mine (iPhone 6) seems to crash every time I change views (switching from Monday's to Tuesday's sessions, for example). Still, not a huge deal to restart the app.

-Jim

Thanks,
Andy

Thanks,
Tom

Thanks,
Tom

Mike,

Thanks,
Tom

Hi Tom -

Later, Mike

Thanks,
Tom

---

From: William Denniss <[email-masked]>
Date: Tue, 5 Apr 2016 11:58:38 -0300

I had to delete & reinstall once after upgrading a few weeks ago, but not
on the latest update.

On Tue, Apr 5, 2016 at 11:08 AM, Tim Chown <[email-masked]> wrote:

> On 5 Apr 2016, at 14:11, Jim Fenton <[email-masked]> wrote:
>
> Did you delete the app and re-download it from the app store? if it still
> crashes after that, we can hook it up to the debugger if you have time.
>
> Tom
>
> On Apr 5, 2016, at 9:27 AM, Jim Fenton < <[email-masked]>
> [email-masked]> wrote:
>
> On Tue, Apr 5, 2016 at 1:06 AM, Jim Fenton < <[email-masked]>
> [email-masked]> wrote:
>
>>> On Mon, Apr 4, 2016 at 9:26 PM, Tom Pusateri < <[email-masked]>
>>>> On Apr 2, 2016, at 3:49 PM, Tom Pusateri < <[email-masked]>