Subject: [96attendees] Recipe to set up Jabber?

From: Dave Dolson <[email-masked]>
Date: Mon, 11 Jul 2016 16:37:54 +0000

Over the last couple of years I've tried to get Jabber working on a few occasions, but couldn't figure it out with the (small) amount of effort I was willing to invest.
(This is why I look at my feet when the chair asks for a jabber scribe.)

A few meetings ago I got a client, but couldn't figure out how to get an XMPP account.

Can anyone provide a recipe for setting up Jabber to participate with IETF?
IETF won't recommend a specific client, but I'm hoping individuals will.
Web-based clients seem like the way to go?

-Dave

---

From: Michael StJohns <[email-masked]>
Date: Mon, 11 Jul 2016 12:51:09 -0400

On 7/11/2016 12:37 PM, Dave Dolson wrote:
>
> Over the last couple of years I’ve tried to get Jabber working on a 
> few occasions, but couldn’t figure it out with the (small) amount of 
> effort I was willing to invest.
>
> A few meetings ago I got a client, but couldn’t figure out how to get 
> an XMPP account.
>
> IETF won’t recommend a specific client, but I’m hoping individuals will.
>
> _______________________________________________
> 96attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/96attendees

https://xmpp.net/directory.php - has a list of public jabber servers.    
Hover over the name link for each server for a description of where and 
who.  Generally, that link leads to the home page which generally has a 
link to the registration page: E.g. lightwitch.org  -> 
https://lightwitch.org/xmpp/register

Once you have that and a client set up, go to 
https://www.ietf.org/jabber/index.html for information on how to connect 
to the IETF specific jabber rooms.

Mike

---

From: Ted Lemon <[email-masked]>
Date: Mon, 11 Jul 2016 09:53:50 -0700

This is really hopeless.   If we are to use jabber for IETF business, there
should be a jabber server that is supported by the IETF.   The "good luck"
jabber server web page is not helpful.   I tried using it in BA and was
unable to participate on jabber during that IETF.

On Mon, Jul 11, 2016 at 9:51 AM, Michael StJohns <[email-masked]>
wrote:

> Over the last couple of years I’ve tried to get Jabber working on a few
> occasions, but couldn’t figure it out with the (small) amount of effort I
> was willing to invest.
>
> A few meetings ago I got a client, but couldn’t figure out how to get an
> XMPP account.
>
>
>
> 96attendees mailing [email-masked]://www.ietf.org/mailman/listinfo/96attendees
>
>

---

From: Tim Chown <[email-masked]>
Date: Mon, 11 Jul 2016 16:56:07 +0000

Hi,

On 11 Jul 2016, at 17:53, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

This is really hopeless.   If we are to use jabber for IETF business, there should be a jabber server that is supported by the IETF.

^^ This!

Tim

The "good luck" jabber server web page is not helpful.   I tried using it in BA and was unable to participate on jabber during that IETF.

On Mon, Jul 11, 2016 at 9:51 AM, Michael StJohns <[email-masked]<mailto:[email-masked]>> wrote:
On 7/11/2016 12:37 PM, Dave Dolson wrote:
Over the last couple of years I’ve tried to get Jabber working on a few occasions, but couldn’t figure it out with the (small) amount of effort I was willing to invest.
(This is why I look at my feet when the chair asks for a jabber scribe.)

A few meetings ago I got a client, but couldn’t figure out how to get an XMPP account.

-Dave

_______________________________________________
96attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/96attendees

https://xmpp.net/directory.php - has a list of public jabber servers.    Hover over the name link for each server for a description of where and who.  Generally, that link leads to the home page which generally has a link to the registration page:  E.g. lightwitch.org<http://lightwitch.org/>  -> https://lightwitch.org/xmpp/register

Once you have that and a client set up, go to https://www.ietf.org/jabber/index.html for information on how to connect to the IETF specific jabber rooms.

Mike

_______________________________________________
96attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/96attendees

_______________________________________________
96attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/96attendees

---

From: Jared Mauch <[email-masked]>
Date: Mon, 11 Jul 2016 12:57:00 -0400

> On Jul 11, 2016, at 12:53 PM, Ted Lemon <[email-masked]> wrote:
> 
> This is really hopeless.   If we are to use jabber for IETF business, there should be a jabber server that is supported by the IETF.   The "good luck" jabber server web page is not helpful.   I tried using it in BA and was unable to participate on jabber during that IETF.
> 

I run my own jabber server.  It’s not *that* hard.

I understand you can also integrate jabber w/ your gmail account (since many people have these).

There is also the web interface to jabber that IETF does provide, you could always use this.

- Jared

---

From: Michael StJohns <[email-masked]>
Date: Mon, 11 Jul 2016 13:00:53 -0400

On 7/11/2016 12:53 PM, Ted Lemon wrote:
> This is really hopeless.   If we are to use jabber for IETF business, 
> there should be a jabber server that is supported by the IETF.
There is an IETF jabber server (run by the secretariate) that hosts the 
chat rooms.  It doesn't (AFAICT) support user registration. Given the 
wide set of available public chat rooms and the already heavy load on 
the secretariat, I wouldn't argue for them to take up yet another user 
support role.

> The "good luck" jabber server web page is not helpful.   I tried using 
> it in BA and was unable to participate on jabber during that IETF.

Hmm... usually its as simple as <wgname> @ jabber.ietf.org as in input 
to "join conference" or "join chatroom" depending on your client.

Mike

>
> On Mon, Jul 11, 2016 at 9:51 AM, Michael StJohns 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>>     Over the last couple of years I’ve tried to get Jabber working on
>>     a few occasions, but couldn’t figure it out with the (small)
>>     amount of effort I was willing to invest.
>>
>>     [email-masked] <mailto:[email-masked]>
>     https://xmpp.net/directory.php - has a list of public jabber
>     servers.    Hover over the name link for each server for a
>     description of where and who.  Generally, that link leads to the
>     home page which generally has a link to the registration page: 
>     E.g. lightwitch.org <http://lightwitch.org>  ->
>     https://www.ietf.org/jabber/index.html for information on how to
>     connect to the IETF specific jabber rooms.
>
>     Mike
>
>
>
>
>     [email-masked] <mailto:[email-masked]>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 11 Jul 2016 10:01:47 -0700

No, jabber integration with gmail died a couple of IETFs ago; that's why
this is a problem.   I agree that running a jabber server isn't that hard,
but should every IETF participant set up their own?   Isn't that a poor use
of time?   The web interface you are referring to, is that coupled with the
Meetecho system?   If so, I think it's a bit of a bandwidth hog if everyone
uses it.

On Mon, Jul 11, 2016 at 9:57 AM, Jared Mauch <[email-masked]> wrote:

> there should be a jabber server that is supported by the IETF.   The "good
> luck" jabber server web page is not helpful.   I tried using it in BA and
> was unable to participate on jabber during that IETF.
> >
>

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 11 Jul 2016 13:08:16 -0400

On 7/11/16 12:53 PM, Ted Lemon wrote:
> there should be a jabber server that is supported by the IETF.   The
> "good luck" jabber server web page is not helpful.   I tried using it in
> BA and was unable to participate on jabber during that IETF.
>

+1 here.

---

From: Yoav Nir <[email-masked]>
Date: Mon, 11 Jul 2016 20:14:20 +0300

> On 11 Jul 2016, at 7:53 PM, Ted Lemon <[email-masked]> wrote:
> 

I tried six servers from that list that were totally non-functional. The seventh one I tried worked like a charm.  FWIW it was SUChat.org, and the client still seems to be working with that account.

But it would be great if we had something more reliable than that list.

Yoav

---

From: Jonas Jared Jacek <[email-masked]>
Date: Mon, 11 Jul 2016 19:16:17 +0200

Hi Dave, 

you can find a list of Jabber/XMPP clients here:
http://xmpp.org/software/clients.html - They ask for your account
credentials. I hear 'Pidgin' is the client of choice: http://pidgin.im/ 

Getting an account is easy. Sign up for an account with one of the many
Jabber-Server providers. Try jabber.org for example
http://www.jabber.org/faq.html#account or any other provider:
https://www.google.com/#q=jabber+account+providers 

Alternative:
If you have administrative rights over a domain name, you can also set
up an email address at that domain name for using jabber. E.g.
[email-masked] You can get a hassle-free Jabber account for your email
address here: https://hosted.im/ (that's what I did).

I hope this helps. 
Cheers, Jonas
-- 
Jonas Jared Jacek
http://jonas.me/

---

From: John Dowdell <[email-masked]>
Date: Mon, 11 Jul 2016 18:21:49 +0100

> On 11 Jul 2016, at 18:14, Yoav Nir <[email-masked]> wrote:
> 
> 

For BA, participating remotely, I used Meetecho for the first time. Bit of a fiddle to find a web browser that works on your OS of choice, but Firefox seemed to work best (i.e. supported more of the standards on which meet echo is based) than the others for OSX, though others reported Chrome working for them. It’s a lot less fiddly than Jabber. Just follow the links for the meeting you are attending. Do not be frightened to ask others doing the same for help, because help will be forthcoming.

Can’t remember what I used on the mac for Jabber but Taikonaut is a good client for iPad.

Regards
John

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 11 Jul 2016 14:25:34 -0300

I believe getting a free Jabber account is not particularly difficult,
although I agree that it hardly seems like a robust solution.

Maybe it's not beyond imagining an IETF-run jabber server, with account
creation tied to registration to one event.

---

From: Dave Dolson <[email-masked]>
Date: Mon, 11 Jul 2016 17:54:00 +0000

Yoav,
Thank you for providing a place I can register (suchat.org) !

There is a secondary advantage that I will learn some Spanish to use it :-)

I thought the client at conversejs.org looked promising, but when I selected room name [email-masked], it said, "A new room has been created"
That's not correct if a new room was created, is it?
I don't think conversejs.org works properly.

I downloaded pidgin, and set my account to the suchat account, and now I can enter [email-masked] , and other users are there.

-Dave

-----Original Message-----
From: 96attendees [mailto:[email-masked]] On Behalf Of Yoav Nir
Sent: Monday, July 11, 2016 1:14 PM
To: Ted Lemon
Cc: [email-masked]; Michael StJohns
Subject: Re: [96attendees] Recipe to set up Jabber?

Yoav

---

From: Dave Dolson <[email-masked]>
Date: Mon, 11 Jul 2016 17:54:15 +0000

Well, from Firefox:

   "register.jabber.org uses an invalid security certificate. The certificate expired on Tuesday, December 17, 2013 5:54 PM. The current time is Monday, July 11, 2016 1:28 PM."

So I'm thinking this web site isn't maintained since 2013?
I don't like to click through this.

-----Original Message-----
From: 96attendees [mailto:[email-masked]] On Behalf Of Jonas Jared Jacek
Sent: Monday, July 11, 2016 1:16 PM
To: [email-masked]
Subject: Re: [96attendees] Recipe to set up Jabber?

Hi Dave, 

Alternative:

I hope this helps. 
Cheers, Jonas
-- 
Jonas Jared Jacek
http://jonas.me/

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 11 Jul 2016 17:58:26 +0000

Jabber.org is no longer registering new users.

Use another server from the list at xmpp.net

Brian

On 7/11/16, 1:54 PM, "96attendees on behalf of Dave Dolson"
<[email-masked] on behalf of [email-masked]> wrote:

>Well, from Firefox:
>
>   "register.jabber.org uses an invalid security certificate. The
>certificate expired on Tuesday, December 17, 2013 5:54 PM. The current
>time is Monday, July 11, 2016 1:28 PM."
>
>
>> Over the last couple of years I've tried to get Jabber working on a few
>>occasions, but couldn't figure it out with the (small) amount of effort
>>I was willing to invest.

---

From: Reem Albuainain <[email-masked]>
Date: Mon, 11 Jul 2016 21:07:25 +0300

Hi there,
Sorry but how can i unsubscribe from this mailing list?. My inbox is full and i cant keep track of the events important documents due to the chat board.

Apologies for any inconvenience this might cause
Regards,
Reem

Sent from my iPhone

Begin forwarded message:

> From: Dave Dolson <[email-masked]>
> Date: July 11, 2016 at 8:54:00 PM GMT+3
> To: Yoav Nir <[email-masked]>, Ted Lemon <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, Michael StJohns <[email-masked]>

---

From: Jonas Jared Jacek <[email-masked]>
Date: Mon, 11 Jul 2016 20:09:50 +0200

Hi Dave, 

here is a simple how-to for Pidgin with DuckDuckgo's Jabber Server: 
https://duck.co/blog/post/2/using-pidgin-with-xmpp-jabber 
You can even get the account from within Pidgin.

Jonas
-- 
Jonas Jared Jacek
http://jonas.me/

---

From: Ted Lemon <[email-masked]>
Date: Mon, 11 Jul 2016 11:18:15 -0700

As an alternative, consider using the gmail feature to "mute" threads that
you aren't interested in, if you think the list in general is useful.
Sorry about the noise, but it's typical for the attendees list.   The
unsubscribe link is at the bottom (the listinfo link).

On Mon, Jul 11, 2016 at 11:07 AM, Reem Albuainain <[email-masked]>
wrote:

> Hi there,
> Sorry but how can i unsubscribe from this mailing list?. My inbox is full
> and i cant keep track of the events important documents due to the chat
> board.
>
> *From:* Dave Dolson <[email-masked]>
> *Date:* July 11, 2016 at 8:54:00 PM GMT+3
> *To:* Yoav Nir <[email-masked]>, Ted Lemon <[email-masked]>
> *Cc:* "[email-masked]" <[email-masked]>, Michael StJohns <
> [email-masked]>
>
> *Subject:* *Re: [96attendees] Recipe to set up Jabber?*
>
> Yoav,
> I thought the client at conversejs.org looked promising, but when I
> selected room name [email-masked], it said, "A new room has been
> created"
> I downloaded pidgin, and set my account to the suchat account, and now I
> can enter [email-masked] , and other users are there.
>
>
>
> -Dave
>
>
> From: 96attendees [mailto:[email-masked]
> <[email-masked]>] On Behalf Of Yoav Nir
> I tried six servers from that list that were totally non-functional. The
> seventh one I tried worked like a charm.  FWIW it was SUChat.org
> <http://suchat.org>, and the client still seems to be working with that
> account.
>

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 11 Jul 2016 15:23:02 -0300

Or set up a GMail filter:

https://www.youtube.com/watch?v=APky7ocQlrY

On 7/11/16 3:18 PM, Ted Lemon wrote:
> As an alternative, consider using the gmail feature to "mute" threads
> that you aren't interested in, if you think the list in general is
> useful.   Sorry about the noise, but it's typical for the attendees
> list.   The unsubscribe link is at the bottom (the listinfo link).
> 
> On Mon, Jul 11, 2016 at 11:07 AM, Reem Albuainain <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Hi there,
>     Sorry but how can i unsubscribe from this mailing list?. My inbox is
>     full and i cant keep track of the events important documents due to
>     the chat board.
> 
>>     *From:* Dave Dolson <[email-masked]
>>     <mailto:[email-masked]>>
>>     *To:* Yoav Nir <[email-masked] <mailto:[email-masked]>>,
>>     Ted Lemon <[email-masked] <mailto:[email-masked]>>
>>     *Cc:* "[email-masked] <mailto:[email-masked]>"
>>     <[email-masked] <mailto:[email-masked]>>, Michael
>>     StJohns <[email-masked] <mailto:[email-masked]>>
>>
>>     Thank you for providing a place I can register (suchat.org
>>     <http://suchat.org>) !
>>
>>     I thought the client at conversejs.org <http://conversejs.org>
>>     looked promising, but when I selected room name
>>     [email-masked] <mailto:[email-masked]>, it said,
>>     "A new room has been created"
>>     I don't think conversejs.org <http://conversejs.org> works properly.
>>        
>>
>>     I downloaded pidgin, and set my account to the suchat account, and
>>     now I can enter [email-masked]
>>     <mailto:[email-masked]> , and other users are there.
>>
>>
>>
>>     -Dave
>>
>>
>>     Cc: [email-masked] <mailto:[email-masked]>; Michael
>>     StJohns
>>>     On 11 Jul 2016, at 7:53 PM, Ted Lemon <[email-masked]
>>>     <mailto:[email-masked]>> wrote:
>>>
>>>     This is really hopeless.   If we are to use jabber for IETF
>>>     business, there should be a jabber server that is supported by
>>>     the IETF.   The "good luck" jabber server web page is not
>>>     helpful.   I tried using it in BA and was unable to participate
>>>     on jabber during that IETF.
>>
>>     I tried six servers from that list that were totally
>>     non-functional. The seventh one I tried worked like a charm.  FWIW
>>     it was SUChat.org <http://suchat.org>, and the client still seems
>>     to be working with that account.
>>

---

From: Reem Albuainain <[email-masked]>
Date: Mon, 11 Jul 2016 21:51:07 +0300

Thank you all for your useful responses
Very much appreciated

Sent from my iPhone

> On Jul 11, 2016, at 9:23 PM, Carlos M. Martinez <[email-masked]> wrote:
>