Subject: [97attendees] SIM card for Seoul

From: Börje Ohlman <[email-masked]>
Date: Sat, 29 Oct 2016 07:36:28 +0000

I’m considering getting a SIM card from this site: http://www.egsimcard.co.kr/eng/about-eg-sim-card/about-eg-sim-card-new.asp

As I understand it should be possible to pick it up at the airport upon arrival.
Does anyone have a better recommendation?

Börje

---

From: Yoav Nir <[email-masked]>
Date: Sat, 29 Oct 2016 11:13:10 +0300

A more complete list of options is available here:
http://prepaid-data-sim-card.wikia.com/wiki/Korea,_Republic_of_(South) <http://prepaid-data-sim-card.wikia.com/wiki/Korea,_Republic_of_(South)>

But I didn’t see anything better.

Yoav

> On 29 Oct 2016, at 10:36, Börje Ohlman <[email-masked]> wrote:
> 
> I’m considering getting a SIM card from this site: http://www.egsimcard.co.kr/eng/about-eg-sim-card/about-eg-sim-card-new.asp <http://www.egsimcard.co.kr/eng/about-eg-sim-card/about-eg-sim-card-new.asp>
> 
> _______________________________________________
> 97attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/97attendees

---

From: Michael Richardson <[email-masked]>
Date: Sun, 30 Oct 2016 12:36:05 -0400

I've bought from:
     http://krsim.net/page/call.html

apparently, I pick up from the bootstore in the airport.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Yoav Nir <[email-masked]>
Date: Mon, 31 Oct 2016 20:56:09 +0200

At first I thought they were the same price. Then I noticed that EverGreen charges extra for Nano.

Yes, I can probably get a micro and cut it, but I’d rather not.

Yoav

> On 30 Oct 2016, at 18:36, Michael Richardson <[email-masked]> wrote:
> 
> 
> I've bought from:

---

From: [email-masked]
Date: 31 Oct 2016 19:13:02 -0000

>At first I thought they were the same price. Then I noticed that EverGreen charges extra for Nano.

So does this one: mini/micro SIM is $22.90, mini/micro/nano is $26.90.
But the voice call rates to the US on this one look a lot better.

---

From: Dennis Kort <[email-masked]>
Date: Tue, 1 Nov 2016 11:11:50 +0900

EG Sim is okay, I am currently using it. They use the Korea Telecom network with great coverage, but they don't provide LTE and their web interface / app for recharging is a bit dubious.

For short stays you could also consider to rent a SIM card at the airport and go for either KT or SKT. They have service desks in the arrival hall.

Dennis

> On Oct 29, 2016, at 16:36, Börje Ohlman <[email-masked]> wrote:
>