Subject: Re: [abfab] Getting the charter done (Negotiate - HTTPS - channel binding)

From: Thomas Maslen <[email-masked]>
Date: Mon, 9 Aug 2010 16:27:28 -0700

Harking back a few messages:

> Do browsers support Negotiate with HTTPS and channel binding?

Internet Explorer (8, 7, and 6, maybe even 5?) does, as of October 2009 (KB 974455, combined with previous KB 968389).

[In fact, if (for whatever reason) you don't want this behaviour, you now have to tweak a registry setting, "SuppressExtendedProtection"].

The umbrella name they used for this was "Extended Protection for Authentication", which seems to cover a fair amount of channel-binding goodness, including the Negotiate-with-HTTPS case.

I'm not sure whether other browsers running on Windows that call Windows SSPI -- Firefox, fairly recent versions of Chrome, ...? -- now get this automagically or whether you have to tweak code to get the channel-binding bits from the TLS code to the SPNEGO code.

---

From: Nicolas Williams <[email-masked]>
Date: Mon, 9 Aug 2010 18:33:49 -0500

On Mon, Aug 09, 2010 at 04:27:28PM -0700, Thomas Maslen wrote:
> Internet Explorer (8, 7, and 6, maybe even 5?) does, as of October
> 2009 (KB 974455, combined with previous KB 968389).
> 
> [In fact, if (for whatever reason) you don't want this behaviour, you
> now have to tweak a registry setting, "SuppressExtendedProtection"].
> 
> The umbrella name they used for this was "Extended Protection for
> Authentication", which seems to cover a fair amount of channel-binding
> goodness, including the Negotiate-with-HTTPS case.

Or Integrated Windows Authentication.  I'm aware of this.  I'm asking if
there's documentation on how CB is negotiated, if at all.

IIRC what happens is that the initiator just uses CB, and backwards
compatibility just results from either a) krb5 acceptors ignoring CB
when the acceptor app does not provide any, b) NTLMSSP negotiating CB??

> I'm not sure whether other browsers running on Windows that call
> Windows SSPI -- Firefox, fairly recent versions of Chrome, ...? -- now
> get this automagically or whether you have to tweak code to get the
> channel-binding bits from the TLS code to the SPNEGO code.

Using SSPI alone does not get you this.

Nico
--